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Introduction



Chapter 1

Philosophy

The maker of a sentence launches
out into the infinite and builds a
road into Chaos and old Night,
and is followed by those who hear
him with something of wild,
creative delight.

Ralph Waldo

Emerson

Most word processors and text editors aimed at writers assume the creative process will
take place in linear form; that is, they assume that the writer knows how his or her work
will begin and will start at the beginning and continue through until reaching the end,
and for those that do work that way, they assume that a linear form is a useful format
for a text that spans hundreds of pages. Planning and restructuring is therefore forced
into a separate workflow—the writer must either plan before beginning and keep track
of hundreds of different files using the computer or face the laborious task of cutting
and pasting numerous chunks of text to restructure a long piece of work at the end. For
shorter pieces of writing, this is not a massive problem, but for longer texts—such as
novels or academic theses—the writer can often find him- or herself battling against the
tools of their trade. What a word processor does get right is in not presuming anything
of your working methods. It is, at the core, ruthlessly simple.

Scrivener is part of a new breed of writing software which focusses more on providing
a solid open-ended writing too/ (as the word processor does) rather than a writing process,
which presumes a system upon you. As with a word processor, there are no chapters or
sections or scenes; how you use the software determines these things, not some feature
baked into the program. Scrivener’s design is fairly unique in that it easily provides a
platform for writers of many philosophies and disciplines. It’s a tool that works equally
well for a doctoral dissertation, as it does for writing a short story or a screenplay.

2



Often you will hear of “pantsers” vs. “plotsers” within fiction writing circles. Those
that write by the seat of their pants and those that plot everything out before they start.
You will not find that this program urges you into one way of working or another. Rather
you should find that its features and design provide a set of basic abilities which can am-
plify your method and make the mechanics of writing easier for you. If you start with a
big pile of files that need to be sewn together, you’ll probably find an emergent outline
to be useful. If you make the outline first, you’ll probably find the integrated outline-is-
your-book approach to be useful. No longer will you need to maintain a separate outline
document that needs to be kept up to date with the text of the book. The two will be
one and the same. No more will you need elaborate spreadsheets to track crucial details.
All of that can be woven right into the mechanical structure that is your book in this
software. These principles extend to all forms of writing, from the novel to the legal brief
to the documentary shot list.

Scrivener was developed because no other writing environment quite provided all of
the features required for the sort of writing that demands easy access to research, a quick
overview of numerous documents and the easy restructuring of swathes of text.

The main concepts of Scrivener can be summarised as follows:

¢ The software should allow the writer to use many of the formatting features familiar
to word processors—different fonts, italics, paragraph styles and so on. It is up to
the writer to avoid distractions, not the software.

¢ What looks good in print is not always the best way of viewing something on the
screen: the software should allow the user to completely reformat the text on ex-
port or for printing without affecting the original (thus making it easy to export a
manuscript in a format suitable for an editor and then export it just as easily in a
format more suited to publishing on the internet).

¢ There should be a synopsis linked with each document that can be viewed with
other synopses to get an overview of the project as a whole.

¢ Linked to the above, it should be easy to view the project as an outline and use drag
and drop to restructure the project. Moving between the outline and the text itself

should be fluid.

@ It should be possible to view individual “documents” either as discrete chunks of
text or combined with other (arbitrary) documents. Thus, for instance, a chapter
could be viewed as a whole or each scene could be viewed individually.

¢ The user should be able to view more than one document at the same time—for
instance, the end of one chapter alongside the beginning of the next, a character
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sketch alongside a scene in which that character appears, or a research document
alongside the writing it is being used to support.

¢ The software should be capable of storing and displaying common research docu-
ments, because writers do not just use text—they also refer to images, web pages,
recorded interviews and other media.

The overriding philosophy behind Scrivener was in part inspired by a passage written
by the author Hilary Mantel in a collection of essays by writers on the process of writing
entitled The Agony and the Ego. Hilary Mantel described a process of “growing a book,
rather than writing one,” which can be summed up as follows:

1. During the first stage of writing, you might jot ideas down on index cards—phrases,
character names, scene ideas; any insight or glimpse.

2. When you have gathered a few index cards, you might pin them to a corkboard.
Other ideas build around them, and you might even write out a few paragraphs and
pin them behind the index card with which they are associated. At this stage, the
index cards have no particular order.

3. Eventually, you may begin to see an order emerging and re-pin the index cards ac-
cordingly.

4. After you have gathered enough material, you might take all of your index cards,
sheets of paper and jottings and place them into a ring-binder. You are still free to
move everything around, but now you have a good idea of how much work you
have done and how much more work you have to do.

Scrivener is thus a nonlinear writing tool that provides the writer with all of the features
found in any text editor along with the functionality for “growing” your work organically
within the program itself in a way which will become more useful the more you write,
naturally and effortlessly.



Chapter 2

About This Manual

This manual has been written using Scrivener and is available in three different formats.
In addition to the PDF available from the Help menu, under User Manual, you should
also find two copies which have been specially formatted to be printed on either US Letter
or A4 standard printer paper on the Support section of the Literature & Latte website'.
The Scrivener project used to author the manual can be downloaded from our website as
a demonstration of writing in Scrivener. It has been written using the MultiMarkdown
formatting syntax and so demonstrates that system as well.

Annotating the PDF: If you wish to make notes and annotate the PDF using software
such as Reader or Skim, it is recommended you download a separate copy, or locate the
PDF in the Scrivener installation and drag a copy out for your own personal use. When
Scrivener updates, it will very likely overwrite the existing PDF in the installation

(often with revisions to the text), which will destroy any of your notes.

The manual itself has been split into five primary sections and an appendix. The first
section introduces Scrivener’s terminology and interface and gives a quick tour for those
who want to start writing as soon as possible. It is highly recommended that you also
go through the separately available Interactive Tutorial (which can be accessed via the
Help menu in Scrivener) to get the most out of Scrivener and eliminate confusion over
some of its unique features, but the Quick Tour (chapter 5) should have you writing using
Scrivener’s basic main features within half an hour.

Scrivener has a wide variety of features to accommodate many different purposes, in-
cluding novels, screenplays, academic papers and dissertations, general non-fiction, jour-
nalism, blogging, and much more. While it strives to present as simple an interface as
possible, once you start digging into the application, you will find a degree of flexibility
and complexity to suit even the most esoteric needs. To help organise all of these concepts,
the next three sections take a pragmatic look at the primary stages of any major project,
Preparation (Part IT), Writing (Part III), and Final Phases (Part IV), and detail Scrivener’s
tools for aiding you through the drafting process and ultimately exporting and printing

Thttp:/ /www.literatureandlatte.com/support.php

5
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your work. In each section the features most useful to you during those phases will be
explained in depth. If you want to find a specific feature, consult the appendices at the
end of the manual for a cross-referenced list to every menu item and window.

Users who are already familiar with prior versions of Scrivener will want to consult
the What’s New section (Appendix A), where new major features are briefly explained
and a list of minor changes and features is provided as well.

2.1 Terms and Conventions

Some features apply only to the standard version of the software, and others only apply
to the Mac App Store version. Various key features will be marked to indicate this. If
you have purchased the program directly from our web site, then you have the standard
version. If you used Apple’s App Store tool to buy Scrivener, then you have the Mac App
Store version. Sections applicable to only one or the other will be indicated as such:

: Standard retail version of Scrivener: [Standard Version]

& Mac App Store version of Scrivener: [App Store Version]

Whenever the documentation refers to an action that must be taken by you, the visible
name for that action will be formatted like so. Button labels, menu items, and keyboard
shortcuts will all be displayed in this fashion.

»

Menus will be displayed in a hierarchy using the “» ” character to separate top-level,
sub-menu, and items. Example: To convert a range of selected text to uppercase, invoke
the Format» Convert» To Uppercase command.

Keyboard shortcuts will use the following symbols:

@ %—: The Command key, or the Apple key, is the one located directly to the left and
right of your spacebar.

@ \U: The Option key is also labelled the Alt key on some keyboards, depending on
which country you purchased your Mac from. Some laptops only have one Option
key on the left side.

@ ~: Control is usually located to the left and right of the Option keys on their re-
spective side. Some laptops only have one Control key between the Option key
and the Fn key on the left side.

@ {r: The Shift keys are rarely used by themselves in shortcuts but are often used in
combination with other modifier keys.



2.2. FINDING THINGS 7

When a keyboard shortcut requires a combination of modifier keys, they will be
printed together. Example: 4+ 8-V, which matches Edit » Paste and Match Style, means
you should hold down all three of these modifier keys and then tap the V key on your
keyboard. The hyphen is used to separate the modifier keys from the target key and is
not meant to be included in the shortcut itself.

Interface elements will be capitalised as proper nouns to help differentiate them from
standard nouns when appropriate. A Collection is an interface element, while the word
“collection” can be used to indicate a casual grouping of items, and not necessarily a formal
Collection.

Some of the names for various elements within Scrivener are customisable on a per
project basis, and how you name these will impact much of the interface. A good example
is the Draft, the place where your manuscript in progress is built. This can be called
whatever you like, and what you name it will impact the names of menu items that refer
to it. In all cases, this documentation will refer to these malleable elements by their default
names.

In cases where file paths are printed, the UNIX convention of providing a shorthand
to describe your personal home folder will be used. An example might look like:

~/Documents

The tilde is a shorthand which means: “/Users/yourusername”. In this case, the path
refers to the Documents folder in your home folder.

2.2 Finding Things

Since this PDF has been birthed within the age of digital documentation, and has yet
to make its way to print form, a proper index has never been compiled for it. Despite
this, in practice you should have little difficulty in locating the topic you are interested
in. Modern PDF reader software features excellent searching capabilities; most things can
be discovered merely by searching for the proper names of things—as labelled in menus,
buttons or dialogue boxes—in the PDF.

Alternatively, the appendices have been designed to use as a sort of topical index. If
you have a question about a particular menu command, for instance, you can find it in
the appendix, Menus and Keyboard Shortcuts (Appendix B). Often, if the feature merits
it, there will be a cross-reference to a more thorough description of the feature in the main
manual. When all else fails, a detailed table of contents has been provided at the beginning
of the document.
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2.3 What's New

This section has been moved to the appendix. If you would like to read up on significant
changes since your last update to Scrivener, refer to What’s New (Appendix A).



Chapter 3

Installation and Upgrading

If you purchased Scrivener through the Mac App Store, then this chapter will not be
relevant to you, as it pertains to the registration, installation, and maintenance of the
standard retail version. You may safely skip to the next chapter, Interface (chapter 4). All
installation and application updates will be handled by the Mac App Store application for
you.

If you purchased the boxed version of Scrivener, insert the CD-ROM into your com-
puter and wait for it to appear in the Finder. Create a new Finder window with -N and
choose the Go» Applications... menu item. Drag the Scrivener application from the CD
to your Applications folder.

For online downloadable purchases, download the trial version from the Literature &
Latte web site. The trial version can be unlocked at any time with the registration se-
rial number that was sent to you when you purchased the application. When the DMG
finishes downloading, double-click on it in the Finder (if it hasn’t opened for you automat-
ically), and follow the above instructions to drag the Scrivener icon to your Applications

folder.

Scrivener will not be correctly installed on your system if you drag the icon from either
the CD, or the DMG, straight into the Dock. It must be dragged into the Applications
folder or, if you do not have administrative rights for the computer, you may install it
into an Applications folder within your home folder (you can create one, if necessary).
After copying the Scrivener application to your hard drive, you can then drag a copy to
the Dock from the Applications folder if you wish.

If you attempt to run Scrivener from a “non-standard” location, you will get a warning
message which will offer to you the chance to have it install it for you. If you intend to
run Scrivener from outside of an Applications folder, then you should check the box that
will inhibit this warning from appearing again in the future.

Once this is complete, you should eject the DMG or CD from your computer. Click
the Scrivener icon in the Dock (if you have placed it there), or double-click the icon in
the Applications folder to launch Scrivener.

9
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3.1 Portable Installations

We do not recommend installing Scrivener on a portable drive that you routinely remove
from your computer in order to keep your data portable between multiple machines. It
is best to install and register Scrivener on each machine independently.

3.2 Registering
3.2.1 The Trial Version

You can try out all of the features of Scrivener for 30 non-consecutive days without hav-
ing to pay or register. During that period, Scrivener will be fully functional. After 30
days of use, you will no longer be able to access Scrivener at all' unless you register. If
you are getting close to the end of your trial and have decided to not purchase Scrivener,
please skip forward to the sections on Compiling the Draft (chapter 24) and Exporting
(chapter 25), for details on getting your data out of the program.

3.2.2 Purchasing Scrivener

During the trial period, whenever you launch Scrivener, you will be reminded of how
many trial days you have left and given the option of buying and registering. Clicking
on the Buy Online button will take you to the Literature & Latte online store, where you
can purchase a licence for Scrivener. You can also visit the online store at any time whilst
using Scrivener with the Help » Purchase Scrivener... menu item.

When you buy a licence for Scrivener online, you will be e-mailed your unique serial
number, which will have the following format*:

SCRVNROO1-XXXX-XXXX-XXXX-XXXX-XXXX

Make sure that you keep this serial number, along with the exact name under which you
registered Scrivener (the “Serial Number Name”), in a safe place, as you will need both
to register Scrivener again in the future. Remember that you may need to re-register at a
later date, too—for instance when installing Scrivener on a new computer, or re-installing

! Actually, Scrivener will allow you a single “grace” session after the 30 days so that you can export all
of your work. This way, if you have decided not to buy Scrivener but forgot to export during the 30 days,
you can still easily get your work out of the program.

Actually, Scrivener will allow you a single “grace” session after the 30 days so that you can export all of
your work. This way, if you have decided not to buy Scrivener but forgot to export during the 30 days, you
can still easily get your work out of the program.

2The number in the first block may be something other than ‘1’, this is okay. However if your number
is ‘0’ you have an old serial number and will need to upgrade.
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after wiping your hard drive for whatever reason—so it is very important to store this
information safely.

If you have lost your serial number, clicking Retrieve Lost Serial... in the registration
window will take you to our vendor’s self-service support site, where you can request to
have the information sent to you.

3.2.3 Registering Scrivener

After purchasing a licence and receiving your unique serial number, you can register
Scrivener by clicking on the Enter License... button in the “Scrivener is unregistered!”
box that appears whenever you launch Scrivener. Alternatively, you can choose Regis-
ter... from the application (Scrivener) menu.

In the “Serial Number Name” box of the registration window, enter the exact name
under which you registered Scrivener. Enter your unique serial number in the “Serial
Number” box, then click the Register button. You must make sure that both the user
name and serial number are exactly as they appear in the registration e-mail you received,
or registration will fail.

If you receive a message stating that the name or serial number is invalid:

@ Check and make sure they are in the right order. The name of the software owner
should be in the top field; the serial number in the second field.

@ Try using copy and paste to transfer the information from the e-mail to this form
and make sure that when you select the text in the e-mail, that the selection range
does not extend beyond the first or last letter or number in the field.

For this reason, it is probably best to copy and paste both the user name and serial
number directly from your e-mail. Be sure to select only the text and not any additional
white space.

After clicking the registration button, Scrivener will attempt to authenticate your copy
over the Internet. No private information will be relayed during this. If for some reason
the Internet cannot be accessed from your computer, you will receive a warning message
with instructions on how to activate the software. A URL will be provided which you
can use on another computer to access the activation code you’ll need to complete the
registration process on the original computer. You can use copy and paste into the forms
to make this easy.

Once Scrivener has been registered, you can begin using it immediately. There will no
longer be a time limit on its use and you will no longer see the nag box at startup.
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3.2.4 Use of System Contacts

When Scrivener is first run on Mac OS X 10.8 or greater, you will be asked by the oper-
ating system if it is okay for Scrivener to access your Contacts. This is a standard request
for permission that is generated by all programs that use your contact list. Scrivener only
uses your list for one purpose: it will use information in your system’s default card to gen-
erate your name into page headers, as well as generating cover sheets and the like when
creating templates. If you would rather not grant Scrivener the ability to do this, you will
need to fill out these details yourself.

Pro Tip: In cases where your personal identity is rarely the name under which you
publish, you might want to have Scrivener use another contact card entirely, rather
than the system default. Rather than changing the default card to your pseudonym,
you can simply set up a special address card entry for your writing persona, and then
place the text “(Scrivener:UseMe)”, somewhere in the “Note” area of the contact card
you wish to use. This will be used to generate the headers and footers, as well as any

contact information for coversheets and so forth in the templates.

3.3 Application Updates

When you first start using Scrivener, you will be presented with a panel which asks
whether or not Scrivener should automatically check for updates. To use this feature,
you must have a connection to the Internet.

Software vs. Your Work: The advent of mobile operating systems for tablets and
smart phones has unfortunately blurred the line between what a program is and what
your data is. On these devices, deleting or re-installing an application can destroy your
work.

Standard operating systems don’t work that way. They are considerably more robust
and well designed for content creators, down to the very core of their technology and
philosophy. Like all programs on your computer, Scrivener saves your work into files.
You’ll learn more about the specifics of this in the coming sections, but for now simply
know that there is absolutely no connection between the software and your hard work.
Upgrading versions, registering your trial, or switching to a beta build will have no
impact on your data (save that you of course will not be able to open it so long as

Scrivener is not installed; it will be accessible once the software is available again).

If you click Check Automatically, once a day when you launch Scrivener, if your ma-
chine is connected to the internet, Scrivener will do a quick check to see if there is a
newer version available and will prompt you to update if one is found. (It is strongly
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recommended that you always update to the newest version available.) Choosing Don't
Check will disable automatic checks, but you can always manually select Check for Up-
dates... from the application (Scrivener) menu. This option is available even if you also
have Scrivener checking automatically.

You can change your mind later by setting this option in the application preferences,
under the General tab (section C.2). There you can also adjust the frequency of the auto-
matic checks, ranging from hourly to monthly.

When a check finds available updates, a window will appear outlining the details of
the upgrade. It is recommended you brief yourself with the update notes, as sometimes
changes in operation occur. You can view the full list of changes at any time on our web
site’.

To upgrade the application, click the Install Update button. Scrivener will download
the latest version of the application for you, and when it is done downloading you will
be presented with a button to restart the program. Click this, and after Scrivener restarts
your copy will be up to date.

3.4 Upgrading from Scrivener 1

While it is possible to run more than one version of Scrivener at once on your computer,
it is advisable to first delete your copy of 1.x before installing the new version. To do this,
make sure Scrivener is closed, then drag its icon from the Applications folder to the trash
in your Dock before following the above installation instructions. Since the application
preferences have all been updated, you will need to go through the new preference system
and set up your defaults again.

The project file format has been updated considerably, and new or upgraded projects
cannot be opened in Scrivener 1.x versions of the application. The first time you load
each of your older projects in 2.x, you will be presented with a dialogue box asking if
you wish to upgrade the project format. Until you do so, it will not be possible to open
these older projects in Scrivener 2.x. When updating the project, Scrivener will create a
backup copy of the original project, preserved in the 1.x format, which you can choose
to set aside or delete once you’ve verified the update was successful.

Once the update process is complete, the project will open and you can begin working
immediately.

Updating large projects: When updating very large, multi-gigabyte projects, be pre-
pared to wait a while for the process to complete. A good rule of thumb is how long it
would take to copy the project from one disk to another and then half that time again.

Shttp:/ /www.literatureandlatte.com/scrivChangeList.php
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If your project is so large that it will take 20 minutes to copy, then you should be pre-
pared to wait at least a half hour for the project to update, as part of the update process
is creating a backup of the original. You will also want to keep this fact in mind when
considering drive space. Do not attempt to update a multi-gigabyte project file on a
drive that does not have enough space left on it to accommodate a duplicated copy.

In some cases, you may need to keep a copy of 1.x installed. If you are working with a
colleague who has yet to upgrade to version 2, you will want to make sure not to update
these collaborative projects and will need to use 1.x to interface with them. It is perfectly
safe to do so, but if you elect to keep a copy of Scrivener 1.x installed, you will need to
consider the following:

@ scriv files will open in Scrivener 2.x by default. To open older projects in Scrivener
1.x, you will need to drag these items onto the Scrivener 1.x icon in the Dock or
use the File » Open... menu command from within Scrivener 1.x.

@ So long as you have both versions installed, the Mac might get confused over the
clipping services, which can be used to clip information from other programs into
Scrivener. Once you have fully uninstalled the old version of Scrivener, these clip-
ping services should work just fine after a reboot.

« It is safe to run both copies at once, as they use different preference files.

@ Scrivener’s manual has been entirely moved to PDF (what you are likely reading).
If you leave 1.x installed on your machine, the old Apple Help system will still
have entries listed for Scrivener, so if you use the Help menu’s search field (in Snow
Leopard) to look up a topic, it will return search results from the wrong version’s
help. Instead, load the PDF in your preferred viewer and use the search tool there
to find a topic.

@ In some cases custom keyboard shortcuts, which are assigned using Apple’s Key-
board Shortcuts tool, can get assigned incorrectly or lost.

3.5 Staying Informed

If you would like to keep up to date on the latest developments and releases of Scrivener,
you can sign up for our low-volume newsletter using Help » Keep Up to Date.... Once you
submit the form, a confirmation e-mail will be sent to the address you provided. You will
need to click a link within this e-mail before you will be officially added to the list. If you
cannot find the confirmation e-mail after 24 hours, check your spam folders, and consider
adding “literatureandlatte.com” to your white-list.
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The “Keep Up to Date...” window also has links to our Twitter feed and Facebook
page. We frequently publish small tricks and tips through these channels.



Chapter 4

Interface

The Scrivener interface has been carefully designed to cover a wide range of uses. At its
most minimal, the interface could look no more complicated than a basic word processor
like TextEdit. In this section, we will go over some of the basic interface elements that
will be present in nearly every project you work in. Advanced features will be gradually
introduced in their own sections as they pertain to specific areas of the writing process.

4.1 Interface Overview

When you initially run Scrivener, you will be presented with a Getting Started and project
template selection window. This is actually a full-featured launching pad for all of your
future and existing projects. Whenever you are ready to start a new project (the details of
which you’ll read about later on), such as a new novel or paper for a journal, you’ll use
this interface to select a starting template, or a blank starter. You can hide the “Getting
Started” interface in the Options... drop-down menu in the bottom of this window.

The remainder of this section briefly summarises the main components of a typical
project window. Each area will be discussed in greater detail later on, and if you are
interested in a particular feature you’ll find cross-references to more exhaustive articles on
these topics. You may want to click on the “Blank” category in the left list, and then use
the “Blank” starter to create a temporary test project to play around with, while reading
this chapter. Skip forward to the Quick Tour (chapter 5) if you need instructions for
doing so, but come back after you make a project, as it assumes a basic understanding of
what we will cover in this chapter.

The main project interface comprises five main elements, not all of which are visible
when a new project is created.

1. Toolbar: Frequently used tools displayed in a standard fashion, familiar to most
macOS applications, which can be customised as you see fit.

2. Binder: A hierarchal list of all items in your project, including the manuscript; a
general collection area for research materials, notes, and so forth; a trash can for

16
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collecting deleted items; and finally the top-level area where you can create your

own files and folders.

3. Format Bar: Supplies frequently used text editing and formatting tools, available
to both editor splits.

4. Editor: The editor can be split into two panes which can show two parts of the

same document, or two different items altogether. This is where all viewing and

editing is done.

5. Inspector: A feature-packed tool providing information about the currently active

split. The inspector has six separate sub-panes, which address various aspects of the

viewed resources. Not all of them are available for all media types.

Most of the main interface sections (binder, editors, and inspector) can be resized within
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the window via the grab handles located at the bottom, or in the case of splits, by dragging
the divider line between them.

Each of these elements will now be explained in greater detail.

41.1 Toolbar

Scrivener has a customisable toolbar which includes many common functions, including
a project search tool. To change the order, add, or remove icons, use the View » Customize
Toolbar... menu item.

It is also possible to hide the toolbar by using the View » Hide Toolbar menu item. Note
that when the toolbar is hidden, you can still access project search via the Edit » Find » sub-
menu, or 2\ F, which will provide a pop-up window featuring the same search controls
available as on the toolbar.

4.1.2 The Binder

The binder is so-called because it really acts as the ring-binder for your project. It provides
a hierarchical list of all items in your project. You can drag items around to restructure
your project and double-click on any item to rename it. Selecting an item in the binder
displays its content in the editor pane that most recently had the keyboard focus (see
below) and its meta-data in the Inspector (again, see below).

You can create as many folders and files as you wish in the binder, but there will always
be three top-level folders that cannot be deleted (although they can be moved around
within the top level and renamed):

Draft The Draft folder is where you place all of the pieces of text you want to include in
your final manuscript. As such, the Draft folder is unique in that it can only hold
text files and folders—it cannot directly hold image files, PDF files, QuickTime
media or web pages as other folders can, though it is of course perfectly possible to
embed figures into the text itself, much as you would in a word processor, at the
editor level. All of the writing you want as part of your finished work should be
placed inside the Draft folder, in the order you want it (which, of course, is easy
to change by dragging and dropping). When you are ready to export or print your
manuscript, use File » Compile.... This will combine all of the individual documents
inside the Draft folder into one long document, formatted as you specify. Each file
you place inside the Draft may represent a chapter, a scene, a paragraph or whatever
you want.

Some templates may rename this folder to something else, but its function remains
the same.
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Research The Research folder can hold any type of file supported by Scrivener (text,
image, media, archived web pages or PDF files). It provides a default place for non-
text files to be imported and stored (although you can create other top-level folders
for this purpose if you so wish).

Some templates may rename this folder to something else, but its function remains
the same.

Trash When you delete an item from the binder, it is not really deleted but just moved
to the Trash folder. You can drag items in the Trash folder back into the main
binder, but you cannot create new items inside the Trash. To empty the Trash, use
the Project » Empty Trash... menu command. This will permanently delete all items
inside the Trash folder (and cannot be undone).

The Collection tab interface can be toggled on and off with the associated toolbar but-
ton, or the View » Collections » Show Collections menu item. You can organise material
into tabs you create, or save common searches as dynamic collection. In most cases, if this
manual refers to having a “binder selection”, it is often accurate to assume that applies to
collections and search results as well. Collections and search results can also be dismissed
by clicking the X button in the footer bar for the Binder. Due to the similarity of these
views, the entire sidebar is often referred to in this manual as “the binder sidebar”. This is
meant to indicate that you needn’t take the referenced action only in the Binder tab itself,
but in any view that presents itself in this sidebar, such as the Search Results lists.

See Also:

@ Setting Up the Binder (chapter 7)

¢ Navigating and Organising (chapter 8)

4.1.3 Format Bar

The Format Bar stretches across the top of the main application view, right below the
toolbar, and provides easy access to the most common text formatting tools. It can be
selectively hidden when not needed with the Format » Hide Format Bar menu command.
For more information, read The Format Bar (subsection 15.4.2).

4.1.4 Edifor

The main editor occupies the large space to the right of the Binder, and will be your main
working area for all manner of tasks. It automatically loads whenever you click an item
in the Binder. Not only is it where you will be doing most of your writing, but it also
has the ability to display groups of selected items in various useful fashions, which we
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will be getting in to shortly, and is a capable multimedia viewer, too. The editor will
take on different appearances and functions depending on what sort of document you are
displaying and which group view mode you are in. The editor can also be split, either
vertically or horizontally, giving you two independent working areas at once.

At the top of each editor is a header bar or view. This contains navigation buttons
(the arrows) which allow you to navigate backwards and forwards through the document
history. Next to the navigation button pair is the title of the document along with its icon.
Clicking on the icon will display a pop-up menu that collects together some common
menu commands. The entire header bar has three colour status modes:

¢ Plain grey is the default, and is what you will see unless you have split the editor.
¢ Blue appears when you have split editors, and indicates the active editor.

@ A reddish appears when the editor has been locked (\°¢2-L), which inhibits it from
receiving binder clicks.

On the right side are two vertical arrows which allow you to navigate through the
binder in a flat list fashion. You can also use the keyboard shortcuts, 8- UpArrow and
\#-DownArrow. Using these navigation tools will also focus the binder on what you are
selecting (and is one of the few instances in which an action taken in the editor will change
the Binder selection).

On the far right of the header view is a button that controls the split. The icon in the
button will indicate the type of split that is available - horizontal, vertical or none (close
split). Option-clicking on this button will change the split type.

Clicking on this button when both editors are visible will cause the editor associated
with that Header Bar to take over and the other editor to close.

Below each editor pane is a Footer Bar. This will change depending on the type of
document visible and the current editor mode. When a standard text document is being
viewed, for instance, it will display the word and character count along with a pop-up but-
ton for changing the text scale and a button for setting document targets. In scriptwriting
mode, it will provide shortcuts for accessing various script entry macros. Various types
of multimedia, and PDF, will display their own appropriate relevant information in the
footer bar. Corkboard and Outliner group view modes have their own footer bar func-
tions, too.

See Also:

¢ View Modes (section 4.2): for further information on the various group and text
view modes available.
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Figure 4.2: Inspector panel buttons, with "Keywords" selected.

@ Viewing Media in the Editor (section 14.3): for details on how various read-only
media are displayed in the editor.

¢ Header Bar (section 14.1): for more information on the informative strip along the
top of the editor.

@ Footer Bar (section 14.2): on how to use the strip along the bottom of the editor,
which will change according to what type of document you are viewing.

4.1.5 The Inspector

The Inspector is not always visible by default in new projects, but will always be on the
right side of the project window when it is visible. Its purpose is to display all meta-data
associated with the document shown in the editor pane that most was recently viewed in
either editor. Note that the special top-level folders in the binder—Draft, Research and
Trash—have no meta-data associated with them, and therefore the inspector just shows
the project notes or references when these items are selected. More on that later; for now,
if the inspector appears suspiciously empty, know you have an item selected that does not
support meta-data.

The inspector has six different sub-panels, which can all be accessed via buttons along
the very top of the Inspector (Figure 19.1). If an associated panel has had data entered
into it, an asterisk will appear in the upper-right corner of the button. The sub-panes are
listed in the order they appear:

1. Synopsis, General and Notes

2. Synopsis, General and References

3. Synopsis, General and Keywords

4. Synopsis, General, and Custom Meta-data
5. Snapshots

6. Footnotes and Comments
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The lock icon at the end locks the inspector so that you can reference the material in it
even when switching to a different editor split.

The first three sub-panes include the synopsis card, and general meta-data in addition
to their specialised information. These initial sections can be collapsed by clicking the
disclosure arrow on the left side of the header bar for each. The two common meta-data
sections are as follows:

Synopsis & Image The top frame shows the written synopsis for the binder item, which
is what also appears in the index card representation of the item in corkboard mode,
among other places. Using the top drop-down menu, you can optionally also attach
an image to the item to represent it in Corkboard mode, instead of a text synopsis.
Media files by default will display an image synopsis, but you can use the drop-down
menu to switch to text if you prefer.

General The middle frame of the inspector shows basic meta-data for the current doc-
ument. This includes the label and status (which can be renamed to something
more appropriate to the current project), the modified and created date of the doc-
ument (click on the arrows to switch between the modified and created date) and
checkboxes that affect how (and whether) the document will appear as part of the
compiled draft for exporting or printing. For more information on the types of
meta-data available, read Setting Up Meta-Data (chapter 9).

The Notes, References, Custom Meta-data and Keywords panels all display the above
two components. They are described as follows:

Notes Displays a notepad for the document. Each document has an auxiliary notepad
associated with it; it only appears while you are viewing that item. Clicking the
header bar of the notes area will bring up a pop-up menu from which you can select
“Document Notes” or “Project Notes”, the latter of which is global to the project
and accessible from any part of the project. If you have multiple project notepads,
you may see more than one option here in parenthesis. For more information, read
Document and Project Notes (section 19.4).

References The References table lets you to hold links to related material within the
project itself. Links can also point elsewhere on your hard drive or on the Internet.
Click the header bar to switch between document references and global project
references. Use the latter to make links available throughout the project. For more
information, read References (section 19.5).
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Keywords Displays a list of keywords associated with the selected document. Keywords
can be used to tag your document. Use the + and - buttons to add and remove
keywords, or the gear menu to access the project’s central keyword list. Read more
about them in Keywords Pane (section 19.6) and Using Keywords (subsection 9.1.4).

Custom Meta-Data Each custom meta-data field will be displayed in a linear list with
editable text fields. Fields can be added and managed using the gear menu. The
fields can also be added to the Outliner as columns. Read more about Custom
Meta-Data (subsection 9.1.6) and the Custom Meta-Data Pane (section 19.7).

The last two sub-panes, Snapshots and Comments & Footnotes, take up the entire
inspector.

Snapshots An integrated view which displays all of the document’s snapshots (a way
of saving the current text of the document as a version, which can be reviewed or
recalled at a later time) and the contents of the selected snapshot in the text area
below. Snapshots can be created (from the state of the current text) or deleted with
the + and - buttons in the header bar. The Compare button will show changes
between the selected snapshot and the current text. The Roll Back button lets you
revert the main editor to an older version of the text. For more information on
using this, see Snapshots Pane (section 19.8), and Using Snapshots (section 15.6) for
more general information on Snapshots.

Comments & Footnotes Words and phrases in the text editor can have notes attached
to them. The contents of the notes will be stored in this pane. New comments can
be created with the + button and new footnotes with the +fn button. Selected notes
can be deleted with the - button. For more information, see Linked Notes Pane
(section 19.9), and Annotations and Footnotes (chapter 18).

4.2 View Modes

There are three primary “group view modes” available in Scrivener. View modes give you
a powerful way to view and modify multiple documents at once in a variety of fashions,
each tailored to different tasks. View modes are generally only triggered when the editor
is asked to view more than one document at a time. This can happen if you Cmd-click
on more than one binder item or even if you just click on a folder. It is also possible to
manually enable a view mode, allowing you to easily flesh out a single document with
new index cards beneath it.

For the most part, Scrivener will anticipate what you are trying to do and react accord-
ingly. If you click on a single text file, it will display the contents of that text file in the
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editor. If you then click on the group containing that file, it will automatically switch to
your preferred group view mode, the one which you used last (corkboard by default).

An exception to this rule is when the view mode has been explicitly set to single text
file mode. If you intentionally disable the corkboard to edit a folder’s text, then the view
mode will remain text-only until changed, no matter what type of item you click on in

the binder.

A key principle is that view modes are just that. They are alternative ways of viewing
a binder item and thus, like the binder, are methods for organisation. You can think of
view modes as being like an elaborate extension of the binder, and in that sense they work
closely with it and display information in the same top-down fashion. You can drag items
from a corkboard into the binder to move those cards, or vice versa.

All file or folder item in the binder can both contain text and children. This is a depar-
ture from how most applications work, where the only way to organise items into other
items is to use a folder. Scrivener doesn’t restrict you to that, and indeed even allows you
to convert a text file to a folder and back again. Consequently, even though it selects the
most appropriate view mode depending upon what you click on, you can always override
the default. For folders, you can turn off the current view mode and read or add text to it.
For files you can select a view mode manually and then add items to them as if they were
folders. When performing the latter, you will most likely be presented with an empty
corkboard or outliner at first. This is fine, because you can still go ahead and add items to
that view, and in doing so you will add children automatically to that file. This is a great
way of expanding scenes and fleshing out rough ideas, so take a moment to play around
with the view mode buttons in the toolbar, or their corresponding shortcut keys, to see
how you can get the most out of Scrivener’s unique file and folder structure.

The default view mode will prefer whatever mode you have selected last. If you choose
outliner, then this is the mode that all containers will default to when clicked upon. It
will remain this way until you manually change modes again.

The section on Project Planning (chapter 11) goes into greater detail on how to use
corkboard and outliner modes to their maximum power. The section on Editing Multiple
Documents (section 15.9) will cover the unique Scrivenings mode in detail.

4.2.1 The Group Mode Toolbar Control

Included in the default application toolbar is a so-called “segmented control”. It is in the
middle of the window, and contains three buttons embedded in a single row (Figure 4.3).

The figure depicts the control when a group of items or a container has been selected.
When a single item has been selected, the label will change to “View Mode”, and the icon
on the far left will depict a single page.
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View Mode

Figure 4.3: Segmented control in group mode with Scrivenings mode selected.

The control displays the active view mode with a shaded background. This is the last
view mode that you picked, and it means that editor will always use that method to display
groups of content until you change it again while viewing a group. To change a mode,
simply click on any of the other buttons in the control. The view for the active editor
will immediately change, and simultaneously set your preference for that view mode for
that project.

You can also click on the shaded view mode that is already selected to intentionally
disable it and view the text of the container that you are viewing. If you have clicked on
a folder and are viewing its index cards on a corkboard, clicking the corkboard button
again will switch to viewing the text of the folder. This is considered to be a view mode
setting as well (or rather the absence of a preference). All future clicks to container items
will load the text editor in single file mode until you again choose a view mode from the
control.

These three options can also be accessed via the View menu, or by using the associated
shortcut keys that can be found there. The shortcut keys and menus work in the same
fashion, where invoking corkboard while you are already viewing an item as a corkboard
will switch that view mode off and go to single text mode.

422 Corkboard

Scrivener has made the corkboard metaphor popular in modern writing software. The
concept of representing many documents as index cards, letting you move them around to
restructure your book, or opening them up to edit their text, is quite useful—but Scrivener
2 takes this even further. Now you are no longer constrained to viewing index cards in
columns and rows; you can use the new freeform mode to move cards around as freely as
you might on a desk or real corkboard. Group together cards that are related, but spread
throughout your draft; spread things out in a chronological order; the choice is yours.
While you can choose to commit your freeform ordering back into your draft, you can
also feel free to just leave things as they are, as an alternate way of viewing a section of
your work.

The important thing to realise with the corkboard is that each of the displayed index
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cards represent files or folders in your binder outline. They display the title and the synop-
sis (a short description of the item), and optionally can represent a few kinds of meta-data
using real-world metaphors as well. Just remember, cards are documents, and conversely
documents can all be viewed as cards.

The corkboard view is rich with features, to read more about it and how to best use it,
see The Corkboard (section 11.1).

4.2.3 Oufliner

While the binder is in a sense a very simple outliner, there are often times when you need
to view your book, or parts of it, in a much larger context and with a greater degree of
information at your disposal. The outliner view lets you see your book structure in a
standard outline format with indenting used to indicate depth. It also has the ability to
display many details of your documents, such as label colour, word counts, modification
dates, keywords, your own custom meta-data and much more.

Since the outliner provides feedback for so much meta-data, it is a great mode for easily
making and viewing bulk changes to your documents. Many people like to brainstorm
in the outliner view as well, as it shows more than one level of depth at once. Whether
you prefer the analogue experience of the corkboard or the more literal but expanded
information in the outliner is up to you.

As with the corkboard, there are many features and uses for the outliner. To read more
about it, see The Outliner (section 11.2).

4.2.4 Scrivenings

This isa unique view mode in that it works not only with the viewed items themselves, but
specifically with their text, and is consequently a tool for working with text (and folder)
items, rather than multimedia files. All of the text content (even empty documents) will
be stacked together as if on a long spool of paper, letting you read through large sections
of your book at once, no matter where they are located. As you make adjustments to
the text in this view, each of the corresponding documents will be updated as you work.
The overall effect is as if you were working in a single long document, but in fact you are
editing potentially dozens or even hundreds of files as you go.

Scrivenings (frequently referred to as a “Scrivenings session” and known to users of
version 1.x as Edit Scrivenings) are temporary editing sessions. You don’t need to worry
about saving them, or what will happen if you click on something and they go away. It is
merely a way of pulling together a number of files so you can edit their text at once, and
then releasing them when you move on.

For more information on how to best take advantage of this editing mode, see Edit-
ing Multiple Documents (section 15.9). We will also explore a simple usage of it in the
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following Quick Tour section.

4.3 Composition Mode (Full Screen Editing)

Composition Mode (formerly known as “Full Screen”) is a special interface which will
blot out not only the rest of Scrivener, but the rest of your computer as well, allowing you
to concentrate fully on the production of text. It only works for documents and folders,
and while it provides access to the menus, QuickReference panels, and most aspects of the
inspector, its default state is to simply display the text contents of the selected document
(or documents, if you are viewing a combined text) in a “page” in the middle of your
screen. Read more about Composition Mode (chapter 17).

4.4 Selections

Selection and “Focus” are often important in Scrivener, as there are features which work
when only certain types of things are selected in the interface. A good example of this is
the Format » Convert » To Uppercase menu command. It has no meaning when a selection
of index cards is currently active, rather than some text. If there is a selection restriction
on a feature, this manual will often indicate as such using the following terminology:

@ Active: this relates to “focus”, or where the application is currently accepting key-
board input. In other words, if you tapped the ‘h’ key, that is where the ‘h’ would
be sent. In some cases this might not do much or anything at all; in an active editor
it would insert an ‘h’ letter, and in the Binder it would select an item starting with

‘.

@ Active selection: expanding on the above, an active selection is when something
is selected within the active area of the application. An example might be some se-
lected text in the editor, or three selected items in the binder or corkboard. Active
selections are often used as the target for various commands in the menus. An ex-
ample would be the Documents » Convert» Formatting to Default Text Style, which
would reset the text formatting for any selected documents in the active selection.

a Inactive selection: A selection can be inactive. If you select the Draft folder in
your Binder and then click in the editor, the selection will become dimmer (or
grey, depending on your settings). Inactive selections are seldom used, but there are
a few cases, especially when exporting.

@ Active text editor: the main text editor must be active (the insertion caret must
be blinking within it or text must be selected). In cases where the interface is split
into two editors, this not only means any editor must be selected, but the editor
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you wish to perform the function in. Some commands do not require text to be
selected, only an editor, others will perform universal actions if no text is selected,
but an editor is active; others will refuse to work unless you have a selection.



Chapter D

Quick Tour

Before going over this section, it is suggested that you skim through the prior chapter,
introducing the interface, if you haven’t done so already.

This chapter will get you up and running with a simple sample project and will in-
troduce a few of the most basic concepts you’ll need in order to start working in thirty
minutes or less. Scrivener is a complex program with a lot of potential depth, but we hope
this section will demonstrate that despite this, it is also very straightforward and intuitive,
so its complexity can be gradually learned as required. There is often a temptation to dive
in and learn as much as possible about a new tool, but if you are here for the same reason
as most people who’ve picked up this software, it is because you are serious about writing,
and so the most important thing this manual can do is get you doing that as quickly as
possible, in a fashion which is not too dissimilar from what you may already be used to.

We will go over the following tasks:

¢ Creating a new project from a blank template

¢ Navigating the binder and adding new documents to the Draft folder
- Working with the corkboard and Scrivenings text view

¢ Compiling the document into an RTF file

If you need to learn more than the above, we strongly suggest going through the full
tutorial, which can be found in the Help menu.

9.1 Project Format

Scrivener is a project based application, which means that it stores your projects as sep-
arate files, rather than working like a database which hides the location from you and
loads everything automatically when you start up the program, or a file based program
like Word, which creates an empty document whenever you launch it. The intended use
of a project is to store everything relating to a single major work, be it your next novel or

29
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Project Templates

‘ Getting Started
' User
Manual

Blank e Y YOlI Tube

e | femtmtpee
| .| Fiction
o Interactive Tutorial Scrivener User Manual Video Tutorials
i Non-Fiction
6 Scriptwriting

Poetry & Lyrics

—= Miscellaneous

+++ RECOMMENDED FOR ALL NEW USERS +++
An interactive tutorial in the form of a Scrivener project, enabling you to learn about all
of Scrivener's main features as you use them. This tutorial provides the fastest and most

effective way to get up and running, preparing you for creating your own projects. (Also
available from the Help menu.)

Options v Open Recent v Open an Existing File... Cancel Open

Figure 5.1: Template Wizard

screenplay, a dissertation for your masters, or a serial collection of articles for a magazine
or blog.

It is recommended that for each new “real world” project you embark on, a new project
file should be created'. When you create a new project, Scrivener asks where you want
to save the file. By default this location is your personal Documents folder, but you can
choose to organise your projects on the computer however you like. It is a good idea to
choose a place you will remember. Even though Scrivener provides convenience functions
for finding the projects you’ve worked on most recently, and will even reopen your last
session for you if you choose, these tools should not be relied upon as your sole reference
point for where projects exist.

Okay, enough theory. Let’s create a new project right now. Invoke the File » New

'There are, of course, many exceptions to this. A series of articles for a magazine might work very well
together in a single project.



5.2. THE MAIN WINDOW 31

®ee® &) interface-new_project - Untitled

B =2 [+ I 5] = 5 -+ El= a  Q
Binder fav Cochin </l Regular $J( 14 < B / U EE=E B (v | T(12 ¢ =
v ) E’aﬁ [ Untitled
> 5 Ressarch
» § Trash
+ m+ - 100% ¢ Words: 0 Chars: 0

v

Figure 5.2: A typical new blank project

Project... menu command (¢+8-N) if you do not already see the template selection inter-
face (Figure 5.1). In the left list of categories, click on the “Blank” entry (if necessary), and
then select the blank starter project. Click the Choose... button in the bottom right, or
just press Return. A window will appear asking where you wish to save the file. Choose
a location you will remember (the default is your Documents folder, but you might wish
to create a special sub-folder just for Scrivener projects), and give the project a name in
the “Save As” field. This name is what will be used on your disk, and so should be mem-
orable and placed in a location you’ll easily find in the future. Click the Create button
once you've decided on a file name and location.

5.2 The Main Window
The project will be created, and you’ll be presented with a fresh Scrivener project window
(Figure 5.2).

The left sidebar panel is your project binder, where everything stored or created in your
project will be represented in an outline structure. On the right side of the window we



32 CHAPTER 5. QUICK TOUR

have the editor (which is more than just a text editor, as we will shortly see). In most cases,
what you click on in the binder will be displayed on this side of the window. Along the
top, above the editor, is the Format Bar, which provides access to common formatting
tools such as font selection, justification, line spacing, and so on. If you cannot see all
of the tools, try expanding your window horizontally. If you want to see tab stops and
margins, use the menu command Format » Show Ruler or press $8-R.

Directly below the Format Bar is the editor Header Bar. The title of the current doc-
ument is printed here (“Untitled” since we haven’t named it yet). There are also some
buttons for moving around in your project and adjusting the editor view, but we’ll get
to that later. The important thing to notice right now is that the Untitled document has
been selected in the binder, and that this selection is being viewed in the editor.

Below the editor text area is the Footer Bar which contains information about the editor
session, such as your current word and character count, and often contains useful buttons
for adjusting the view.

The cursor is blinking in the text editor, and with zero words so far, it’s time to get to
work!

5.3 Outlining Your Draft

Why do that when we can procrastinate for another minute, though? Take a look at
the binder. Let’s discuss how best to use Scrivener’s Draft folder. Unlike a word proces-
sor, Scrivener’s design philosophy revolves around creating and organising your writing
project in arbitrary pieces according to what is most comfortable for you. For example,
you could make a new file for each chapter, or take that even further and make a new file
for each scene within those chapters. It is totally up to you, and unlike in most programs,
you won’t be penalised for breaking things down as small as you desire. The binder dis-
plays these pieces like an indented outline. It is easy to change your mind later, so don’t
get hung up on which is “right”, that may very well change for each project, or as you
progress in your familiarity with the program.

Let’s try it. If you haven’t touched anything yet, the cursor should still be blinking in
the main text editor (if it isn’t, just click in the middle of this white text area with your
mouse). Type afew words in here and then press the Return key to create a new paragraph.

Glance up to the top-left close window button (which is red on most Macs; or the left-
most traffic light button). You should see a little dot within the button. This means your
project hasn’t been saved yet. If you don’t see a dot, try typing another word into the
editor. By the time you finish examining it, the dot ought to disappear—your project has
been saved.
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The Implications of Auto-Save: Whenever you pause for two seconds, Scrivener’s
auto-save feature will kick in and save all your recent work. This is a very key thing to
be aware of, because many people have cultivated the habit of relying upon their last
save point as being a bit of a milestone. They can write freely and in an experimental
fashion, and if what they’ve done displeases them they can just revert to the saved copy
on the disk. The good news is that Scrivener is designed to work with this method, and
in fact its way of doing so is in general superior to using the traditional model, because
whenever you put down an anchor point, or a Snapshot, in Scrivener, you leave a trail
of them. You can view them all in a list later on, preview their text, and roll back to
any point in a document’s history. This is a little out of scope for this quick tour, so
for now put it on your list of things to look into if this is how you work, and when
you’re ready to start writing, check out Using Snapshots (section 15.6).

You might have noticed that the title of your document (printed above the editor, as
well as in the binder) changed when this happened. If you leave a document as “Untitled”,
the first line will be used as the title (or the first few words if it is a long line, like a
paragraph). This will only happen once, and you can always change the automatic title
to something more descriptive if you wish (you can also turn this feature off).

Let’s make a new document in the binder. There are a number of ways to do this, but
first let’s try the most direct method: click the large green + button in the toolbar just
once.

The cursor will flip over to the binder and let you type in the name of the new docu-
ment. Type something here, like “Masked Avenger”, and press Enter to confirm. You’ll
notice that the content you just typed into the editor has disappeared. This is because you
are now viewing “Masked Avenger”; you can verify this by reading the title in the editor
header bar. Let’s fix the name of the first document while we are in the binder. Press the
UpArrow on your keyboard once. Immediately, you should see the words you just typed
re-appear in the editor. That is because you are now viewing the first starter document.

To change the name, just press Esc and type in “After Math”, once again pressing Enfer
to confirm the name change.

You might notice something going on with the icons in the binder (Figure 5.3). The
document “After Math” looks like a page of text, but “Masked Avenger” just looks like
a blank sheet of paper. That’s because we haven’t typed anything into the editor for
“Masked Avenger” yet. Scrivener lets you know which parts of your project are still
placeholders.

For now, let’s use another method for adding new documents. When you are in the
binder, there is a simple way to add new entries below the currently selected item. Select
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Figure 5.3: Progress so far

“Masked Avenger”, and just press Enfer. Call this one “Wineries”. You can quickly build
outlines this way.

Now we will take a look at a great way to get an overview of your Draft. Either click
on “Draft” in the binder with your mouse, or simply press the LeftArow to jump up to it.
That key selects the “parent” of whatever item you currently have selected, in this case,
the Draft. When you view a folder in Scrivener, by default it will automatically switch
to showing you the corkboard in the editor area. You should see three index cards, one
for each of the items you’ve created (sometimes referred to as ‘Scrivenings’), but the cards
will be blank; this is because they display the synopsis for a document, not its internal
text. Double-click in the empty ruled text area on the “Wineries” card and type in a short
synopsis for this section of the book. When finished, pressed Enter to confirm.

At this point, if you look in the binder you’ll see a third icon type that looks like a small
index card, next to “Wineries”. This new one indicates that you’ve typed in a synopsis,
but haven’t yet typed in any text for the section. Once you enter text into the editor for
the “Wineries” section, the icon will be replaced with the one you see for “After Math”.
Some people like to work in a top-down fashion, building a conceptual outline and then
filling in what they intend for each section in the synopsis. These three levels of icons
give you an overall idea of your level of progress with this task.

We’ll try that now. Load the “Wineries” card by double-clicking on the icon next to
the title. If you can’t find the right spot, just click on it in the binder. Type in a short
sentence and observe that, as predicted, the icon has now changed to match the “After
Math” section.

You might be wondering how much text each section should hold. The answer is
largely up to you. With a word processor, it is often convenient to work in longer doc-

<
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uments because lots of small windows can create unmanageable clutter, but Scrivener
allows you to break things down into smaller pieces, since it organises all of these files
for you and keeps them in a logical order in the binder. In fact some people break things
down into pieces as small as paragraphs, others stick with chapter-sized chunks. You can
use index cards to represent beats, scenes, whole chapters, or even a mix of these depend-
ing on how much attention you need to give that portion of the book. It’s all very flexible,
and in many ways you can use the Scrivener outline to structure things according to how
you think, not according to how the book will appear. That may change later on when
you are ready to compile, but this can be ignored for now; there are good tools for break-
ing things down and merging things back together at whim. Working in a fluid fashion
at every stage of your project is more important than trying to force yourself to work
toward a strict goal.

5.4 Scrivenings Mode

Scrivener contains features intended to make that balance a little easier to work with.
Unlike most applications of this type, you can choose to view many different sections at
once and edit them as if they were a single file without actually merging them all together
permanently. Doing this is easy; let’s try it now. Select the Draft item in the binder again,
this time by clicking on it once with the mouse. You’ll get a corkboard again; now invoke
View » Scrivenings, or press $- 1. You are now viewing the collection of documents as a
Scrivenings session, rather than a Corkboard.

Each section will be divided with a horizontal rule, letting you know where one ends
and the next begins. Try clicking in the blank area between the two sections you've al-
ready added text to, and keep an eye on the Header Bar: note the title changes to let you
know where you are, “Masked Avenger”. Add some text by typing normally, then select
“Masked Avenger” in the binder all by itself. Note that your edits have been made directly
to the document. It couldn’t be easier.

Now we will do something else that is impossible in many programs. Right-click on
“After Math” and select Convert to Folder. The icon will change to a blue folder with a
small page in the corner. That page means the folder has text stored in it, in the same
way a text file might, and indicates that the text you added to this document earlier is still
there. This differs from stating that a folder has text items as children beneath it. The page
badge will only be applied if the folder item itself has text content. In Scrivener, folders
and text files are pretty much the same thing; it’s yet another demonstration of how you
can work fluidly now, and worry about details later.

Let’s move the folder text into a new child document: with the “After Math” item
selected in the Binder, press 8N, which is another way to create new documents. When
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a folder is selected in the Binder, new documents will automatically be assigned to it as
children. Call this new document, “Scene A”, and then click on “After Math” again to
select the folder and view it as a Scrivenings session. Scrivener always remembers the last
“view mode” you used. Since we switched to viewing items as Scrivenings, the project
will go on working that way until we switch it to something else (such as the default

Corkboard).

The first line of text you typed will be visible above the divider line, we want to move
it below the divider line, moving it into “Scene A”. You can select paragraphs in Scrivener
by triple-clicking anywhere within them. Try that now, and then drag and drop the text
below the divider. Notice that the page icon badge in the Binder has been removed from
the folder?, and the Scene A icon now has a page of typed text in it. Once again, anything
you do in a Scrivenings session is instantly made to the underlying sections it represents.
You could also have used standard copy, cut, and paste commands to move the text.

No doubt you can see that Scrivener is very comfortable with the notion of splitting
things up, and with this feature you can feel free to work in small portions without losing

sight of the big picture.

5.5 More About Corkboards

For our next experiment, select the View » Corkboard menu item to return to the cork-
board view. What you are seeing here is an important concept in how view modes inte-
grate together. The editor was in Scrivenings mode, giving you access to each file’s text
content, but is essentially focussed on the “After Math” folder. When you switched to
using Corkboard mode nothing changed about what you have selected, but rather how
you are viewing it. What you are looking at is the corkboard for the “After Math” folder,
which currently only contains one card, “Scene A”. Try clicking the Draft again in the
binder. Now you are viewing the index cards that belong to the Draft. “Scene A” has dis-
appeared because it is a child item of “After Math”, not the Draft. Meanwhile, the “After
Math” index card looks like a stack of cards. Folders will always look this way, even if
they don’t have cards within them.

¢ Corkboard mode will only show you one layer of depth in your outline at once,
but you can tell when index cards are folders or files that contain subdocuments
by the stacked appearance of their index card. Double-click on the “After Math”
index card’s icon and you’ll return to where you were at the start of this paragraph.
You’ve navigated “into” the “After Math” corkboard.

?1f that didn’t happen, you might have an empty line or two still in the folder text area.
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@ Qutliner mode, which we haven’t explored yet, is a bit more like the Binder in that
you can see items at all levels of depth beneath the current selection. It also has the
ability to show many columns of tabular data, and is great for tracking word counts
per section, just to name one usage.

- Scrivenings mode usually includes all text content beneath the current selection, no
matter how deep they are in the outline.

There is one main exception to these rules of thumb: Multiple Selections, which hap-
pen when you select more than one binder item at once. But, for simple single selections
such as what we’ve been doing so far, the above guidelines will help you decide which
view mode to use, depending on what you need to do.

You might be wondering about that oddly titled “Wineries” card. Let’s move it to the
Research section of your Binder, since in our hypothetical little universe here, it would be
used to collect research on various wineries that the characters are involved with. There
are multiple ways of moving items around in the outline, but the most familiar will be
drag and drop. Select the Draft folder again, then click and hold on the Wineries index
card in the Corkboard, and drop it onto the Research folder over in the Binder. This
demonstrates how easy it is to move material in and out of the drafting area, as well as
the fact that you can use a view mode to help organise your material in the Binder. In
larger projects, the Binder might become quite large, so remember this trick as it can
make moving items from one remote section of the Binder to another very easy. As you
learn more about the program, you’ll find other ways to specify content as being “meta”
to the draft manuscript itself, even while leaving it in the Draft.

Hopefully by now you can see the relationship between index cards, the binder, and
the text within the items in the binder a bit better. Feel free to play around with things a
bit more before proceeding to the next step.

Working with Existing Material: Likely, you already have content from an existing
work in progress you would like to bring into Scrivener for your first project. While
the methods described here could certainly help you with that, you might find the
Documents » Split » sub-menu to be even more useful in converting a long document
into an agile outline. For more information on this technique, explore Splitting The

Document (section 15.3.3).

5.6 Compiling the Draft

We’ve only scratched the surface of what can be done, but before ending this tour we’ll
look at one more thing: compiling. Compile is Scrivener’s terminology for what most
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applications refer to as Exporting. This name was chosen to reflect the fact that Scrivener
is doing quite a bit more than just converting the data from one format to another or
moving data to an external location that other programs can access. Scrivener’s compiler
can generate documents to a number of different formats, do simple or complex trans-
formations on the binder structure, reformat everything to a consistent look, and much
more. The philosophy of letting you work the way you want to work is very much sup-
ported by the compiler. There is no need to work in Courier, Times New Roman, or
whatever your editor or publisher prefers. You can choose an elegant font or one that is
easy to read at 3am with sore eyes. In the end Scrivener will generate a document to your
required specifications.

Let’s try it now. Press \-E or select the menu command, File » Compile.... After all
of the features described above, you might think you got the wrong function at first. By
default Scrivener presents a very simple form with some industry standard presets, some
common options, and an export file format chooser.

@ From the “Format As” menu, select “Standard Manuscript Format”

@ Change the “Compile For” option to Rich Text (.rtf)

That’s it. Click the Compile button, choose a name and location for your RTF file, and
once the dialogue box dismisses, open the file using the Finder. It should open with your
system’s default RTF editor. As you can see, all of the test lines you typed in are there,
with the header names prefixed with chapter numbering, and hash marks in between the
sections as well, those came from the Compiler too, as a part of the manuscript preset.
This can all be changed, or turned off entirely. Notably, the text you typed into the
Wineries card will 7ot be here. That’s because we moved it outside of the Draft folder.
The compile feature works exclusively” with the Draft folder.

Let’s try one more thing. Close your RTF document, switch back to Scrivener and
open up the compile window again. Leave everything the same, but this time click the
”All Options” tab at the top. The full compile interface will appear, and with that, you’ll
be able to see just how much power is available. Feel free to explore the interface and do a
few test compiles to see how things change. For example, if you don’t like the hashmark
separator between scenes, click on the Separators panel and change the first option “Text
Separator” to something else. Many of the options are self-explanatory, but if you find
yourself confused over something, read the relevant sections in the chapter on Compiling
the Draft (chapter 24).

3Well, all right, not entirely exclusively, but that’s a topic for another time!
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There is much more to learn, but if you are in the middle of a major project and want to
get started right away, you should now know enough to make a simple outline and start
writing content into that outline, and then compile your work as a single draft document.
As you've seen from the amount of flexibility we’ve demonstrated, you can rest easy on
the topic of “doing things the right way from the start”. Unlike many programs, Scrivener
makes it easy to change your mind later on. Folders can become files, items can be easily
re-arranged, merged, or split apart, and so on; so don’t worry too much about adhering to
any proper ways of working. Scrivener has no standard except for your standard, which
will develop in time as you become more familiar with the software.

Importing Existing Work: Chances are, you’ve already got some words down in an-
other program somewhere. Scrivener supports many different text formats, and even
a few data formats as well, like outliner formats (section 10.1). Importing material is
often as simple as dragging and dropping the file into the project binder. After doing
s0, you may wish to split it up into more manageable pieces (section 15.3.3). A good
rule of thumb is that RTF is the best. It is Scrivener’s native file format, so if you can
export your existing work to the RTF format before dropping it into the Binder, that

will generally be the best solution.

If you have a spare hour or two, it would be really beneficial to go through the full in-
teractive tutorial or watch the introductory videos* available on the Scrivener homepage.
Together, they cover Scrivener’s features in much more detail and should address most of
what you should know to get the best results in your work.

Further recommended reading:

1. Interface (chapter 4)

2. Navigating and Organising (chapter 8)

3. Gathering Material (chapter 10)

4. The Editor (chapter 14) and Writing and Editing (chapter 15)

5. Compiling the Draft (chapter 24)

For now, happy writing!

*http://www.literatureandlatte.com/videos/index.php
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The pages are still blank, but
there is a miraculous feeling of the
words being there, written in
invisible ink and clamoring to
become visible.

Vladimir
Nabokov

One of the principal goals of Scrivener is to be your first stop when a new major project
is embarked upon. The program therefore contains a variety of tools which address the
early phases of a writing project. These include: brainstorming, outlining, collecting and
organising research, gathering prose snippets, building background and world-building
information, and more.

Another Scrivener principle is that what works best for your readers and even your
editor might not work best for you as a writer. As writers, we see the text in a different
way, and we have different demands on how we organise that text. A table of contents is
great for a reader, but is it the best tool for a writer? What if you could have your own
table of contents, one that evolved out of the structure of the work itself, to a level of
detail you require and no less or greater?

This section will cover the majority of the tools that you may use to accomplish these
goals. If your methods couple the processes of writing and preparation, you might find
it beneficial to read portions of both this section and Writing (Part III). The level of
fuzziness between preparation and writing in Scrivener is very intentional, because the
same tools you use to build up initial structures and ideas will be the tools you use to write,
edit, and finish off your text with. In Scrivener, there is no separation between outline and
book order or content. This seamless approach will help you get straight into the writing
phase, even while you are still planning and evolving the work. Conversely, you can just
easily start writing prose immediately, and let the bigger picture emerge organically out
of what you write.

To better learn the fundamentals of Scrivener—such as where your works will be saved,
and how to use the binder to select items within your project to view or edit them—it is
recommended that you read the next three chapters. After that point, we’ll discuss some
more practical research, planning and project usage techniques, which can be learned as

needed.

The topics that will be covered in this part are:
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@ Project Management (chapter 6): Creating, saving, backing up, and managing
projects on the disk.

« Setting Up the Binder (chapter 7): Using the built-in sections of the binder, manag-
ing collections, organising your work, and setting up document templates.

¢ Navigating and Organising (chapter 8): Optimise how you navigate within a
project.

@ Setting Up Meta-Data (chapter 9): The various forms of meta-data available for
tracking progress and types.

& Gathering Material (chapter 10): How to collect material from other resources and
applications.

@ Project Planning (chapter 11): How to rapidly capture your ideas and give them
shape, shapes that will eventually become your manuscript.

¢ Cloud Integration and Sharing (chapter 13): How to take your work with you,
collaborate with others, and manage cross-platform usage between macOS and the
Windows operating systems.



Chapter 6

Project Management

Scrivener is a project based application and stores your projects on your computer in
the locations you designate when you create them. In this way it is much like any pro-
gram that loads and saves files to your disk—rather than a database style program where
all of your information is managed behind the scenes. These project files are saved into
your Documents folder by default, though you can choose to organise these projects how-
ever you like, even after you've created them. Some find it convenient to rely upon the
File » Recent Projects menu item to organise their projects, or simply just let Scrivener
maintain which projects are open whenever they start Scrivener for the day. These tools
are valuable, but shouldn’t be a substitute for good organisation on your computer, as the
tools can sometimes lose track of projects.

The intended use of a project is to store everything relating to a single major work,
be it your next novel, screenplay for a film, a doctoral dissertation, or a serial collection
of articles for a magazine. This can be approached in a flexible manner. It is possible
to use a project as a daily journal or maybe a collection of random things you intend to
one day utilise in future projects. Ultimately, the choice is up to you, and there are ways
to work around the default assumption where the Draft folder contains a single work.
These alternatives will be explored in more detail much later on, but you should know
early in the process that if you feel you would benefit greatly from having shared research
and notes for multiple real-world projects, you won’t be deeply penalised for doing so.
Also you should know that merging and splitting projects is fairly painless, so even if you
change your mind later, it won’t be a major setback.

Going a bit deeper, the project file is a cohesive folder of files, which will appear as a
single bundled package on a Mac, containing all of the pieces that make up your project
using industry standard formats. The accessibility of this format is meant to be used as a
last resort safe-guard, not as a way to allow you to edit a project in places where Scrivener
is not available. Project damage and data loss can occur from attempting to edit the
internal files by hand.

43



44 CHAPTER 6. PROJECT MANAGEMENT

6.1 Project Size Limitations

Since Scrivener was primarily written with the long-form author in mind, much effort has
been put into making the project format as robust as possible. It can handle book-length
manuscripts with ease, store large quantities of research material, and handle many thou-
sands of individual components, even on a single corkboard. Scrivener has been tested
against projects with millions of words in them; way beyond what it would normally
have to face. So for ordinary usage, you will never need to worry about limitations.

There is one caveat to keep in mind, however. The bigger your project is on the disk,
the longer it will take to produce backups. When combined with the automated backup
system, this could mean waiting long periods of time for backups to complete in the most
extreme cases. While Scrivener is very capable of handling large amount of media, some
users have found it better to use database software in conjunction with Scrivener, when
gigabytes of data are involved.

There is no universal rule of thumb on upper limits, this will be whatever you are com-
fortable with, and how much available storage space you have in order to keep consistent
backups. If you have an 8GB project, that means each backup will consume another 8GB
maximum (less if you use the slower zip archival option), and will take as long to produce
as it would to duplicate 8GB of data on your hard drive.

6.2 Creating a New Project

When you first start Scrivener, you will be presented with the Project Templates window
(Figure 5.1), which also includes a handy “Getting Started” section. You may hide (or
choose to reveal it again) this at any time using the Options... drop-down menu in the
lower left of this window. In addition to providing an easy selection mechanism for new
projects based on templates, you can also create a blank new document, open existing
projects from your disk, or select from a short list of recently opened projects. To call up
this window later on, use the File » New Project... menu command, or press 1+&-N.

Along the left side of the window are template categories. A number of useful templates
have been provided, and it is easy to make your own as well. The Options drop-down
menu provides template management tools. To read more about creating and managing
templates, see Templates (section 6.10).

To create a new project based on an existing template, click on that template to make it
active, or select the “Blank” template to start with a fresh project that can be constructed
to your needs. A description of the template, if one has been provided, will appear in the
grey text box below the selection area. Click the Choose... button to proceed. Enter the
name of your project in the “Save As” field. This is what you will use to identify your
project in the future, and it will also be used to name the folder (which will contain your
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entire project) saved onto your disk. It can be changed later, on the disk, if you please, so
if your work in progress doesn’t have a name yet, don’t worry!.

The next step is selecting where you would like to save the project file. It is a good idea
to choose a place on your disk that you will remember. You might want to create a special
folder in the Documents folder just for your Scrivener projects, for instance. You can use
the New Folder button to do so.

The Create button will activate once you have supplied a name and valid save location.
Click this button to proceed with the settings you have chosen.

6.3 Saving and Making Copies

While you work, your projects will be automatically saved on a frequent basis. By default,
this means that after two seconds of inactivity, the project will always be saved. You
can monitor this process by watching the upper-left corner of the window. The left-
most “traffic light” button will have a dot inside of it whenever the project contains edits
which have yet to be saved to the disk. If you stop typing or clicking in the interface for
a moment, the mark should disappear after a brief pause, and now everything is saved to
the disk. You can change how rapidly this happens by adjusting the inactivity interval in
the General section of the application preferences.

At times, or if you have selected a very long interval for some reason, you might wish
to manually save the project. This can be done as per normal in any application, by se-
lecting File » Save, or pressing - S. This feature need not be used to fully save the project,
however. Very often, by the time you activate this command, the project will already be
saved to the disk and it will do nothing. However if you work rapidly and rarely produces
pauses, it might be a good habit to get into.

It is also possible to save a separate copy of the project, while working, and continue
working in the new copy. To do this, select File » Save As... ({+&-5), and choose a new
name for the project. After supplying a new name and clicking the Save button, the active
project will become the new one you created, and the old copy will be closed. This can be
a useful tool when you wish to experiment with a series of radical structural changes. If
you merely wish to create a backup, or a trail of major milestones, but continue working
in the primary project, read about creating backups on the fly (subsection 6.11.3). It is also
recommended you use this method when creating copies of the project with the intention
of storing or sharing it over the ‘net. See Sharing Projects Over the Internet (section 6.8)
for more information.

Additionally, since Scrivener projects are just files and folders on your system, you can
use the Finder to manage projects, create duplicates, and archive old versions. Always be
sure to close your projects before doing so.
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6.4 Opening Existing Projects

Existing projects can be opened in a variety of ways. For convenience, Scrivener keeps
track of the last several projects you have opened, and stores them in a list, accessible from
File » Recent Projects.... In addition, this list can be accessed from the Project Template
window, via the Open Recent drop-down menu at the bottom.

By default, Scrivener will remember any projects you leave open when you quit, and
will re-open these for you the next time. This behaviour can be changed in the General
preferences tab.

You can open older projects using File » Open... (#-0), or click the Open an Existing
Project... button in the Project Templates window.

As with managing projects that have been saved, you can also use the Dock, Finder,
Spotlight, or other system tools to open files stored on your drive. Simply double-click
the project you wish to open in the Finder. Spotlight is also handy when a project gets
misplaced and you are unsure of where it is saved. If you don’t recall the name of the
project, you can search for “.scriv” to find every Scrivener project in your Spotlight index.

When trying to sort out the differences between near similar versions of a project, you
will find that the Quick Look information for your projects is quite extensive. A full
outline of the entire Draft will be presented to you, including any synopses that have
been typed into index cards. Use this ability to figure out which project is the correct
version, before opening it.

6.5 Moving and Deleting Projects

Despite being folders full of files, you can otherwise treat the project as you would any
other file or folder on your system. Everything that Scrivener needs to work with the
project is contained within the project file, and so moving it will have no detrimental
effect on it, and since everything is self-contained within this folder, it is a handy way to
transfer all of your working data to another machine.

Always close a project prior to moving it. While a project is open, Scrivener main-
tains a very close connection with the files inside of it. Since it cannot predict where you
will move the project, if it is moved while open the software will no longer save files in
the correct location, and can lead to lost work.

Projects act just like ordinary files in the Finder. The fact that they are special folders
can be largely ignored, and so they can be easily moved just as you might move a JPEG
file you downloaded, or a .doc file you have written in Word.

As with all file based programs, it is not possible to delete old and unwanted projects

from within Scrivener. To remove projects you no longer want, use the standard file
management tools as you would with other folders and files on your computer.
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6.6 Splitting Projects Up

Occasionally, one or more portions of your project might exceed the scope of your orig-
inal planning and become what should be their own projects. A classic example of this
might be a chapter in a biography that ends up becoming another biography about an-
other person entirely, or a short story that keeps growing and starts to become a novel.
Another common example are from those who use a dedicated Scrivener project as a com-
monplace book, or idea gathering tool. They might start developing an idea in this project
and once it is ready to become a screenplay or what have you, they’ll want to move it out
of the idea journal.

Fortunately, nothing could be simpler. There are two ways of going about this:

1. Create a new project for the pieces which merit moving them out of the parent
project. You can use whatever template you wish for this, or even blank, it doesn’t
matter. Now with the original project open alongside the new one, position the
windows so that you can see both binders at once. Now simply drag and drop the
pieces from the old project into the new project’s binder. That’s it, you’re done.

2. Use File » Save As... to create a fork copy of the entire project. Once you run this
command, you will immediately begin working in the fork. Simply delete every-
thing from the binder that isn’t necessary for this new project.

The first method might work better if your needs are simple. If you do not have a lot of
meta-data and never work with linking items together, it’s safe to do. However if you use
a lot of labelling, custom meta-data or status markings, the second method will be better.
Most meta-data will transfer, even snapshots, when dragging and dropping. Anything
that requires the project itself be set up a certain way however, like particular labels with
predefined colours, will be more touchy and transfer, and Scrivener Links will always fail
(references, so long as they point to items within the dragged selection, will work, so long
as they are all moved at once).

At this point in your reading (if you are going through this in a linear fashion) some
of the above might be arcane knowledge, so feel free to bookmark this page if you feel
you’ll need it in the future, so that once you know more about the things you can do in
Scrivener, you can make a more informed decision.

6.7 Tips for Working Cross-Platform

The Scrivener project format!' is fully compatible with its Windows companion. No con-
version is necessary, and both versions can work off of the same source file (at different

!On a Mag, it is important to note that only Scrivener version 2.x and greater is cross-platform compat-
ible. If you intend to use the Windows version as well to edit your projects, you should consider upgrading
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times; no project should ever be opened more than once). The primary difference in ap-
pearance between the two platforms is that Windows does not have a “package” or “bun-
dle” format like the Mac does. Thus, the Scrivener project will appear in its ordinary
state, which is a folder. This is invisible to a Mac user, but in fact there is no difference
between the two.

To open a project on the Mac, you need only double-click the “MyProject.scriv” project
bundle, or open it from within Scrivener. On Windows this will be a folder, so you
will need to descend into the “MyProject.scriv” folder and select (or double-click on) the
“MyProject.scrivx” file that you will find at the top level within that folder.

To transfer projects between computers, always make sure to copy the entire “MyPro-
ject.scriv” folder from Windows, not just the .scrivx file by itself; the entire folder is your
project. If you intend to use e-mail, file sharing services or other common methods of
sharing files over the Internet, refer to the next section, Sharing Projects Over the Inter-
net (section 6.8).

6.8 Sharing Projects Over the Internet

If you wish to share a project using the Internet, you might think to attach it as an e-mail,
or upload it to a file sharing service so that one can download it or save a copy to an online
backup service. Given that a project is a folder of files (whether you can see that aspect
or not on the disk), the best way to send a project as a single “document” is to use zip files
(or whatever archive format you prefer).

There are numerous ways to create zip files, including using the operating system it-
self, but if you’re looking for an easy way to do so from within Scrivener, try using the
File » Back Up» Back Up To... menu command from the project you wish to send off.
Within that dialogue box you will find an option to back up as a zip file. This will “pack”
your entire project into a single compressed file which will transfer across the ‘net more
quickly and safely.

Opening zipped projects: Zip files do not load in Scrivener, you will need to “unpack”
the project from the zip file before it can be opened. This is usually as simple as double-
clicking on the zip file and extracting the contents to your working folders.

6.9 Project Format Upgrades

Sometimes we need to modify how Scrivener works with project, and in these cases it will
be necessary for the software to update the project format. This will entail modifying how

to the latest version.
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various internal components of the project work, and will not modifying your content,
merely how the software works with it.

When opening an older project you will be asked if you wish to update the project.
Click the Update Project button to proceed with the project update. It is safe to cancel,
your project will not be touched by this version of Scrivener.

Coffee Break Alert: Larger projects may take some time to update. A complete copy
of the entire project will be created before the updating process is started, so for projects
that measure in the gigabytes, it may take quite a while for the full process to complete.
It is strongly encouraged that you let the process complete fully, rather than interrupt-
ing it. If you are in the middle of a busy schedule or coming up on a hard deadline, it

might be best to defer upgrading Scrivener until you have time to devote to the process.

The first action that will be taken is to create a complete backup of the project in its
current state in the same folder where the project is presently located. If you have a project
called “My Thesis.scriv” in your Documents folder, then a backup project called “My
Thesis Backup.scriv” will be placed in your documents folder.

Next, the main project will be updated to the new format. At the conclusion of the
process, the project will open.

Trouble? If for some reason the project won’t update correctly or open at the conclusion
of the process, the backup created earlier will be handy to restore from. Again using our
example from above, set aside or delete the “My Thesis.scriv” project file and rename
“My Thesis Backup.scriv” back to how it should be, then try again. If you have repeated
difficulty updating the project, please contact technical support?.

Projects used with Scrivener 2.7 for Mac and 1.9 for Windows will not open in
older versions of the software for either platform. Make sure to update all of your
machines to these versions or greater, and make sure that your colleagues are up to date
as well if you collaborate by sharing a project.

6.10 Templates

Simply put, project templates are ordinary projects which have had some basic structure
and settings added to them. In some other applications, templates are almost a way of
modifying the way the entire application behaves and so in a way the presence (or lack)
of templates as features define the shape of what the software can do. With Scrivener, it’s
best to think of them as example starter projects, or even better yet, a learning tool. Many
of them come with a few example items added to the binder, but these are meant to be

Zhttp:/ /www.literatureandlatte.com/support.php
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helpful guides for laying out your book, not forms that you have to fill out or features that
must be worked around. The items added to templates are like any other items you’ve
added to projects on your own. They can be deleted, modified, duplicated, or set aside
and ignored.

In fact, you can create your own templates for future use, which will be covered in more
detail in the following pages. This is often a useful way of further customising Scrivener’s
default behaviour, as many settings found in menus are specific only to the projects you
make them in. Since the built-in templates are just starter projects, you can use them
to create your own derivative templates based upon them. Like many others, you may
decide a better starting point for you is just the blank starter, or a slightly modified version
of it with a few of your preferred project settings.

6.10.1  Using Built-in Templates

Most of the built-in templates will provide you with a readme-style document at the very
top of the Binder that explains what the purpose of the template is, what has been modi-
fied and set up for you, and how best to use it to develop your project. Most also contain
a sample PDF showing how the final manuscript will be formatted if all of the project
settings are left alone.

For templates that do not come with a help file, here are a few things to keep in mind
as you explore templates:

It is worth saying again: templates are just starter projects. With the exception of a
few and somewhat technical differences, there is nothing in a template-generated project
that is different from a blank project. In fact, a blank project is essentially an extremely
minimal template. Everything that you see in a template can be handled just as you would
handle any other items in the binder. They can be duplicated, deleted, modified, turned
into document templates, or what have you. Scrivener templates do not provide you with
“forms”, “wizards”, or parts of the interface that you must fill out before proceeding. A
sample chapter with an empty scene in it is just what it looks like: a folder with a file in
it. To change it, edit it as you would any other piece of outline. If you want another one
to make a second chapter, duplicate it. Scrap it if you don’t like the style at all and want
to design your own structure.

When you use a new template for the first time, check the project meta-data settings
(Project » Meta-Data Settings...) and make sure that everything is arranged the way you
prefer.

Some templates will change the name of the Draft and Research folders to some-
thing more appropriate. The novel template, for example, changes the Draft name to
Manuscript. Note that when the Draft has been renamed, all interface elements that refer
to it will have their labels updated.
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Some templates will have “document templates” inside them, already pre-configured.
This will provide you with starter documents for creating new elements within the tem-
plate. You can modify the items in this folder to customise them or add your own.

6.10.2 Creating Your Own Templates

Creating custom templates is as easy as creating a new project, and if you often set up
projects with the same starter items—like character sheets, keywords, or custom labels—
personalised templates will save you a lot of time. Here is a list (by no means complete)
of things that are commonly changed or added to custom templates:

¢ Custom labels & status: add the types of labels, preferred colours, and status stamps
that you find useful for your projects.

- Project references: try making a list of writing resources, critique groups, and re-
search portals that you often use.

¢ Character sheets or research note starters use Document Templates (section 7.5) to
supply yourself with your favourite starter documents.

@ Compile settings: since compile settings are stored in the project settings, you can
configure these so that your future projects will be ready for one-click export (or
close to it!).

8 Starter Collections: standard collections as well as saved search collections can be
placed in a template as well, though initially they will probably be empty.

& Starter story structure: set up your favourite story-building techniques and outlines

in the Draft.

The important concept to keep in mind is that whatever you can save within a project,
you can save as part of a template’. There are a few differences (mostly pertaining to how
a template is loaded and the description and thumbnail that can be saved with it), but for
the most part you should consider a template no different from an ordinary project.

Try not to worry about getting everything perfect the first time through. On average,
it will take at least half a dozen new projects before things start to settle down. It is easy
to update existing templates with revised material; this will be covered in greater detail in
the following pages.

3Technically, there is a 50 MB size limit to what can be saved as a template, but given that a template is
intended as a starter project, you are unlikely to ever encounter this restriction.
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Once you have set everything up, use the File » Save As Template... menu item to start
the template creation process.

In the “Template Information” box, provide the following details:

Title The visible title of the template (what will appear beneath the thumbnail in the
template browser).

Category Which section to add the template to in the browser.

Description A brief description of what the template provides. You may not find this
necessary for yourself, but if you intend to share the template with others, it is a
good idea to explain what the template is meant to provide.

The “Icon” box on the right gives you options for setting the appearance of the template
thumbnail. You can choose from a number of available presets, or if you wish to make
your thumbnail stand out from the built-in templates, you can click the Save Icon as
File... button, which will generate an image file for you based on the currently selected
thumbnail. After you have edited this image in your favourite image editor and saved it
as a graphic file, you can use the drop-down menu to select Custom... and choose the saved
file from your computer.

After clicking OK, the template will be saved into the system, and you can delete the
original project or continue working in it without affecting the template.

Retina Friendly Icons

Creating graphics that look good on both high-resolution displays and standard displays
requires the use of special files, formatted with two individual images inside of it. Un-
fortunately the technique that Apple uses to work these special images is not a standard
technology, so no normal graphics editing programs will be able to view both pieces of
the file or create one. Opening and saving the TIFF file that Scrivener creates will discard
the normal quality image, meaning that the resulting graphic will be too large for standard
displays and be reduced by the software, causing a blurry image to appear in the template
chooser.

Literature & Latte has created a free tool called MultiTIFF, available from our web
site in the free downloads section® which can help you extract multi-TIFF files or cre-
ate them. All of Scrivener’s default template icons are embedded with high-resolution
and low-resolution versions of the icon. If you open them using this tool, use the
File » Export» Both Images menu command to create two PNG files. These can then be

*http:/ /www.literatureandlatte.com /freestuff.php
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modified in the image manipulation tool of your choice, saved, and then dropped back
into the MultiTIFF window in the respective slots. Saving the file will create the dual-
image TIFF file which can then be used in the project template creation tool as describe
previously.

Custom Document Icons: For the same reasons, custom document icons you create
for the binder (section 7.6) would need to have two versions of the file if you intend to
view the project on more than one computer and care about the quality of the graphics.
For best quality, icons should be 32 x 32 pixels for high-resolution, and 16 x 16 pixels

for standard resolution.

Template Placeholder Tags

In addition to the standard project elements you can include in a template, there are a few
placeholders that you can type into the editor which are especially useful if you intend to
share the template with others. For example, if making a template for yourself, you could
just write in your name and address on your manuscript submission cover-page. This
wouldn’t work so well if you wish to share the template, though, and in fact Scrivener
will check your templates for stuff that looks like your personal information and warn
you if you wish to proceed. Template variables let you place a special code where text
should occur, and when the template is used to create a new project, it will consult your
Contacts.app for the relevant information. Many of the built-in templates that ship with
the software have been set up to do this already, which is how they place your personal
information into new projects. You’ll find a list of available placeholders here (Table 6.1).

If you wish to edit a template which uses these variables (such as many of the built-in
templates), follow these instructions:

1. Create a new project ({+&-N).
2. Select the template you wish to edit.
3. Hold down the Option key, and click on the Choose... button.

4. You can let go of the Option key and give the project a name.

Holding the Option key will inhibit the substitution of these placeholders for their
Contacts.app equivalents, so you can edit the template file and then save it as an update.

Updating Templates
To update a template which has already been saved, follow the above instructions to create
a new project using the template you wish to alter, without substituting the placeholders,
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Table 6.1: Project Template Placeholders

Code Description

<S$template_firstName> First name from Contacts.app

<S$template lastName> Last name

<$template_fullName> Combines the first and last name for you, ordering them
according to system language preferences.

<S$template_initial> First letter of first name from Contacts.app

<S$template_street> Street address

<S$template_city> City

<S$template_ZIP> Postal code

<$template_state> State or county

<$template_country> Country

<S$template_phoneNumber>  First phone number listed in your address card.

<$template_email> First e-mail address listed

<S$template_projectName>  The file name of the project from when it was created.
Note this will not include the “.scriv” portion on the end.

make any changes you wish, and then choose File » Save As Template.... All of the infor-
mation from the original template will be filled in for you, so you do not have to worry
about replicating this information every single time. If you do not need to make any
changes here, just click the OK button and then Yes to confirm that you wish to update
the existing template.

Note that after you have created a project from a template, the two have no further
connection. Thus, existing projects that you created from a template will not be modified
to reflect changes made to the template. Likewise, if you have created a project purely to
update a template, there is no need to keep the project around after that point, as allowing
the project to auto-save will not automatically update the template; you must choose Save
As Template... again.

Built-in templates cannot be overwritten. However, you can create projects from them
for editing and then save your modifications as a new template by giving it a new name.

6.10.3 Managing Templates
In the Template browser window, the Options menu in the bottom left provides the fol-
lowing for managing templates:

Set Selected Template as Default Changes the default template selection to whichever
template you currently have selected. A yellow border will appear around the se-
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lected template. Once this is set, the next time you call up this window it will
highlight that template for you.

Hide Getting Started Disables the special starter category at the top of the category
list, which contains useful links to the Interactive Tutorial and the User Manual.
These can also be access from the Help menu at any time, so it is safe to remove the
Getting Started category once you’ve familiarised yourself with the program. You
can also choose to reveal it again in this same option drop-down.

Import Templates... If you have downloaded templates from the Web or copied your
custom templates from another computer, use this feature to import the files into
the template system.

Export Selected Template... Useful for sharing your templates on the Web with other
authors or for transferring templates to another working computer.

Delete Selected Template When a custom template is selected, you can use this menu
item to remove it from your system. Note that the built-in templates cannot be
removed.

6.11 Backing Up Your Work

Regularly backing up your work is an important part of the writing process in that it
keeps your efforts safe, and while there are many external strategies for keeping your
work safe from catastrophes and mistakes, the most important part is remembering to do
it. Fortunately it is possible to set up Scrivener to handle most of the latter part for you.

6.11.1 Configuring Automated Backups
By default, Scrivener will automatically back up every project that you work on, when-
ever you close it. These backups will be stored in your user folder:

~/Library/Application Support/Scrivener/Backups

For those using the Mac App Store version, this will be in your Scrivener sandbox
container instead:

~/Library/Containers/com.literatureandlatte.Scrivener/Data/
Library/Application Support/Scrivener/Backups
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[10.8 (Mountain Lion) Only] It is important to note that if you have changed this
location in the past, when you first run the new Mac App Store sandboxed version, the
target backup folder will be changed to the above. If you wish to go on using the original
location you set, you will need to manually choose it again. This action gives Scrivener
permission to continue doing so in the future, it cannot imply permission based on your
prior settings, so this explicit step must be taken by you.

This location can be changed in preferences, and could even be set to save into a folder
that is synchronised over the Internet, such as with Dropbox. Also by default, projects
will be zip archived to save space and protect the internal files from external utilities or
transmission errors, and Scrivener will rotate the files (delete old backups) to keep the
maximum for each project under 5 backups. In most cases, the more automatic functions
you activate here, the slower things will get. Finding a balance between frequent backups
and usable settings will be up to you.

It is important to note that the backup system, as it ships by default, is set up with a
common method of working in mind, whereby you close your project on a regular basis
(say at the end of every day). If you find your own work habits deviate from that, you
would do well to go over the Backup preference tab, and change the settings to better suit
your style of working. Those who leave their projects open for weeks or even months at
a time, will most certainly want to change the backup settings to be triggered by manual
saves, and remember to run a manual save at least once a day for maximum protection.

On the other hand, if you open and close projects multiple times a day, you might
find the default limit of only five copies too limiting. Mistakes you’d like to revert may
have rolled off the backup list because five backups were created in the past day or two.
Increasing the number of stored backups to a higher value means more drive space will be
used for each project, but will ensure you have something from more than a few sessions
ago to restore from.

In cases where security is a concern (if you are working with confidential files in a
protected area for example) the automated backup system might present a security risk
if it produces files in an unencrypted area of your hard drive. If you are working in an
encrypted environment, make sure the backup location is set to also output to that area,
or use the File » Back Up » Exclude From Automatic Backups menu command to restrict
the sensitive file from getting backed up with the rest. Read Using Scrivener in a Secure
Environment (section E.2) for more tips on locking down your projects.

Read about the various options available in the section on the Backup tab (section C.11)
in Scrivener’s preferences.
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6.11.2 Managing Backups for Large Projects

Very large projects can conflict with what would ordinarily be good settings for the auto-
mated backup system. If a project has reached a point where backing it up automatically
has become a nuisance, rather than decreasing the amount of backup security globally,
consider excluding the large project from the automated system.

While the project is open, use the File » Back Up » Exclude From Automatic Backups
menu command. Once this option is checked off, the automatic backup system will ig-
nore this project entirely. It will then be up to you to keep manual backups of the project.
The File » Back Up » Back Up Now feature is useful in this regard.

6.11.3 Manually Backing Up

Backups can be created whenever and wherever you want. Use File » Back Up » Back Up
To... and select a backup location and filename. The “Backup as ZIP file” option in the
subsequent dialogue will compress the backup project into a zip file after saving it, and is
thus useful when backing up to remote storage locations, such as Dropbox. By default,
backups will be timestamped, making it easy to find a precise version later on and reducing
confusion over which version of the project is the most up to date (the one without a date
1s your primary project).

It is also possible to manually trigger the automatic backup system, even for projects
which have been excluded, by using File » Back Up » Back Up Now. This will follow any
relevant options that have been set in preferences, such as how many to keep, where to
store them, and how many to keep around. Do be aware that since automatic backups
rotate the oldest versions out, if you use this command frequently you might end up losing
a backup you later want. If unsure, use the manual command to create a new backup file
at a location of your choosing.

Frequent use of this feature will help safeguard your work in progress, and it is recom-
mended that you start forming a habit of making backups whenever a decent amount of
work has been committed to the project.

6.11.4 Restoring from Backups

In the unfortunate event that a backup is needed to fix a problem with your current work-
ing project, restoring couldn’t be easier. As noted previously, backups are by default just
Zip archived projects, a compression format that is natively supported by all modern op-
erating systems. They are, compression aside, no different from the project you work
with on a daily basis, though they will be successively older revisions, and therein lies
their power. The only other thing that makes them special is that they are tucked away
in a safe out of the way place, to help avoid being inadvertently modified. If you are un-
sure of where your backups are located, you can always open the folder they are stored
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in by opening the Backup tab in Scrivener » Preferences... and clicking the button at the
bottom, Open backup folder..., to reveal them.

What are Zip files and how do I use them?: Zip files are a “container” file format.
You can think of container files as being a bit like boxes. You can stuff other things into
a box, tape it up and store it in the attic. It takes up less space and protects the things
inside the box to a degree. It makes them easier to move around because it makes lots
of little things seem like one thing. However a box is not the thing(s) you put into it.
This might seem like common sense, but a lot of people wonder why they cannot open
their .zipped project backups in Scrivener. The reason is simple: so longasitisina.zip
file, it is not a Scrivener project. You would not try an eat a candy bar that had been
placed inside of a cardboard box. To eat the candy bar you need to remove it from the
box (and probably from its own wrappings) first. The same goes for digital files that
you store inside of a digital box. They must be removed from that box before they can

be used.

Once there, you'll find a number of files named respectively with the projects they
relate to. After the project name there will be a sequence number or a date stamp. It
is best practice to select the backups you wish to check and copy them to a temporary
location, first. The backup folder rotates content, so copying a set out will ensure these
backups do not get deleted by Scrivener’s cleaning routine while you experiment. To do
so, simply click and drag the selected .zip files while holding down the Option key, and
drop them some place convenient, like your Desktop.

Locate the most recent backup’ and unzip it by double-clicking on the ‘.zip’ file.
Zipped projects cannot be opened directly in Scrivener. The unzipped project is a full
project and can be opened in Scrivener in the usual way. Examine it, and if it will suffice,
close it, then remove the broken version of the project and replace it with this extracted
copy. You can now clean up the temporary working area if you wish and continue work-
ing as normal. If it contains the error as well, then proceed to the next older backup,
continuing until you find a valid copy.

If you find you need to only restore pieces of a project, you can open your current
working version at the same time as the backup, and drag those pieces from the restored
backup project into the live working project, from binder to binder. This can be useful if
you’ve done a lot of work since the last backup, and have only just noticed that one file

>The sequence number cannot be used to determine this as Scrivener rotates through numbers. If
you have not enabled the date stamp option, you will need to use your operating system to determine the
modification date of the file.
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had been accidentally messed up some time ago, and there are no snapshots to recover
from.

Once you've finished, the files you’ve worked with on the Desktop can be removed at
your convenience.

6.11.5 Tips for Using Time Machine

Time Machine will automatically back up your computer once every hour, and store
backups as far back in time as possible, reducing the frequency of these backups the further
back in time you go.

This presents a unique problem with Scrivener in that the hourly backup routine is
likely to run while you are working in Scrivener. This means that Time Machine will
be capturing your project while it is open and in progress, a state that could produce
incomplete backups if you try to restore from that particular point in time. Frequent
users of Scrivener may very well keep their projects open for weeks at a time, meaning
good backups of their project will be few and far between.

There are fortunately a few tips you can use to help Time Machine work effectively
with Scrivener:

1. Time Machine can be set to run manually at any time of your choosing, using the
menu status icon in the upper-right hand portion of your display. You can thus
control when Time Machine makes a backup of your projects, making sure they
are closed first.

2. As Time Machine starts to erase hourly backups that are old, it saves only the last
backups made in a single day. In conjunction with the first tip, you can make certain
that your “safe” backups are retained once Time Machine starts erasing old backups,
by always running Time Machine manually at the end of every day.

3. Always use Apple’s Time Machine interface to restore projects. The way they are
stored on the backup disk means they are in actuality held at scattered locations
throughout the external backup disk. It only saves the parts of a project that have
changed to save space. Copying a .scriv file out of the backup disk will hardly ever
result in a valid project file. Apple’s Time Machine tool will always re-assemble a
complete version of your project by building it together from hundreds of individ-
ual backups.

Going the extra mile: Time Machine is a wonderful tool for what it does, but it
shouldn’t be used as your sole backup for two important reasons. First, being attached
to your computer at all times, it is thus susceptible to the same risks of damage and loss
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due to theft or catastrophe. Second, no backup system should be considered infallible,
and thus you should have more than one method. Time Machine isn’t perfect; don’t
let it be your single safety net.

6.12 Sandboxing and Authorised Folders

[App Store Version ] Sandboxing is a technology introduced with Mac OS X 10.7 (Lion)
intended to provide extra security. In order to enforce these enhanced security measures,
Apple has ruled that all applications sold via the Mac App Store must be sandboxed.
Sandboxing provides this extra security by limiting the tasks that applications are allowed
to perform. One such limitation is that applications can only access files and directories
that the user has granted access using an Open or Save panel.

This means that Scrivener is unable to open or access arbitrary files on your system
without you telling it to. For the most part, this is fine—when you open a Scrivener
project, most of the files it needs are contained within that project file and, by opening
the project, you have given Scrivener permission to operate on those files, meaning that
you can edit, save and work as usual. However, there are certain types of files that, under
sandboxing, Scrivener will not be able to access so easily:

@ References: Scrivener’s inspector can store a list of references to external files. Be-
cause these files are stored outside the project, Scrivener may not be able to open

them by default.
@ Alias files: it is possible to import research files as aliases using
File » Import» Research Files as Aliases...  under sandboxing, Scrivener may

not be able to open such files, and when you try to open such files in the editor
you will see a message telling you that the file cannot be opened.

@ Linked images in text: when inserting an image into text, rather than inserting a
copy of the image, it is possible to insert it as a link to the original file on disk using
Edit» Insert » Image Linked fo File... If the original images are stored in locations to
which sandboxing does not grant Scrivener access by default, these images may not
appear correctly in the text, a placeholder image being displayed instead.

6.12.1 How to Grant Scrivener Access to More Files

Fortunately, there’s an easy way to grant Scrivener permission to various locations on
your computer so that Scrivener can still use all of these files. Here’s how:

1. Use the Scrivener » Authorize Folder Access... menu command to open the directory
access panel.



6.12. SANDBOXING AND AUTHORISED FOLDERS 61

2. To grant Scrivener permission to access external files, simply click on the Add Fola-
ers... button. This will bring up an Open panel from which you can select the
directories you wish Scrivener to have access to. Alternatively, you can just drag
files into the “Accessible Folders” list from the Finder.

3. To stop Scrivener accessing files, select the folders in the list that you no longer wish
Scrivener to have access to and click on Remove Access.

6.12.2 Tips

When you grant Scrivener permission to access a directory, it will be able to access all of
the files inside subdirectories of that folder too. Thus, you need only select the highest
level folders that you feel comfortable giving to Scrivener.

The main thing to consider when adding folders to the list is which files you need
Scrivener to access. For instance:

@ If you tend to import many different files into Scrivener as aliases (using
File » Import » Research Files as Aliases...), or if you make heavy use of Scrivener’s
“References” inspector list to refer to external files, then you may wish to con-
sider adding your entire home folder to the list of accessible folders. This will
give Scrivener access to all folders inside your home folder without you having
to add them all separately, such as your Pictures, Movies and Documents folders.
The downside of this approach is that it somewhat defeats the point of sandboxing,
which is to ensure that, should any malicious software take control of your other
programs, it is limited in what it can access. Thus, although adding your entire
home folder is the easiest approach, it is also the least safe in the event that your
computer is exposed to malware.

@ If you are very careful about where you store all the files on your hard drive, and
you only tend to add images to Scrivener as linked files and import a few sound and
movie files as aliases, you might only need to add the ~/Pictures, ~/Movies and
~ /Music folders to the list.

¢ Perhaps the safest and easiest approach would simply be to have a folder somewhere
on your hard drive for storing your research documents, and only grant Scrivener
access to that.

Essentially, though, for any files you want to be able to view in Scrivener
that are not stored inside the Scrivener project, you must grant access to one of
the folders containing that file. For instance, suppose you have added the file
“~/Documents/Ideas/Writing/MyGreatldea.pdf” as a reference in one of your projects.
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For Scrivener to be able to open that file, you must grant access to one of the following

folders:

@ ”~ /Documents/Ideas/Writing”: in which case Scrivener will be able to access all
files inside the “Writing” folder.

@ ”~ /Documents/Ideas”: in which case Scrivener will be able to access all files in the
“Ideas” folder, as well as any folders contained in the “Ideas” folder and any files or
folders inside those.

@ ”~ /Documents”: in which case Scrivener will be able to access all files, folders,
subfolders and sub-files within the “Documents” folder.

@ ”~/”: in which case Scrivener will have full access to your home folder. (Adding
this is the easiest option if you do not want to have to worry about authorising the
right folders every time you add a new file, but it is also the least secure.)
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Setting Up the Binder

This chapter will go over the various aspects of the binder, and how to best use Scrivener’s
features to structure, navigate around in, edit, and write your draft. Scrivener does some
things which are unusual, and generally restricted to high-powered expensive applications.
As a consequence, this can result in some interesting surprises, some of which are revealed
in the built-in templates distributed with Scrivener.

/.1 How the Binder is Organised

The binder is the document browser on the left of the main window where you can or-
ganise your files (by default it is coloured a pale blue when the project window is active).
It allows you to structure and rearrange your work with the utmost flexibility, much like
a ring-binder in the real world (hence the name). To provide one example, you can drag
files from the Finder straight into the binder to import them, which you can read more
about in Gathering Material (chapter 10), or from one project binder to another.

The binder is an optional element, though in most cases you’ll want to rely on its
organisational features at all times. To hide the binder, click the Binder icon in the toolbar,
select View » Layout » Hide Binder, or press \#-B. All of these commands can be used to
restore its visibility if it has been hidden.

The binder is labelled at the top. Some functions will automatically replace the Binder
view with a specialised listing. Project Search Results are the most common of these. This
label will change to reflect whatever sidebar view is currently in use, and additionally the
colour of the sidebar background will change to help notify you that you are no longer
looking at the main project binder. You can always get back to the binder by clicking the
small X button in the footer bar of the binder, or by clicking on its tab, if Collection tabs
are set to visible.

7.1.1 The Three Rooft Folders

The binder has three default root folders which cannot be deleted or moved from the
top level (although they can be renamed, moved around amongst each other, but not
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Binder
i - | Draft

Research
 Trash

Figure 7.1: The three default top-level folders

within each other or other folders). To use Scrivener effectively, it is very important to
understand the significance of these folders.

The Draft Folder

As the name suggests, the Draft folder is where you place all of the files you want to
include in the actual work that others will read. How you structure it is entirely up
to you—you may have parts and chapters, or you may have separate files for each scene
within each chapter, or even separate files for each individual paragraph if you so wish.
This user manual, for example, has each section of the manual in its own document. From
this header “The Draft Folder” on to the next, “The Research Folder”, is the contents of a
single document nested within the “How the Binder is Organised” section, which is turn
nested within the “Setting Up the Binder” chapter group, and so on.

My Project Doesn’t Have a Draft Folder: Some of the templates that we provide with
the software have had the Draft folder renamed to something more meaningful to that
template’s purpose. For example the Novel template has the Draft folder renamed to
“Manuscript”. The Draft folder can be renamed to whatever you prefer, and in fact
some people use that to type in the name of their work. The key thing to look for is
the special icon'. Only one item can have that icon, so no matter what it is called, that
is your Draft folder.

Everything that goes inside the Draft folder will be compiled into one long text file
when you use the “Compile...” command from the File menu (excepting documents
that have their “Include in Compile” setting unchecked). Thus, the Draft folder is central
to Scrivener: ultimately, you are aiming to complete and arrange everything inside the
Draft folder so that each of the elements it contains form an organic whole that can then
be output as a single file to the format you require (which could be anything from a web
page to a Word document to an e-book).
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Because the Draft folder is what is used to create the final manuscript, it is unique in that
it can only contain text and folder files. While media files cannot be placed directly into
the Draft folder, images can be placed into the text files themselves, in their appropriate
locations within the text, just like in a normal word processor.

A good way to think of the draft is like a long spool of paper or a scroll. In a normal
word processor, this entire spool would be presented to you in a single window, with
one scrollbar. Moving text around within that spool means cutting and pasting it from
one spot to the next. In Scrivener, you can take that long spool of text and chop it up.
These chopping points are entirely up to you—what you find useful as a writing tool.
The compile feature offers a way to tape the whole thing back together into a single file,
which is what you’ll need to work with the rest of the world. Meanwhile the “Scrivenings”
editing mode does the same thing, but in a temporary fashion, and as such is an authorial
tool which makes working in smaller pieces easier, since you can at any time view and
edit a larger segment of your draft as though it were a single file. These features will be
discussed in depth in due course, but for now it is good know that there are no penalties
for slicing and dicing up your manuscript into an easy to visualise outline.

The Research Folder

The Research folder is the default location for non-text documents such as images, PDF
files and so on (although it can hold text files too). You can create as many subfolders as
you wish to organise your research, or you can rename it and create other folders in the
root level to hold different types of research. You aren’t limited to using this one location
to store material. Anywhere outside of the Draft folder a valid place to organise old drafts,
notes and inspirational materials.

The Trash Folder

Whenever you delete a file in Scrivener (by pressing 8- Delete, for instance, or by select-
ing the Documents » Move to Trash menu item), the file is not actually removed from the
project but is instead moved to the Trash folder. You can tell at a glance if the Trash
folder has anything in it, as its icon will appear full. To permanently remove files from
the project, select “Empty Trash” from the Project menu after having moved files to the
Trash folder. Note that although you can rearrange items inside the Trash folder or view
it like any other binder item (and of course, you can move files into the Trash folder by
dragging); you cannot create new files inside it. It is not meant to be a working area. If
you wish to have a secondary holding area for files you are not sure if you want to really
delete, you can create your own folder in the binder to hold them.

Files that have been placed in the Trash will have their icons ghosted. This is useful
in differentiating old files, since project search results will include trashed items as well
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(trashed items can also be hidden entirely using the magnifying glass option menu).

/.1.2  Scrivener as an Outliner

If, like many authors, you are used to using a word processor for all of your writings, you
probably have a few habits that you’ll inevitably end up bringing with you to Scrivener.
One of these is working with large sections of information. In a word processor, it can
be clumsy (and even dangerous) to work in extremely long files the length of an entire
book, but at the same time it can also be clumsy working with sections that are too short;
it means having so many files open at once and no good way of keeping all the windows
organised.

A common tendency is to treat the binder like a flat list of those semi-large files, say the
length of a chapter, because even just that small incremental step can be so much better
than working in a word processor. But if you organise your project in this fashion, you
could be missing out on a part of the Scrivener experience.

As it uses the convention of folders and files, you might instinctively approach the
binder as a sort of “super-Finder”, but in actuality, it’s far better to think of the binder in
terms of being a bonafide outliner. You might have been drawn to Scrivener for this very
reason, but because of the daunting number of things that must be learned all at once,
have found yourself falling back to using a simplified file-is-chapter approach.

If you have never used or even heard of the type of software referred to as an “outliner”,
some of this may not make immediate sense. Outliners are a fairly old software invention
(nearly as old as the spreadsheet), that never really caught on as dedicated software. How-
ever the concept of outlining has become widespread in many programs, even including
the way our operating systems show the contents of our disks. Outlining is in part a vi-
sual metaphor that declares some things as being “children” to other things, based upon
their relative level of indent. If something is indented “beneath” an item, then it is consid-
ered a child of it, and that item is a parent to it. Items at the same level of indentation are
referred to as “siblings”. Another crucial feature of the outlining principle is that you can
hide the child portions of the outline by folding, or collapsing their respective “parents”,
keeping your screen focussed on what you are currently working on.

You might immediately draw a connection between this and the outlines we had to
compose prior to writing essays in school. Unlike those pen and paper outlines, a digital
outline has the benefit of being able to contain the content of the work within the outline.
You can imagine it as being as though each line on the paper had a stack of pages beneath
it, where the portion of that essay is represented by the topic line it relates to. Thus,
moving topic lines around in a digital outline moves the content beneath the outline for
you. It is like having your very own table of contents that instead of reflecting upon your



7.1. HOW THE BINDER IS ORGANISED 67

choices, allows you to use it like a tool and make those choices with a single and easy drag
and drop.

If all of this still does not make sense, I recommend going over the Quick Tour (chap-
ter 5) provided in this manual. It approaches the concept of outlining and how the text
you write can be organised into a topical tree. You might think this is all more complex-
ity than you need, but in my experience, once the lightbulb switches on to this idea, it
becomes second nature in the same way we now think of individual files on our computer
as holding discrete chunks of information. You will likely find your work becomes more
fluid and visible to you as you can now survey not only the major peaks of your work
(chapters), but smaller components within those chapters, too.

The next section will demonstrate how Scrivener approaches this concept, and how it
can allow your book to emerge as a genuine outline. That is what the binder can do for
you, and unlike other word processor applications or plug-ins that tout outlining capa-
bilities, you can use your own internal “authorial outline” which may or may not have
anything to do with the visible structure (e.g. chapter names, space breaks between scenes,
subsection numbering) of the book itself.

/.1.3 Folders are Files are Folders

As you no doubt instinctively know, a folder is a place where you organise files. You can
create folders on your disk and then put files and even other folders inside of them to keep
everything nice and tidy.

Let’s throw away all of those notions for a moment and take a new, fresh look at folders,
because in Scrivener, folders are an entirely different animal. Select a folder in one of your
projects by clicking on it in the binder. You’ll probably get a corkboard view of its child
items or perhaps an Outliner view if that is how you have things set up. This is all pretty
straight-forward, but what happens if you close the corkboard view?

With the folder still selected, click the currently active Group Mode button (Corkboard
is the default) in the main toolbar (or use View » Corkboard). You can tell which mode is
active by its shaded background. After clicking the shaded button, you should get a blank
view that looks suspiciously like an empty text document. In fact, that’s precisely what it
is. Type in some text and see what happens. Note that in the binder, the Folder icon has
changed, and now sports what looks like a little page of paper in its corner. This means
the folder itself has text associated with it.

Let’s try something a little more radical. Right-click on the Folder in the binder and
select “Convert to File”. It should change to a stack of papers with words on them. Delete
the line you wrote in that item and it will turn into a stack of paper with an empty page
in front. Go ahead and right-click and select “Convert to Folder”. Nothing fundamental
changed here. You didn’t lose any information, the only thing that changed is the under-
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lying type of the item, which is really primarily a visual change. When an item has other
items beneath it, but it is a file, it is often referred to as a document stack, or a file group,
but fundamentally it can act just like a folder does. This documentation will often refer
to either folders or file groups as “containers”, when the distinction does not matter.

Let’s test that theory. Select one of your files in the binder. You should see its text
appear in the editor as you always do. But let’s do the same thing we did earlier with
the Folder, click on the corkboard icon. It will be empty, but you are now looking at
the corkboard for that file. With the focus in the Corkboard, press $6-N to make a new
document. An index card should appear, just as if you were adding items to a folder. In
the binder, you’ll notice that the icon for this file has changed to the aforementioned stack
of paper.

Perhaps you can better see why it is a good idea to think of the binder as an outliner,
instead of a glorified Finder. What is all of this flexibility good for? You don’t have to
be thinking in terms of constrictive structural elements as you flesh out the skeleton for
your book. You can just add items as you go, building out new corkboards, and changing
things to folders or back to files once a structure begins to emerge.

Scrivener lets you work the way you find most comfortable. There is no need to build
out a strict outline if you’ve always worked text-first, but if you like to work in outlines,
or use the snowflake model of expansion, you can accomplish these with ease. An outline
can literally emerge out of your book, the book can be built onto an outline or even a
mix of the two. It’s all up to you and how you work best.

In Scrivener, the concept of a Folder is fluid. It’s an important concept to grasp, because
organising your book will inevitably mean a hierarchy of documents, and wherever that
hierarchy takes you it will take so in the form of folders, or their cousins, the document
stack. The concept of hierarchy is important, because it means you can keep the parts
of the book you aren’t currently working on tucked away, and that means you can feel
free to break things down as far as you want, no matter how many hundreds of items you
make in the binder, if you sort things into folders (or file groups!) you can always keep
the clutter at bay.

/.2 Binder Icons

There are many binder icons (Table 7.1) used to show the type of item, and in the case
of folder and text documents, hints about its status as well—the text and folder document
icons will change depending upon certain conditions. A new document that you’ve just
created will look like an empty sheet of paper, until you add a synopsis to it, then the icon
will change to an index card. If you start typing into the main text editor, the icon will
then show a sheet of paper with “words” in it. Likewise, folders will display if they have
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synopsis or text content (see the prior section if that comment resembled gibberish).

How you use this information is up to you. Some people like to develop their outline in
stages, first building the skeleton, then fleshing out the longer descriptions in the synopses
fields, and finally starting to write prose into the pieces of the outline. These indicators
can help them see how far along into the process they have gone, and what areas of the
draft need more work.

Table 7.1: File and Folder Binder Icons

Icon Explanation

Text Document Icons

An empty text document.
A synopsis has been added to the document, but nothing has been typed into the
main text.

= This text file has text content.

Scriptwriting documents.

l -

These variations of the above icons indicate that the text item contains subdocu-
ments; child items indented beneath it in the outline.

Folder Document Icons
08 A standard folder document.
= The small index card badge means this folder has a synopsis added to it.
[E

A printed page badge indicates the folder has main text content.

= ) . . « » .

_ 15 Any of the above icon variations can be “dog-eared”. When an icon has a flap
folded over in the top-right corner, that means the item has snapshots (sec-
tion 15.6) saved for it.

/.3 Binder Conftrols

This section contains some tips for manipulating the outline in the binder.

Revealing and Hiding Elements Click on the arrow to the left of any container to re-
veal or hide its contents in the binder.

Use the LeftArrow and RightArrow keys to open and close containers.

In conjunction with the Option key with either of the above methods, expand or
collapse an entire portion of the outline tree at once.
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Reveal and Hide All “Expand All” and “Collapse All” in the View » Outline » sub-menu
will disclose or reveal the entire outline at once. Expand All can be accomplished
with 8-9; collapse All with $-0. Both of these commands work in many areas of
the interface where it is possible to disclose items.

Collapse All to Current Level Working in a similar fashion to Collapse All, this com-
mand will collapse the entire outline, but only up to the currently selected item’s
level. So for example if you if have an outline that has six levels of depth, and select
a folder on level 3, running this command will completely collapse all items except
those at levels one, two and three.

Hoisting Focus on one area of the binder by selecting a container and choosing Docu-
ments » Hoist Binder. Documents » Unhoist Binder will return the binder to its full
display.

Moving items with drag and drop Items can be moved around in the binder with drag
and drop. Simply pick up the item by clicking and holding the mouse button down,
then drag the mouse pointer to where you wish to drop it. The binder will display
a blue target underneath the pointer, showing where the drop will end up. Holding
down the Option key while dragging will inhibit the “Drop on” feature, making it
easier to move siblings amongst one another.

Moving items with the keyboard - Arrow keys can be used to move an item around
spatially in the binder, step by step. Up and down will increase or decrease its
placement in the outline, while left and right will promote and demote the item.
For example, selecting a folder that holds the contents of chapter eight, and pressing
~g-DownArrow will move it down one spot, swapping its position with the chapter
below. It will now be chapter nine, and the other chapter will be eight.

Keyboard navigation The arrow keys by themselves will move the selection around in

the binder.

@ Up and down arrows will move up and down the outline.

@ Left and right will ascend and descend the hierarchy. When a container is
selected, the first time you press LeftArrow, a container will be closed, the
second time will jump up to the next parent.

@ Combining the Shift key with the UpArrow and DowArrow keys will select
multiple items in the chosen direction.
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Advanced keyboard navigation ~\X UpArow and ~ X DownArrow will jump from one
visible container to the next. If a container is hidden from view, it will not be
selected. When “Treat all documents with subdocuments as folders” 1s enabled in
the Navigation preferences, file groups will be included when navigating this way.

. UpArrow and \-DownArrow jump to the top and bottom of the binder. Note this
is different from the Home and End keys, which will only scroll the view, but retain
your current selection.

Copying Items While ordinary copy and paste functions are not allowed in the move-
ment or reproduction of binder items, copying a selection of items can be useful.
In most cases this will place a list of names on the clipboard. When copying images
from the Binder, the graphic will be placed on the clipboard and can be pasted into
rich text editing fields, such as the main editor, project notes, and document notes.

You can effectively copy any number of items by duplicating them with the Doc-
uments » Duplicate » sub-menu. They will be copied in place, and you can then
move them to their intended location.

7.4 Using Collections

Collections are a way to augment the binder method of organisation, and they will tem-
porarily supplant the binder view in the sidebar, allowing you to reorganise or arrange
collections of items in a flat list, regardless of their position in the actual project or hier-
archal relationships with one another.

You can think of collected items as being a bit like an alias, or a shortcut to that item.
Changes made in the editor to items within the collection will also be made to the original
item in the binder, it is better to think of them as being the same thing. A single item can
be in one collection or in many. Each instance will point back to the same original item
in the binder.

When setting up a new project, you might like to create a few starting Collections to
help organise material as it flows into the project, or as you generate new outline ideas. If
you find yourself creating a sequence of common Collections at the start of every project,
you might want to design a custom template (subsection 6.10.2) for yourself. Here are
some example uses for Collections:

@ Experiment with an alternate scene flow without disrupting the original layout.
@ Collect all scenes which still need to be edited.

@ Designate items which you wish to share with another author using one of the
various syncing methods.
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Collections -+

Q Search Results
New Collection

- Binder -

Binder
» ) =| Draft

> Research
Trash

Figure 7.2: The basic Collection interface with the binder selected.

- Search for any occurrence of words you tend to overuse. Saving a search that looks
for any word amongst the listed words, clicking on this tab would highlight all of
the problem words, listing only those sections of the binder that contain them.

@ Create a special compile group with an alternate selection and order than a typical
compile of the draft.

8 Store saved searches for future use, or to monitor workflows.

- Set aside groups of documents in a day-by-day schedule, removing them from each
daily collection as you address them.

7.4.1 The Collection Interface
To reveal the Collection interface, click the Collections icon in the toolbar, or select
View » Collections » Show Collections.

Each tab represents a single collection. In the screenshot (Figure 7.2), the “Binder” tab is
selected. While not a true collection, this is how you can navigate back to the Binder after
viewing a Collection. Click on any tab to select it; when a tab is selected, it will re-colour
and ghost all of the tabs below it to help indicate which is the active tab. Additionally
the header bar will change its title to the name of the tab. You could hide the Collections
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interface at this point and continue working in that tab. The background colour of the
sidebar and the header bar will help remind you that you are not in the full Binder.

When first created, Collections will be assigned with an automatically generated colour,
but their tabs can be recoloured by double-clicking the colour chip to the right of the
label. Likewise, double-click on the title to change the name of a collection. The Binder
and Search Results tabs cannot be renamed or permanently removed.

The are three main types (excluding the Binder) of Collections:

1. Standard Collections: allows you to freely add and remove items as you work. This
is the most flexible form of Collection.

2. Search Results Collection: a special collection type that cannot be removed. Any
project searches will have their query and results stored in this collection. This is
persistent between project sessions.

3. Saved Search Collections: indicated with the same magnifying glass used for Search
Results, on the left side of the label; they will be dynamically populated with a
search query every time you view the tab.

Disappearing Collection Tabs on Lion On account of the new behaviour of scrollbars
in Lion’s default setting, it may not be obvious that the Collection tab interface can be
scrolled, causing tabs to mysteriously disappear. If you do not like this behaviour, you
can change your Mac’s system settings in the General preference pane to always show

scrollbars.

7.4.2 Setting Up Label & Status

Creating a new standard Collection is as easy as pressing the + button. Any items that
you have selected in the active view (including the Binder, other views, or even other
Collections), will be automatically added to it.

Once a Collection has been created, you can add or remove items to it, so it is not
critical to select everything before you create it. There are several ways to add items to a
collection:

@ With the tab interface revealed, use drag and drop from any view including the
binder. If you hold over the target tab for a moment, Scrivener will switch to the
tab allowing you to drop the items precisely where you want to place them in the
list.
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Figure 7.3: Standard Collection Controls

@ Using the Documents » Add to Collection » sub-menu, any selection of items, in-
cluding the active item that is being edited or viewed in the editor, can be added to
the bottom of a collection list.

- In the binder sidebar, you can right-click on an item(s) to access the “Add to Col-
lection” menu.

In all cases, if an item already exists in the collection it will not be added again, and its
original position will not be changed, so it is safe to err on the side of “over-selection”.

Remove items by selecting them, and then clicking the - key (Figure 7.3) in the lower
title bar, or by simply pressing Delete on your keyboard.

Delete the entire Collection by first selecting the tab you wish to remove, and then
clicking the - button in the upper title bar.

Items can be re-ordered within the list using click and drag, or the same ~ 8- ArrowKey
combinations used in the Binder. Since there is no hierarchy in a Collection, you will not
be able to promote or demote items.

Collections take advantage of the same view modes that containers do. Click the
coloured header bar title (not the tab) to view all of the contained items using the de-
fault view mode. This can be used to view Scrivenings, Corkboard (freeform and linear),
or Outliner. You can also remove items from a Collection by deleting them from these
views.
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Figure 7.4: The special Search Result collection

Where new items go: In Standard Collections, you may create new items using all
of the ordinary tools available for doing so. Since collections are uncoupled from the
Binder structure in every way, new items will be placed into folders with names cor-
responding to the name of the collection they were created within. These folders will
be created at the top level of the binder, at the bottom of the list, above the Trash. An
example might be a new text file called “Joseph” in the Characters collection. When

you return to the binder, you will find a new text file called “Joseph” in a folder named
“Characters (New)”.

/4.3 Search Result Collection

If you’ve used Project Search, then you’ve been using a Collection without perhaps real-
ising it. Search results are placed into this special collection every time you run a search,
and the criteria of your search are saved into it along with the project. This means the last
Project Search that you ran will always be available to you, even after you have rebooted
your computer. Like the Binder tab, the Search Result tab cannot be deleted, and there is
always one included with every new project, even when no search is currently in use.

Both the built-in Search Results collection, and Saved Search Result Collections, al-
low you to view the label and status of the matching items, making it convenient to en-
act workflow changes without using the outliner. You can toggle the visibility of these
columns by right-clicking in the column header area and selecting Show (Hide) Label \&
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Status Columns.

When you click on the Search Results tab, the previous search criteria will be loaded
into the search bar tool, allowing you to further tweak the results if you desire. Since
search results depend upon the search criteria, you cannot manually add, remove, or
change the order of items from the Collection, as you can with the standard type.

/4.4 Saved Search Result Collections

As with the Search Results tab, saved searches have a magnifying glass in the corner to
indicate that it is a special type of Collection which automatically generates its contents
for you. Saved searches are created by clicking the magnifying glass in the Project Search
tool, and selecting Save Search as Collection.... When saving from a Keyword or Label
search, the associated colour of the meta-data you are looking for will be used for the tab’s
colour as a convenience

If the Collection interface is hidden, the sidebar background will change to a random,
automatically generated colour, and the header bar title will adjust to the name you pro-
vided. To leave the saved search, you can either click the close button in the sidebar footer,
or enable the Collection tab interface and select another tab.

The contents of a saved search are dynamic. Every time the tab is clicked on, the saved
criteria will be checked against the current state of the project. If you wish to “freeze” a
list for later reference, there are two ways you can do so:

1. Convert the saved search to a standard type: This will destroy the saved search, so
only use this method if you no longer need the search criteria. To convert a saved
search result to a standard collection, select the tab in the sidebar, and use the menu
command, View » Collections » Convert to Standard Collection.

2. Copy the contents into a new collection: This is quite easy to do. Simply select all
of the items (- A) in the search result list, and click the + button in the collection
header bar to create a new Standard Collection from the current selection.

Saved Search Collections can be removed in the same fashion as Standard Collections,
by selecting the tab and clicking the - key, as shown here (Figure 7.3)

Limitations: Searches performed using the “Binder Selection Only” option cannot be
saved for future use, because the binder selection is a temporary state which changes
whenever you click in the binder. If you find yourself unable to save a search, make
sure this option is disabled.

See Also:
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@ Project Search (subsection 21.1.2).

7.4.5 Back to the Binder

Often you might wish to know the overall disposition of a collection in the binder, or
where a specific select few items in the list are located in the overall structure of the project.
The View » Reveal in Binder menu command (- R) works from collections and search
results. Since this command can be used on many items at once, it makes for a handy way
to see what 757’ in large collections.

It is possible to select some or all of the items in a collection and instruct Scrivener
to gather them all together into one spot, based on the order of their appearance in the
collection. There are several ways of doing so.

¢ Drag & Drop: you will need to have the collection tab interface visible. Simply se-
lect the files you wish to gather, drag them to the binder tab and hold for a moment.
The binder will activate, and you can drop the selection wherever you please.

¢ Drag & Drop with the Option key: works identically as above, but instead of mov-
ing the items into the drop location, they will be duplicated.

@ Documents» Move » To» sub-menu: select the items you wish to gather together,
and either use the main application menu or the contextual menu to move them
to a selected item or container. This action will operate in the background, leaving
your focus in the Collection.

- Select all of the items that you wish to collect together and use the Docu-
ments » Group command to assemble them into a new folder in the Binder.

Experienced users of outliner style programs will recognise this ability as “mark and
gather”. The marking phase is done by assigning documents to a collection. Moving them
back out to the binder then gathers them quickly into one focussed spot. This can be an
extremely useful technique for some workflows.

It can also be useful to experiment and implement an experimental text flow. If a chap-
ter or section just doesn’t seem to flow right, you can quickly create a new collection,
Option-drag the container of items to the new tab, and then re-organise the flow using
the collection’s ability to view itself as a corkboard or outliner, then reviewing the text
with scrivenings mode. Once you are satisfied with the new layout, select all of the sub-
files and drag them back into the original folder in the binder using the above method.
The items will be re-organised for you in the actual book structure.
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Figure 7.5: Example Document Template Structure

7.5 Document Templates

Document templates give you the ability to designate a set of items that can be used to
create new items with stock boilerplate settings and text. Much as with project templates
(section 6.10), everything that you add to a document template item will be added to new
items created from it. This includes the various meta-data, notes, keywords, references,
synopsis, and of course any text. Additionally, folder items designated as templates will
create copies of their children too, allowing you to quickly generate complex repeating
structures. Certain special features that can be assigned to items will be carried along as
well, such as default subdocument types (subsection 7.5.5) and locked view modes (sub-
section 8.4.1).

Document templates do not provide forms that you can fill out with the tab key. They
are simply a convenient way to reproduce ordinary folders and files, with their meta-data
intact.

7.5.1 Setting a Document Template Folder

Templates are designated by placing them into a special folder, marked as being a template
container (which can be a folder or file group). Each project can only have one template
container at a time. To set it up, select the container of items you wish to use as templates,
and use the Project » Set Selection as Templates Folder. The binder icon will change to
indicate its status, and all of the items indented beneath it will have a small blue “T”
badge added to their icons.

Some of the built-in project templates will come with a template folder already set up
for you. To use your own templates folder, first clear the default setting (described in the
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next section). Optionally, you could just remove the contents of the default, and fill it
with your own templates.

If you find yourself doing this often, you might wish to create your own project tem-
plate (subsection 6.10.2) so that everything is set up the way you prefer when you start.

7.56.2 Clearing Document Template Folder

To clear the document template folder, use the Projects» Clear Templates Folder menu
item. This action will not delete anything in your project. It will merely remove the
special status from the designated templates folder. Template folders can be placed (or
designated) anywhere in the binder, even in the Draft (though do note that if you do that,
they will likely show up in the final manuscript, and toggling them to be hidden would
lead to generated items being hidden by default, as well).

7.56.3 Creating Document Templates

Creating new templates is as easy as creating a normal file or folder item in the binder.
There is nothing special about these items, save for their position within the designated
templates folder. Anything that you add to the templates folder will be available for usage
in the project.

It is possible to pre-configure all aspects of an item. The only thing that will not be
carried over is Snapshots. The latest version of the item’s text will always be used and any
Snapshots will be ignored.

7.5.4 Using Document Templates

Once a container is designated as a Template Folder, and items have been added to it,
you can generate copies of these templates elsewhere in the project via the Project » New
From Template sub-menu, or by using the green + button in the toolbar. The items in this
menu will be arranged precisely as they have been organised in the binder, with groups
becoming further sub-menus. As with the other commands that create new items, they
will be created in relation with the current binder selection.

@ If you select an entire group from the menu, it and all of its child items, will be
created in the selected position.

¢ The first template item in the template folder is a special spot as it will be given a
keyboard shortcut, £+ 08 -N. Using this shortcut, you can easily create this special
item on the fly, so if applicable, choose the top position for a template you will be
using most frequently.
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@ As with project templates, once created, document templates have no connection
with the item that they were modelled after. It is safe to delete a template that is
no longer being used to create new items. However, you might wish to move the
template item to another location in the Binder, outside of the template folder, in
case you ever need it again.

It is also possible to assign your own keyboard shortcuts to other items, using the in-
structions in Customising Keyboard Shortcuts (chapter 28), but note that these shortcuts
will only apply to those projects which have identically named templates.

7.5.5 Default Subdocument Types

Depending upon the type of document templates you design for your project, it might
occasionally be useful to set up a folder so that when you create new items within it, they
will be created as a particular template type, rather than the default text file. Quite sim-
ply, assigning a default type to a container will cause all of Scrivener’s ordinary methods
for adding text files to generate using the declared document template instead. This ex-
tends to all of the actions you can take to create new blank items, but no actions which
would result in an item that already has content. For example, if you press &-N while
looking at a corkboard that has a default type assigned to it or using Append Selection to
Document » New..., then the new card will be created as that default subdocument type.
If however you import a pre-existing word processing file into this folder, then it will not
use a defined default type, but will instead just be ordinary text.

To set a default subdocument type, use the Documents » Default New Subdocument
Type» sub-menu to select from the standard template selection menu, as listed in the
main Project » New From Template » sub-menu.

A simple example of how this might work is if you created a “Note” document tem-
plate, which sets up some boilerplate questions and answers, and has a custom icon set to
use the yellow note icon. Now, if you create a folder called “Notes” in your Binder, you
might want to assign the “Note” document template you've created as a default type for
new items created there.

Watch Out for Folders: In some cases, the default subdocument type that you’ve
specified might in fact be a folder. Since Scrivener considers text files and folders to be
synonymous, this is not too big of a deal. However it can result in a slight inconsistency
with the typical behaviour for creating new folders. Ordinarily when you create a new
folder with another folder selected, it will be created as a sibling to that folder. In
the case where the default subdocument type is a folder, it will be created as child and
assigned that type.
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Figure 7.6: Default Subdocument Type Demonstration

Besides the already mentioned exception for imported and otherwise automatically
generated documents with content (such as those imported, created via clippings or ap-
pended text), there are other cases where items are never created using the default type:

@& Where pre-existing items are moved into the folder. This should be considered a
feature, as it allows you to mix types later on and override the default by creating
an item elsewhere and then moving it in. It also holds to the rule of thumb where
items with content do not acquire a default type.

¢ When a different type of item is specifically called for. If you use the Project » New
From Template » sub-menu to specifically create another type, create a folder, or if
outside of the draft import a web page, the chosen type will overrule the default
type. The default type only applies where a new blank text item would be created.

Cascading Default Subdocument Types

Each folder (or container, if a file has subdocuments) can have their own default type
assignment. Where sub-folders are concerned, the default type “cascades” into all sub-
folders, no matter how deeply nested, they will acquire that default as well. The exception
to this is when a sub-folder has its own default template type assigned to it.

In the provided illustration (Figure 7.6), a container called “Characters” has been set
up to use a “Character Sheet” template type as its default subdocument type. Whenever
the user adds a new item to this container, it automatically acquires the “Character Sheet”
template style (in this case, a folder with a custom icon). If that was all that had been
configured, these character sheet folders (you can tell they are folders because they have
disclosure arrows even though they are empty) would create further character sheet fold-
ers beneath them, because of the cascading rule. However in this case the user has set up
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the Character Sheet template to use the “Trait” document template for its subdocuments
by default. Thus it overrides the default supplied by the “Characters” folder above it. Any
new items created instead the character sheet folder will automatically be Traits.

This demonstrates a more complicated example of this feature’s usage. Most often,
you’ll just want to create a particular type of item within a certain container and that
will be it. But if you wish to set up more complex arrangements, remember that the
subdocument default setting is itself something that will be duplicated along with the
rest of the template type, and thus allow quick scaffolding of common types. Another
practical example might be Part folders that automatically create Chapter folders with a
blank scene, and those Chapter folders automatically creating new scenes within them.

/.6 Custom Icons
Custom icons can be used to embellish the appearance of your binder items. All items

can have a custom icon, even the three root folders: Draft, Research, and Trash. Scrivener
comes with many icons right out of the box.

There are a few ways you can change the icon for an item:

@ Click on the item in the Binder, Corkboard, or Outliner, and use the Docu-
mentfs» Change lcon» sub-menu.

@ Access the item’s contextual menu, and use the “Custom Icon” sub-menu.

¢ Use the quick icon selection menu by holding down the Option key when right-
clicking.

& Jcons can be set to many items at once by selecting them all in the binder, and right-
clicking on them to choose Change Icon, or by using the Documents menu.

You can also set the icon of the document you are currently editing in the text editor
using the main Documents menu. When using Scrivenings mode, this will only impact
the document that your cursor is within.

To reset an icon to its binder default (remove a custom icon from an item), select Doc-
uments » Change Icon » Reset Icon to Default, at the top of the menu.

Setting an icon over and over? If you find yourself using a particular icon frequently,
you might wish to make a document template (subsection 7.5.4) for it, so that you do
not have to constantly re-apply icons to new files or folders.
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The icon menu is organised into two major parts. The first part displays up to five
of the most recent icon selections you’ve made, so you can quickly use them again (if
you have never used the feature before, you won’t see this yet). The recent icon list is
retained between sessions, and is universal to all of your projects. The second section
in the menu displays sets of icons, grouped together to save space, and finally all of the
remaining ungrouped icons that are available.

7.6.1 Creating and Managing Custom Icons

It is easy to make your own icons, even if you do not know how to edit images in a graphics
program. Load the icon manager with Documents » Change Icon » Manage Icons... and
click the + button in the lower table, under “Icons in Application Support” (we’ll explain
what that means in the next section). Find the graphics file you wish to convert to an
icon on your disk with the file chooser, and click the Open button. If the graphics file is
larger than 16x16 pixels, Scrivener will automatically resize it for you. You can also drag
and drop images into the list to import icons.

What to do about strange results: After you click the Open button, what you see
in the icon manager is what you will see in the binder and other views. If the icon
looks “strange” to you in this window, then it will look strange everywhere. Common
problems are files with lots of white or transparent padding around them. Open these
files in a graphics editor (even Preview will do for simple cropping) and use the software
to cut out the excess padding. You can remove a bad attempt and add it again using the
above instructions until it looks right.

Another common problem is a white background. This may or may not be obvious
in the icon browser, but will look bad in the binder. Removing a white background
is more difficult. If you lack the expertise to do so, try selecting another icon that is

similar, from a different source. JPEG images cannot have transparent icons, so 24-bit
PNG and TIFF files work best.

Icons can be dragged between the “Application Folder” section and the “Project Pack-
age” section individually, or en masse. Icons in the lower list will be available to all of your
projects; past, present and future. Icons in the top list will only be visible to that project;
however they can be duplicates of icons that are in the lower list. If you’ve created an icon
for a project, and later decide you’d like to use it everywhere, you can simply drag and
drop it into the Application Support table. If you try to drag an icon with an identical
name from one list to another, you will be informed of the collision, and confirmation
will be required before it is replaced.

When Scrivener loads your project, it checks this location (which is printed below the
table in this sheet for your reference) for matching icon names, but before doing so, it
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checks within the project package itself first. This means any duplicate names (not graph-
ics) in the top list will override any names in the bottom list. This way, you can set project
overrides.

Optimum Icon Sizes: The “native” size of a Scrivener icon is 16x16 pixels (32x32
for Retina screens), but many of the built-in Scrivener icons are a few pixels smaller
than that, to account for a subtle shadow around them. Therefore if you want your
custom icons to fit in with the stock icons, it is best to size them a few pixels smaller
than 16 pixels square, but leave the graphic file that large; padding the extra space with
transparent pixels. For some types of icons, it will not be necessary to tweak the icon
to fit in like this, so you can easily leave it larger.

Also note that if you intend for your icons to look good on both Retina and standard
displays, you should read Retina Friendly Icons (section 6.10.2) for tips on how to do

SO.

7.6.2 Working with Mac Finder Icons

Many icon packs for the Mac are distributed as Finder icons. If you would like to use an
icon that you have seen in the Finder, the easiest way to create a custom icon for it is to
follow these steps:

1. Select a file in the Finder that has this icon.
2. Press &1 to get info on that file.

3. Click once in the small icon in the upper-left corner. You will see a halo surround
it when it is properly selected.

4. Press $-C to copy the icon.
5. Open Preview.app and press 8- N to create a new file off of the clipboard.

6. You will probably see several options to choose from in the sidebar, selecting the
16x16 version, or the next smallest available icon.

7. Press - C once again to copy the single icon choice; and then 8- N to create another
new document from the clipboard.

8. Now you can save this icon to your Desktop or some other convenient location. It
is best to use the PNG or TIFF format, leaving the “Alpha” box checked.
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7.6.3 Creating Your Own Icon Sets

Icon sets are generated simply by naming conventions. How you name your custom icons
will determine whether or not they are grouped together as a set in the custom icon menu.
The format for this naming convention is “Category (Icon Name)”. A practical example
of this from one of the built-in sets would be “Flag (Blue)”. This causes this particular
icon to be grouped together with the Flag set.

7.6.4 Custom Icon Portability

The final thing to consider is whether or not icons will be visible off of your computer. If
you’ve been adding icons to “Application Support” all along, if you take your project file
to another computer, when you load it all of those icons will disappear. They will still
be assigned, but since Scrivener cannot locate any replacement icons, they will simply be
ignored until you return to the original computer.

So when working on multiple computers, it is good idea to drag your Application Sup-
port list into the Project Package list. This way your icons will be available wherever you
go, and once you are on the second computer, you can drag them back into its Applica-
tion Support list, installing them on that computer as well. Now you will no longer need
to put them in the Project Package list for them to appear on both systems.

When collaborating with other individuals, it is a good idea to install custom icons into
the project package. This way everyone can see and use them.



Chapter 8

Navigating and Organising

Moving around within a large project is an important part of writing efficiently, espe-
cially in an application like Scrivener, which lets you cut your work up into small pieces.
An average book might have anywhere between several dozen and a few hundred sections
arranged into many containers in the Draft folder alone, and that’s not counting any re-
search you may have added to the project. Along with the binder, there are two primary
tools for making sense of all of these pieces: The Outliner (section 11.2) and The Cork-
board (section 11.1), covered later in detail in this chapter of the book. For now we will
concentrate on how to use them as navigational tools, and as your skills increase, you’ll
find other uses for them beyond mere navigation.

Beyond the three primary navigation tools, there are a number of other features which
can be used as needed to enhance the main three, and these will be covered in this chapter
as well.

8.1 General Navigation

Some navigation features are common to both the Corkboard and the Outliner:

@ Double-click on any icon (to the left of the title itself) to load that document in the
current editor. This process is sometimes referred to as “drilling down” into the
outline.

@ 32— 0 to load the selected item in the editor. When more than one item is selected,
those items will be isolated using the current view mode so you can focus on them.
This latter usage is quite useful when you have a large Corkboard or Outliner, but
only wish to work with a selection of those items. By default, the Spacebar is syn-
onymous with this command, though if you prefer you can change the Spacebar to
load items in a QuickReference panel, the same way the Spacebar works when used
from the Binder, in the Navigation preference pane (section C.6).

@ 388-0 loads the selected item(s) in the opposing split, opening a new one if neces-
sary. This command can also be used from the Binder, when you wish to target the
split that clicking in the Binder wouldn’t otherwise impact.

86
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Figure 8.1: The Auto-Load button will appear blue when activated.

The following commands can also be used on the Corkboard and Outliner, and can
also be used within a Scrivenings session:

¢ Unlike most other forms of navigation, the View » Go To » Editor Selection (§8-4
command will always load the selected item as a single document, even if the selec-
tion is a container. As an example, this can be useful if you like to jot down notes
into a folder’s text area. Since this command will disregard the usual view mode
preference (such as viewing containers as a corkboard) it also has no impact on that
passive setting. Use of it will not cause containers to load as single documents in
the future. It also, unlike most other navigation commands, will not be added to
the editor history buttons.

When used in a Scrivenings session, the effect is to “isolate” the text, allowing you
to focus on that one section alone.

& Sometimes you may want to go “up” a level of hierarchy (especially when using the
previous command, which doesn’t use history), to the enclosing group of the selec-
tion, instead of “down”, as all of the commands above do. Going up will select the
currently viewed item in that item’s own parent container. For example, if you have
afolder in your corkboard called “Chapter 10”, and that folder is nested beneath the
Draft folder, then using this command will select the Draft folder in the editor, with
“Chapter 10” selected within it. The command is View » Go To » Enclosing Group
or ("#8-R).

When used in a Scrivenings session, the effect is to broaden the current text content
to include the content from around the section you had been editing in isolation.

8.1.1 Split Editor Auto-Load

Both corkboard and outliner views have an Auto-Load feature that when enabled, will
load any selected item(s) in the other split, much like when clicking on an item in the
Binder, but only if the editor has already been split, it will not create a split for you. The
Auto-Load button (Figure 8.1) is located in the footer bar, and will appear blue when
switched on. Click the button again to disable the feature.
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8.1.2 Header Bar Drag and Drop

In the areas listed below, an item (or even many items selected together, unless otherwise
noted) can be dragged and dropped with the mouse onto an editor header bar, loading the
item in the associated editor:

¢ From the Binder. Instead of clicking in a split and then clicking in the Binder, you
can just simply drag the document from the Binder into the split you wish to load
1t in.

@ From any editor group view, drag index cards or outliner rows to any editor header
bar to load them there. This can even replace the view you dragged them from.

@ Single item selections can be dragged from the References pane in the Inspector
(section 19.5). Note this can even load resources off of the disk, if Scrivener can
display the type of file, such as PDFs or images.

& Snapshots (section 15.6) can be dragged from the Snapshots Pane (section 19.8) into
an editor header bar, loading the content of the snapshot as a read-only document.
Hold down the Option key while dragging to track changes made between the cur-
rent version of the text and the snapshot you dragged.

¢ The Favourites panel (section 8.6) allows items to be dragged from it to header bars.

: Finally, the Find Synopsis (subsection 21.1.4) panel can be used to locate and drag
items to header bars.

8.2 Go To Menu

In most cases, it will be easiest to use the binder, or the group views in the main editor, to
select and navigate to various components in your project. There will be times when this
is not true. If you prefer to work with the binder hidden, are working in composition
mode, or just would rather not drill down to a particular spot solely to select an item, the
Go To menu is an easy substitute for other methods, and in some cases can even be faster
than traditional navigation. The Go To menu always takes action on the activated split
if relevant, even when it has been locked. You can alter this behaviour by holding down
the Option key, which will load the selected item in QuickReference panel, instead.

There are three locations where this menu appears:

¢ The main application menu, View » Go To» . Unlike the contextual variants of this
menu, it will always show the entire binder even when the active split is in a Scriven-
ings session. It additionally provides four shortcuts for navigating within an editing
session:
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- Previous Document (\08-UpArrow): Selects the previous item in the binder,
no matter what the relative depth.

- Next Document (X $-DownArow): Selects the next item in the binder, no
matter what the relative depth.

- Enclosing Group (~8-R): Selects the parent container which the currently
selected item is within; in effect traversing up the hierarchy, much as if you had
clicked on the parent container using your mouse in the binder. The current
view mode preference will be used if possible. If you are editing a section of
the Draft using Scrivenings mode, then using this command will expand the
Scrivenings session to include the parent and its siblings, just as if you had
clicked on the parent; if working on a corkboard, the next corkboard higher
up will be viewed. In cases where the current view mode conflicts with the
selection, corkboard will be used as a fall-back.

An example might be if you have scrivenings mode enabled as your default view
mode, but you are currently viewing an image or PDF. Since scrivenings does not
apply to these items, this command will switch you over to corkboard.

- Editor Selection (32-4): Isolates the current selection (or active document in a
Scrivenings session) in the editor in single text mode, no matter what type of
item it is. Useful for viewing folder text, or eliminating everything else in a
Scrivenings session so you can focus on one piece.

- Via clicking on the item icon in the editor header bar.

@ In composition mode, the Go To menu is accessible in the control strip along the
bottom of the screen, as a button.

In all cases, both sub-folders and items can be selected. When a sub-folder is selected,
it will be loaded with the default view mode (Corkboard by default), and when using the
button in composition mode, it will load the text of that item. The header bar menu is
provided as a convenience, and more readily applies the navigation action to a particular
split, whereas one must first ensure the right split is active before using the application
View menu.

8.2.1 Navigating Within Scrivenings

When the active split contains a Scrivenings session (section 15.9), the “Go To” menu
will be transformed into a table of contents for that session, letting you quickly jump
to sections exclusively within the session. The exception to this is the main application
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Figure 8.2: Hoisting: Before and After

“Go To” menu, which will reliably show the entire binder under all circumstances. The
header bar menu will always show the contents of the current session for that split.

See also, Editing Multiple Documents (section 15.9).

8.3 Hoisting the Binder

When you need to focus on one specific area of the binder, you can use Documents » Hoist
Binder to isolate the currently selected container. Only one item can be selected, and it
must be a container (file or folder).

When a container has been hoisted, the appearance of the binder will change!. The
header bar will be replaced with the name of the container that has been selected, includ-
ing a small icon representation of its type, and the list of items available will be reduced
to only those items which are children of the selected container.

If you wish to select the container itself (for example to view Scrivenings, or its cork-
board), click on the header bar. Once selected you can choose the view mode you prefer,
if necessary.

laction-hoisting.png
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To return to standard Binder view, either click the indicated X button in the footer bar
of the binder area, or select the menu command, Documents » Unhoist Binder.

How to Hoist the Outliner: the Outliner view in the editor does not have a dedicated
feature for hoisting. This is because it is an automatically hoisted view by design. Sim-
ply clicking on a sub-folder in the binder would be the same as viewing its container
folder contents and then hoisting that container from there. Sometimes however the
binder item you wish to hoist to is not readily available—you might be working in a
Collection at the time, for instance. It is possible to hoist or isolate individual items
in an Outliner view. Simply select the container or items you wish to isolate, and use
the Documents » Open » sub-menu, selecting the editor you are currently working in
as the target, or press \“g-0O. This will form a Multiple Selection, and once you are
done with it you will be able to use the history buttons in the header bar to get back

to where you were.

8.4 Controlling Binder Infegration

With a few exceptions, whatever you click on in the binder sidebar will be automatically
loaded into the active editor. This can become more complicated when there is more
than one editor split in use. When this is the case, the split which has its header bar
highlighted in blue (or graphite, when the dark grey theme option is in use) will be the one
that receives binder clicks. The inverse of this is however not true. The binder will not
automatically select items based upon what you are viewing in the editor. The editors can
drift from the original selection quite easily. All you need to do is use the history buttons,
double-click on an index card icon in a Corkboard, use the View » Go To » menu, click on
a Scrivener Link in the text, and so forth. There are three features available which change
how clicking in the binder sidebar work.

8.4.1 Locking the View Mode

Which view mode to use when selecting a group of items is determined by the last view
mode (chapter 11) you selected. If you click on a folder and switch the view mode to
Scrivenings, then you later select five separate items together, they will be shown us-
ing Scrivenings as well. In most cases this works quite well as we tend to do tasks in
bunches. Sometimes however, you might wish to designate a certain container as always
being shown using a particular view mode, no matter what the default may be.

To set a container (defined as a folder, file group or collection) to use a particular view
mode, simply use the View » Editor » Lock Group View Mode menu command on the active
editor you wish to freeze. If the toolbar is visible, you’ll see a small lock icon added to the
segmented control for this. So long as the view mode is locked, you can change the view
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mode of this container and this activity will set Scrivener to remember the last mode you
used within the container.

1. A folder (A) is set to have its group view mode locked while in corkboard mode
2. Another folder (B) is clicked on, and the view mode changed to outliner

3. When switching back to folder A, the view mode returns to corkboard

4. Viewing folder B will return to outliner mode

5. Now if folder A is viewed again and changed to Scrivenings, folder B (and the rest
of the project) will use Scrivenings mode as per normal. Additionally, this action
will also lock the selected view mode to folder A. It will now use Scrivenings mode
by preference instead of the corkboard.

There is no limit to the number of containers that can be locked to a view mode in a
project. The setting is unique to that container and does not impact any other containers.

Locking the View is an Integral Setting: This means that if it is duplicated that
setting will be carried along with the new duplicate. If this setting is applied to Docu-
ment Templates (section 7.5), then each new instance created using that template will
also bear that setting. However from that point on these new containers will maintain
their own settings; changing one will not impact the others that came from it, or vice

versa.

8.4.2 Locking the Editor

Any editor split can be locked with View » Editor» Lock in Place, or 8 -L. The header
bar for the editor will be changed to a dusty red colour which persists even when the split
is not active. Either or both splits can be locked independently. This feature can also be
accessed from the header bar icon menu (subsection 14.1.2).

Locking the editor prohibits external clicks from impacting the locked editor. This
means that clicks in the binder, corkboard or outliner (when Auto-load is enabled), will
be blocked. This makes it easy to keep your editing session while you use the binder
or these other views to explore the outline. What locking will not do is prohibit actions
taken from within the editor itself. This includes use of the binder navigation arrows, his-
tory buttons, manually dragging items to the header bar, or menu navigation commands.
Locking is meant primarily to keep the interface from taking actions that it would or-
dinarily take automatically. Locking will not inhibit intentional actions that yo# make.
These actions (as with the View » Go To » sub-menu) will navigate as requested and cancel
the lock state.
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A common exception to this rule of thumb is when it makes sense to scroll your view,
or select items within it, based on an external selection. If the editor is a locked Scrivenings
session (where more than one text file is viewed at once), then if you click on a portion of
the outline that is contained within that session, Scrivener will scroll to the right spot for
you. In a large locked corkboard, you can jump to individual cards by clicking on them
in the binder. Again, this alternate method of navigation only works when the item you
click on in the binder sidebar is already contained within the locked view. You will need
to unlock the editor in order to use the binder to select items outside of the current view.

An alternate behaviour can be set in the Navigations preference tab (subsection C.6.3),
“Binder selection affects other editor when focussed editor is locked”. Ordinarily if the
editor split you have active is locked, nothing will happen when you click on things in the
binder. With this option enabled, the binder click will be loaded in the opposing editor
split if one is already open.

8.4.3 Binder Affects

Binder Affects... The View » Binder Affects » sub-menu contains several choices for al-
tering the standard behaviour to become locked rather than dynamic. For example,
if you have a left and right split, ordinarily when you click in the binder what you
click on will be loaded in the active split. If Binder Affects Left Editor has been
enabled, however, all clicks will be sent to the left split no matter which is active.
The precise contents of this menu will alter, depending upon whether you are using
a vertical or horizontal split orientation.

Alternately, the “Other Editor” choice will cause the binder click to always act in
opposition to its normal behaviour, loading the binder click in whatever editor is
not currently active.

When binder clicks are being diverted, a small indicator will appear in the binder side-
bar header, to the left of the title. This iconic depiction will use a darker shade of grey to
indicate where future binder clicks will go. This indicator will be removed when operat-
ing in the default behaviour, and so its presence is not only useful to determine where a
click will go, but that clicks will not be functioning normally in the first place.

You can right-click in this area to directly change which editor the Binder affects.
To reset the binder behaviour to default, use View » Binder Affects » Current Editor.

See also:

- Splitting the Editor (section 14.4) for further documentation on how to use editor
splits.
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8.5 Linking Documents Together

Much like hyperlinks on the Web, Scrivener Links make it easy to create and use a net-
work of text-based cross-references within your project. Since in most cases they do not
export from your project, it is safe to use them in the text of your work wherever you need
them. They can also be used within Document and Project Notes. Their ability to ele-
vate the visibility of information in your project can turn them into a valuable navigation
tool (much like having a personal wiki inside your project), or optionally in providing
navigability beyond the project itself, such as cross-referencing that will be useful to the
reader.

The creation of links can even be a good brainstorming tool, as you can build your
outline with links, while typing. Links appear much like URL links do on the Web. They
will sport a blue appearance and be underscored. The link colour can be customised in
the Appearance preference tab, under “Customizable Colors”, in the Editor section. The
underscore cannot be removed, so even links set to be the same colour as the base text can
be identifiable.

To use links, simply click on them with the mouse pointer, as you would in a web
browser. Similarly, you can modify how the link is opened using modifier keys. What
the modifiers do will depend upon the “Open clicked Scrivener Links in” setting in the
Navigation preferences pane (subsection C.6.7). By default Scrivener Links (but not or-
dinary hyperlinks to the Web) will open a split editor (if necessary) and load the linked
item in the split. This will use the ordinary view mode preference, and so is identical to
clicking on that item in the binder. If you link to a folder, it will open in Corkboard view,
for example.

If you would like to see where the link will take you without actually going there, you
can simply hover your mouse over the link for a few seconds, and the full Binder path of
the item will be printed in the tooltip.

Right-click on a Scrivener Link to access the “Open Document Link In” sub-menu for
additional ways to open a link.

Keyboard shortcuts can also be used to access these optional methods directly:
Other Editor (default) @ Command: open in QuickReference panel
@ Option: open in current editor

Current Editor @ Command: open in other editor

@ Option: open in QuickReference Panel

QuickReference Panel @ Command: open in other editor

@ Option: open in current editor
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8.5.1 Creating Scrivener Links
Drag and Drop
¢ To create a link to a specific item in the binder, drag the item into the text where
you would like it to appear, while holding down the Option key when dragging.
The blinking cursor will help show you where the final location of the drop will
occur. When creating links in this fashion, they will be automatically titled by the
name of the document that was dragged.

@ It is possible to drag more than one item into the text area at once. Select multiple
items in the binder and drag them over as above. Links will be separated one per
line.

& Jtems can be dragged into the Notes Pane (and the Project Notes window) as well
as the main text area, in this fashion.

a In aslight variation of the above, select the text you wish to link to a document and
then Option-drag the item onto the selection range. This will link the text to that
item without inserting the name of that item.

Select Items and Copy

When you want to create links to items in multiple places at once, it is usually easier to
use the Edit » Copy Special » Copy Documents as Scrivener Links menu command. Now
you can paste (38-V) the items into several different places rapidly. As with Drag and
Drop, you can select more than one binder item at once, producing quick lists of links.
For e-books, this can be useful for creating a custom table of contents, as that system uses
Scrivener Links to assemble e-book compliant hyperlinks.

Select Text and Link

Often you will want to link a phrase to a specific document without having the name of
that document be a part of the link. To create links in this fashion, select the text you
wish to link, and then right-click on the selected text. Use the Scrivener Link sub-menu to
create a new link. This menu is also located in Edit » Scrivener Link.

This sub-menu functions in a very similar manner to the Go To menu (section 8.2), by
providing an organised list of every item in the Binder. The menu is organised as follows:

New Link (32-L) Brings up a sheet which gives you the option between creating a new
item and choosing where to place that item, or to navigate through a list of items
that already exist.
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Link to Existing Document

Destination: Research

Title: ' Joseph Aarin

A new document with the specified title will be created
inside the destination document, and a link to it will be
added to the current document.

4 Only show containers in destination list

Cancel

Figure 8.3: Create a New Linked Document

There are two tabs available in the sheet. The default tab, “Create New Linked Doc-
ument”, will let you generate a new document and attach it to an existing container
(or optionally, another item, forming a new container).

The “Destination” drop-down menu provides a list of all the containers in the
project Binder. Use this to select where the new document should be created. By
default, it will select the Research folder for you. If you have unchecked “Only show
containers in destination list”, then the drop-down menu will display all items in
the Binder, allowing you to form new containers by creating new items beneath
existing documents®.

The “Title” field is where you type in the name of the new binder item which will
be created. It does not need to match the text of the link.

The “Link to Existing Document” tab will provide a Binder browser displaying all
existing items in the project for easy link-up. Using this method is very similar to
right-clicking on the text and selecting an item from the Scrivener Link sub-menu,
and 1s mainly provided as a convenience for people using the shortcut to create new
links, or wiki linking, discussed below.

Suggestions If the selected text contains material that is found in existing binder item
titles, these matching titles will be added to the menu as well as suggestions. This
is handy when you have typed out the name of a Binder item, and wish to create a
link to it.

This section will not appear if no suggestions are found.

21f this is unfamiliar, I suggest reading Folders are Files are Folders (subsection 7.1.3).
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Favorites Aswith the Go To menu, “Favorites” will be added to the list. Consider adding
frequently linked to items to make it easier to access them in the future (section 8.6).
This section will not appear if no “Favorites” have been created.

Binder List The remainder of the menu will be organised according to how your project
is laid out. Containers will be converted into sub-menus, allowing you to navigate
the project and select a link target (much as you would with the “Go To” menu).

Wiki Link Style

An optional method lets you type in new links without using the mouse at all, or even be-
ing fully aware of the title you wish to link to. To enable this method, visit the Corrections
tab of Scrivener’s preferences, and turn on “and [[Scrivener links]]” in the Substitutions
section.

To use this method, while typing in the text you can enter two double-brackets, type in
the title of the item you wish to link to, and then close it with a second pair of brackets,
as shown. Scrivener will detect what you are trying to do, and if it finds an exact match
to a document, will link it for you automatically. If it does not recognise the text inside
the brackets as correlating with an existing title, the New Link sheet’ will pop-up, giving
you the option to either create a new item and place it in the Binder, or via the second tab,
“Link to existing document”, navigate to an existing document in the Binder and create
a non-literal link. Non-literal links are useful when you wish to link phrases in your text
without directly referencing the name of the item you are linking to. Once substitution
has been performed, the brackets will be removed.

Quickly Referencing a Name: If you don’t recall the precise name of the document
you wish to link to, a quick way to search for item names without using Project Search
(and messing up your current view) is the Edit » Find » Find Synopsis... tool. Using this
window you can rapidly search only titles and text synopsis. Once you know the name
of the item you are looking for, close the window and proceed with creating the link.

As with other substitution types, wiki linking* works only on newly typed material.
If you have previously typed in double-bracketed words, and then enable the option, you
will need to re-bracket them.

3sheet-new_link-new.png

*Referring to these links as “wiki links” does not imply that your project can become a wiki. It merely
refers to the appearance of the syntax as it is typed in. Scrivener links must always point to an existing
resource (even if you create that resource while generating the link) unlike true wiki links, which can be
placeholders for items which do not yet exist.
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8.5.2 Removing Links

Links can be removed (including URLs to external web pages) with the Edit » Unlink menu
command, without destroying the underlying text. Any link falling within the currently
selected text will be removed, so there is no need to be precise about what you select. This
is an easy way to wipe out dozens of links at once, something which is of particular use
when pasting text from web files, or other Scrivener documents with links you no longer
require.

Note that linked comments and footnotes will 7ot be deleted with this command.

8.5.3 Changing a Link Target
The link target, what Scrivener will display when you click on the link, can be modified
in one of the following ways:

« Select the text of the link and use the Edit » Scrivener Link » sub-menu to select a new
target. You can also right-click anywhere in the link text and use the contextual
menu to make this selection.

- Select the text of the link in the editor and then and drag the item you wish to link
to on top of the selection with the Option key held down.

8.5.4 Updating Link Text Automatically

When using Scrivener Links as a form of visible cross-referencing that will be available
to the reader, a mechanism for updating the link text with revised section titles will fre-
quently prove to be useful. Since Scrivener links are themselves merely arbitrary text
pointing to another item, it is not possible for Scrivener to determine your ultimate pur-
pose for that link, nor is it possible for it to guess at whether a string of text which was
once an exact copy of a title should be updated with the new title, since it is unaware of
what that old title was. In other words, if you change a section name from “Absinthe”
to “Chartreuse”, Scrivener would not be able to discriminate the fact that a link called
“Absinthe” pointing at a section named “Chartreuse” is in fact meant to be updated or is
any different from a link called “exotic liquors” which also happens to point there but was
never meant to be a cross reference. The software doesn’t store a history of every name
you ever gave to an item, so it cannot guess that “Absinthe” is an old title for that section.

Thus, this action requires an intentional command from you, though the actual updat-
ing will be automated. There are two ways to go about fixing links. If you are certain that
all of the Scrivener Links you have created in your draft are functioning as cross-references
(you have no links at all of the variety which are merely meant to be used for your own
reference), then you can select large portions of text at once, even in a Scrivenings session,
and fix the links using the Edit » Update Links to Use Target Tifles in batches. You may also
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fix links one-by-one when you come across them with this command (just make sure the
whole link 1s selected).

Updating the Link Target: This feature only updates the visible text of the hyperlink.
It does not adjust the target which the link points to internally. If you wish to change
the target of the link itself, select the link in the editor, and use the Edit» Scrivener
Link » sub-menu to select a new target, or use the - L shortcut and access the “Link to

Existing Document” tab.

Additionally, if you use a mixture of cross-reference style links and links for your own
benefit, you’ll probably want to step through them all one-by-one to make sure that the
update command only hits those links that are meant to be cross-references. The easiest
way to do this is to use the Find by Formatting (section 21.1.6) panel, which contains a
handy button you can use to replace the link text with the title of the item it links to.
Since the Find by Formatting panel will automatically select link text for you, this will
be the easiest way to do spot updates.

8.5.5 Configuring How Links Work in the Interface

Most of the configuration options for links are located within the preferences Navigation
tab (section C.6), in the Scrivener Links section. Here you can configure how links will
act when they are clicked, and what will happen when new links are created.

Both settings have three options available:

@ Current Editor: The link will replace the current editing session with the linked
item. This method works most like a web browser, and like a web browser you can
use the forward and backward buttons to get back to where you were after following

a link.

@ Other Editor: Will use the other split to load the clicked link. If necessary,
Scrivener will open up a new split (section 14.4) for you, using the last used split
type (horizontal or vertical).

¢ QuickReference Panel: The item will be loaded into a QuickReference panel (sec-
tion 21.2)°.

The colour appearance of links can also be adjusted in the Appearance tab (section C.3).

>Scrivener Links activated from within a QuickReference panel will always open a new panel.
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8.5.6 External Links

It is not only possible to link to and from individual items within a project, but between
projects as well. In fact, you can copy a special type of URL to the clipboard and then use
it to create a link in any program on your computer.

Linking Items Between Projects

The easiest way to link to an item from another project is to use the References feature
(section 19.5):

1. Open the Inspector in the project you want the link to be in and click on the stack
of books icon to view the References pane.

2. From the Binder of the project with the item you want to link to, drag that item to
the References pane, opened in the prior step.

You will see a link to that item, with the URL filled out. When you double-click the
icon on this Reference, to activate the link, the original project will be opened if necessary,
and this item will be loaded in the editor.

The URL text can be used to create other links at will. You could for instance drag this
Reference line into the main text to create a clickable hyperlink, there. You could also
copy and paste it into another program.

Linking From Other Programs

Any software that has a concept of linking should allow you to create useful links back
to individual components of your project. This is done via the use of a special type of
URL, which can be used to instruct applications on your system to take certain actions.
In this case, this link will instruct Scrivener to launch, open the target project and then
display the requested resource in the editor. If Scrivener or the project is already open,
then clicking the link will have a much more immediate effect.

¢ To copy an external link, select the item you wish to link to and use the Edit » Copy
Special» Copy Document as External Link. Now you can paste this URL into any
context that takes one.

@ Alternatively, right-click on the item directly in the Binder, and select “Copy Doc-
ument Link” from the contextual menu.
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8.5.7 When Scrivener Links can be Compiled

Depending upon the file format used , when compiling your work into a single file,
Scrivener Links can be a feature that reside entirely within the realm of Scrivener, being
stripped out of the final product, or something that can be used for linking (or referenc-
ing) that your readers can make use of. Some examples range from tables of content,
cross-references, hyperlinks to the web, and more.

When compiling, unless the target format (such as RTF, PDF and HTML) supports
point-to-point linking, they will be stripped from the output, and thus are handy for in-
serting useful links for your own purposes. For those formats that do support linking,
you can opt-out of this behaviour in the Transformations compile option pane (subsec-
tion 24.15.2), by selecting “Remove all hyperlinks”.

Compiling with Automatically Adjusted Titles

Sometimes you may need a link to adjust the hyperlink text—what your readers will see—
to match the given title for the section it refers to. For example, you might need the Table
of Contents list to print the chapter numbers, which are also be compiled into the titles.
This method requires a few conditions to function properly:

1. Link text which is solely the title of the document they link to.

2. Atitle prefix or suffix applied to the document level that contains the links. (Addi-
tionally, enable the “Update titles in Scrivener links with prefix and suffix settings”
option, in Compile under “Title Adjustments”.)

This is a more advanced feature of Compile (which is discussed in its own chapter) but
in essence it allows you to create a link to document titles in the text which will be altered
to match their final appearance in the compiled version. Since titles can be added to, or
even entirely replaced, by the compiler, this set of features will ensure that referenced
titles will remain valid after export. This can be used even in formats that do not support
linking, since it primarily is concerned with keeping the text of your document up to date
with the final presentation of its structure:

The original text reads:

To read more about this topic, see How to Grow Better Tomatoes .

The phrase “How to Grow Better Tomatoes” is linked to a binder document of the
same name, in the Binder. However, the author has arranged for this title to be prefixed,
so that in the final output it will appear as “Chapter 7: How to Grow Better Tomatoes”.
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With the above options configured correctly, Scrivener will recognise that this link
points to atitle and that it should be updated to reflect the final version. It will be compiled
as the following result:

To read more about this topic, see Chapter 7: How to Grow Better Toma-
toes.

The Table of Contents generator uses this trick to keep its list of documents up to date
with the final manuscript version of titles.

Pro Tip: If you link the special placeholder tag, <$p>, to a particular document in
the Draft, the compiler will insert a special RTF code which lets compatible word
processors cross-reference the actual page number of that item. This technique is also
used in the Table of Contents generator, but could also be used for formatting nicer

cross-references for your readers.

If you wish to cross-reference a document in a more generic fashion, without display-
ing the entire title, the <$hn> placeholder can be linked to a source document, if it is
numbered likewise. The number of the target section will be printed here, instead of the
number for the source document. Note that if the intention is to show the title and the
number of the section together, and the placeholder is being added to the title via a com-
pile prefix, there is no need to manually add this yourself. The compiler will update the
name to include any prefix, including numbering, for you. This technique will mainly
be useful if you intend to cross-reference to a section without including the title, using a
generic “(see section 1.2.3)” nomenclature.

E-books are afforded the power to link to items in the Binder which are otherwise not
true sections. This can be useful if you wish to link to a particular figure—you could place
that figure in a text file all by itself, and then link to that resource with a Scrivener link.
This will navigate to the image in most reader hardware and software.

Linking to Images with MultiMarkdown

There is one other case where a Scrivener Link will be used intelligently by the compiler,
and that is with the MultiMarkdown format. When a link points to an image file, that
file will be included in the output folder when you compile, and the name of the file will
substitute the hyperlink text. In this way you can use the MultiMarkdown syntax for
images. An example might look like:

I[Caption text for the figure]( Scrivener Link to Graphic )

Which would compile as:
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I[Caption text for the figure](name_of graphic.jpg)

Since the image file, name_of_graphic jpg is exported alongside the source file, it will
naturally link up correctly and display in the ultimate output.

See also:

1. Compiling the Draft (chapter 24)
2. Creating a Table of Contents (chapter 23)

3. MultiMarkdown and Images (subsection 22.4.1)

8.6 Using Favourites

Setting binder items as favourites will increase their visibility in a few key areas of the
application. One of these has already been covered; the “Go To” menus. Setting an item
as a favourite will make it easy to navigate to that item in the future, as it will always be
present at the top level of that menu (with the exception of when the menu is acting as a
table of contents for a Scrivenings session).

All of the menus which have favourites added to them:

@ Edit» Append Selection to Document » (Also available as a contextual menu when
text is right-clicked upon.)

@ Edit» Scrivener Link » Creates text links to documents, like URLs in a web browser.
(Also available as a contextual menu item.)

@ View» Go Tow Provides navigation features to any spot in the binder. (Also avail-
able from the header bar icon menu; except when operating at a table of contents
for a Scrivenings session.)

@ Documents» Move » To» Moves selected binder items to other locations in the
binder. (Also available as a contextual menu item from the main sidebar.)

@ View » QuickReference » Opens a QuickReference Panel for the selected item from
that menu.

8.6.1 Adding and Removing Favourites

Adding and removing items from the list of favourites is easy to do. Simply select the
item in the binder and right-click on it to view its contextual menu. At the bottom of the
menu, there will be two options:
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@ Add to Favorites: Adds the selected document(s) to the favourite list.
- Remove from Favorites: Removes the selected document(s) from the favourite list.

- To clear all assignments, use the Documents » Favorites » Clear Favorites menu com-
mand.

8.6.2 Managing Favourites

Favourites can be managed centrally using the Documents» Favorites» Manage Fa-
vorites... menu command. You can drag items from the Binder into this floating window,
or use the - button along the bottom to remove selected items that have fallen in disfavour.

Items can be dragged around to change their order in this window. This will also impact
the order in which they appear in the various menus where favourites are included.

The items in this list are also valid objects for dragging. This means you can drag items
out of this list into header bars to load them, drag them into text editors to paste their
contents (or with the Option key held down, to place a link to that item).

8.7 Layouts Panel

The Layouts panel allows you to save different layout set-ups and load them again easily.
For instance, in the early stages you might focus on a large corkboard without any other
interface to get in the way; as structure starts to emerge, you may have the binder open
with the corkboard in the top editor and text in the bottom editor; whilst composing,
you may have only the text open, with the binder, inspector and toolbar hidden. By us-
ing the Layouts panel to save different layouts, you can switch between these view settings
quickly, without having to go through the process of hiding the binder, toggling the tool-
bar and so forth. You can even specify that outliner column settings and other details will
be restored from a layout. To show the Layouts panel, select Window » Layout » Manage
Layouts..., or press {18 -0.

If you do not have any layouts saved yet, you’ll be presented with a window and an
empty list. You can try the feature out immediately by clicking the + button. A screenshot
of your current project window will be taken and placed into the right side of the screen,
and you’ll be given the opportunity to name the layout something meaningful. With a
combination of names and screenshots, your layouts should remain accessible and easy

to find.

Switching to a saved layout is easy, you can either double-click on the icon next to its
name, tap Enter, or just select the layout and click the Use button in the footer bar of the
left list. Another way of switching layouts is to use the main menu instead of the Layout
panel. When you save a layout, it will be added to the Window » Layouts» sub-menu.
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Since these are assigned a menu command, you can configure custom keyboard shortcuts
for quick access to commonly used layouts, using the standard macOS system shortcut
tool.

To remove a layout you no longer need, select the layout and click the - button in the
footer bar. You will be warned that once it is deleted you’ll be unable to retrieve it. This
warning can be dismissed so that it no longer appears, if you wish.

To update an existing layout with the current project window layout, simply select that
layout in the list, and click on the gear menu in the footer bar, choosing Update Selected
Layout. A new screenshot will be taken and the old settings will be updated to reflect the
current window layout.

Layouts can also be exported and installed into Scrivener. Using the gear menu, select
the layout you wish to export, and then choose Export Selected Layout. The layout will
be saved as an XML file in the location you provide. Use the Import Layout menu choice
to import a layout you have transferred from another computer or downloaded from the
Internet.

Because layouts are separate from projects, there are some things that they cannot save,
such as which collection you are viewing, which QuickReference panels are open, or
whether the binder has been hoisted to a certain level or switched to viewing a particular
collection. Even within one individual project, these details might change or no longer
be relevant. Here is a list of things layouts do save:

& Binder visible/hidden

@ Collection tab interface visible/hidden

- Inspector visible/hidden

- Split type (horizontal /vertical /none)

& Binder mode (whether it affects one or current editors)
¢ Header bar visible/hidden

¢ Footer bar visible/hidden

- Editors locked in place

¢ Ruler and Format Bar visible/hidden

- Selection auto-load in alternate editor settings

- Window size and position and view sizes
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@ Toolbar visible/hidden and view mode (such as small or large icons)
¢ Corkboard/outliner/scrivenings/editor mode for each split
¢ Page View or standard draft view for each split

¢ Full Screen status [10.74 (Lion) Only]

In addition, optional settings are saved depending upon whether these two checkboxes
are enabled for the specific layout.

Save outliner and corkboard settings All corkboard display settings, such as card size,
ratio, card wrapping, and so on will be produced when using the layout.

In the outliner, which columns are visible or hidden, and column sorting.

Preserve all meta-data appearance options This will determine whether or not label
tinting used in the various areas of the interface; and pin, stamp, and keyword chip
visibility in the corkboard, will be produced when using the layout.

8.8 Full Screen Mode

Full screen mode, as provided by macOS, pushes the Dock and main system menu bar
off-screen, providing maximum space to the window you’ve maximised.

With Scrivener, this means you can run several different projects at once in different full
screen “spaces” on your system. Each project window will feature a full screen expansion
icon in its upper-right hand corner.® This button corresponds with the View » Enter Full
Screen menu command’ and can be toggled with ~#-F.

The system creates a new “Space”, dedicated for any project window that has been set to
use full screen, any peripheral windows that had been opened (such as the colour palette,
Find tool, QuickReference panels, etc.) will not be conveyed to that new space for you.
New windows that you open while working in full screen will remain in that view, but
existing windows will not, and cannot be moved afterwards without closing them and
then re-opening them.

®In Mac OS X 10.10 and above, the green “zoom” button has been removed and replaced with the
full screen button. You can still “zoom” a window, causing it to take up a sensible amount of space in the
current working area, by holding down the Option key and clicking on the green + button.

’In prior versions of Scrivener, this menu command would enable the distraction free writing mode.
Due to naming conflicts, this feature has been renamed to Composition Mode (chapter 17).
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Full Screen with Multiple Displays: Due to how macOS handles full screen mode,
if you are using multiple displays and enter full screen mode, all of the other displays
will be blacked out. This is unfortunately out of our control.

8.8.1 Slide-out Sidebars

[10.7+ (Lion) Only] On smaller screens, such as found on the 11” MacBook Air, you
might want to dismiss both the binder and inspector sidebars automatically to maximise
the amount of space provided to the editor(s) or to better focus on the content. The
“Hide binder and inspector when entering full screen mode” option, found in the General
preference tab (subsection C.3.5), will do this for you.

When hidden, sidebars will slide in and out when moving the mouse to the relevant
side of the screen—or if you use any of the keyboard shortcuts that might otherwise reveal
these sidebars. For example, pressing \'88-R or using View » Reveal in Binder will typically
show the binder if it has been hidden, and so in full screen 1t will slide out the binder so
you can see the position of the file you are editing.

8.8.2 Full Screen and Layouts

Saved Layouts (section 8.7) will remember if they have been saved in full screen mode.
Switching to a Layout that has been marked with a full screen icon beside it will enter
full screen as well as re-arrange the window, making for a convenient way to work with
special-purpose Layouts intended to use a lot of space. If you do not wish for a Layout
to transition you to full screen, you can hold down the Option key when selecting the
Layout for use.

You may also select up to one full screen layout to use as a default. This will cause
Scrivener to trigger the use of this layout even when using the standard menu command,
rather than using the Layout features to access it. You can think of it as a way of setting
up Scrivener to have a different form of interface when entering full screen.

If no Layout has been selected as a full screen default, then the current window settings
will merely be expanded until the project window fills the screen.

8.8.3 Full Screen and Fixed Width Editing

Most of the default preferences have been chosen to complement the full screen feature.
When you enter full screen, the editor will switch automatically to using a fixed width
display, rather than a fluid width as it does normally. This means that no matter how wide
your screen is, the text editor will keep itself to a readable line length. If you’d prefer for
your editor to print text across the entire display no matter what, then you’ll want to
disable the “Use fixed width” and “Full screen only” options, in the Editor preferences
tab (section C.7).
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8.9 Filtering Items in Views

One of the ways in which you can work in Scrivener is with interleaved notation amongst
your work in progress. This is a method that some prefer, as it keeps their thoughts and
ideas immediately contextual with the text itself, and it supports a working method where
notes are more extensive than what can easily be put into annotations attached to the text
itself. In Scrivener, you can place text documents right alongside the documents used to
contain portions of your Draft, and then instruct these special note documents to not
compile (subsection 9.1.5)—in other words when you turn the Draft folder into one long

file, these note files will be hidden.

Ordinarily, when you view a portion of the draft with the Scrivenings view mode (sec-
tion 15.9), you will see all of your notes and draft text together. This can be advantageous,
especially if you use an alternate font for your note files—but there will be times when
you want to just see the compilable text that will become your book.

You can also select one or more containers and use the Documents » Open » (with)
Compilable Subdocuments menu item. The name of this menu item will change depend-
ing on whether or not you’ve set up your preferences to consider the container as part of
a Scrivenings session. Some prefer to omit the container, and so set “Include folder text in
Scrivenings (composite text mode)” in the Navigation preferences tab (subsection C.6.1)
to off. When this setting is disabled, the menu item will omit the ‘with’, and only the
children of the selected container will be included in the flat list.

A quick way of doing this is to hold down the Option key and click on a container
containing the portion of the draft you wish to view in this fashion. For some people
who use minimal organisation, this might mean using the Draft item itself. The result of
this action will be a flat multiple selection of items. You can actually view these in any
group view mode that you prefer, though in most cases you’ll probably want to use the
Scrivenings view mode.



Chapter 9

Setting Up Meta-Data

Documents of any type in Scrivener can have various meta-data associated with them.
Meta-data is a way of talking about something without changing it directly. A simple
example from the analogue world could be a Post-It note on a paper-clipped stack of paper.
The Post-It note is a kind of meta-data, as is the paper-clip.

In Scrivener, meta-data can be applied in similarly analogue fashion, like stamps across
the face of an index card, or what colour of pin or marking it has in its corner. Other
types of meta-data in Scrivener are more abstract, and you can even make up your own if
the built-in types are not enough.

Some of this meta-data can be viewed in the corkboard, the QuickReference panes and
outliner views, but the main interface for viewing and editing all of the meta-data for a
given document is the Inspector (chapter 19). This section will brief you on the various
types of meta-data available, and how to create more types if necessary, it will not go into
all of the details of the Inspector pane; please read that section to gain a full understanding
of how meta-data is assigned to documents.

9.1 Meta-Data Types

The basic meta-data types include the title and a text or image synopsis. The title is the
most important component of any item in the binder, as it will be used to identify the
document in the many views, menus, and export methods. When exporting as files, file-
names will be set according to the title field; when compiling, titles can be used to generate
headers for that section; index cards use the title; titles may also be used intelligently by
the compiler when linked to the document by that same name; and the outliner is com-
posed of a list of titles.

The synopsis is a plain-text field, primarily intended to be a short summation of the
contents of the document, though how you choose to use it is entirely up to you. The
synopsis is displayed in a variety of ways.

1. Corkboard: used to display the content area of the card.

2. Outliner: will be placed beneath the title (which appears in bold), by default.

109
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3. Binder: revealed in the tooltip when hovering the mouse over the corresponding
title.

Instead of the text synopsis, you can elect to use an image to represent a document
on the corkboard. This image will be used on the corkboard and in the inspector, but
whatever text exists in the standard synopsis field will be used in the outliner and binder
as described above, and in the various export and print options that include a synopsis
field. The image is not a replacement for the synopsis, but an override for the corkboard.

In all cases, specific types of meta-data can be displayed as columns in the Outliner view,
including custom meta-data.

@.1.1 Setting Up Label & Status

The next two forms of meta-data are flexible in what you can refer to them as. Using the
Project » Metfa-Data Settings... (X #-,) you can set up custom names for both the label and
status, and the interface will adjust accordingly, no longer referring to them as “Label” and
“Status” for that project. If you wanted, you could have “POV” and “Location” instead of
“Label” and “Status”, or “Focus” and “Type”, or “Monkeys” and “Bananas”, or anything
else you want. The documentation will continue to refer to them as labels and status for
convenience. They are also, after the title, the most visible items in the entire interface.
They can be represented in the corkboard and outliner views, are best administered in
the inspector, are given a priority position in the QuickReference panel, are displayed in
search results, and are given priority placement in most of the printing methods. Labels,
having an associated colour, can also be used to visibly tint various interface elements,
such as binder or outliner rows or even the entire index card “paper”.

The default blank project and many of the templates come packaged with a few example
status & labels, but you will most likely wish to create your own. To add or remove
project labels, use the Project» Meta-Data Seftings menu item. The interface provides
tabbed tables for four meta-data types.

Label and status lines can be added or removed with the + and - buttons. Edit an existing
entry by double clicking on the text. For labels, the colour can be changed by double-
clicking on the colour chip to the left. The order in which these items appear in their
respective menus is determined by their arrangement in this table. Click and drag rows
to rearrange them.

When you create new items in the binder, either by adding items or importing, they
will automatically be supplied by a default label and status value. Ordinarily this will be
assigned to the “No Label” or “No Status” choices, which is a special entry that cannot
be deleted, but they can be renamed. If you wish to change this behaviour, select the
alternate value by clicking on its row, and then click the Make Default button.
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Once you click the OK button, the interface will update with your changes it neces-
sary, and the new options will be available from respective meta-data drop-down menus
throughout the interface.

9.1.2 Label Colours

Labels can have a colour associated with them and are completely customisable—you can
even rename “Label” to “POV” or something that better fits your project (see below).
Labels are one of the most flexible meta-data types in terms of how visible they are in
the interface, so you can pick a colour to reflect how prominent you wish them to be
(richer more vibrant colours will stand out amongst pastel choices) depending on their
associated material’s content. Label colour can be expressed in the following ways, nearly
all of which are optional, and can be toggled in the View » Use Label Color In» sub-menu.

1. Corkboard: will be used to shade the upper right corner of the card when using the
rounded card theme. When using the classic card themes, the pin will be coloured
according to the label. Use View » Corkboard » Show Pins or ~8-P to toggle the
visibility of pins. The visual style can be changed in the Corkboard preference tab.

2. Outliner: can be set to tint the background colour for each row using the label
colour with View » Use Label Color In» Outliner Rows.

3. QuickReference Panels: the label is one of the priority meta-data values always vis-
ible at the top of the QuickReference panel for each document.

4. Binder: can be set to highlight the background of each binder item using the label
colour in a manner similar to the Finder. Toggle this behaviour with View » Use
Label Color In » Binder.

5. Icons: enabled with View » Use Label Color In » Icons, this option will tint document
icons wherever they appear.

6. Index Cards: enable with View» Use Label Color In»Index Cards this optional
method will tint the “paper” colour of index cards wherever they appear.

The label can also be used to tint colour printouts when printing corkboards and out-
liners.

9.1.3 Status Stamps

As with the label, the status field can have its representative name altered to suit your
project’s unique requirements. By default, this field represents the status of a document
in terms of its completion, such as “To do” or “Rough draft”, but this field can be used
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for whatever purpose you desire. Unlike the label, there is no corresponding colour, and
so its display potential is more limited.

Corkboard: can be displayed as a diagonal “stamp” across the face of the card. The
appearance of this can be adjusted in the Corkboard and Appearance preference tabs, and
display can be toggled with View » Corkboard Options » Show (Hide) Stamps or /3 -S.

QuickReference Panels: the status is one of the priority meta-data values always visible
at the top of the QuickReference panel, for each document.

@.1.4 Using Keywords

Each document can have a list of keywords associated with it. These are useful for making
documents easily searchable—for instance, you can list all characters and locations con-
nected with a scene in the keywords even if they are not mentioned explicitly in the text.
Creative uses for keywords also include extended status control, plot management, and
whatever else you can think of.

Like labels, keywords have an associated colour which will be displayed beside the
keyword in the inspector list, as an underscore in the relevant outliner column, and in
the Project Keywords window (see below). Additionally, keywords can be used in the
corkboard as small coloured squares along the right-hand edge of the card. The visibility
of these can be toggled with View » Corkboard Options » Show (Hide) Keyword Colors, or
~g-K. The display preferences for these can be adjusted via the corkboard display con-
trols (subsection 11.1.5).

When exporting or printing, keywords will be displayed on a single line, separated by

comimas.

9.1.5 General Meta-Data

In addition to the primary types of meta-data, there are a few smaller items, located in the
General meta-data section of the Inspector:

Modified The date and time the document was last changed and saved.

Created The date and time the document was first created. You’ll need to click on the
“Modified” label, beside the double-arrows, to switch to see this data.

Include in Compile A checkbox determining whether the document should be included
in the draft when exported or printed via Compile from the File menu. If checked,
the document is exported or printed; if not, it is excluded from the export/print
(this can be temporarily overridden in Compile). This way, you can have docu-
ments in the Draft folder that act as notes that are never included in the final draft.
Note that this setting really only has any meaning for documents that are inside
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the Draft folder, though it can be set anywhere, allowing you to modify text doc-
uments outside of the Draft in cases where they might at some point end up being
compiled, or used as templates for files that will be compiled. The checkbox never
has any meaning for media entries, as these items can never be compiled.

Page Break Before If this checkbox is ticked, a page break will be inserted before the
document when compiled. Useful, for instance, if the document marks the begin-
ning of a chapter. As with Include in Compile, this only has any meaning for text
documents inside the Draft folder.

Compile As-Is All options set in the compile formatting options pane (section 24.11)
will be ignored for the checked document. This means no extra material will be
added, nor will text be removed, including titles, and no reformatting of the text
will be done (the one exception to this being when a Quick Font Override (sec-
tion 24.26) is in use). As with the above two items, this checkbox has no meaning
for items outside of the Draft.

9.1.6 Custom Meta-Data

Custom Meta-data is a free-form feature which you may find a use for if you are looking
for the ability to mark sections with a specific piece of information that is often different
for each item in the outline, but has a common theme. This is in contrast to things which
have common information shared amongst many items—Labels or Status might do better
for that—or things which lack a cohesive theme where Keywords might be best.

An example of something for a work of fiction with a cohesive theme and a lot of
variety in what gets stored for each item could be timeline information. It is very likely
that most of the items in the outline will be taking place at different points of time. Thus
a special column for timeline date with a free-form field is an exemplary usage for custom
meta-data. Another example, from a non-fiction book on edible plants, could be Latin
names for the plant discussed in that outline item. This information is something you
would probably want to print in the book as well, but it might be useful to you to have a
concise list of Latin names in the outliner as a dedicated column.

And that brings us to presentation. Of all the meta-data types, custom meta-data are
perhaps the least visible. In fact, there are only two ways you can view them: in an
outliner column or in the dedicated inspector pane. As each field can be added to the
outliner as a column, that means you can sort by their values. This can prove quite useful
for some types of information. In the Inspector, you will be presented with a linear list of
text fields, each headed by the name of the field. This presentation makes it easy to write
as much as you need into the fields, or quickly see at a glance all of the details of the item
you are viewing.
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Hopefully you get the idea. You can of course use them however you like, just keep in
mind that they will not auto-complete (like keywords) or provide you with a list of stock
answers (like labels or status will). Custom fields are fundamentally free-form plain-text
fields, much like the Synopsis.

If you're still foggy on how this might be useful to you, a good example of custom
meta-data in use is provided with the application. Try creating a new project using the
Recipe Collection template in the Miscellaneous category. Don’t worry, you can toss it
later if you don’t need it, but take a moment to look at how custom meta-data has been
used to amplify the information storage techniques available to the project.

Custom-meta usage is generally limited to the inspector and outliner, though it can also
be exported along with the rest of the meta-data when compiling, exporting binder items,
and printing. The text content of custom fields can be search, as a unified group, using
Project Search (subsection 21.1.2).

See Also:

@ Custom Meta-Data Pane (section 19.7) for information on using meta-data in the
Inspector.

¢ Managing Columns (subsection 11.2.1) for details on how to add columns to your
Outliner view.

Managing Custom Meta-Data

Custom field management is done in the “Custom Meta-Data” tab, within the
Project » Meta-Data Setfings... window. For each column you wish to add, press the +
button (Figure 9.1) and supply a field title (which will be displayed as a header for each
text block in the respective Inspector pane, or a column header in the outliner). Each field
has two options:

Wrap Text Useful for fields where you want to display all of the entered text, even if that
text causes the row to expand in height in the outliner. Unwrapped columns will
only ever show the first line of text unless you edit the field. This holds true for
the inspector pane as well, unless you choose to wrap all fields regardless of their
settings.

Colored Text When checked, the colour selection tool at the bottom will be enabled,
allowing you to customise the text colour for this column. Text colour will be
displayed in the inspector (for the title of the field, not the text body) and outliner
columns for the text content of each row.
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Meta-Data Settings

Manage the label, status and custom meta-data lists specific to this project.

Project Properties Labels Status )

Custom meta-data can be added as columns to the outliner and will appear in the "Custom
Meta-Data" pane of the inspector.

Meta-Data Title Wrap Text Colored Text
Title v
Publication Date
Author
Abstract v
+ Text color: |
Cancel | ,

Figure 9.1: Project Custom Meta-Data Setup Tab.

Changing Appearance Order
As with label and status, fields can be reorganised by dragging rows in the configuration
table. The order displayed here will impact the following displays:

¢ Their order within the Inspector sidebar panel.
- Their appearance in the Outliner column view menu.

@& Most importantly, the order they will be printed when compiling with meta-data
enabled, as well as within the special meta-data text files that can optionally be in-

cluded when exporting files.
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9.1.7 Exporting Meta-data

All meta-data can be exported in a variety of ways, usually text-based for maximum
compatibility, so you needn’t fear having important organisational information getting
locked-in with the project format. Meta-data can be exported in the following fashions:

@ Compiling: when compiling the Draft, enabling meta-data export is an optional
feature of the Formatting pane. The various types of meta-data will be exported
into the Draft in a variety of ways best suited to the type of data involved.

- File export: when exporting files from the Binder, meta-data can be placed into
optional “sidecar” plain-text files corresponding to the main document being ex-
ported. This method is used to preserve the integrity of the original document,
and to enable meta-data export in formats which would not otherwise allow text
data to be inserted into it, such as mp3 files.

¢ Drag and Drop: When dragging documents from one Scrivener project to another,
all meta-data will be preserved where applicable. In some cases, like labels and sta-
tus, these values will need to already exist in the target project.

@ Qutline and Corkboard printing: both of these printing methods optionally allow
meta-data to be expressed in the printout. Unlike the above two examples, these
allow for a more fine-grained approach, letting you export just the label or keywords
if you want.

9.2 Copying Meta-Data Between Projects

Meta-data can be easily copied between projects by opening both projects at once, re-
vealing their respective Project » Meta-Data Setftings... panels, and then using drag and
drop to move selected labels, status or custom meta-data fields from one to the other. To
copy keywords from one project to another, use the same technique with both respective
Project » Show Project Keywords windows visible. Whole nested groups of keywords can
be copied at once.

In addition to this, dragging items from one project binder to another with assigned
meta-data will also update the target project if it does not yet have those pieces of meta-
data set up within it. This also includes keywords.

Changing the Defaults: If you find yourself doing this often, you might consider
making yourself a custom project starter template (subsection 6.10.2) with common
meta-data values already configured to your liking.
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2.3 Project Keywords

The Project Keywords window holds all of the keywords in use by the project. As you
enter new keywords into the Inspector (section 19.6), they will be added automatically
to the central project list. You can access this pane via Project » Show Project Keywords
(*C88-H) or by double-clicking any of the keywords in the Inspector pane.

You can create or delete keywords by using the buttons at the bottom of the panel:

¢ The left-most button creates a new keyword as a sibling of the selected keyword
¢ The second button creates a new keyword as a child of the selection.

¢ The third button deletes the selected keyword(s).

Keywords are automatically sorted alphabetically. You can drag any keyword onto
any other keyword to make the dragged keyword a child of the one onto which it was
dropped. For the most part, the hierarchical structure of keywords are really only an
organisational convenience with no effect on how the keywords are represented in docu-
ments themselves. There is one exception to this, below.

To assign keywords in the panel to a document in the main window, select and drag the
desired keywords from the panel and drop them into the keywords table in the inspector
of the main window, the header view above the document editor or onto the document
in the binder, corkboard or outliner. If there is a multiple selection in the binder, cork-
board or outliner and the keywords are dropped onto one of the selected documents, the
keywords will be applied to all selected documents. Hold the Option key down whilst
dragging to drag not only the keyword but also any parent keyword(s) under which it is
grouped.

You don’t have to use the keyword panel to create keywords, of course—you can also
enter keywords directly into the keywords table, in the inspector (section 19.6), to apply
them to the current document. Note that whenever you apply keywords via the inspector,
they will automatically be added to the list in the panel if they are not already contained
there, so that the panel should always have a complete list of the keywords you are using
in your project no matter how you have created them.

Keywords can be managed from the panel. By changing the name of a keyword in the
project keywords window, all of the associated keywords in the project can be updated
in the background. When removing keywords from the panel, they will also be removed
from all of the documents they had been assigned to. To change the colour that represents
the keyword, double-click on the colour chip to the right of the keyword.

The project keywords window also provides an easy way to search for keyword usage
in your project. Simply click on the keyword you wish to look for, and click the Search
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Meta-Data Settings

Manage the label, status and custom meta-data lists specific to this project.

| Labels Status Custom Meta-Data

Project Title: <$projecttitle>
Abbreviated Title: Manual <$abbr_title>
Author's Full Name: <$fullname>
Surname: <$surname>
Forename: <$forename>

(Gray text indicates the default values. Type over them to change them.)

You can use the tags next to each text field in your text or in the Compile settings (for
instance, in the header and footer settings). During the compile process, the tags will
automatically be replaced with the values in the text fields. If left blank, the file name will
be used for the project title, and the author's name will be taken from Address Book.

Cancel

Figure 9.2: Project PropeSetting Up Meta-Datarties Tab

button in the bottom of the panel. If you instead wish to search all text in the project
for that keyword (instead of just real keywords), hold down the Option key and click the
Search All button.

You can also search for combinations (using the Boolean AND logic) of keywords by
selecting more than one keyword and then clicking Search. All documents containing all

selected keywords will be returned. When searching for only one keyword, the “Exact
Phrase” method will be used.

See Also:

@ Project Search (subsection 21.1.2)

¢ Keywords Pane (section 19.6)
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.4 Project Properties

The fourth tab of the Project » Meta-Data Settings... panel contains some optional labels
that will be used in some of the built-in compile format presets, and can be used on your
own using the referenced placeholder tag to the right of each field (which can be copied
and pasted for your convenience).

As you might note from looking at this panel, Scrivener will attempt to use reasonable
defaults for these fields if they are not changed by you.

Project Title The Project Title is ordinarily taken from the name of your project file on
the disk, but in cases where that does not match reality (as it is often convenient to
use naming conventions in your project file names to set large revisions apart), you
can use this field to override the default and use your own title for the work.

Abbreviated Title Especially useful in headers, long titles often need to be shortened
to fit in the header area, so you can optionally use the <$abbr_projecttitle> place-
holder to display a shortened version of it. If nothing is supplied here, it will use
the project title value (modified or not) as a fallback.

Author’s Full Name, Surname, and Forename Ordinarily, these three fields will pull
information from your Mac’s Contacts.app (which may be called “Address Book”
in older versions of the operating system). program, using the default card set up by
your system when you first set up your computer. If you need to use a pen name,
these would be the fields you should modify. Do note that if you started with a
built-in template, some of these values will already be evaluated to text, particularly
in any title page material. Since they have been evaluated to text and are not using
a token, you will need to edit them separately; this panel will not update them.

Pro Tip: If you would prefer Scrivener to always use another identity than your
Mac’s main contact card, and cannot change that card for other reasons, you may tell
Scrivener to use another card instead. Simply type “(Scrivener:UseMe)” into the note
area of the contact card you wish to use from this point on for filling in all name and
contact information values. This change should take effect immediately, as soon as
the contact card is saved. However it will not change any existing text that has been

generated using template tokens in the past.



Chapter 10

(Gathering Material

10.1 File Import

Whether you are using Scrivener for the first time and want to use it with documents
you have already created in other programs, or whether you just have reference files lying
around that you want to bring into an existing project, the chances are that at some point
you will need to import documents created in other word processors and programs into
your Scrivener project. Fortunately, this is very easy.

Importing files into the project binder means that these files will be copied (and possi-
bly transformed into a fashion that Scrivener can use better) into the project itself. The
original copies on your disk will not be removed or altered in any way. While it is pos-
sible to easily edit many file types from within Scrivener with an external editor, if you
wish to retain maximum external control over the files, you might wish to use References
(section 19.5) or aliases (subsection 10.1.3) instead, which are useful when your research
material measures in gigabytes.

There are two ways to import documents from other programs:

1. Dragand Drop. In the Finder, select the files you wish to import and then just drag
them straight into the binder (not the corkboard or outliner) in Scrivener. When
dragging folders, all of the contents of that folder will be added recursively, and the
file structure on your disk will be recreated in the binder.

2. TheFile » Import sub-menu provides some handy methods for bringing existing ma-
terial into your project binder, including directly off of the Internet, if you have the
URL. In cases where the imported material has some sort of innate or optionally
defined structure, Scrivener will attempt to convert that into outline hierarchy; doc-
uments with split markings can be set up to create many documents upon import;
Final Draft files can be split by element; and MultiMarkdown files with their innate
header structure will be converted to outline hierarchy.

The first time you import anything, you will be presented with an informative window
describing important information pertaining to the various limitations of the import fea-
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ture. If you do not wish to view this warning every time you import files, be sure to check
“Do not show this warning again”.

When importing text documents, they are internally converted to the RTF format so
that Scrivener can work with them easily (again, note that this has no effect on the original
file on your disk, only on the copy that is made inside the Scrivener project during the
import process). This can cause some loss of data for some file types, or documents with
complex embedded data, like Excel spreadsheets.

When using the import menu items, material will be imported according to where
the current binder selection is set. If you have a line selected in the binder, the material
will be inserted between the selected line and the one below it. If more than one item
is selected, the last item (in top-down fashion) will be used as the insertion point. This
means that some forms of import will be disabled depending on where your selection
is. If your selection is in the Draft, you will be unable to import media of any kind; if
your selection is in the Trash, all importing will be disabled. The only exception to this is
importing another Scrivener project, and importing via the Dock or when using the PDF
print service. These ignore binder selection and create top-level items and/or folders at
the bottom of your binder.

When using drag and drop, the dropped material will be placed wherever the insertion
indicator in the binder shows. If you try to drag media into the Draft, the drop will be
prohibited until you move the mouse out of that folder.

10.1.1  Supported File Formats

Scrivener supports the following text types for importing:

@& RTFD (rich text format directory): A proprietary Apple rich text format com-
monly used by macOS Cocoa applications.

: RTF (rich text format): the universal rich text standard. This is often the best for-
mat to use for importing from word processors, purely upon the basis of speed.
With the new improved converters you can now import high-quality .doc/x and
.odt files into Scrivener directly, but with very large batches of documents you may
find this method to be too slow (although batch converting a hundred documents
to RTF can also take a long time without a good tool for doing so).

@ DOC & DOCX (Microsoft Word format): if you intend to import .doc/x files
directly, you should use the improved converters for doing so (you’ll be asked the
first time you try). This method is slightly slower, but the results will be much
better than using the macOS converters. DOCX is only support on Leopard and
greater with improved converters disabled.
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@ ODT (Open Document Text): the same statement above applies to OpenOffice

.odt files. ODT is only support on Leopard and greater without the improved con-
verters.

TXT (plain text): note that Scrivener tries to import all plain text files using Uni-
code UTF8 encoding; this should be absolutely fine in most cases, but if a plain text
document gets imported as gibberish you may need to convert it to UTF8 format
using TextEdit before importing it into Scrivener. If all else fails, use copy and paste.
Files with the following extensions will be imported as text as well: .log, .do, .xml,
.tex, .mmd, .md and .markdown. Additional extensions can be added to the Plain
Text Import Types (subsection C.10.3) tab of the Import/Export preferences pane.

PDF (portable document format): standard format for preserving and publishing
documents in a read-only format.

HTML (hypertext markup language): the language of the Web. Imported HTML
files can be converted to either rich text to extract just the content, or to We-
bArchive for full page archival. WebArchive files themselves can also be imported
directly into Scrivener.

FDX (Final Draft format): using the standard document format for Final Draft,
you can import scripts directly into any area of the Binder and have those im-
ported documents converted to Scrivener’s script formatting. Better yet, use the
File » Import » Import and Split... command to automatically split an FDX file into
smaller documents, with the ability to select where splits occur.

fountain (Fountain plain-text screenplay): like Markdown, this format is more of a
convention of how you type within a plain-text file. This makes the format suitable
for editing on nearly any digital device. Screenplays written in Fountain can be
dropped straight into the binder, or automatically split by scene.

FCF (Final Draft 5-7 File Converter Format): a special format for conveying scripts
into and out of Final Draft. Use this format to import scripts into Scrivener if Final

Draft 8 or greater is not available. As with FDX, can be automatically split into
individual files.

OPML (Outline Processor Markup Language): commonly exported from outlin-
ing style applications, this format well let you transfer an outline tree from one
application to another. Many applications will also save text notes attached to out-
line nodes, and if Scrivener detects them, it will use this material in the main text
editing area. This behaviour can be changed in the Import & Export preference tab
(section C.10). By default, each top-level outline node will be imported into the
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binder with all of its children. To contain the entire import in a single folder, you’ll
find an option in the aforementioned preference tab.

« .indexcard (Index Card for 1OS files): if you have no need for keeping Index Card
and Scrivener synchronised (section 13.3), and just want to import some cards
you’ve created, you can import an .indexcard file straight into the Binder. This
will work in a fashion similar to OPML. It will create a sequence of matching cards
for you based on the original cards in Index Card. This feature will not organise
cards from “stacks” into folders.

& No extension. Documents with no extension get imported into Scrivener as plain
text files (note that this can often be a source of confusion - if you try to import
an RTF or DOC file that has no extension, when you import it into Scrivener you
will see all of the raw code because it will be imported as plain text. Make sure you
add the appropriate extension before importing to ensure that Scrivener recognises
it as an word processor file).

As well as these text file types, Scrivener also supports all of the main image file types
(TTF, JPG, GIF, PNG, BMP etc), all of the main QuickTime audio/visual formats (MOV,
MPG, WAV, MP3 etc), PDF files, HTML, and .webarchive file types for importing saved
web pages from Safari and other macOS applications that support it.

Unsupported Formats on Snow Leopard and earlier: Any file type can be imported,
even if it is not supported by Scrivener. Such files will appear in Scrivener’s editor as an
icon with a link which, when clicked on, will open the file in the program associated with
it. Or you can click on the Quick Look icon in Scrivener’s footer bar to view the file in
a Quick Look panel. Unsupported files in the binder, while they cannot be viewed in a
split or edited are otherwise fully capable of everything other media files are capable of.
They can be organised, keyworded, annotated, and referenced. “Import supported file
types only” must be disabled in the Import & Export preference tab.

Unsupported formats on Lion and later: Most of the above still applies. The only
difference will be that Quick Look data is loaded into the split view, instead of simply
revealing an icon. If the selected item does not have any Quick Look data, then the icon
view will be used instead.

See Viewing Unsupported Document Types (subsection 14.3.5) for more information
on how to work with these types of files.

10.1.2 Web Page

This lets you enter the URL of a web page that you would like to import into Scrivener.
The web page will be archived on import, meaning you will no longer need to be con-
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nected to the Internet to view it (you can convert it to a text file afterwards by using
Documents » Convert » Web Archive to Text should you wish to edit the file). Web pages
cannot be imported into the Draft (which only supports text), so you must ensure that
a non-Draft item in the binder is selected for this item to be available, or change your
preferences to import web pages as rich text files. When such conversion is performed,
Scrivener will store the page’s original URL in References (section 19.5).

Functional Web Pages: Many web pages these days are “functional” in that you can do
things inside the web page after you load it. A good example of this is Gmail, Google
Docs, or even a simple search form. These sorts of pages, if they require a login, will
not import correctly. You will need to use copy and paste, or somehow export the

material from the web site to your drive in order to archive them.

You may also drag and drop URLSs from many supporting browsers’ location bar, into
the Binder itself, just as though you were importing a file from your hard drive.

10.1.3 Linking to Research Material

The default method for bringing research material into your project results in the original
file being duplicated into your project. From there, it becomes a part of the project in
every way. If you move the project to another computer, your research material will
follow. There are a few downsides to this. One is when you need to continue refining
and editing these external resources. While this can be done from within Scrivener, by
loading the file in an external editor—if you want these files to be up to date and available
to other applications, fully importing them represents a compromise. Another downside
is project size. While the project format itself is capable of great quantities of imported
material, this can slow down the automatic backup routine, and will make creating your
own backups less convenient, especially if the project contains many gigabytes of research
material.

The solution is to link to these items instead of importing them. The special menu
command, File » Import » Research Files as Aliases, can be used to establish a link between
the original file(s) and your project. Linked resources will be displayed with a small arrow
in the lower-left corner of the icon, in Scrivener. If these files are renamed or moved, the
link will adjust accordingly.

However if you move the project to another computer, the research files will no longer
function. The links will stay in place, and all meta-data or organisation you have assigned
to them will remain, but the source of the file will be offline until you return to the
primary computer where the link was established.
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This feature is only available for non-text research (PDF, multimedia, and web files)
that Scrivener can display in the editor window. On account of technical limitations, it
is not possible to link to a supported word processor file or plain-text document.

10.1.4 MultiMarkdown File

This imports a MultiMarkdown text file into the project by splitting it into multiple files
based on its structure, and recreating that structure in the binder. The Meta-data block
will be inserted as the first document at the top level, which Compile will use as auxiliary
meta-data on top of any Compile Meta-data settings for MultiMarkdown. Below that,
each header found in the MMD file will be used to create a new document at an appropri-
ate level of depth, with any text following that header up to the point of the next header
included in that document.

10.1.5 Plain Text Formatted Screenplay

Not to be confused with the Fountain format. When importing screenplays from Movie
Magic Screenwriter, Celtx, and other programs that export plain-text scripts, you can
use this import utility to have them converted into Scrivener’s script formatting auto-
matically. You can optionally choose to have the imported file split into multiple scene
documents for you. If you are working in Final Draft, you should use the FDX format
instead, with the Import and Split utility, or FCF for a version of Final Draft prior to 8.

10.1.6 Scrivener Project

Allows you to import another Scrivener project into the binder of the current project.
The files of the other project will be imported into a folder entitled “Imported Project
(original project name)” at the bottom of the binder, with the full binder structure intact.
Keywords, project references and any project notes are imported as text document(s).
Project notes will be imported as files into a “Project Notes” folder, placed at the top
of the main import folder. This command can also be used to import, and therefore
restore, corrupted projects. If you have a project that has somehow become corrupted
so that it can no longer be opened in Scrivener, use File » Import» Scrivener Project... to
have Scrivener do its best to retrieve all the data. All the text, synopses and notes will be
retrieved, along with snapshots. The outline structure may not be recovered from badly
corrupted projects, but every attempt to import the raw data will be made.

10.1.7 Import and Split

There are three modes for this tool:

1. Plain or rich text: when a supported text file is selected you will be presented with
a text field. Type in the separator that was used in the text to define sections. A
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common example might be a “#” character. Any line in the document that contains
only the text entered into this box will be removed from the file and used to split the
results in two. This process continues, further splitting the work into subsequent
binder items, until all of these lines have been processed. A portion of the first line
will be used to generate a binder title for each chunk.

2. FDX and FCF: Final Draft files can be imported using this tool, and when they have
been selected the interface will change, giving you a selection of elements to choose
from. You can select any one element to split by, such as scene breaks. The im-
ported Final Draft file will be split into multiple binder items at these break points,
and the script formatting will be converted to Scrivener’s internal formatting. The
sluglines will be used to name the individual scenes imported.

3. Fountain: Plain-text screenplays written using the Fountain markup syntax will be
automatically split up by scene, when the file uses the “.fountain” extension and
is chosen by this tool. The sluglines will be used to name the individual scenes
imported, unless scene titles have been specified. Additionally, scene descriptions
will be placed into the synopsis card, if discovered.

10.1.8 From Index Card for iPad

If you export projects from Index Card to Dropbox, you will get an .indexcard file. It
is possible to drag these files directly into the Binder to import them. Each card will
be imported as a separate document in Scrivener. If you would like to keep your Index
Card projects synchronised with these items in Scrivener, then see Index Card for 10S
(section 13.3).

This method does not have an associated menu command, it is purely a drag and drop
method.

10.1.9 From Scapple Documents

Scapple!, the freeform text editing software from Literature & Latte, gives you an easy to
use interface for roughing out a new idea.

At some point, it may be advantageous to move your idea from Scapple into Scrivener.
There are three ways of doing so:

1. If individual notes are dragged from an open Scapple document into the Scrivener
binder, or into a freeform corkboard, they will be converted into individual Binder
items, one per note. When dropping into a freeform corkboard, they will be placed

Thttp:/ /www.literatureandlatte.com/scapple.php
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spatially within the freeform corkboard in accordance with their relative positions
in the Scapple document (this cannot be precise, since index cards are static in size
and Scapple notes change their height depending on how much content they have
within them). If dropped into a standard corkboard, or directly into the Binder,
the spatial properties will not be maintained. This will be useful in cases where
the conversion from notes to index cards is not advantageous and results in a lot of
overlapping.

2. When bringing in a Scapple document that is not intended to be converted into
individual items, one per note, you would want to export as a text document from
Scapple (using the File » Export » menu in Scapple), and then import that as you
would import any other text document into Scrivener. If you find this results in a
confusing order, it might be better to use the first method, and then once you have
the order set up correctly in the binder, select all of the imported items and use the
Documents » Merge menu command to concatenate them into a single document
in the Binder.

3. If a Scapple document is dragged into the Binder (excluding the Draft), it will im-
ported as a file, rather than as notes. On Mac OS X 10.7+, a Quick Look preview
of the document will be displayed for you in the editor when you view it. Oth-
erwise the typical file icon will be displayed. You can now open it as you would
any other unsupported media format via the Documents » Open » in External Editor
menu command, or clicking the application icon in the footer bar of the editor.
This will be the most useful choice if the contents of your planning session are not
meant to form a literal foundation for the work you will be doing in Scrivener, but
rather as a reference to build from.

10.2 Scrivener Services

Scrivener installs several services that aid in grabbing text from other applications and
getting them straight into Scrivener without having to worry about manually opening
Scrivener and then pasting in the text yourself. The Services menu is not found in the
main menu bar, but in the Services submenu of the application menu (which will be
named according to whichever application currently has the focus). In all cases, you will
need text to be selected for the appropriate services to become available.

Services never show up: In some cases, you will need to log out of your account and
back in, after installing Scrivener for the system to properly register the services.
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Where the clipped text shows up will depend in part on the service chosen. In all cases,
the active project (the last project in use, even if Scrivener is in the background) will be
used as a target, and in some cases the active document or split will be used as the target.
In all cases, you must have at least one project open for services to work. If you wish to
collect text into Scrivener, but do not yet have a project created, you can use the Scratch
Pad Panel (section 10.3) instead.

Each method has an alternate form that will bring the selected text in unformatted.
This can be useful when clipping text from the web, which often has inappropriate text
colour and other formatting applied to it. All methods include an optional titling prompt.
If you supply a separator or title, this will be placed into the document separating it from
whatever content already existed. When using the formatted services, this title will be
emboldened.

The following methods are available:

Append to Current Notes Targets active document split.

Selected text will be appended to the active document’s Notes field, which may not
appear to do anything unless you have the Inspector open.

Append to Current Text Targets active document split.

Selected text will be appended to the active document’s main text area. If the current
document in Scrivener is not one that can hold text (for instance, if it is an image
document), the Scrivener icon will bounce and Scrivener will display a warning
panel telling you that you cannot append text to any open documents, and asking
if you would like to create a new clipping for the text instead.

Make New Clipping Targets active project.

Creates a new text document in the active project in Scrivener from the selected text
in the active application. Note that all new clippings are placed inside a “Clippings”
folder which will appear right at the bottom of the binder. This service is slightly
different from the above two in that the title you provide will be used to name the
clipping document that is created in the binder. A default, date-based title will be
provided in case you do not wish to bother with naming them individually.

It is possible to adjust whether or not you are prompted for a title, or whether Scrivener
comes to the foreground after using a Service, in the General preferences tab (section C.2).

10.3 Scratch Pad Panel

The scratch pad is a universal Scrivener tool that is not tied to any particular project.
You can use it to jot down notes that don’t fit anywhere else, or that arise whilst you
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are looking at another application. You can access it from the Window » Show (Hide)
Scratch Pad menu ({+ 8- Enter), or you can right-click on the Scrivener icon in the Dock
and select “Scratch Pad” (which will bring up the scratch pad over the currently active
application). The +3-Return shortcut is universal to your Mac, meaning you can use it
to toggle the window while working in other programs, so long as Scrivener is running
in the background.

The scratchpad is a floating panel, which means that you can have it open over all
windows in Scrivener, and even while you work on other documents or even other appli-
cations.

The top pane contains a list of all the note documents you currently have stored in the
scratch pad (by default there will only be one untitled note). New notes can be added by
clicking the + button in the lower-left, and notes you no longer need can be deleted with
the delete button next to it. Deleted notes will be moved to the system trash, so if you
make a mistake, you’ll find your notes by clicking on the trash can in the Dock.

When projects are open, the Send fo Project... sub-menu will provide you with a list of
all opened projects. There are two ways of bringing notes into the project:

1. Append Text To: The contents of the selected note will be appended after any exist-
ing text of the document you select in the project sub-menu. A list of your entire
binder will be arranged so you can easily select any text item. Note that media files
cannot be used since they cannot have text appended to them.

2. Import as Subdocument of: A new document will be created beneath the selected
document. This sub-menu operates in a similar fashion to the above, though it will
allow you to select any of the items in the binder since all types can contain children.
The name of the scratch pad note will be used to populate the title field for the new
document.

Since the scratch pad does not store your notes in any projects, it uses ordinary RTFD
files, which by default will be stored in your Documents folder under “Scrivener Scratch
Pad Notes”. These are regular files that you can edit with other programs. You can even
create your own rich text (or plain text) files in this directory, making it possible to add
notes while Scrivener is closed.

To change where notes are stored, and the system-wide shortcut, use the General prefer-
ences tab (subsection C.2.5). Pointing your scratch pad folder at a synchronised or shared
location (like a DropBox or Google Drive folder) means you can share scratch pads be-
tween Scrivener installations if you use multiple computers.

The Windows version of Scrivener uses RTF as its format, rather than RTFD. If you
wish to share scratch pads between platforms, you will want to change the default setting
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in the General preferences tab (subsection C.2.5). Existing scratch pad documents that
originated from the Mac will need to be converted by hand using a tool like TextEdit.

10.4 Print as PDF to Scrivener

If the information you wish to import into Scrivener is locked in a format that cannot be
used, a somewhat common way of capturing this information is to print the document
from the source application, and when the print dialogue appears, use the PDF drop-
down menu to select the target application. When you first ran Scrivener, it installed the
necessary mechanism for this to work. You should see an option in that list to “Save PDF
to Scrivener”. The source application will assemble the print, save it as a PDF file, and
then transfer that file to your active project. The imported PDF file will appear in your
Research folder.

TIPBOX: Mac App Store Installation: If you purchased Scrivener through the Mac
App Store, you will need to install this by hand, as the App Store guidelines do not allow
our software to handle this for you. To install the PDF service you will need to create an
alias of Scrivener in your Applications folder, and then place that alias in your personal
Library folder, under “PDF Services”. If you do not see a folder by that name, you can
create one from scratch. The Library folder will most likely be hidden. To access it, use
the Finder’s “Go” menu with the Option key held down, to see it. Whatever you call the
alias in this folder is what you will see in the PDF print menu. So feel free to name it to
something more appropriate like the default, “Save PDF to Scrivener”.



Chapter 11

Project Planning

11.1 The Corkboard

The corkboard provides a familiar, visual way of viewing documents in your binder. You
can arrange index cards in direct correlation with their order in the outline structure,
or alternatively as a freeform corkboard where cards can be freely moved about without
directly impacting the structure of the book. We will explore the various features in
depth, shortly, but first let’s take a look at the index card itself.

In Scrivener, every document you create is a document and an index card and a cork-
board and an outline. This can be a little confusing at first, for in the real world, an index
card clearly cannot also be a corkboard. In Scrivener, though, you can choose to view any
document as a corkboard. Each index card on a corkboard represents a document held
within the selected document in the binder that is represented by the corkboard itself.
Another way of looking at it: the corkboard displays the subdocuments of the selected
document as editable index cards. At the same time, the document displayed as a cork-
board or outline is also an index card (which holds the synopsis of that document), and
itself could also be viewed as an index card on a corkboard or a row in the outliner.

If that 1s as clear as mud, then read on.

11.1.1  So What are Index Cards, Anyway?

One of the principles that takes some adjustment to get used to is the relationship between
index cards and the text of the book itself. You can type titles and text onto the card just
like you would the real thing, but there is sometimes confusion as to why that text doesn’t
get dropped into the book.

So let’s take a look at what an index card really is. There are seven different components
to an index card, but depending on your preferences you might not see them all at once.

1. The document icon
2. The document location numeral (optional)

3. The title of the document
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=/ 3. A section of your book

This is the synopsis for the document
represented by this card. It is meant
to be a short summary of what the
document contains.

Figure 11.1: A fully loaded index card using the rounded card theme.

4. The synopsis of the document
5. The colour label (colour swatch in top-right corner; optional)
6. The status stamp (diagonal text stamped across the middle; optional)

7. Keywords indicators (swatches along the right; optional)

Also, not shown in the screenshot (Figure 11.1), it is possible to tint the colour of a
card based on its label. This can be used in addition to, or instead of, the colour chip in
the upper-right corner. To tint cards by label type, use View » Use Label Color In» Index
Cards.

At its most minimal, you’ll only see the icon, title, and synopsis, the three core elements
that cannot be removed. By default, keyword indicators will be shown, all other items
must be enabled in the View » Corkboard » sub-menu. All of the options you select for
corkboard appearance and label tinting will be saved into the project. If you prefer a
certain look by default, consider creating your own custom starter template.

The icon, as you might have guessed, correlates directly with the icon that is visible
in the binder. In most cases, this will be one of the variations of a folder or text icon,
depending on its content status, but in some cases it might be a custom icon if you have
supplied it with one, or if you are viewing a corkboard outside of the Draft, it might be
some kind of media file icon.

The title is simply what you would expect: it is an editable name of the item as it
appears in the binder, or in the header bar when you are editing it or view its corkboard.
The title is also often used by the compiler if it has been set up to consider it, but we’ll
come back to that in a later section.



11.1. THE CORKBOARD 133

The synopsis is meant to be a brief encapsulation of what the document’s purpose is,
but you can use it for whatever you like. Some people use it to keep track of the things
they need yet to do, others keep highly visible notes about what they’ve written so far, and
some don’t even fill them in at all just leaving them blank or using Scrivener’s automatic
generation tools to form a synopsis from the first few lines of text. Whatever you end up
using them for, it is important to realise that they are separate from the actual text of the
document, and in most cases what you type into them will not appear in the final book.
Use this to your advantage.

To edit either the title or the synopsis on a card, double-click in the text field you wish
to edit. Once editing, you can use Tab and 1+ Tab to navigate between cards and their two
editable fields, much like you would in a spreadsheet. To terminate editing, press the Enter
key at any time.

11.1.2 Index Cards as Images

Instead of text, you can choose to display a graphic for the synopsis instead. This choice
will be reflected in the inspector, as well as on the corkboard. There are two ways to set
an item’s synopsis to image mode. The easiest, if you have the graphic file already handy,
is to simply drag and drop it into the index card in the inspector. This will automatically
set the mode to image synopsis and import the graphic into the card for you. You may
drag graphics from the binder, a text document in Scrivener, from the Finder or other
software that allows one to export drag and drop graphics out of it. Alternatively, click
the index card icon in the header area of the synopsis card in the inspector, or press -7
on your keyboard to toggle back and forth. A blank placeholder will be shown until you
drag and drop an image into this spot.

Something to consider is that even if a card has been set to image mode, any text that
was typed into it before will be preserved. You may not be able to see it directly, but it
will be retained for tooltips, project searches and when compiling when the “Synopsis”
checkbox is active in the Formatting compile option pane (subsection 24.11.1). Likewise,
if you switch the card back to text mode, the image will be preserved in the background
in case you ever switch back.

To remove an assigned image, click the X icon in the far right top of the index card in
the inspector.

Image Size Opftions

Once placed, it is possible to adjust the display of the image to better fit the shape of the
index card aspect ratio. Right-click on the image in the Inspector to access this menu.
You can only select one from each of the two sets of options. The first set lets you choose
how the image will be scaled to fit:
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 Scale to Fit: this is the default mode and it will display the image so that both the
height and the width of it can be completely seen, even if this means adding extra
padding to the sides.

@ Fit Horizontally: scales the image so that the width of it will fit the frame, cropping
pixels off on the top and bottom if necessary.

a Fit Vertically: likewise, but scaling the image so that the height of it fits the frame
and the sides are chopped as necessary.

The second set lets you choose whether the image should be pinned to one side of the
index card or another, and will the options will change to reflect logical choices depending
upon your selection. For example, if horizontal fitting is chosen, the width of the index
card will always be filled, so choosing to pin left or right would make no difference. In
that case you choose between top and bottom. The default for both is to centre the image.
This choice 1s irrelevant when “Scale to Fit” 1s selected, above.

11.1.3 Linear Corkboard

The standard, or linear, corkboard displays a linked representation of one level and section
in your binder hierarchy. You can visualise this as a bit like looking at specimens on a
slide. Each slide has a slice of a tree branch on it. To look at a different (whether deeper
or higher) portion of the branch, you’ll need to load a different slide. The corkboard
displays one layer at a time, and by clicking up and down in the hierarchy you can view
different layers.

In the linear corkboard, moving items around will change the actual order of those
items in the binder. This makes it very useful for getting a “bird’s eye” view of a section
of your book, and enables you to affect changes upon the ordering of that book with
simple drag and drop (you can also use the ~ - Arrow keys to move cards around in the
direction corresponding to each arrow key). If you enable “drop-ons” in the Corkboard
preferences tab (section C.4), you’ll also be able to stack cards with other cards, just as
you would drop items onto a folder. Many other appearance and behaviour settings can
be adjusted in that tab.

11.1.4 Freeform Corkboard

While freeform corkboards have the same “single layer” method of looking at your binder
structure, they do not have a rigid linked relationship with it. You can move cards around
freely and without any sort of grid constraints. To switch to freeform view, click the small
“stack of cards” icon in the segmented control in the lower-right hand corner of the footer
bar. Click the grid icon to its left to return to standard linear mode.
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Figure 11.2: Corkboard options pane

You can freely switch between modes at will. Scrivener will store the position of your
cards in freeform mode even if you switch back to linear for a while. The two modes
remain discrete from one another, though they do share some preferences which you can
read about in the following pages.

Commit Order

Freeform mode can be useful for playing with an ordering idea without actually impacting
binder order. You might wish to see how a sequence of scenes looks without actually
changing the order and confusing things up in the binder. If you reach a point where you
feel you have an improvement, you can choose to commit the freeform order back to the
binder. Click the Commit Order button in the footer bar.

You will be given a few options to define your ordering style. Some work left to right,
other right to left; this panel will let you apply the ordering no matter which way you
work. Once you click the Okay button, nothing may appear to happen unless you were
paying attention to the binder. Committing the order will never disrupt the cards posi-
tion.

When using freeform corkboards for this purpose, you might find it useful to enable
View » Corkboard » Show Card Numbers.
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11.1.5 Corkboard Options

The Corkboard Options pop-up contains settings which are specific to each project.
Changes made to this pane will only impact the active project they have been made in, let-
ting you have two entirely different visual appearances for each major work. Any changes
made will be saved with the project, meaning you can save your preferred defaults into a
custom project template for future use.

To access the pop-up, click on the “Corkboard Options” footer bar button, as shown
(Figure 11.2). You can click anywhere on the corkboard to dismiss this pop-up pane.

Since the interaction between some of these settings are interdependent, here is a useful
guide for adjusting the settings based on what you want:

@ A large corkboard that ignores the width of the editor: disable Size to fit editor,

set the Card across to the desired corkboard width, and adjust the Size slider as
desired.

¢ Cards that have a fixed size that wrap like words depending on the editor width:
disable Size to fit editor, set Cards across to Auto, and adjust the Size as desired.

¢ Cards that adjust their size according to the editor width: set Cards across to the de-
sired amount and enable Size to fit editor. This is how the screenshot (Figure 11.2)
has been configured. It will always print two cards per row, sizing them to be as
large or small as necessary, depending upon the width of the corkboard in the edi-
tor.

Size There are two ways of arranging index cards within a corkboard. The first is to set
the size of cards and then let the corkboard wrap the cards as they fit, the second
is to provide a number of cards you always want to see in each row, and let the
corkboard resize the cards to fit that number. When the latter method is in use (see
below, for setting that), the Size control will be disabled.

Ratio Determines the size ratio between height and width. By default this will be 3 x 5,
in order to emulate the appearance of real index cards. If you write very long or
very short synopses however, you might find that adjusting this to produce shorter
or taller cards will be of benefit.

Spacing The amount of space that will be drawn between index cards, both vertically and
horizontally. To pack more cards into the display at once, move the slider toward
the left. To spread out the cards and make them more distinct, move the slider to
the right. This option is only relevant to linear corkboards.
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Cards Across Set this to the number of cards you would like to appear in each row. Use
“Auto” to have Scrivener determine this amount based on the size of the cards.
When “Size to fit editor” (below) is disabled, it is possible for corkboards to grow
larger than the editor size, which may be desired for some purposes, and will re-
quire horizontal scrolling in order to see the entire corkboard contents. You can

b}

choose any number between 1 and 10 cards across, or use the “Other...” option to

specify any arbitrary amount. This option is only relevant to linear corkboards.

Keyword chips Set the maximum number of keyword colours to be “taped” to the right
side of the index card. When a document has more than that amount assigned to it,
all keywords below the specified point will be ignored. You may wish to adjust the
Ratio to increase the height of the index card, if you want to view large numbers of
keyword chips at once.

Size to fit editor This option is not available when “Cards Across” is set to Auto. When
the Cards Across option is set to a number, this option will resize the cards to fit
the current editor width. With this option off, the card size option will be used,
and cards will be forced to wrap at the specified number regardless of the window
size. This option is only relevant to linear corkboards.

Use small font The small font settings can be configured in the Corkboard preferences
tab (section C.4). Note that since you have full control over this and the standard
index card fonts, “small fonts” might not actually be any smaller than the regular
font size.

Further Options: There are a number of other appearance related preferences that
you can set, which can dramatically alter the look and feel of the corkboard. Most
of these options are included in the Corkboard preference tab (section C.4), but a few
colour related options are also in the Appearance tab (section C.3).

11.1.6 Stacked Corkboards

When more than one container of any type has been selected, the corkboard will switch
to a special stacking mode, displaying the contents of each container, separated by a line.
By default, this will wrap each container’s section as though it were a normal corkboard;
cards will be displayed according to your view settings. You can also select between ver-
tical or horizontal stacking by clicking on one of the left two buttons in the segmented
control, found on the right side of the footer bar, near the view options button.

Horizontal mode will place all of the cards within each container on a single row, so
you can easily view them sequentially. Vertical mode will do likewise, but reserving one
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column for each stacked container. There is no functional difference between these modes
save for aesthetics and how they use screen space. Both are useful for tracking the precise
flow of index cards between a large selection of containers. You might, for instance, use
it to compare how scenes in a novel are balanced between chapters, but using the label or
keyword colours to scan for POV and character appearance frequency, or plot threads.

An optional numbering scheme can be applied with View » Corkboard » Number Per
Section combined with the above option to “Show Card Numbers”, this will start count-
ing from one for each container stack. When disabled, cards will be numbered sequen-
tially even across container sections.

11.1.7 Placing Images on the Corkboard

When working in an area of the binder outside of the draft folder, it is possible to import
graphics and other media into your binder. They will be supplied with special icons,
indicating the type of file they are. Graphics will be represented with a small iconic image
of a sunset photograph.

When viewing a corkboard that contains graphics, they will be drawn on the corkboard
as a photograph, rather than the typical index card. This behaviour can be changed in the
Corkboard preferences tab (section C.4), if you prefer to see your summary synopsis for
the image instead.

You may also change how any item at all in the corkboard is represented in a way which
will always override the default. Even folders and standard text files can be represented
by a photograph, or vice versa, photographs can be represented as index cards with a text
synopsis. For further instructions on how to do this, read the Synopsis Card (section 19.1)
overview in the chapter on the inspector.

This will only change the item’s representation on a corkboard. The text synopsis will
not be deleted, and can be edited using the outliner. The binder icon will not change. If
your graphic files have text icons, this means they have been dragged into a text file, rather

than imported directly. You can rectify this problem by dragging the image from the text
file back into the binder.

11.2 The Outliner

Outliner mode shows all of the descendants of the current document along with select
associated meta-data in a tabular format like a spreadsheet. The default configuration will
show the title and synopsis in the main column on the left. You can edit by double-
clicking into the text field you wish to edit. Once editing, you can move between titles
and synopses with the arrow keys, much like in an ordinary text editor or outliner. Press
Enter to exit editing mode.
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You can expand or collapse the outline by clicking on the small disclosure arrow to
the left of the title. When viewing an outliner with only text documents, you may not
see any arrows. All items can be expanded completely with View » Outline » Expand All.
Conversely, all items can be completely closed with View » Outline » Collapse All. Addi-
tionally, you can hold down the Option key and click on any arrow to completely expand
or collapse that portion of the tree.

Most columns that allow you to edit their data will provide controls for doing so.

¢ Checkboxes: an example, “Page Break Before” will present a checkbox that you can
click to add a page break before that document when exporting. You can impact
many checkboxes at once by holding down the Option key and clicking on a check-
box. All visible checkboxes will be impacted. This means if items have been hidden
with their disclosure arrows in the outliner, they will not be impacted. However
if you select a number of items first and Option-click on a checkbox, only those
selected items will be modified.

¢ Labels and Status and Target Type will provide drop-down menus that you can use
to adjust the meta-data for a row. For labels and status, If you wish to impact more
than one row at once, select these rows first and then use right-click to access the
contextual menu, instead of clicking directly in the outliner.

¢ Columns with editable text, such as the Title, custom-meta data, or Target column
will not provide a control, but you can simply double-click on the field to change
their value.

11.2.1 Managing Columns

To add or remove columns from the display, click the small ”»»” button in the far-
right column header bar, right-click in any of the column header names, or use the
View » Outliner Columns» sub-menu. Column settings are saved per editor split. So you
can set up an outliner to perform a particular function on the left side of your screen, and
display extended information on the right side, just to provide an example. The column
selection pop-over will remain focussed until you click elsewhere or press the Escape key,
making it easy to manage multiple columns. If you would prefer to use the single-access
menu instead, right-click on the “»»” button.

To change the order in which the columns are displayed, drag and drop the column
header to the desired location. You can resize the column width by moving your mouse
between column header titles until the cursor changes to a double-pointed arrow, then
click and drag to increase or decrease the width of the column.
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Title Column: these three options specify how the compound Title column should ap-
pear. This column will be named “Title and Synopsis” when the “with Synopsis” column
is checked.

@ Title

- and Synopsis

- with Icons

Corresponding to the general meta-data: the first two columns allow you to edit the
Label and Status of each row individually. The remaining three columns are read-only.
Keywords will be underlined using the colour that has been assigned to that keyword.

- Label

@ Status
 Keywords
- Created Date

8 Modified Date

Statistics: the first two options show the word or character counts for each item in the
outliner. The second set will not only show the statistics for that row, but will sum up all
of the items descending from that row as well. A folder itself might have no words in it,
but if it contains five text files with 1,000 words each, the folder’s row will display 5,000
in the Total Word Count column.

The word count columns will colour the text according to your progress bar colours.
So if you prefer to not turn on the progress bars (discussed below), you can still get a
rough idea of how far you are form your goal, based on the colour of the text.

x Word Count
:a Character Count
: Total Word Count

@ Total Character Count

Further options from general meta-data: the checkboxes displayed in these columns are
directly linked to their respective options in the Inspector, general meta-data section.
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@ Include in Compile
¢ Page Break Before

@ Compile As-Is

Targets and progress tracking: as with statistics, these show target tracking information
for each item in the outliner, and the “total” variants will add up the combined statistics
for all descendants as well. If a folder has five text documents, each with a goal of 1,000
words, the Total Target column will display 5,000. If the sum total of all words in the
descending documents is 2,500, the Total Progress tracking bar for the folder will be filled
to 50%.

- Target

a Target Type
@ Progress

@ Total Target

¢ Total Progress

Any custom meta-data fields you have created will be listed at the bottom of the menu
as well.

11.2.2 Special Columns

In addition to the standard columns, there are two choices which impact the main Title
column. They are indented beneath the Title option in the column menu.

@ and Synopsis: embeds the text of the index card synopsis field beneath the title.
With this option enabled, the title will be emboldened and you can edit both Title
and Synopsis together right in the outliner. The Show (Hide) Synopsis button in the
footer bar provides a shortcut to turning this special column on or off.

- with Icons: When disabled, item icons will be removed from the outliner display,
producing a cleaner, more “text like” appearance.

The Title (and Synopsis) column is also special not only in that it provides compound
information, but if it is the only column present, it will automatically fill the entire width
of the outliner.
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11.2.3 Sorting by Columns
To sort by columns, click on the column header. The first click will sort ascending, click-
ing again will sort descending, and a third click will turn off sorting.

This form of sorting is a way of viewing information in the Outliner. It will not impact
the underlying order of the items in the Binder, so you can safely use it in conjunction
with other methods of gathering items or viewing them, such as search results or multiple
selections, without fear of disrupting your book structure.

If you do indeed wish to change the underlying Binder order to match the outlining
sort order, you can do so by selecting all of the outliner rows you wish to change and
dragging them back into the folder they reside in, in the Binder or back into the folder
they are indented beneath in the Outliner itself. When items are dragged (even back to
their same location), their order is remembered, so as long as the sorted items come from
the same folder, dragging them back to that folder will re-order them in according with
their visible order in the Outliner (or Corkboard, for that matter) view. This cannot be
used to re-order many items within sub-folders at once. You’ll need to re-order each folder
individually.

In the case of the Title (and Synopsis) column, sorting will be performed by item title,
not the synopsis content.

11.3 Project Notes

As your project begins to take shape, you will no doubt have many ideas that you wish
to capture, but nowhere concrete to put them yet. Documents all have a separate note
pane which can be accessed in the Inspector (section 19.4), but if you don’t even have a
stable outline built yet, there are no documents to put notes within. There are a number
of ways you could approach this problem, such as keeping notes as documents in the
Research folder or somewhere else outside of the Draft or even in the Draft with their
respective “Include in Compile” flags disabled.

You might also find the Project Notes tool to be useful, as it is accessible from every-
where in the program. Project notes, like document notes, are a rich text field. That
means you can format within them however you please, even drag pictures into them.
Project notes can have different styling than document notes, making it easy to tell which
you are currently viewing or editing. These can be set up in the Appearance preferences
tab (section C.3).

Their primary advantage is that they can be viewed from the Inspector, no matter what
you are viewing, and even make an appearance when what you are viewing what would
ordinarily have no Inspector data, like the Draft or Research folders.
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Project Notes and Exporting: Project notes are not set up to be easily exported. There
is no way to compile them at all, without copying and pasting their contents into a
Binder document. Document notes can be included in various compile options, but
project notes cannot; nor can they be exported via any menu commands. So use project
notes only for things which are strictly internal to the project. If you intend to export
or compile notes at some point, it might be easier to take the original suggestion of

using documents in the binder.

To demonstrate, open the inspector if necessary (click the blue ‘i’ button in the toolbar,
or press X #-1) and click on the Draft folder. The inspector will be replaced by a single
pane titled “Project Notes” (if that didn’t happen, you might be viewing one of the index
cards in the corkboard that pops up. Just click once in the background of the corkboard
to de-select any cards.) Type in a sample line into Project Notes so we can track it around
the interface as we explore this feature.

This field is not only accessible from the Draft, but any document can view the project
notes in their Inspector as well. Try clicking on one of those index cards in the Draft
corkboard and make sure the left-most button in the top of the inspector is selected (the
one that looks like a little notepad). By default, this will show you the document notes
for that selected card. You can click on the header bar where it says “Document Notes”
and select “Project Notes” instead. The sample line that you typed in above will become
visible and the background colour will change. You can easily flip between notes with
8- 6 while the inspector is open.

Project notes can also be viewed in a floating window. To view the project notepad, in-
voke the Project » Project Notes menu command, or press 88— P. The text area is a mirror
copy of what you see in the Inspector.

See also: The Inspector (subsection 4.1.5).

11.3.1 Managing Project Notes
Open project notes by using the Project » Project Nofes... menu command or by pressing
X 3-P.

The sidebar along the left will display the available notepads in this project. Along the
bottom you’ll find a + button. Click that to create a new tab. Now you have two project
notebooks. These are completely independent from one another, and so can be used to
store different types of notes.

To rename a notepad, double click on its name in the sidebar. Notepads can also be
re-ordered by clicking and dragging on them.

Delete the selected notebook by clicking the - button.



144 CHAPTER 11. PROJECT PLANNING

11.3.2 Using Multiple Notepads in Inspector

With multiple notepads you’ll probably want access to them in the Inspector as well. To
see how this is done, view a document and open the Inspector, click on the notes header
again and you’ll see the new notepads you created.

As always, use -6 to flip between them all, and now ~8-6 is also available to rotate
backward through the list. Both of these commands wrap around the list so if you get to
the top or bottom they will keep going in the same direction in an endless cycle.

11.4 Setting Default Project Formatting

Sometimes a project will need its own visual font and ruler settings. Ordinarily, all new
files you make in all projects will conform to the settings in the Formatting preferences tab
(section C.8). Using Projects » Text Preferences..., you can supply an override to a specific
project, so that its new documents take on a custom appearance.

Scriptwriting and Fonts: when using Scrivener to compose scripts, the font for the
script will be selected for you based on the script settings, not the application settings
or this override. See Scriptwriting (chapter 20) for further details.

First, enable “Use different default formatting for new documents created in this
project”, with the checkbox at the top, and then proceed to use the mock editor to set
up your preferred styling for this project. This works just like the Formatting pane, or if
you haven’t used that before, much like the standard text editor. The Use Current button
provides a handy way of importing settings from the current text editor at the cursor po-
sition. So if you’ve already set up a document to look the way you want it to, using this
button can save some time.

Use different font for footnotes This also overrides the application preferences for an
alternate footnote font. This setting will impact both inline and linked footnotes
(chapter 18). It will work even if you are not setting a custom font for footnotes in
the main application preferences.

Use footnote marker An alternate way of referencing linked footnotes, which places a
custom marker after the selection or current word, rather than highlighting it. In
documents that make use of heavy notation, this can help keep the editor looking
clean. The marker used can be typed into the text field.

If you prefer this behaviour for all of your projects, clicking the Make Default button
will force your setting on all projects, even those you’ve already created.

Read more about this feature in Linked Footnotes (subsection 18.2.3).



Chapter 12

Working with Scrivener for 105

This chapter will go into how to use the 1OS version of Scrivener, save for where its usage
intersects with the macOS or Windows versions. We’ve prepared a tutorial /reference for
you, built right into the 10S app. If you’d like to learn how to use it, that’s the place to
go!

As for here, we’ll dig in to the ramifications of what 10S now means from the perspec-
tive of using your computer, whether you wish to use the mobile version to edit your
own projects, or if you intend to work with others who use it. You should find things
won’t have changed much when it comes to using Scrivener on your laptop or desktop.
We hope you find the transition to be easy to use and liberating (that is, if you’re the one
walking around with your manuscript in your back pocket).

12.1 Basic Usage

The Scrivener project format has been internally revamped to support seamless mobile
usage. The 10S app comes with Dropbox integration built-in—which will make for the
most convenient option—but the syncing system was specifically built to withstand all
forms of file transfer (seeing as how Dropbox is a file-based system, this is no mere side-
effect!). You can package the project up by exporting it from the app, send it to yourself
via e-mail, AirDrop or even copy the project to a thumb drive and send it to a colleague
through the post. Syncing happens when projects are opened, the rest is up to you.

When sync occurs, every change made with the mobile version will be in turn made to
the main project, effectively merging them together. From your point of view, the effect
will be to simply pick up right where you left off on your iPad, moments ago, right down
to the last document you were working on being shown in the main editor.

Meanwhile all 10S devices share the same mobile data within the project. Keeping an
iPhone and iPad synced together is easy, and for some people that might be more common
than syncing a laptop and iPhone together.

This does all mean that syncing must be done whenever you switch devices. If you edit
the same project from two locations at once, or overlap editing sessions without syncing
intermediate changes, you will most likely need to resolve some conflicts. We’ll get in to
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that later, but don’t fret, it’s just a way of letting you decide which copies to use, or which
parts within those copies should be merged into the best version you meant to write.

First, we’ll discuss how to get projects from point A to point B, and then we’ll talk
about what happens once you’ve copied them (subsection 12.1.3).

12.1.1  Sync with Dropbox

This should probably go without saying, but there are two basic ingredients you’ll need
to get this all working:

« First thing you will want to do is set up Scrivener for 10S so that it is hooked up
to your Dropbox account. If you are unsure of how to do that, please consult the
built-in tutorial on your device, or tap on the circular arrow icon in the main project
screen and walk through the setup screens.

@ On your computer, you'll need Dropbox installed and running in the background.

In the process of setting up sync in mobile Scrivener, you will be asked where you
wish to save your projects. By default this will be to the Dropbox/Apps/Scrivener folder
(one will be created for you if it does not already exist). Where this is relevant to your
computer is that once you select or create that folder, you can simply navigate to it and
open projects in Scrivener (section 6.4), directly, as you would open any other file from
your Dropbox folder. You can also drag projects on your computer into this folder and
then sync them to your device once they have finished uploading to Dropbox.

While on your computer, you can organise your projects into subfolders within this
chosen sync folder. This will change nothing on the mobile side, there are no “folders” in
the project management screen, but if you’d like to keep your projects organised you can
safely do so.

The basic ideas to employ here are:

@ Projects you create and sync to Dropbox, from your devices, will appear in the
designated folder on your computer where they can be opened and worked with
like normal projects. Once you’ve done that, they are normal projects.

& Projects you place into that folder can be synced and edited remotely, even if you
leave it open on your computer.

If that’s all you want to do, you could probably stop reading this chapter right now! But
before doing so, I'd urge you read up on Avoiding and Resolving Conflicts (section 12.2).
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Using Multiple Sync Folders

Although we do not recommend switching sync folders frequently (you will need to
download everything all over again every time you switch), if you need it, you've got
it. This may be useful if you’re collaborating with another person over Dropbox, or if
you use your device for personal writings as well as using a shared work folder, and wish
to keep the two separate.

1. On your i0S device, return to the main project screen.
2. Tap the Edit button at the top of the project list (in the sidebar on an iPad).
3. Tap the “gear” button at the bottom of the list.

4. Select “Dropbox Settings”. At this point you would select your preferred sync
folder.

At the conclusion of this process, you can choose to keep the projects you've been
syncing (they will be moved to the device, not uploaded to the new sync folder), or to
remove the local copies. Neither option will touch Dropbox. If you keep local copies
and later switch back to the first sync folder you may end up with duplicate copies of the
projects, those stored on your device and those in the sync area. It will be up to you to
sort out which to keep.

Where is iCloud Support? If iCloud were compatible with the format we use to store
your project, we’d support it, that’s the simple fact. At this time, Apple’s interface
for working with iCloud is designed around a model which presumes one single file
stores all of the information needed to open and save the document. To be fair, in
most cases this is a safe assumption! Scrivener’s format, designed with the capacity to
store gigabytes of research data, uses a special folder-based format used by your Mac.
A single project may require dozens, maybe even thousands of files, to all be working
together in unison as a single “format”. Until such a time as iCloud supports this form
of working with data, we will be unable to provide that method for synchronisation.

While automatic syncing is out, we do support importing from your iCloud Drive;
you’ll be able to download PDFs and other materials into your projects. If you are
unwilling or unable to use Dropbox for full syncing, please refer to Managing Projects
Directly (iTunes) (subsection 12.1.2).

12.1.2  Managing Projects Directly (iTunes)

Dropbox may not work for all of your projects, or you might be unable or unwilling to
use it at all. No fear! You still get all of the goodies, but you’ll need to handle copying
projects to and fro.
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iTunes and other file managers

The easiest option will be with the iTunes software itself, using its “File Sharing” to access
documents stored by the various apps on your device. With Scrivener’s document list
loaded, you can copy projects directly onto the device over WiFi or USB cable, and copy

updated projects down to your computer in the same way, with drag and drop to or from
the Finder.

Third-party iOS device managers may provide more features as well as better ways of
working with files. If you don’t like how iTunes works, there are plenty of choices on
both platforms.

Third-party sync

You may also find that other cloud services with an 10OS app work, albeit in a manual
fashion (more like copying than “syncing”), as a way of transferring projects on or off the
device. If the 1OS sync app lets you send folders to other apps on your device, then try
sending the project folder, ending in “.scriv”, to Scrivener for 10S, from that app.

Export as Zip

Finally you can export projects from your device by sharing them as Zip files:

1. On the device, from Scrivener’s main project screen, tap the Edit button.
2. Select the project you wish to send.

3. Tap the “Share” button at the bottom of the project list.

At this point a number of services are available to you, depending upon what you have
installed on your device. At a basic level you’ll be able to e-mail a copy of the project.
Other programs may allow you to store the .zip locally, as a backup, or sync it to another
cloud service.

Using AirDrop to Transfer Projects
With Mac OS X 10.10 “El Capitan” or greater, you can use AirDrop to copy projects

between an 10S device and your Mac.

To copy a project to your mobile device:

1. Enable AirDrop on your iOS device (by default you can swipe up from the bottom
of the screen, tap the AirDrop button below the volume slider, and select your
privacy setting).
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2. Now open the AirDrop window on your Mac, using the Finder’s Go» AirDrop
menu command ({8 R).

3. You should see your 1OS device appear as an avatar, to send the project, drag and
drop it onto the avatar in the AirDrop window, then accept the file transfer on your
device.

4. Once it has transferred, you may be asked which program you wish to load the
project in, choose Scrivener (naturally!).

To copy a project from your device to your Mac:

1. Open the AirDrop window on your Mac, using the Finder’s Go » AirDrop menu
command ({1 #-R), and ensure “Allow me to be discovered by:” is set so that your
Mac can be seen.

2. On the device, from Scrivener’s main project screen, tap the Edit button.

3. Select the project you wish to send.

4. Tap the “Share” button at the bottom of the project list.

5. You should find your Mac’s avatar as an option in the share panel, tap on it.
6. From the Mac, accept the file transfer.

7. The project will be saved to your Downloads folder, as a .zip file. Double-click the
.zip file to extract the project (you can discard the zip if you wish) and then drag it
wherever you’d like.

12.1.3 Updating Projects with Mobile Changes

When you open a project that either originated from iOS or has been modified by it,
loading the project may take a little longer than it ordinarily would. This is because
Scrivener is going through all of the changes that have been made in both directions, and
doing its best to build a cohesive merged copy out of the two. At that point, all necessary
changes will be made to the project, potentially building out dozens of binder items and
populating them with thousands of words of text, if you’ve been on the road for a while.

The first time this process concludes, you will be asked whether you’d like to have
changed documents listed in a yellow Collection (section 7.4) called “Synced Docu-
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ments”.! The previous contents of this collection (in subsequent syncs) will be replaced
with the listed items from the latest sync, so if you plan to review them, do so before the
next sync, or copy the list to a new collection for safe-keeping.

In most cases, at this point you’re all done! To sync a project you need only open it.

If the project was already open on your computer, when you switch back to the win-
dow, Scrivener will check for mobile changes and alert you if it needs to sync before you
can safely continue. Use this opportunity to double-check and make sure Dropbox
isn’t actively working, if it is, it may still be downloading parts of your project and sync-
ing right now would make a mess. Once Dropbox has stopped working, click the button
to update your project. It will need to reload in order to do so, and by default a backup
will be created before syncing.

Sometimes you might leave the project open and its window active. Scrivener won’t
constantly check the disk to see if there are mobile changes available, it only does so when
loading or activating the project window. To initiate a sync from an active project win-
dow you can click the mobile sync button in the main application toolbar, or use the
File » Sync » with Mobile Devices menu command. You can also try using this if for any
reason you think sync should be happening but isn’t. If no mobile changes are found,
nothing will be done, so it is safe to try.

12.2 Avoiding and Resolving Conflicts

Although we’d like to say that sync is magic and never gets anything wrong (and that we
as humans never misuse it!), reality often sticks a wrench into the works. A conflict is
typically nothing to be too concerned with. All it means is that particular aspects of the
project were edited in two or more locations without keeping them in sync, and in such a
way that Scrivener can’t figure out which is best. For example if you step away from your
computer, sync properly to your iPhone and make a change to a particular binder item,
but forget to save your changes from the phone back to Dropbox, then editing that same
text file on the computer later on would mean both machines might now have valuable
work you wouldn’t want to lose, once they finally do sync.

We do our best to warn you when it looks like a sync really should happen before you
start working, but not all situations can be detected automatically. Your first warning
will be when conflicts are detected. We give you a chance to wait and make sure Dropbox
is done working. After proceeding past that checkpoint, the project will be synced.

'Tf you change your mind later on, you can adjust whether this list is created with the “Place docu-
ments affected by sync into a “Synced Documents” collection” checkbox, at the top of the Import/Export
preference pane. Additionally you can choose whether or not this collection is shown after syncing.
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If any conflicts were found, a second copy of the item will be created within a folder
called “Conflicts”, added to the top level of the Binder. The original binder title of the
conflicted item will be used for each, with “(Conflicted Copy)” appended to their titles.
Additionally a Reference (section 8.5) will be added to the conflicted copy, pointing back
to the original version in the Binder that it conflicts with. With default settings, that
means you could open a second split and double-click the reference icon to view the two
copies side-by-side for comparison.

Of course the best way to handle conflicts is to avoid getting into the situation in the
first place! These simple rules should help you stay out of trouble:

& Remember to sync your device when you’re done using it. Think of it like saving,
the more you do it, the safer you’ll be.

@ Don’t edit your project from more than one device or computer at once.

: Pay attention to Dropbox status on your computer. Don’t start syncing with i1OS
until your computer has stopped uploading the most recent changes to the project.

In the other direction, even though you might have already synced the iPhone to
Dropbox, that doesn’t mean your computer is instantly up to date. It may take a few
seconds or minutes for your changes to fully download. Don’t risk it! Wait until
Dropbox has stopped working for several seconds before syncing mobile changes
into the project.

For additional protection against conflicts, consider enabling the “Take snapshots of
updated documents” checkbox, in the Import/Export preference pane. Be aware that
option will, over a long period of time, generate quite a number of snapshots.

12.3 Working with Fonts

When working across multiple platforms, fonts can sometimes be a problem (yes, even
between 10S and macOS), resulting in the font assignment being lost, and typically drop-
ping to some editor default, such as Helvetica. The problem originates with how each
platform refers to fonts differently, and small variances such as these can cause one plat-
form to not understand how another has assigned fonts to your text.

In short it’s not a serious problem, you can select the text and apply the font again
(possibly using the Documents » Convertf » formatting to Default Text Style..menu com-
mand (subsection 15.4.5)), but it is annoying, and so you may find using another font for
writing is more efficient, even if it isn’t your first choice. We’ve done our best to make
sure as many default system fonts, especially the common ones, work cross-platform, but
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the unfortunate fact is that it is not possible to make all fonts work all of the time. If you
find a font that isn’t working, your best bet will be to find another.

Keep in mind that Scrivener can compile using a different font than what you write
with. The font you use while writing with can be treated more as a personal preference
in many cases.

12.4 Storing Seftings and Fonts on Droplbox

You can store iOS compile appearance settings, custom fonts and formatting presets in
your Dropbox folder, making them automatically available to every device hooked up to
this sync folder. Whenever changing or adding files, you should sync your devices with
the server, and to play it safe, restart Scrivener for iOS (press the Home button twice
quickly, then swipe the Scrivener tile #p to remove it from the running apps list, then tap
on its icon to load it again).

- Fonts: instead of having to install your favourite writing fonts on each device, you
can place them within a “Fonts” subfolder (create one if necessary) of your main
Dropbox sync folder. For example, if you are using the default sync folder location,
you would place your fonts into Dropbox/Apps/Scrivener/Fonts. Scrivener can
read TrueType (T'TF) and OpenType (OTF) font formats. Not all fonts may work
as expected (section 12.3).

- Compile Appearance: or Scomp files, are used to style your document when compil-
ing from 1OS?. You can save custom Scomp files directly to Dropbox from within
the app, and of course you can write and save your own Scomp files from a com-
puter using a plain-text editor. These files should be placed in a subfolder called
“Compile” (if you save them from within the app, it will create this folder for you).
For more information on Scomp files, refer to the in-app help, from the Appearance
Editor screen.

- Formatting Presets: the app ships with a set of default formatting presets (subsec-
tion 15.4.3) that match the default macOS presets. If you’ve created your own pre-
sets, you might like to export those to your iOS device so that you can make use
of them on the go. From your Mac, use the Format » Formatting » Export Presets for
i0S... menu command, and select your Dropbox sync folder as the save location.

2You can not share compile settings between your Mac, PC or iOS, as they all use distinctly different
systems for compiling. The only compile settings you should put into this folder are 10S .scomp files.
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12.5 Options

New preferences have been added to Scrivener pertaining to how syncing is handled. You
can read more about them in their respective appendix entries:

@ Import and Export (subsection C.10.1)

@ Backup (section C.11)

Linux Support: Since the Linux version was discontinued, it will be unable to sync
projects that have been edited on the go. We recommend running Scrivener for Win-
dows under something like WINE or a virtual machine, to at least sync the changes
in. Once the changes have been synced, the project could be edited with the last Linux

version made available, if you prefer.




Chapter 13

Cloud Integration and Sharing

It has become commonplace to make your work instantly available everywhere you go,
no matter what device you might currently be using. Sharing files through the “cloud”
among a circle of colleagues, proofers, and editors has also become part of how we work.
While Scrivener for 10S addresses many of those scenarios, there may be situations where
you need to use other technology or methods. This chapter will cover the options avail-
able to you for integrating with Simplenote, Index Card for i10S and finally, a general
purpose syncing tool designed to use simple files and folders.

Synchronisation should always be done with care, no matter what method you use.
Computers will do exactly what we tell them to do, even if the outcome is not what our
original intention was. Whenever using automated syncing tools, be sure to double-check
your settings, and backup frequently. Scrivener uses automatic Snapshots to protect your
work by default. This can mean a lot of automated Snapshots may build up over time,
but given the unpredictability of all the many factors involved, it’s generally a good idea
to leave it turned on.

13.1 Simplenote

The Simplenote Sync wizard allows you to easily sync documents in your Scrivener
project with Simplenote. To use this feature, you will need to own a Simplenote account.

13.1.1 Getting Started

Login details The Simplenote Sync wizard will first prompt you to enter your login
details. Enter the e-mail address and password which you used to register for Sim-
plenote. You can check “Remember in keychain” to have your login details remem-
bered for the future.

Project keyword Along with your Simplenote login details, you must also enter a project
keyword if you have not already chosen one. This is used by Scrivener to identify
documents in Simplenote that are associated with the current project. You should

Thttps://simplenote.com/
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Simplenote Sync ?
Configuration

Click the "?" button in the top-right to learn how best to use this feature.

Email:

Password:

Remember in keychain

Project keyword:

This is used for finding project documents in Simplenote.

Cancel

Figure 13.1: Simplenote Sync: Configuration

choose a keyword that is meaningful to the project, easy to remember, and that is
unlikely to occur on the first line of documents in general. For instance, you might
use a wordsJammedTogether version of your project title, such as “MyGreatNovel”.

Do not use (parentheses) or [square brackets] as part of your keyword. Since these
are used by Scrivener to identify the salient portions of the note’s identification,
adding additional brackets into the token can cause the sync to malfunction.

NOTE: It is important to understand that Scrivener has no way of knowing which doc-
uments in Simplenote are associated with which Scrivener project without this keyword,
so it is up to you to choose a unique keyword for each project. If two projects have
the same keyword, you could run into problems, with each trying to sync the other’s
documents in Simplenote.

The project keyword is also very useful for viewing notes in Simplenote, because you
can use it as a search term to filter Simplenote so that only documents from your project
are shown in its file list. In addition, Scrivener will add this project keyword as a tag
to each document, so you can view by tags to isolate notes corresponding to a specific
project.
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Simplenote SynC Project keyword: Memoir ?

Step 1 of 2: Select existing project documents to sync with Simplenote

Sync all text documents in project
) Select documents to sync (recommended)

./ Take snapshots of affected documents before updating

4 Insert blank lines between paragraphs

.4 Delete from Simplenote any project documents not selected for syncing
Q

Draft Folder Other Text Documents
=| Introduction
4 @ To Do
) Chapter 1
# section a

<

v # section b
section ¢

) Chapter 2
section d

(Opt-click on checkboxes to select or deselect all.)

Cancel Change Settings |

Figure 13.2: Simplenote Sync: Step One

Once you have entered your login details and ensured that a project keyword has been
supplied, click on Continue. You won’t be prompted for the project keyword or login
details next time you sync the project with Simplenote, but if you need to change anything
you can return to this pane by clicking on the Change Setfings button in Step 1. Note
that the project keyword is shown in the top right of the wizard in steps 1 and 2.

13.1.2 Step 1: Synchronizing Existing Documents

You will next be asked to choose which documents in the project you wish to sync with
Simplenote. You can choose to sync all documents in the current project or to specify in-
dividual documents. It is generally recommended that you don’t sync all documents in a
project, because this can clutter up Simplenote and severely slow down synchronisations.
Because Simplenote notes are stored on the cloud (that is, online), Scrivener has to down-
load them into memory every time you sync, so the more notes you have in Simplenote,
the longer the sync process will take.

If you choose to identify the documents you wish to sync (as recommended), you are
presented with separate lists for documents contained in the Draft folder and all other text
documents in the project (Simplenote is text-only so you can only choose text documents).
You should go through and tick the documents you wish to upload to Simplenote for
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editing while on the go.
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All documents that have already been uploaded and exist in Simplenote will be ticked

for syncing automatically. The icons (Table 13.1) next to the document titles will tell you

what will happen whe

n you choose to sync.

Table 13.1: Simplenote Status Icons

Icon

Meaning

Green check

Up arrow

Down arrow

Green asterisk

Red asterisk

No icon

The document is up to date both in the project and on the Sim-
plenote servers—the version in the project is the same as the ver-
sion in Simplenote.

The document will be uploaded. This indicates either that the
version of the document in the Scrivener project is newer than
the one in Simplenote or that it has not yet been uploaded at all
and is now selected for syncing.

The document will be downloaded. This indicates that there is
a newer version of the document in Simplenote which will be
downloaded in order to update the version in the project.

The document needs updating in Simplenote. This green asterisk
appears if you choose (by deselecting) not to sync a document
that exists on the Simplenote servers but which has been edited in
Scrivener since the last sync. If you select to sync the document,
the asterisk will turn into a green “up” arrow to indicate that it
will be uploaded.

The document needs updating in Scrivener. This red asterisk ap-
pears if you choose (by deselecting) not to sync a document that
has a newer version available on the Simplenote servers. If you se-
lect to sync the document, the asterisk will turn into a red “down”
arrow to indicate that it will be downloaded.

The document is not selected for syncing and does not exist on
the Simplenote servers.

The following options are available.

Take snapshots of affected documents before updating When ticked, Scrivener will

take a snapshot of documents being updated before overwriting them with the

new version of the text. This ensures that you can return to the earlier version if

something goes wrong with the sync process. It is therefore highly recommended

that you keep this ticked, as it provides a good degree of protection against losing

work in cases where you have inadvertently made changes to the documents both

in Scrivener and

in Simplenote between syncs.
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Simplenote SynC Project keyword: Memoir ?

Step 2 of 2: Select documents to import from Simplenote
Import selected documents into: Research |
.4 Only show containers in destination list

4 Remove blank lines between paragraphs in imported notes.
Delete from Simplenote notes marked for this project but not selected for syncing

Q

Notes marked for this project: Other notes:

Welcome to Simplenote!

Assign imported notes to project
Red indicates notes apparently deleted from the project. Show notes from other projects
(Opt-click on checkboxes to select or deselect all.)

Cancel Go Back |

Figure 13.3: Simplenote Sync: Step two

Insert blank lines between paragraphs For most writing, you’ll want to leave this on,
as plain-text documents do not show any space between paragraphs unless they lit-
erally have a space. If your already includes those spaces, or has precise line based
formatting, disabling this option will cause Scrivener to leave the line spacing alone
in the document. You will likely also want to disable the opposing option in step
two, below, which strips out extra lines.

Delete from Simplenote any project documents not selected for syncing When
ticked, Scrivener will delete from Simplenote any files that were previously up-
loaded from this project that are no longer ticked for syncing. This is recommended
in order to avoid clutter and slowing down Simplenote.

Once you are happy with the documents selected for sync, click Continue.

13.1.3 Step 2: Importing Documents From Simplenote

The final part of the wizard allows you to choose to import documents that exist in
Simplenote but which do not yet have corresponding files in the project. Given that
Simplenote is a general purpose note-taking system, there may be many notes in your
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Simplenote account that you do not wish to import, including notes belonging to other
Scrivener projects. This pane of the wizard therefore contains two lists.

The first list contains documents that seem to have been marked as belonging to this
project. These are documents that contain the project keyword (see above) on the first
line of the note enclosed in brackets, and which were not detected as already belonging
to the project. This makes it very easy to create a document in Simplenote and mark it
for importing into a particular Scrivener project: just write the document title followed
by the project keyword in brackets on the first line of the note, e.g:

MyNewNote (MyProjectKeyword)

(The two hyphens on the second line are optional.)

Note that there is no numerical ID in square brackets in this case because that is some-
thing only Scrivener can assign (and when you sync these documents, Scrivener will in-
deed add a numerical ID). Do not try to guess and assign your own. The documents in
this first list are usually all ticked by default. The exception are documents that Scrivener
thinks might have been deleted from the project but are still on the server—such docu-
ments appear in this list but are coloured red and are not ticked. These are documents
that contain the project keyword on the first line and a document ID in square brackets,
but for which the ID does match any existing documents in the project. If you see notes
coloured red in this list, the most likely explanation is that you synced them in the past
but have since deleted them from the project. If you leave them unticked and have “Delete
from Simplenote notes marked for this project but not selected for syncing” checked, then
these notes will be removed from the Simplenote servers too.

The second list contains all other Simplenote documents, and these are not ticked by
default. You can use this list to assign notes to the project, if the “Assign imported notes
to project” option is checked, below the list. If you do not assign them, they will be
imported but the original note will not be set up to sync with Scrivener in the future.

Additionally, you can enable “Show notes from other projects” to see items which are
already assigned to other Scrivener projects that are syncing with Simplenote.

The following options are available:

Import selected documents into At the top of the “Import” pane you can choose the
folder in the project into which imported documents should be placed (the Research
folder is used by default). Only show containers in destination list limits the doc-
uments shown in the list to containers (folders are always considered containers,
even if empty); if unchecked, you can choose to import documents as the subdocu-
ments of any file in the project. (If you are unsure, just leave it ticked.)
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Remove blank lines between paragraphs in imported notes Allows you to choose
whether or not empty lines should be removed in imported documents: because
Simplenote is plain text, it is common to separate paragraphs using empty lines, but
in Scrivener paragraphs are less likely to need blank lines between them. (Note that
when uploading documents to Simplenote, Scrivener automatically places blank
line padding between paragraphs to make them easier to read in Simplenote.)

Delete from Simplenote notes marked for this project but not selected for syncing
When checked, any notes that appear in the “Notes marked for this project” list
that are not ticked for syncing will be removed from the Simplenote servers.
(Given that this could result in the deletion of the only copies of such notes, you
will be asked to confirm this deletion during sync.)

Once you are happy with the documents you have selected for synchronisation and
import, click on Sync. You can choose Go Back at any point to make changes.

13.1.4 How It Works

Simplenote is a general purpose note-taking system and knows nothing of Scrivener or
Scrivener projects. When uploading documents to Simplenote, Scrivener therefore places
some information on the first line so that it is able to find and recognise these documents
when syncing. The information Scrivener places on the first line is formatted like this:

MyDocumentName (MyProjectKeyword [ID])

“MyDocumentName” represents the document title as it appears in the binder,
“MyProjectKeyword” is the keyword you assign to the project in this wizard (see below),
and “ID” is an internal numerical ID that Scrivener assigns to all documents, which you
won’t normally see. In practice, it might look like this:

The Grand Finale (MyGreatNovel [756])

These three pieces of information in combination allow Scrivener to sync documents
with Simplenote. You should therefore not edit this line in Simplenote. In particular,
if you edit the project keyword or numerical ID, Scrivener may not recognise the Sim-
plenote text as belonging to the current project, or worse, it may try to sync it with the
wrong document in Scrivener. It is thus generally recommended that you leave this line
alone. However, you can edit only the document title (the part before the parentheses),
which will update the title in Scrivener when synced, if you really want to.
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13.1.5 Using Simplenote Tags

When syncing files, Scrivener will assign two tags to each file:

1. The tag: “Scrivener”, which will make it easy to find all files associated with any
Scrivener project.

2. A tag corresponding to the project keyword you selected above, making it easy to
filter your note list in the Simplenote application by project.

You can also add new documents to the project from Simplenote by simply adding the
project keyword tag to that document. When using this method, you needn’t supply the
project keyword in parentheses after the title; Scrivener will add it for you.

Another way of assigning notes to a project is to use the “Other notes” browser, in Step
2, to find the note, tick its checkbox, and then also the “Assign imported notes to project”
checkbox, below this list.

13.1.6 Clearing Out Simplenote

When you’ve reached a point in your project where you no longer require external sync-
ing, or would for any other reason like to clear off everything belonging to your project,
it is very easy to remove everything from the server pertaining to the project.

Before following these instructions, it might be a good idea to run one last sync to
make sure everything is up to date. Then, simply make sure the “Delete from Simplenote
notes marked for this project but not selected for syncing” is enabled in Step 1 and Step
2, and then X Click on any file checkbox currently enabled. This will de-select everything
and wipe out the related notes on Simplenote when you click the Sync button. Note
that nothing in the project will be impacted when you do this, it will only clear out the
associated notes on the Simplenote server.

13.1.7 Limitations

Formatting Note that Simplenote, like most mobile note-taking solutions, can only
store plain text, so all formatting—bold, italics, line spacing and so forth—will be
stripped in the versions of documents stored in Simplenote. Thus, when updat-
ing documents in a project with corresponding versions that have been edited in
Simplenote, the following formatting limitations apply.

@ Scrivener maintains the formatting of paragraphs within a note that have not
been changed.

& Any paragraphs that have been edited in Simplenote will lose their formatting
in Scrivener.
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a Images will be stripped from documents that have been edited in Simplenote.

@ To avoid having inline notation become confused with standard text,
Scrivener will export inline annotations by wrapping them in double-
parentheses ((and)). Inline footnotes will be similarly wrapped in curly braces
{{ and }}. These work in both directions. If you type them into a paragraph us-
ing your text editor, they will be converted to their respective type of notation
upon syncing.

- Inspector comments and footnotes will not be exported. If the retention of
this information is important to you, it is recommended you use inline no-
tation with plain-text. You can easily convert your notes to inline with the
Format » Convert tools.

Number of Notes At the time of writing, Simplenote is limited to syncing 2,000 notes
a day. Although this sounds a lot, if you end up syncing the entire contents of ten
projects that contain 200 text documents, you can soon end up with a lot of notes
in your Simplenote account. It is therefore strongly recommended that you only
sync the documents you need for working on while away from Scrivener, and that
you ensure the option is ticked to trim documents that are not being synced. This
will also help ensure that syncing remains as fast as possible.

13.2 Synchronised Folders

Scrivener lets you prepare a special external folder on your disk, which it will use to keep
the text contents of a project up to date if (but not when) changes are made to the contents
of this folder. Because it works with a simple flat list of files and a few prefab folders,
the format is uniquely suited for integrating with various folder sharing services such as
Dropbox, SpiderOak, iCloud, and others. Using this feature, you can share your work in
progress with collaborators, agents, or editors, and later read back any changes they have
made directly into your project. Additionally, you could use the feature in conjunction
with mobile applications and devices, making it possible to edit your project’s content
anywhere, and later automatically merge those edits with your main project.

Important Note: This feature is nor intended for keeping two versions of the same
project in sync and should not be used in such a manner—you should never try to sync
two different projects with the same folder. Rather, this feature is intended to allow
you to edit or share project files with other applications or on other platforms, and
then to have any changes made to the shared files reflected in your Scrivener project. It
also cannot be used to perform structural or outline order modifications, just simple

text content modifications.
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Sync with External Folder ?

Shared Folder
Choose a folder with which to sync files from this project:

Choose... Clear

Options
4 Sync the contents of the Draft folder
Sync all other text documents in the project

.4 Prefix file names with numbers
.4 Take snapshots of affected documents before updating
.4 Check external folder on project open and automatically sync on close

Import
Import new non-Draft items into: Research

Format
Format for external Draft files: Rich Text (RTF) |V |
Format for other external files: Rich Text (RTF)

.4l Automatically convert plain text paragraph spacing

Cancel

Figure 13.4: Sync External Folder Sheet

13.2.1 Setting it Up
To access the feature, select the menu item, File » Sync » with External Folder.... A sheet will
drop down in the active project with some basic settings.

The first thing you will need to do is select a new, empty folder which Scrivener will
take over and use for syncing files with this project from this point forward. Click the
Choose... button, and navigate to the location where your cloud service keeps your
computer synchronised. For Dropbox users, this will be the Dropbox folder in your
home directory. Keep in mind that the folder you create will need to be dedicated to this
Scrivener project, and so must be initially empty. When you sync documents with this
folder, Scrivener will create one or more of the following three subdirectories to store the

synced files:

:a “Draft” - stores documents contained inside Scrivener’s Draft folder.
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- “Notes” - stores text documents contained elsewhere in the project.

- “Trashed Files” - stores documents that had been synced but have since been re-
moved from Scrivener, or which had some sort of conflict. You should occasionally
review these files and trash them if they are no longer required.

It is not possible select a folder which has already been used to synchronise another
Scrivener project! In this case, another project can very well mean the same exact project
you just copied to another computer. This will most often be an issue when you use the
project on more than one computer, and your account name on those computers are
different (thus making the full path different). When working in situations such as these,
it is best to turn off automatic sync on project open and close, and run it manually from
your primary computer. There is never a reason to use this feature to keep two copies
of the same project up to date. If you need to work on your project from more than
one machine, it is best to copy the project completely. The reason for prohibiting this is
that even when working from the same exact project, it is all too easy to cause problems
between copies of the project, which will inevitably differ over time, internally.

Using this feature in an attempt to merge projects, or to have more than one person
using a copy of the project, could result in lost data or confusing results.

Saving changes without syncing: If you merely want to adjust your sync settings
(commonly to enable or disable automatic checking on project open and close), you
can hold down the Option key in the set-up window to change the Sync button to a
Save button. Clicking this will update your project settings without running sync.

This feature provides the following options:

Sync the contents of the Draft folder Enabled by default, the entire Draft folder will
be kept in sync with the folder when this is on.

Sync all other text documents in the project Keep the rest of the project up-to-date
with this option. Note it will only work with text files. Enabling this option also
activates the Import settings, below.

Sync only documents in collection If this is selected, only documents that are con-
tained in the collection specified in the pop-up list next to this checkbox will be
kept in sync with the folder. This essentially acts as a filter for the other two above
“Sync” options. For instance, if “Sync the contents of the Draft folder” is selected
but “Sync all other text documents” is not, and if this option is selected, then only
documents that are contained in the Draft folder and in the specified collection will
be synced.
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Prefix file names with numbers By default, Scrivener will prefix each filename with a
numeral corresponding to its position in the binder. This will keep your files in the
same order as the binder, making them easier to find. Disabling this will remove
the number and the contents of the folder will be subject to ordinary alphanumeric
sorting based on the names of your binder items.

Take snapshots of affected documents before updating Enabled by default. With this
option turned on, Scrivener will automatically generate snapshots of each docu-
ment if it requires updating. If you prefer to handle snapshots manually, you may
want to turn this off. However be aware that leaving it on is the safest option, par-
ticularly when both items have been accidentally edited separately. Since Scrivener
cannot determine which is meant to be the most up-to-date other than by the file
modification date, having snapshots available will allow you to review the specific
changes and decide how to manage conflicts should they occur.

Check external folder on project open and automatically sync on close Enabled by
default. When this project is opened, it will briefly scan the contents of the ex-
ternal sync folder and alert you if there are any changes detected, offering you the
ability to update your project immediately. When closing, the same check will be
performed. This option will ensure that the sync folder and the project remain up
to date, though they will differ while editing, until you run sync again.

The Import section allows you to choose where files that have been created in the Notes
folder outside of Scrivener will be imported. You can select a target container (Research
by default), or uncheck the “Only show containers in destination list” option to choose
any item to become a container for imported files. This section will be disabled if “Sync
all other text documents in the project” is turned off, above.

The Format section determines how the files will be created in the sync folder. For
instance, scriptwriters might not want to use a script format for notes and research docu-
ments, so there are separate options for files stored in the Draft folder and other files in the
project. There are three file formats available, and depending on your intended purpose,
selecting the right option will be important:

@ Plain text (TXT): Formatting will be stripped from edited portions when using
this option. The resulting files will be standard, plain-text files in the UTF-8 format.
If they are edited outside of Scrivener, when synced back in, all custom formatting
in paragraphs that have been edited will be lost. Scrivener will protect those areas
of the files which have not been edited, wherever possible. Scrivener does its best
to retain as much formatting as possible when re-syncing, but if formatting is as
important to your workflow as synchronising, then you will either need to find a
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solution that can take advantage of RTF files, or save formatting for the final stages
In your writing project.

When plain text is the chosen format, you can change the default extension that
Scrivener will use for the exported files. If you use an editor that displays markup,
for example, it can be handy to change the extension to the markup’s accepted form,
like .md for Markdown. When using this option, be aware that files added to the
sync folder using a different extension will not be recognised. This means once you
choose an extension you should stick with it (lest all of the existing files become
unrecognised and moved to the “Trashed Files” folder). If you wish to change the
extension you are using, use a batch rename tool to fix the sync folder, or regenerate
it from scratch.

@ Rich Text (RTF): This provides the cleanest transfer of information. Most format-
ting will be retained, especially when used in conjunction with a word processor
that handles all of Scrivener’s RTF features, such as Word or Nisus Writer. This
is the best option for collaborating with other individuals who do not have access
to Scrivener, or for working in a multi-platform setting yourself. All versions of
Microsoft Word fully support the RTF format.

@ Final Draft (FDX): Those working with Final Draft, version 8 or greater, and
scriptwriting mode should use this setting, as it will retain all special script for-
matting in a round-trip.

0 Fountain (fountain): For use with screenplays, this popular plain-text markup for-
mat can be edited anywhere plain-text files can be edited, and so has a similar appeal
to Markdown for its portability. Scrivener’s internal scriptwriting format will be
converted to Fountain syntax when updating the folder contents, and then in re-
verse the syntax will be converted to Scrivener elements when updating the project.
Additional formatting supported by Fountain markup will be converted as well.
For details, read more about Working with Fountain (section 20.6).

All files in the Draft folder will be treated as Fountain format for purposes of import
and export. This includes any new text documents added to the “Draft” sync folder
from outside of Scrivener. If you wish to add notes or comments in the form of new
files, enable the ability to sync outside of the Draft folder, using another format than
Fountain, and place your text files in the “Notes” sync subfolder.

Automatically convert plain text paragraph spacing When this option is engaged,
Scrivener will intelligently convert your documents’ paragraph spacing to better
suit the intended environment. Since plain-text editors cannot display pseudo-
spacing between paragraphs, this option will insert a second carriage return to help
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set them apart from one another. Upon import, these extra carriage returns will be
removed for you.

Keep this setting turned off if you require a certain standard, one way or the other, and
do not want Scrivener to adjust things for you. In particular, those working in the Multi-
Markdown workflow require double-spaced paragraphs, and so will not want Scrivener to
remove these spacings upon import. Note that this option only affects plain text (TXT)
documents.

When using plain-text, inline annotations and footnotes (chapter 18) will be scanned for
within the external files, and any text matching the following patterns will be converted
to the corresponding notation style. Using this feature, you can round-trip your notes,
and even create new notes in an external editor. Annotations will use double-parentheses,
and footnotes will use double-curly-braces.

Additional settings which impact export and import can be found in the application
preferences, under Import & Export. If you prefer to work with inline annotations and
footnotes, make sure the default setting in this pane has been changed, otherwise your
RTF comments will all become Inspector comments after a sync cycle. For further doc-
umentation on this pane, see Import & Export Preferences (section C.10).

13.2.2 Usage

After clicking the Sync button for the first time, Scrivener will export a copy of every
item according to the options above. If the export folder is located in an area where it is
accessible to other computers and mobile devices, you can log on to Dropbox with your
external application and start browsing the files as soon as they finish uploading. Note
that folders in the Scrivener project will appear as ordinary files in the sync folder, because
Scrivener folders can contain text.

Scrivener will export all items associated with your manuscript into the Draft folder. If
you choose to export non-Draft files, everything else will be placed into the Notes folder.
If you intend to start editing these files immediately, it would be a good idea to close
your Scrivener project at that point. While Scrivener will make scrupulous copies of
everything it changes (unless you’ve disabled snapshot generation), it is best to work in
an alternating pattern to reduce confusion between which file is the most up to date.

Using the sync folders as an inbox: In addition to creating files for material that
already exist in your Binder, you can use this feature to collect notes while you are
away from Scrivener. If you intend to use this feature only as an inbox, that is, for
collecting new notes and not working with existing material, you can set up sync to

use an empty collection. The empty Drafts and Notes folders will be created for you
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if their respective checkboxes are ticked. Any files you create in this folder will be
imported into the project in the future, and will be available for further sync unless
you explicitly remove them from the Collection filter.

In a collaboration environment, it may not be possible to wait until the other person
is finished. It is safe to work in both the project and the exported copies at once, so
long as changed files are looked over after syncing. In most cases Scrivener will select
the best option for you, but in cases where both you and your colleague have changed
the file in between syncs, you might need to resolve the differences using Snapshots and
the Compare feature. For more information on using Snapshots, see the Snapshots Pane
(section 19.8).

When performing a folder sync, only resources which have changed (either in the
project or on the disk) will be synchronised, to save time. In the case where project binder
items have been updated from the disk, a list of these changed items will be presented to
you upon completion. The list will not contain items which have only changed on the
disk. Use this tool to browse through the changed items and review them with the Snap-
shot Compare feature. This interface is much like Project Search, and can be dismissed
by clicking the X button in the bottom corner of the binder footer bar.

For those that want to dig a little deeper, this is really a Collection that will be created
and titled “Updated Documents”, with each changed project document added to it. Every
time sync needs to change project files, it will look for a Collection named “Updated
Documents”, and replace the contents of it with the results of the latest sync, so if you
wish to retain a list of changed files for future reference, change the name of the Collection
to something else.

New files can be created while you are away from your project. Simply name them
whatever you would like them to be called in the binder, and save them to the Draft
or Notes folder. Scrivener will import files created in the external Draft folder into the
project’s Draft folder, and files created in the external Notes folder into the designated
auxiliary container (Research by default), when you sync. Initially they will be imported
at the bottom of their respective containers, but once you sort them to their proper loca-
tion, they will sync from that point forward in an ordinary fashion.

When you have returned to your computer and wish to integrate any of the changes
made, simply load the project in Scrivener. It will, by default, check for any changed files
and alert you that your project is out of date. If you have this option disabled, or the
project is already open, you can manually activate the sync panel again, using the menu
item, and click the Sync button. Moments later, your project will be updated with all of
your external changes.
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While working in Scrivener, you can easily sync without going through the setup pro-
cess. Use the File » Sync» Sync with External Folder Now menu command, or add the
“Sync” icon to your toolbar. The icon and menu command will be disabled until you
first set up sync settings, or if Scrivener detects that the sync folder has become damaged
or removed.

13.2.3 Tips for Working with Synced Folders

Here are a few guidelines which, if followed, will prevent problems in everyday use:

@ Alternate between external files and the project. This is a rule of thumb, not a strict
rule. Scrivener reads the modification date of each file, and uses the latest one to
determine which should be the binder copy. It does not examine the contents of
files. It is thus best to alternate between using the external files, and the project
folder, rather than working in both separately for a while, and trying to merge
them later.

@ Never try to sync one project’s folder with another. Even if those two projects
originally came from the same identical project, over time there will be differences
in each project that you cannot see, and these differences will lead to confusing
results at best, and a loss of data at worst. A sync folder is meant to allow you
to work without Scrivener for a while, and then come back later and update your
project with those changes.

 Disable automatic sync on open and close before duplicating the project in Finder. If you
create a duplicate from within Scrivener (using the back up features, or File » Save
As...), you do not need to worry about this as Scrivener will clean up any automated
settings for you. However if you intend to duplicate the project outside of Scrivener
using Finder, make sure to disable this option first, otherwise they will both end
up using the same folder automatically, and this can lead to mangling your project
if you continue working in both projects. Once you’ve created the duplicate, it is
safe to turn it back on in the original project, provided you either leave automatic
syncing off in the new project, or point it at another folder.

@ When working from multiple computers sharing the same sync folder, always make sure
your project file is the most current. It is perfectly safe to use the same project to sync
to a shared folder from multiple computers provided you are always using the most
recent version of the project and are not trying to bend the feature to sync two
different versions of the project (see above). You will receive a warning dialogue
the first time you try on each system, but in this one case it can be ignored.
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@ Avoid editing the filename. The numeric value on the very end of the filename en-
closed in hyphens, such as “-78-” (the precise number will be different for each item),
is vital to keeping the file identifiable by the item it is linked with in the project;
damaging the number could produce unintended duplication, or data loss in some
cases”.

- Session target goals will include synced changes. When updating project files with
external edits, the session target will be incremented by the amount of text that has
been added. If you wish to keep track of your session target separately, you might
wish to reset the counter after updating your project.

@ If using mixed inspector comments and inline annotations: When using sync folders,
it is best to use either all Inspector footnotes and comments, or all inline annotations
and footnotes, and set your Import & Export preferences accordingly. In some rare
cases, comments adjacent to annotations can result in one of the notes getting lost,
due to the limitations of the RTF format.

Mobile Dropbox: When using the Dropbox app with your iOS device, you can elect
to have documents stored on your device. Ordinarily, you need an active Internet
connection to view files, but when a file has been marked as a “Favorite” it will be
stored on your device for perusal at any time. Note that if you are using a third-party
editor to interface with Dropbox and allow remote editing, this trick will not work,
but many of these editors store their text files on your device as well, and any changes

made to them will be synced the next time you have an Internet connection.

If you are using this feature in conjunction with another author or editor, make sure
to communicate these ground rules with them where relevant. Since it is not possible for
Scrivener to guess at your intentions, good communication over where new files should
go, and what is being independently worked upon will be beneficial.

13.2.4 Limitations

RTF Format Limitations: When using the RTF export format, you can expect zero
to minimal loss of formatting information when used in conjunction with a good word

2You can safely edit the filename so long as the dashed number is untouched. When a file has been
edited in the sync folder, if the binder name portion of the filename is changed, the sync function will
update the binder with the new name. This is considered an advanced feature, however, to be used with
care. Note that changing the sequence number will have no effect on the binder order. Also note that if
all you changed is the filename, nothing will happen due to the way modification dates are stamped on the
filesystem. Advanced users could use the UNIX command, fouch, to force an update.
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processor. There are a few features in Scrivener that have no comparison in RTF, such as
multi-colour annotations and comments, and Scrivener links, which will be normalised
or lost, respectively.

@ If you use sequential annotations separated only by colour, it would be a good idea
to move them so that they have a word or two in between them, or separate them
by putting them on different lines.

a Expect loss of some features when using RTF editors that do not fully support
the RTF specifications, such as TextEdit, Pages and similar. Footnotes, comments,
lists, images, and tables are the most common items which have limited to no sup-
port. Using fully-featured word processors with good RTF support, such as Word
or Nisus Writer Pro will help you avoid this, and even be quite useful as comments
can be used to aid in the collaboration process.

: If the only changes made to a file were formatting, they will not be included in the
sync. This is down to a technical limitation of how these files must be scanned and
processed. So if you have formatting changes you’d like to add, just add a temporary
word at the top that you can remove later.

Plain-text Limitations: Since it is impossible to convey formatting in plain-text with-
out some sort of visible mark-up, Scrivener takes steps to protect as much of your for-
matting as it possibly can. As with RTF, only those files which have been edited will
be transferred back to your project, but further, each changed file will be analysed at the
paragraph level and only replace those paragraphs that have been changed, leaving the rest
of the file untouched with its original formatting.

¢ To avoid having inline notation become confused with standard text, Scrivener will
export inline annotations by wrapping them in double-parentheses ((and )). Inline
footnotes will be similarly wrapped in curly braces {{ and }}. These work in both
directions. If you type them into a paragraph using your text editor, they will be
converted to their respective type of notation upon syncing.

 Inspector comments and footnotes will not be exported. If the retention of this
information is important to you, it is recommended you use inline notation with
plain-text. You can easily convert your notes to inline with the Format» Convert
tools.

¢ Embedded images will be stripped from documents that have been edited outside
of Scrivener.
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13.2.5 Disabling Synchronisation

If you no longer need to maintain an external sync folder, you can shut off this feature
by clicking the Clear button in the setup screen, alongside the chosen path. At that point
the “Sync” button will be removed and replaced with a “Save” button, allowing you to
confirm this window without actually attempting to sync. Additionally, removing the
sync folder from your drive, moving it to another location, or changing its name will
automatically cancel synchronisation the next time synchronisation is attempted.

13.3 Index Card for iOS

Index Card for 1OS is a corkboard and outlining app that was partly inspired by Scrivener.
It allows you to create projects comprising index cards (each of which holds a title, synop-
sis, and main text, just like Scrivener’s index cards) that can be moved around and edited
on a virtual corkboard, or in a list view resembling Scrivener’s outliner.

The synchronisation process involves creating a collection in Scrivener, saving it as
an .indexcard file that can be read by Index Card, and later updating the collection in
Scrivener from the updated .indexcard file written out by Index Card after you have made
changes on the go. There are therefore four steps involved in syncing with Index Card:

1. Creating a Collection to hold the documents to sync.
2. Saving an .indexcard file to your Dropbox folder.
3. Opening, editing and saving the .indexcard file in Index Card on your device.

4. Updating the Collection in Scrivener with any changes you have made.

Because syncing with Index Card relies on Dropbox, which is a service that allows you
to sync files between different devices that has a free option. Before you begin, you
will need to ensure that you have Dropbox installed on your computer. You can
download the desktop version of Dropbox, here’.

You will of course also need Index Card* installed on your iPhone or iPad.

13.3.1 Creating a Collection

Index Card projects consist of a single stack of index cards that can be moved around
on a corkboard. Because Index Card expects a flat list of cards, it is not possible to sync
the entire structure of a Scrivener project, or even all of the contents of the Draft folder,
which will most likely contain documents inside folders several levels deep.

Shttp:/ /www.getdropbox.com
*http://www.denvog.com/iphone/IndexCard


http://www.getdropbox.com
http://www.denvog.com/iphone/IndexCard
http://www.getdropbox.com
http://www.denvog.com/iphone/IndexCard
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For this reason, the Collections feature is used to sync with Index Card. The Collec-
tions feature allows you to maintain different flat lists of any documents in the project,
which can be ordered however you wish. You should thus create a collection before you
sync with Index Card. After editing your project in Index Card, you can easily assign
your new arrangement of documents to the binder.

To create a collection, first select the documents you wish to take to Index Card in the
binder. Next, click on the “Collections” icon in the toolbar to reveal the collections pane
if it is not already visible (or select View » Collections » Show Collections). Finally, click
on the + button in the collections header bar.

A new collection will be created that contains the documents you had selected. You
can rename the collection to anything you like, but something meaningful such as “Index
Card Sync” might be a good idea. (You can change the colour of the collection by double-

clicking on the colour chip in its tab when the collection is active.)

Adding Whole Folders To Collections: If you wish to include the contents of an
entire folder in the collection, select the folder and hold down the Option key down
while clicking on the “Add Collection” button.

To add other documents to the your collection, you can just drag them from the binder
onto the collection tab.

Read Using Collections (section 7.4) for more information on collections.

13.3.2 Saving the Index Card File to Dropbox

We have now set up a collection ready for syncing with Index Card. The next step is to
create a file in our Dropbox folder that Index Card will be able to read. To do so, use
File » Sync » with Index Card for iOS...

Choose the collection you created in the first step from the “Collection” pop-up button.
There are three options you can select from:

Sync includes main text and notes This feature only works with newer version of In-
dex Card, which support adding notes and main text to index cards, as well as syn-
opsis. With this option, Scrivener will store the main text of your draft for that sec-
tion into the text field for the card, and any document notes into the corresponding
notes field in Index Card. This way you can not only see your cards and work with
them, you can edit their contents too.

Do take notice that by default Index Card will not include notes in an exported
.Andexcard file. If that option is left off, no changes you make on the iPad to the
main text will be updated in the project.
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Take snapshot before updating main text As with the other synchronisation tools,
leaving this option on will automatically create a snapshot of the item prior to
changing its text contents, providing an extra layer of safety.

Convert plain text paragraph spacing If you have formatted your paragraphs with sin-
gle breaks between them, this will optimise paragraph spacing to look good in a
plain text file (which Index Card needs for the notes field). Likewise, paragraphs
will be converted back to single breaks when updating the main text.

This option is not necessary (and indeed would be undesirable in most cases) if the
source .scriv project already uses double-breaks between paragraphs.

Once you have everything set up, click on Create or Update Index Card File....

The “Save As” panel will appear, and it should automatically point to the “IndexCard”
folder inside your Dropbox folder. Index Card creates the “IndexCard” subfolder in Drop-
box whenever you sync, so if you haven’t saved any files from Index Card yet, it may not
exist. If it doesn’t, create it yourself—navigate to your Dropbox folder, click on “New
Folder”, and name the new folder “IndexCard” (with no space). You will need to use this
folder, otherwise Index Card will not see your exported files.

Choose a name for the .indexcard file (or use the default one that has been entered
automatically) and click on “Save”. At this point, an .indexcard file will be saved into the
Dropbox/IndexCard folder, and the sync sheet will close. You are now ready to carry
your work around with you.

13.3.3 Editing in the Project on your Device

To open the .indexcard file on your device, follow these instructions:

1. Open the Index Card app on your iOS device

2. If you haven’t done so already, tap on the ‘gear’ button and link your Dropbox
account to Index Card

3. Tap on the ‘gear’ icon from the main project list and select Copy from Dropbox

4. Select the .indexcard file that you created in Scrivener (the title of the Index Card
project will be the title of your Scrivener project with the name of the collection
you synced in brackets). If you do not see it here, you need to make sure and save
it to the “IndexCard” folder in your main Dropbox folder.

You should now be see the .indexcard file you loaded listed in the main project list. The
title of the Index Card project will be the title of your Scrivener project with the name of
the collection you synced in brackets.
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You can now move the cards around, edit their titles and synopses, and create new
cards, just as you would in any Index Card project.

13.3.4 Updating the Collection in Scrivener

When you get back to your computer, you’ll want to update your Scrivener project with
the changes you have made in Index Card. To do this, you’ll first need to update the
.ndexcard file in the Dropbox/IndexCard folder, as follows.

Important Note for Index Card 4 for iPad: Scrivener will not sync with the newer
Index Card 4 version format. This is not a problem, however, as that version has the
ability to save as a version 3 .indexcard file. Use this option when transferring your
changes back from the device to your original project on the Mac.

1. Click on the “Send” button in Index Card and select “Copy to Dropbox” from the
list that appears, using the .indexcard format option. If you are using Index Card 4
for iPad, then choose to export as version 3 .indexcard format.

2. If you are syncing main text as Index Card notes, then make sure the “Include Notes
in Export” option is enabled at this stage, otherwise your text changes will not be

included.

3. Atthis point, Index Card, detecting that the file already exists, may ask you whether
you wish to overwrite the existing file or save using a different file name. Choose
to overwrite the existing file, if necessary.

4. Now, back in Scrivener, go to File » Sync » with Index Card for iOS... again. The
collection we chose to sync should already be selected for us in the pop-up button.

5. This time, choose “Update Collection from Index Card File...”, because we want
to update our project with the changes we made in Index Card.

6. The standard Open panel will appear, and the .indexcard file that you edited should
already be selected for you. If not, select it. Then click “Open”.

The collection in your Scrivener project should immediately be updated to reflect the
changes you made on your mobile device—the order will be changed if you moved things
around, the titles and synopses of any documents you edited will be updated, and any new
index cards you created will appear as new documents in the collection. Additionally,
when you return to the binder, you will find any new documents that were created have
been placed in a folder below the Research folder, which will be named using the title of
the collection followed by “Unsorted” in parentheses.
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If you deleted any index cards in Index Card on the device, they will be removed from
the collection in Scrivener but will zot be deleted from the binder.

Committing Rearrangements to the Binder

Collections exist in parallel to the binder, allowing you to gather disparate documents
from all over the binder in arbitrary lists in any order you wish. If you’ve spent a lot of
time in Index Card on the device rearranging the cards and finding their most effective
order, at some point you will want to take that arrangement to the binder rather than
having it sectioned off in a collection. This is easy to do, and there are several ways of
doing it. Here are the easiest:

With the collection visible, select all of the documents in the collection list. Then,
either:

@ Ctrl-click on the selection, select Move To from the contextual menu that appears,
and then choose a folder into which to move the documents. When you do so, the
binder will reappear to show the documents in their new location.

¢ Drag the selected documents onto the “Binder” tab in the Collections pane and hold
them there. After a second, the collections list will disappear to be replaced by the
binder, and you can drag and drop the documents wherever you want to place them.

Note that in both cases, the collection remains unaffected, and continues to exist sepa-
rately.

When you next want to take your work with you on the device, once more ensure that
the collection contains the documents you want to take, and go through the process again,
overwriting the old .indexcard file with one generated from your updated collection.

Syncing Multiple Collections: It is possible to sync more than one collection in
a project with Index Card—each collection will appear in Index Card as a separate
project. However, bear in mind that if any documents appear in more than one col-
lection, any edits you make to them in one Index Card project could get overridden
were you to later sync with an Index Card project created from another collection that

contains some of the same documents.

Also note that Scrivener will warn you if you try to sync with an Index Card file that
was not created with the selected collection.
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13.4 Scrivener Everywhere

All of the methods discussed so far have worked on the assumption that you only need to
work on a specific aspect of your project when away from home, but many people prefer
to work in several places, and like to use a second computer like a laptop. Many others
would prefer to have total editorial control of the likes only Scrivener can provide, rather
than simply working with content or high-level organisation in an index card style appli-
cation. Keeping more than one computer synchronised can be a lot of work, but keeping
one Dropbox folder (or similar service) synchronised between computers requires little
thought at all.

It therefore follows that placing your Scrivener project into a Dropbox folder so that it
is immediately available to every computer you own, would seem a perfectly natural pro-
gression. What you should be cautious of, when entertaining this idea, is that a Scrivener
project is comprised of many smaller files, and that they all need to be working together
as a cohesive whole. Ordinarily, this is not a problem. Nothing goes into your project
and messes with it, except for Scrivener. When you place a project on Dropbox, however,
you are giving Dropbox permission to scrutinise and curate the individual pieces of your
project that ordinarily only Scrivener messes with. This goes for most synchronisation
technologies in general, but since we’ve tested Dropbox the most, this section will be
framed with that service in mind.

By and large, this is safe to do. Dropbox is designed to carefully make sure each com-
puter has a thorough and exact replicate of what all your other computers have. However,
a problem can arise when one computer edits your project in a way which conflicts with
the copies on the other computers. This can be easy to accidentally do. All it takes is
working on a copy of a project that is not yet fully synced. This might happen because
your computer has been offline for a while, or because Dropbox never got a chance to
fully update all of the files in the project.

When this happens, copies of each “conflicted” file will be duplicated with different
names so that you can decide which one is the best copy, or manually merge them together
in a text editor. Ordinarily, this is fine and easy to do, but inside of a Scrivener project, it
can be more complicated. For one thing, the full contents of your project might not even
be easily visible. Secondly, some of the files in a project are very technical in nature, and
if you are not fluent in XML (not to mention Scrivener’s schema), it might be impossible
to best decide which version is better. The solution is to never get into this position in
the first place, and this is fortunately easy to do.

To avoid conflicts with synced projects:

1. Always make sure your syncing software is done syncing before you open a
project. Good syncing software, like Dropbox, will let you know when it is moving
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data to or from the central server on the Internet. In the case of Dropbox, a small
icon will be placed into the status menu bar area, in the top-right portion of your
screen across from where the main menus are. Keep an eye on this indicator and
wait for the green checkmark® to appear before you open the project.

2. Never open a project more than once. If all goes well, Scrivener will warn you if
you try to do this, but in some scenarios this warning might fail, so try to always
remember to close your project when you are done with it. Ignoring this rule is a
surefire way to cause major headaches.

3. Always wait for your syncing software to finish syncing before you shut down
your computer. This is of course a corollary to the first rule. Just as you should
wait for your computer to be updated before opening a project, you need to make
sure that all of your changes made to the project have finished syncing back to the
server (and thus made available to your other computers), before you put it to sleep
or shut it down.

4. Reduce auto-save frequency: this step is optional unless you are working on a
very slow connection, such as dial-up. Editing a Scrivener project can generate a
lot of network traffic because of how often Scrivener saves files to the disk. With
modern high-speed connections, this should pose no problem, but with slower or
unreliable connections to the Internet, it’s a good idea to set Auto-Save (in General
preferences) a little higher so that changes are sent in larger batches to the Drop-
box server, rather than trickling in constantly. When working this way, you might
want to save manually more often, with the File » Sove menu command. Alter-
nately, pause Dropbox: the newer versions of Dropbox allow you to pause sync-
ing. This can be done from the status icon as all other functions with Dropbox can
be accessed. Pausing syncing means that all changes made to the Dropbox folder
will not be immediately synced to the server. Thus there is no need to mess with
changing the auto-save frequency, and it keeps your entire working session in one
“version” within the Dropbox system. Of course, you will need to remember to
resume syncing prior to shutting down the system.

If you follow these three simple rules, you will dramatically decrease the chance of any
strange conflicts arising due to working in a live syncing folder with Scrivener. As with
all synchronisation technology, it is inherently “less safe” than working local and saving

>It may be possible to customise the status icon, and not all of the visual themes use a green checkbox
to indicate when Dropbox is in standby mode. Familiarise yourself with how your preferred status icon
works.
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remote. It is possible to work safely for years in this fashion, but extra vigilance will be
required of you and everyone participating in the shared project.

While this section has primarily focussed on Dropbox as a means for keeping your
project files synchronised between computers. There are many technologies for doing so
these days. If you have another solution you are using and prefer, test its viability with
copies of your project, or test projects, prior to committing important work to it.

A note on using such sharing services for collaboration: while it is possible for multiple
parties to work off of a single .scriv file hosted on a shared network folder, extra caution
will need to be exercised in order to keep the project data safe. At the very least, this
section of the manual should be distributed to all parties concerned, and good lines of
communication should be established so that everyone knows when a person is actively
working in a project. There are fail-safes programmed into Scrivener to let you know
when another session is currently active in a project, but making sure everyone is on the
same page with who is editing the project will ensure no mistakes are made. Guideline
#2 above deserves to be reiterated: never open a project for editing if another person
is currently editing the project.

To date, only one such technology is known to be a risk to use in this fashion, and that
is Google’s Drive, which simply is not designed with complex formats in mind. It is not
recommended that you use Google Drive for live projects under any circumstances. It
is however, quite safe to use it to “transport” zipped backups of your projects from one
computer to another.

Finally, it has been said before, but it bears repeating: Scrivener’s built-in folder sync
tools should never be used to keep two projects in sync. They are not full projects, and
because of their simple and accessible nature, do not contain nearly enough information
to properly inform a project of everything it needs to keep your data safe, but rather only
what they need to interface with one single project.
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Writing is easy. All you do is stare
at a blank sheet of paper until
drops of blood form on your

forehead.

Gene Fowler

When it comes to the process of writing itself, nobody can tell you how it should be
done. Each author has their own methods, their own rituals, and their own favourite tac-
tics. Scrivener was designed to recognise that everyone is different, and as a result the pro-
gram features an extraordinary amount of flexibility and interface power. You will find
workflows and tools for all manner of writing projects, from a doctoral thesis, the next
blockbuster screenplay, to a novel, game design, a collaborative scientific article, patent
claims, biographies, and much more. Because of this, there are many features you just
won’t need! That is fine, because Scrivener has also been designed to keep these features
out of your way unless you need them.

Consequently, this section contains chapters which could be considered optional. In
particular, screenwriting and bibliographies can be safely skipped unless your works re-
quire these functions.

The exception are the chapters discussing The Editor, and Writing and Editing. These
will be of benefit to all, as this will introduce the text editor, where you will be doing
most of your writing, and if you haven’t already done so, at least skim the prior part
on preparation. Vital concepts have been introduced there, and many of the following
chapters will build off of those concepts.

The topics that will be covered in this part are:

¢ The Editor (chapter 14): Full documentation of the various editor views and how
to use the primary editing and viewing interface.

@ Writing and Editing (chapter 15): Formatting, layout, and tools to enhance the
editing and revision processes.

¢ Page View (chapter 16): An alternate writing environment that emulates the printed
page. Useful for workflows which revolve around page counts, or just as an aesthetic
way of watching your work build pages, instead of a single scrolling view.

@ Composition Mode (chapter 17): Scrivener’s composition mode feature. Wipe aside
all distractions and just wrize!
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@ Annotations and Footnotes (chapter 18): Learn how to comment as you write using
either Scrivener’s exclusive inline annotation tool, or linked comments. Also covers
footnotes/endnotes; marker highlighting; and revision pens.

- Inspector (chapter 19): All about the inspector, which displays document meta-data,
notation, references, and more.

@ Scriptwriting (chapter 20): While Scrivener is not meant to replace an industrial
strength scriptwriting tool, it can still function as a very adept first-draft scriptwrit-
ing solution, and produce exports which will work seamlessly in industry standard
applications, like Final Draft.

¢ Writing Tools (chapter 21): General tools for writing and using the software more
effectively, include:

- Searching and Replacing (section 21.1): Comprehensive tools for finding
items, words, notations, and even formatting are discussed here.

- QuickReference (section 21.2): Taking Quick Look to the next level. Open
items in persistent, editable windows. When two splits aren’t enough, use
QuickReferences.

- Goals and Statistics Tracking Tools (section 21.3): Scrivener has numerous
tools for analysing the content of your project, as well as tracking goals and
progression while you work.

- The Name Generator (section 21.5): Create fictional names with ease, using
the name generator.

- Using Equations with MathType (section 21.7): If you need to insert formulae
into your work, Scrivener integrates with the popular MathType software.

@ Using MultiMarkdown (chapter 22): If you prefer to write in a structured or seman-
tic style rather than with a rich text focus, MultiMarkdown provides a simple, easy
to read way of defining and using styles which can be exported to word processors,
web pages, and LaTeX.



Chapter 14

The Editor

14.1 Header Bar

The header bar appears at the top of each editor pane, and can be toggled on and off via
View » Layout » Show (Hide) Header View. It contains useful navigation tools, displays the
current title of the edited document(s), and provides control over editor splits.

The header bar has three colour states:

1. Grey: when no split is active, this is the default state. If splits are turned on, the
inactive editor will be grey.

2. Blue (or graphite when the dark grey theme is enabled in the Appearance preference
panel): when splits are active, this denotes the active split. Any actions taken which
will impact the current editor will be made to the blue document. The title itself
will also be underlined for the active split.

3. Red: when an editor has been locked, it will turn red to remind you that clicks in
the Binder will not load any files into the editor.

14.1.1 History

On the left-most side of the header bar are history navigation arrows, which should be
familiar in appearance and usage from any web browser. Use these to navigate backward
and forward through the navigation history. If you right-click on the either of the arrow
buttons, a menu will be provided, making it easy to jump straight to something far back
or forward in the history without having to go through each point in between.

14.1.2  Item Icon Menu

Next to the navigation buttons is the document icon, which shows what type of document
is being displayed (which can sometimes be abstract, if more than one item is selected for
display in the view). Clicking on this icon brings up a menu containing some useful
shortcuts to oft used commands. The icon menu works on the current session, which can
at times mean more than one file, when working in Scrivenings mode.

183
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Reveal in Binder (0 $6-R) Will show the location of the currently edited file in the
binder, opening any containers as necessary to do so. This is most useful when
the method you used to arrive at the current document did not involve clicking in
the binder (such as using the history navigation buttons or a such result), or if you
are currently viewing a collection and wish to find where the file is actually located
in your project outline.

When used with Scrivenings mode, all of the entries included in the session will be

highlighted in the Binder.

Path Reveals the location of the current document in descending order. The top entry
will always be the current document; the entry below that its immediate parent;
and so on until the top of the project binder is reached. These can be selected to im-
mediately jump to any ancestor of the current item. This command always works
on individual files. When a Scrivenings session is in use, the constituent portion of
the session that you are currently working on will be revealed in the path.

Go To Offers an alternate way to jump to a specific binder item without using the binder.
If the binder is hidden or you would rather not scroll and open folders, for instance,
it will let you navigate to other areas of the project without having to alter your
layout. Your “Favorites” (section 8.6) will be placed in the top of this menu, making
it easy to jump to them from anywhere in the project.

When viewing a Scrivenings session, the contents of this menu will operate within
the confines of the current session only, thus providing a miniature “table of con-
tents” for the current session.

Bookmarks Displays any text bookmarks (section 15.8) that have been added to the cur-
rent document in a handy menu. Header style bookmarks will be offset and set to
bold, making it easy to cut a larger document into sections of bookmarks. If you
are viewing a Scrivenings session, all of the bookmarks in the entire session will be

displayed together.

Bookmarks can be added to your document using + 8- B, or from the Edit » Insert »
sub-menu.

Take Snapshot This command will take a snapshot (section 15.6) of the current text and
store it for later use. This command always impacts only one file. When used in
a Scrivenings session, only the constituent portion of the session your cursor is
currently in will be saved to a snapshot.

Lock Group View Mode When viewing an container or collection group, this com-
mand will be activated. It will lock the currently used view mode for this container,
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so that no matter what you change it to at a later time, clicking on this container
will always return to the selected view mode (subsection 8.4.1).

Match Split Document(s) Will open the currently viewed item in the inactive split.
This command will not be available if no splits are open.

Lock In Place (1+¢8-L) Locks the editor (or split) so that no Binder clicks will affect it.
When an editor is locked, its header bar will turn a shade of red (subsection 8.4.2).

14.1.3 Header Bar Title

To the right of the history navigation buttons, the title of the currently viewed item will
be displayed. As you navigate through the project, this title will update to reflect the cur-
rent contents of the editor. In most simple cases, it will display the title of the document
you are currently viewing or editing. Whenever the presented title consists of only the
title itself, you may edit the name of it by clicking within the text, and pressing Enter
to confirm. MAC:When a single item is shown, hovering over the title will display the
“path” of the item in a tooltip. This is similar to a file path on your system. It will show
all of the folders the item came from. You can also view this information graphically in
the header bar icon menu, as already described.

When you are viewing a collection of items in a corkboard or outliner, the name of
the viewed container will be displayed. That is, if you click on a folder in the binder, the
name of that folder will be displayed in the header bar, regardless of which index card or
outliner row you have currently selected. Use the Inspector to view the details of selected
items within a group view.

When viewing the result of multiple item selections in the binder (when more than
one item is selected via Shift-click or Cmd-click), the view will display the title, “Multiple
Selection”. This is a unique view which lets you know that the corkboard or outliner

b <«

you are viewing doesn’t “exist” anywhere in the project. You are viewing a selection of
items, but you will not be able to add new items or re-arrange existing items because there

relationship amongst each other does not correlate with anything in the Binder.

In the case of a Scrivenings session that comes about as the result of clicking on a con-
tainer, the name of the container will be displayed first followed by “(Composite)”. Suf-
fixed to this will be the name of the current document you are editing within that session.
When the Scrivenings session is the result of a Multiple Selection, it will be stated as such,
and the name of the currently edited document within the session will be suffixed to that
reminder.

In all cases where the title is a not a literal binder title, you will lose the ability to edit

the name of the document. You will need to use the inspector or the binder to make this
change, or enable Format » Options » Show Titles in Scrivenings.
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14.1.4 Sidebar Navigation

Moving to the right-hand side of the header bar, you will find two arrows pointing up and
down. These arrows allow you to navigate within the project sidebar (be it the binder,
Search Results, or Collection that is currently viewed), as though it were a flat list. This
form of movement is unique in that the binder selection will update. In most cases, when
you navigate to documents using the menus or the various controls available in the header
bar, the binder selection will not update to follow your select, by design. In this case
however, these two buttons are actually synonymous with clicking on documents in the

sidebar.

Clicking the up-arrow will move you to the document immediately above the current
document in the sidebar. The selected document will always be the one immediately
above, even if that item is currently hidden and on an entirely different hierarchical level.
Clicking the down-arrow will always move you to the document immediately below.

If you are viewing a container as a Scrivenings session, the behaviour of this feature
will modify slightly. The nature of selection will still be the same in terms of linear
above /below selection, but the current session will not be dismissed. It thus can be used
as a form of navigation within a Scrivenings session. Note that if you navigate above or
below the boundary of the selection, it will be dismissed. This feature is an augmentation
of the basic behaviour. It is not available to multiple selection based sessions. If you wish
to navigate within a multiple-selection based Scrivenings session, use the item icon menu
“Go To” instead.

These two buttons can also be activated with the keyboard shortcuts, 8- UpArrow
and \#-DownArrow, respectively.

14.1.5 Split View Button

Finally, the last button on the right-hand side is a multi-purpose button which changes
depending upon the current layout of the application and your last preferred split orien-
tation.

If no splits are open, a small line will be drawn through the icon in the horizontal or
vertical orientation to let you know which way the editor will be split if you click on the
icon. If you hold down the Option key, this will switch to the opposing orientation, and
that preference will be saved for future splitting as well.

Once a split is already open, the icon will appear blank. Clicking on it in this state
will close the opposing split. This means you should click on the icon in the header bar
for the document view you wish to retain once the split has closed. Either side can be
dismissed by clicking on the opposing header bar button. Additionally, if you hold down
the Option key while a split is open, a vertical or horizontal line will be drawn, allowing
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you to switch split orientations without otherwise disturbing your layout. Both splits
will remain open, only the orientation will change.

See also: Splitting the Editor (section 14.4).

14.2 Footer Bar

Below each editor pane is the footer bar. As with the header bar, its visibility can be
toggled with View » Layout» Show (Hide) Footer View. This is the most dynamic part
of the editor, in that it will change depending on the type of document visible and the
current editor mode. When a text document is being viewed, for instance, it will display
the word and character count along with a drop-down menu for changing the text scale
and a button for setting document targets. In script mode, it will display scripting hints
and the elements menu. When media is displayed, it shows the current playing time. This
section will cover the tools available to the standard text editor.

¢ For information on the various other document footer bars, see Viewing Media in
the Editor (section 14.3)

¢ For details on how to use the footer bar in script mode, see Scriptwriting (chap-
ter 20).

¢ Read the chapters on The Corkboard (section 11.1) and The Outliner (section 11.2)
for details on how to use the footer bar in those view modes.

14.2.1 Text Zoom

You can make the text in the main editor larger or smaller without changing the font by
using the text scaling pop-up in the left side of the footer bar. See Scaling Text (subsec-
tion 15.3.1) for more information.

14.2.2 Quick Text Statistics

In the middle of the footer, the current word and character account of the text you are
editing will be displayed in real-time as you type. This counter works for all visible text,
even if it would otherwise not be compiled, and will aggregate all text together when using
Scrivenings view. This counter will also display the statistics for the current text selection
if one exists. When the counter is displaying selected text, the colour will turn blue to
indicate that it is no longer counting the entire document(s) text.

Clicking in the statistics area will reveal a pop-over, which will display a little addi-
tional information, but more importantly, provides a quick count without footnotes or
annotations—though you can selectively turn either of these back on. The live counter
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that updates while you type will always include both of these for performance reasons,
so if you need to get a quick statistic scan without them, use the pop-over. The pop-over
also works with a selected range of text.

Pro Tip: If you want to easy grab the word count for the current section you are
working on within a Scrivenings session, you can use the selection counting feature
mentioned above in conjunction with the Edit» Select Current Text command, which
can be enabled by holding down the Option key, or pressing 8- A. This will quickly
select only the text of the current section you are editing, showing the word and char-

acter count in the footer.

14.2.3 Text Goals

When you are editing a single document in standard (not scriptwriting) mode, a small
target icon will appear on the right side of the footer bar. This button brings up the target
options for the current document which will let you set the numeric word or character
goal you intend to achieve with the section. You can optionally use Growl notification
to let you know when you’ve reached your goal. These notifications work in both ways,
whether you are working up to a number while writing, or working down to a number
while editing.

When enabled, the footer bar will acquire a progress bar next to the target icon which
will fill as you type, gradually changing colour until you reach your quota. These targets
are set individually for each document. You may also monitor and set them using the
Outliner, by revealing the “Target”, “Target Type”, and/or “Progress” columns, while
the “Total Goal” and “Total Progress” columns will show an aggregated goal count and
total progress toward that sum, for the displayed Outliner row and all of its descendant
items. In this way, you can easily work toward chapter or other larger section goals, while
still maintaining a fine-grained approach to cutting up the section into smaller pieces.

To disable the goal metre for a document, enter a value of “0” into the target configu-
ration for the document.

14.3 Viewing Media in the Editor

The editor is capable of viewing most of the file types that you will need to interface
with for research and creative use. The footer bar will often change to provide tools for
working with different media types. Note that Scrivener is, by and large, not intended
to operate as an editor for all types of files. It would take years to design these features,
and in most cases your existing applications will do a better job of editing PDFs, movies,
and images. Consequently, a convenience button will be provided on the far-right side of
the footer bar for most media views. You may also right-click on any media file in the
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binder and opt to Open» in External Editor, which will open the file using your system
default for that type of file, making it simple to load the document in an external editor
of your choice. Changes made to the file will be saved within the Scrivener project when

you returnl .

14.3.1 Viewing Images

The image view is displayed whenever an image document is selected, allowing you to
zoom in and out and rotate it. If the image is larger than the viewable area, click and hold
the mouse on the image and move the mouse to drag-scroll the image around. To zoom
in and out and rotate, double-click anywhere within the image or the grey area around it.
This will bring up the image tools pop-up.

The slider at the top of the pop-up allows you to scale the image.The button to the left
of the slider zooms the image as far out as it will go (that is, makes it as small as possible)
and sets the slider to the far left; the button on the right of the slider zooms the image as
far in as it will go (makes it as large as possible) and sets the slider to the far right. Below
the slider, you can check a “Scale to fit” option which will disable the slider and always
size the image according to how big the editor is.

There are three additional tools available: there is a button for rotating the image (rotat-
ing it 90 degrees clockwise, or anti-clockwise when Option-clicked); a button for fitting
the image to the current viewable area; and a button that returns the image to 100% mag-
nification.

In the footer bar, click the toolbox button to open the image in your default external
editor. If you wish to open the file in another program, right-click on this button to
select an alternate from a menu. This menu is provided by the operating system, so if
your favourite program isn’t showing it, you can resolve this by sorting out why it isn’t
showing up in the OS (making sure it is in the Applications folder will solve most issues
of this nature). When you select a non-default application to load the item in, Scrivener
will ask whether you wish to always open this file in that editor. This will impact al/
files of the same type, when loaded from within Scrivener (it will not change your system

default).

Beside this button you’ll see a reload button. You will need to click this after saving
your edits in the external image editor in order to see the changes.

'Tf you are already viewing that file in the editor, you may need to refresh its view in order to see the
changes.



190 CHAPTER 14. THE EDITOR

14.3.2 Viewing PDFs

The PDF view is displayed when a PDF document is selected. Its main view looks and
acts exactly the same as Preview.app. You can control the display of the PDF document
via the View » Media » PDF Display » sub-menu, and you can zoom in and out of it using
the “Zoom In” and “Zoom Out” controls in the View » Zoom» sub-menu. You can also
access many of these tools via right-click on the PDF display itself.

The footer bar contains arrow buttons on the left, which allow you to browse back and
forth through the pages of the PDF document, and text in the centre showing the number
of pages the PDF document has and which page you are currently viewing.

Annotating PDFs: As with ordinary text, you can select ranges of text in a PDF file
and highlight them with {+&-H. This tool is limited to the yellow colour. You may
also strike out portions of text using {8 --. It is not possible to insert comments into
a PDF using Scrivener. To give a PDF file advanced treatment, view it in an external
editor, such as Preview, or Adobe Acrobat. Any changes made to the PDF, once saved,
will show up in Scrivener after you refresh the file display.

Note that Skim, a popular PDF viewer, uses its own system for annotation which does
not show up in Scrivener and most other viewers. Consult the Skim documentation

for details on how to save embedded annotations.

As with images, you can open PDFs in external editors for annotation or more full-
featured browsing, and use the reload button to load PDFs from the disk if changes are
not showing up immediately.

14.3.3 Viewing Multimedia Documents

The QuickTime view is used to display movie and sound files. From the control bar
beneath the viewing area (above the footer bar), you can play or pause the movie, change
the volume, or step backwards and forwards through it. In the footer bar, you’ll see a
rewind symbol with a pause button in the middle of it. This is an optional mode which
will show up as blue if engaged, that will rewind your media by a set number of seconds

whenever you pause. This interval can be configured in the Navigation preferences tab
(section C.6).

To further aid in transcribing, you can use the $-Return shortcut key to pause and
resume a media stream even while you are typing in the other editor, never having to
leave the keyboard. With the focus is in the media editor, you may skip forward and
backward by a number of seconds with ©\8-) and £ & (, respectively.
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14.3.4 Viewing Web Pages

The web view displays imported web pages. Note that clicking on any links in a page
displayed in the web view will open the link in the system’s default internet browser.
Scrivener does not allow internal browsing simply because this would mean integrating
many of the features of a browser into the web view (such as back and forward buttons,
a refresh button, maybe even a download manager...) and this is outside of Scrivener’s
scope.

When the web view is shown, the content of the footer will display the original URL a
as a link that can be clicked on to open the original page in the system’s default browser.

You can increase and decrease the size of the web page font using the standard
View » Zoom » sub-menu.

Pro Tip: If you archive search forms, such as http://www.duckduckgo.com/, and
searches that you perform will have their results opened up in your web browser.
Thus it can be useful to store a number of common research portals in your Binder
for quick access. Note that since this uses an archived version of the web page, if the
host site changes their searching protocol, your archived search might break (this hap-

pens rarely).

14.3.5 Viewing Unsupported Document Types

By default, Scrivener will let you import files into the Binder that it cannot display in
the editor. You can restrict this by checking off “Import supported file types only”, in
the Import & Export preference tab (section C.10). Unsupported file types will use the
default system icon.

When loaded in an editor, the file icon and its filename will be displayed. Double-click
on the icon to load the file in its default external editor, or right-click on the toolbox icon
to select an alternate application (and optionally set it as the default for that file type). The
toolbar will also feature a Quick Look icon. Clicking this will produce the same effect as
using Quick Look in the Finder.

When unsupported file types are viewed in the editor the document icon will be dis-
played. To view the content:

@ Double-Click the icon to load the file in the default external editor for that file type.

@ Click the “Open in External Editor” button in the editor footer bar, or right-click
on the toolbox icon to select an alternate application (and optionally set it as the
default for that file type).

@ Use the Documents » Open » Open in External Editor menu command (~8-0O).



192 CHAPTER 14. THE EDITOR

As with supported files, unsupported files are fully imported (copied) into the project
package itself.

14.4 Splitting the Editor

Scrivener’s editor uses a technique known as editor splitting. You may have encountered
split screen editing in other applications, but the level of integration and power between
the two splits in Scrivener is likely to be unfamiliar to new users. Rather than arbitrar-
ily splitting the interface any number of times and ways, the editor uses a two-way split
system so that you can easily control the flow of information in the opposing split while
you work.

Splitting Documents: Looking for tips on how to permanently splitting a document
into two pieces? Scrivener supports that ability as well, so if that is what you are look-
ing for, you should head on over to Splitting The Document (section 15.3.3) for further
details. Splitting the editor is a purely visual tool.

If you are unfamiliar with splitting an editor in general, you can think of it as a way of
opening a second editor in which you can view the same item you are already working
on with an independent scroll position, or another item entirely. When the same item
is loaded into both splits (which is what happens when you create a new split), any edits
made to either side will be immediately shown in the other split (in a text editor, your
typing will be mirrored; with a corkboard, cards you add or delete will show up on the
other side too). Using two splits makes it easy to edit or refer to other parts of the doc-
ument, or your research & notes, without scrolling back and forth or frequently use the
history buttons.

Loading another item entirely into the second split makes reference a snap. While you
could use the history functions to jump back and forth between a reference source and
the portion of your manuscript that you are editing, splits will present both items to you
at once, even allowing you to play media in the second split while recording notes or
transcribing it as it plays.

In addition to standard file viewing and editing, you can also use splits to do anything
else that you would ordinarily do in a single editor. You can mix Corkboard, Outliner,
and Scrivening sessions together, and even link the splits so that clicking on cards or out-
liner rows automatically loads the item in the second split for you.

We’ll now take a look at all the available possibilities in turn.



14.4. SPLITTING THE EDITOR 193

14.4.1 Horizontal and Vertical Splits

The editor interface can be split in one of two orientations. In vertical mode, the divider
will be drawn down the middle of the screen, and is most suitable to viewing two text
documents side-by-side as it maximises vertical space. Horizontal mode creates a split
that is familiar to many applications like Mail with content on the top and bottom. In
either case, both sides of the split have the same degree of power in loading various views,
media types, and text editing. You can easily switch between orientations by choosing the
opposite split type in the View » Layout » sub-menu, or Option-clicking the split icon in
the Header Bar (section 14.1).

When the editor has been split, a header bar and footer bar will be created for each
split. This means that each side has its own history queue, view modes, zoom settings,
outliner columns and so on. Everything that you can do to a single editor window can be
done to a split window, and those changes will be remembered for that side of the split.
An example of this would be view modes. With a single editor interface, if you choose
to view containers using the Corkboard model, every time you click on a container or
select more than one item, a Corkboard will be presented to you. However, when splits
are engaged, each side has its own view settings. This means the left side (in a vertical
orientation) can be set to Outliner, and the right side set to Scrivenings.

You can adjust the comparative size of the splits by dragging the strip along the middle
that separates them. This can be done freely, though there are limits to how small a split
can be made. MAC: To reset the splits to be of equal width or height, double-click the
splitter bar with your mouse.

Quickly switching between editors: It is easy to jump between splits without using
the mouse, by using ~ 8- E and ~ 8- R. When the split orientation is vertical, E will
access the left editor and R the right; when the split orientation is horizontal, E will
access the bottom editor and R the top. Additionally the keystroke that cycles between
the Binder and the Editor, ~ Tab, will include both splits in the rotation.

14.4.2 Controlling the Opposing Split

There are a few commands that you can use to impact the editor your are not currently
working in, reducing the need to flip back and forth between them. These are located in
the View » Editor » Other Editor » sub-menu, and have shortcuts for handy usage.

Remote scrolling To scroll the other text editor up and down, use ~ 8- UpArow and
A~ %-DownArow. This command does not work when the other editor is view-
ing Corkboard or Outliner views, or media that would not otherwise respond to
scrolling.
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Note that this form of scrolling is based on the scrollbar, not actual text position, so
the position of the scroll point will not be saved when used in conjunction with the
history button, like cursor position is. The exception to this are PDF files, which
are always saved by scroll-point, not cursor position.

Remote history access Just as you can quickly flip through the history with $-( and
$-), you can cause the other editor the jump back and forth in its own history
queue with 8- ( and \“&-). A nice trick here, when working with a sequence
of reference documents, is to “pre-load” them into your reference split by clicking
on each one sequentially. Now they are loaded into the history queue and easily
accessible while you write in the other split.

Controlling media While typing in one split, you can start and stop Quick Time movies
and audio tracks with - Refurn, making this setup extremely useful for transcrip-
tion. If you have Rewind on Pause enabled (section 14.3), this shortcut will also
rewind the piece by a set amount (3 seconds by default), making it easy to catch up.

14.4.3 Managing Split Views

If you wish to swap the actual position of the material in the editors, so that the content
on the left now appears on the right, for example, use the View » Layout » Swap Editors
menu command.

To synchronise the contents of both splits, click the document icon in the header bar
for the side you wish to use, and select the Match Split Document(s) command. This will
duplicate your current view selection in the other editor. So if you are in a Scrivenings
session, that session will be duplicated; if you have a Multiple Selection view, that selection
will be duplicated in the bottom view—and the current view mode in the active split will
be used instead of the active default for that split (and will thus set the default for that split
to the acquired view model for purposes of future navigation).
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Writing and Editing

Scrivener uses the standard macOS text editor, and therefore all of the features of its rich
text editing system (which are showcased in Apple’s TextEdit application) are available'.
Scrivener also provides some extra word processing features. Most of these features are
available via the Format (section B.7) and Edit (section B.3) menus, so it is reccommended
that you familiarise yourself with these.

The text engine, and macOS: Please note that because Scrivener uses the macOS
text system, its behaviour in this regard is defined by Apple. The way double- and
triple-clicking on text works, the occasional awkwardness of features such as tables
and bulleted lists, font changes and so forth, are all governed by the text system, which
is programmed by Apple and is out of our hands. The good news is this also means
you get access to many sophisticated tools which would otherwise take many years to

research and implement.

156.1 Rich Text Editing Philosophy

Scrivener supports a rich text editing environment, which means that it is loosely “what
you see is what you get”. Unlike word processors or desktop layout applications, however,
the precise formatting that you use when writing in Scrivener may in fact look nothing at
all like the final product. The compiler will be covered in greater detail in a later section
(chapter 24), but suffice to say that you can work in one font, say the default Cochin, but
publish in an industry standard font like Times New Roman, without having to change
your source text. What this means for you is that certain aspects of your editing can be
conveyed through the compiler, like a range of italicised text, while the base font itself can
be changed beneath that. Scrivener’s editor can thus be used /ike a typical word proces-
sor, but with the knowledge that rich text formatting can be altered later on to produce
different results.

"The only exception to this is that in Scrivener, you are not allowed to paste QuickTime files into the
text. This is because of a bug in macOS that can cause crashes or strange behaviour when a QuickTime file
is contained inside a single piece of text that is being viewed in two panes, such as Scrivener’s split view.

195
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Scrivener is not intended to be a full-blown word processor, but rather a word generat-
ing environment. It is not a layout tool, but a tool for cutting the text that will become
your book. Many authors who have stricter formatting requirements, such as scriptwrit-
ers, will start their projects in Scrivener, and end in a word processor or desktop publish-
ing, or some other specialised application. Someone writing a novel or short story could
very well do the whole thing in Scrivener, including the final print for submission and
export to Word format for sending an electronic copy.

You might be wondering if Scrivener offers a plain-text editing environment as well.
There is no plain text option, as Scrivener is a writer’s tool rather than a strict text edi-
tor, and many of the tools that are made available to you for writing rely upon rich text
to function, such as highlights, marking revisions, and annotating. Even if you do not
require formatting, you will probably find the formatting tools #seful in the writing pro-
cess, especially if you are compiling to plain-text, where they will all be safely stripped
out and invisible to the reader.

Emulating plain-text: If you find working in a plain-text environment to be more
productive, you may wish to set the default editor font to one that does not support
rich text features, such as Courier, and change the ruler settings so that there are no
indents or paragraph spacing. This set-up will emulate a plain-text environment whilst

still allowing features such as annotations and highlighting.

When using MultiMarkdown to format your work, you will find that some format-
ting, such as inline images, footnotes, and so forth will be converted to MMD markings
during compile. Most formatting, however, will be stripped and thus can be useful in an
annotation setting.

156.2 Editing Basics
15.2.1 Caret Movement and Selection

The following list shows the shortcuts for changing the current selection. To simply
instead move the current insertion caret position, omit the shift key where applicable.

@ {r ArrowKeys: Extend current selection in the direction of the arrow key that is used.
@ (< LeftArrow or RightArrow: Extend the selection by word.

@ {+CUpArrow or DownArrow: Extend the selection by paragraphs.

@ {+88-UpArow: Select from the caret position to the top of the editor.

@ 3-DownArow: Select from the caret position to the bottom of the editor.
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@ (238 LeftArrow or RightArrow: Select from caret position to beginning or end of line
respectively. Note the definition of line is not a paragraph, but is instead dependent
upon the current soft wrap. To select to the beginning or end of the paragraph, use
the above paragraph selection shortcut.

@ {rMouseDrag: Extend the current selection using the mouse.

@ Double-click: Select word. Can be used in conjunction with dragging to select a
range by word.

@ Triple-click: Select paragraph. Can be used in conjunction with dragging to select a
range by paragraph.

An advanced method of selection can allow you to select more than one location at
once. By holding down the Command key and selecting using the mouse, you can select
several areas of non-consecutive text. The Option key can be used to select rectangu-
lar portions of text, which is mainly useful for trimming unwanted characters off of the
beginnings of several lines.

@ Jump to end of current paragraph: ~E. This is equivalent to \XDownArrow, but is
significantly easier to input as it uses the typing keys.

@ Jump to beginning of current paragraph: ~A. Again, equivalent to X UpArrow
but requires less hand movement while typing.

15.2.2 Deletion

Simple character deletion can be performed with the delete key to delete the character
prior to the caret position. On extended keyboards, an additional DEL key (which deletes
the character after the caret position) is provided in the central auxiliary cursor control
area, between the alphabetic keys and numeric keypad. On many compact and laptop
keyboards, you can activate forward-deletion with the Fn-delete combination.

¢ Delete to beginning of current word: \“delete
¢ Delete to end of current word: \Fn-delete or \DEL

@ Alternate forward character delete: ~D. This is the same as DEL or Fn-delete, but
you might find it easier to use since it doesn’t require your hands to be substantially
moved from the home row.

@ Delete to beginning of soft wrapped line: - delete
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@ Delete to end of paragraph: ~K. Do note this deletes all the way to the end of the
paragraph, not the current soft wrap line.

¢ Transpose letters around caret: ~T

16.2.3 Spell Checking

Spell checking in Scrivener can be accomplished either as you type, or after you are done
writing a section. Depending on your preferred way of working, you’ll want to set how
this works in the Corrections preferences tab (section C.9), where you will find other op-
tions such as which language to use, and whether or not Scrivener should try and fix com-
mon typos for you as you write. You may also use Edif » Spelling and Grammar » Check
Spelling While Typing (#-\) to toggle instant spell checking on and off for the project.

By default, Scrivener will highlight misspelled words as you write. If you would prefer
to not be alerted to misspellings while writing, you can defer the spell check process for
later. When you are ready to spell check a document, right-click anywhere in the doc-
ument, and select Spelling and Grammar » Show Spelling and Grammar from that menu.
A familiar floating window will let you step through the document error by error, fixing
mistakes and adding unique words to your personal dictionary as you go. As with most
tools of this nature, if you type anything into the top field and click “Change” you can
add a correction that is not shown in the suggestion list.

The Ignore button will temporarily ignore the misspelled word, while Learn will add
the word to Scrivener’s permanent ignore list. The Guess button can come in handy if
none of the suggestions are correct. You can change the word itself in the top field, or
select one of the suggestions and click this button in an attempt to narrow the list down
to the correct word.

Grammar checking can also be enabled here, and you can look up definitions for words
by clicking on them in the suggestion list and clicking the Define button. This will open
the standard Dictionary tool, with the word pre-selected.

Spell Check Contextual Menu

With active spell check while typing enabled, when you misspell a word while writing, it
will be underscored with a wavy red line. Whenever you see a word with this marking,
you can right-click on it and the contextual menu will contain best-guess suggestions for
which word you were aiming for.

The contextual menu contains a few convenience commands:

Ignore Spelling Temporarily ignores the word for the current session, in all documents
within the project. Note that in some cases you may need to “refresh” the spelling
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engine by viewing another text document and then returning, as ignoring by right-
click will often only impact that one instance you clicked upon.

Learn Spelling Permanently adds the selected word to your personal dictionary. Since
Scrivener makes use of the global Mac spell check engine, this will add the word
to your entire Mac, meaning it will no longer appear misspelled in Scapple, Mail,
Safari and other native Mac software.

Unlearn Spelling This option will only appear when right-clicking on a word that you
have previously “learned”. This will remove the word from your personal dictio-
nary.

156.3 Editing with Scrivener

Beyond the basics of text editing, which are similar to many applications, Scrivener pro-
vides further tools, specifically designed for writers, in its editor interface. The rest of
this chapter will focus on these tools in a comprehensive fashion, where you can glance
through the list of topics covered and pick which items you feel are best suited to your
writing style and the task in hand. You could read this section from start to finish, but it
is meant to be a collection of individual nuggets that you can learn independently, as you
gradually build up your knowledge of the application.

16.3.1 Scaling Text

The text of the editor can be scaled up and down, without affecting the font size, via the
ability to zoom the scale of the text. Each split can have its own zoom setting; additionally
the composition mode can have its own independent zoom setting as well. All of these
settings are preserved between sessions and saved into the project file itself.

In the standard text editor interface, zoom can be set using the zoom tool in the footer
bar (section 14.2). In composition mode, this same tool is provided within The Control
Strip (section 17.2).

You can also use the menu commands:
1. View » Zoom » Zoom In ({+$8-.) to increase the zoom factor of the text.

2. View » Zoom » Zoom Out ({+3- ) to decrease.

If you prefer to always work from a certain zoom setting, the default zoom level for
both standard editors and the composition mode editor can be adjusted in the Editor
preference tab (section C.7), and the Compose preference tab (section C.5), respectively.
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Note that this setting will impact all new projects, or recently upgraded projects, not
projects that have already been created, as each project can save its own individual settings.

Additionally, Inspector footnotes and comments can have their text dynamically scaled,
either to match the current text editor, or at a fixed percentage value (subsection 18.2.4).

15.3.2 Contextual Menu for the Text Editor

The text view’s contextual menu contains many standard commands such as Cut, Copy,
Paste, Spelling and so forth, along with a number of commands specific to Scrivener.
Several common tools, such as Spotlight searching, dictionary access will be located in the
“Writing Tools” sub-menu. If a selection has not already been made, right-clicking will
select whatever word (or words connected by a hyperlink) is under the mouse pointer.

The Scrivener-specific commands (the appearance of which will depend on the selec-
tion) are listed below:

Text Editing Contextual Menu

Remove Link When the active selection contains one or more links, you can strip the
links out with this command.

Look Up ‘word’ [10.7+ (Lion) Only] When right-clicking on a word, or a selected
phrase, the “Look Up” menu item will be inserted at the top. This will open
the Dictionary and Thesaurus pop-over that can otherwise be accessed with ~8-D
when hovering the mouse over a word.

Select Annotation/Footnote When right-clicking within an inline annotation or foot-
note, this option will appear, making it easy to select the entire contiguous range
of text that has been marked as notation. When two inline annotations of different
colour fields are located adjacent to one another, this command will only select up
to the edge of the current colour right-clicked upon.

Split at Selection ($2-K) Splits the current document into two documents at the selec-
tion point (the current blinking cursor point, or the initiating edge of the selection,
which will be on the left by default, or on the right when using right-to-left lan-

guages).

Split with Selection as Title (\-6-K) Splits the current document into two documents
using the current selected text as the title for the newly created document. The
selection will remain after splitting, making it easy to remove the redundant title
text if necessary, or style it like a header. For more details on splitting documents,
read Managing Documents with Split and Merge (subsection 15.3.3).
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Append Selection to Document Provides a menu of all documents in the binder. Se-
lecting a document from this menu will cause the selected text in the editor to
be appended to the document selected from the menu. Read Gathering Material
(chapter 10) for more tips on moving text around and organising information in

the Binder.

Set Selected Text as Title ({+ 38-T) Sets the title of the current document to the text
selected in the editor.

Add Selection to Auto-Complete List Adds the selected text to the project’s auto-
complete list, which can be maintained with the Project» Auto-Completfe List...
menu command. Read more about this feature in Auto-Completion (section 15.7).

Link to Document Allows you to create a link to another document in the project
within the text. Read more about linking items together in Linking Documents
Together (section 8.5).

Text Color Provides the text colour menu, from which you can select from the built-in
colours, or those custom colours you have saved into your colour palette.

Highlight Color Provides the highlight menu, allowing you to select a highlight colour
for the selected text, or to clear it. Read more about this and the above feature in
Text Colour and Highlights (section 18.4).

Spelling and Grammar Quick access to spell check tools.

Apply Formatting Preset Apply one of your saved formatting presets (subsec-
tion 15.4.3) to the selected text.

Font Provides basic character attributes, such as bold and italic, as well as access to the
main font chooser.

Speech Quick access to the Edit » Speech » sub-menu.

Writing Tools » Quick links to a few handy web searches and the system dictionary
and thesaurus application. The current word, or selected text, will be sent to the
search engine or reference site of your choice.

Hyperlink Selections

When the selection is entirely or partially within a hyperlink (not an internal Scrivener
Link), then additional link management options will be provided for at the top of the
contextual menu:
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Open Link The same action as left-clicking on the link with the mouse. This method is
here primarily for accessibility purposes.

Copy Link Copies the underlying URL of the link, as in many web browsers, so that it
can be pasted bare or used in other contexts such as the creation of new hyperlinks,
or to import the web page into Scrivener using File » Imporf » Web Page....

Edit Link Brings up a window for editing the underlying URL of the link. This is the
same as using Edit » Edit Link....

Images Contextual Menu
These options appear when right-clicking on an image that has been placed within the
text (section 15.5).

Save As Picture... Available if you have clicked on an inline image. Allows you to save
the image to disk. You can also drag images into the Binder.

Scale Image... Available if you have clicked on an inline image. Brings up the image
scaling panel.

Linked inline images (subsection 15.5.3) provide a few extra convenience commands

for working with the file on the disk:

Reveal in Finder Opensanew window in your computer’s file manager, with the linked
image highlighted in the window.

Open in External Editor The file will be opened directly off of the disk using the sys-
tem’s default image editor. This will edit the original file, since it is merely linked
into Scrivener.

Scrivener Link Selections

Open Document Link In » This command only appears when right-clicking on a sin-
gle Scrivener Link, where only that link is selected and no extra text around it. This
is most easily accomplished by right-clicking on the link itself (the selection will ex-
pand to include the full link range automatically). The contextual sub-menu gives
you a few extra options for where the link should be opened, letting you override
your application default as set in the Navigation WIN:optionsMAC:preference tab
(subsection C.6.7).
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Update Links to Use Target Titles Only appears when one or more Scrivener Links
are contained anywhere within the current selection. This command updates the
link text to match the binder titles of the items they respectively link to. Read more
about the feature here (subsection 8.5.4).

Tables Contextual Menu
When right-clicking within a table in the editor, additional options will be provided in
the contextual menu:

Table... Accesses the table palette, which provides formatting, cell dimension, and nest-
ing, and cell split and merge features. Inserts a table if one does not already exist.

Add Row Above/Below Will insert a new table row of empty cells above or below the
row in which you right-clicked.

Add Column Before/After Insertsanew table column of empty cells to the left or right
of the column in which you right-clicked.

Delete Row/Column Will delete the entire row or column in which the cell you right-
clicked upon is located.

Sort Rows Ascending/Descending Sorts all rows in the table based on the alphanu-
meric value of the text in the row that the selection is currently in.

Borders This sub-menu provides some handy border tools.

Distribute Rows/Columns Evenly Adjusts the height or width of all rows or columns
so that every cell has the same dimensions.

Remove Table Strips the table code out from the currently active table, leaving all text
behind as linearised.

Lists Contextual Menu

Only one extra option over the base text system has been added for list management:

Re-number List In rare cases, especially when pasting lists from other word processors
like Word, list numbering will sometimes not register properly. Use this command
to attempt to repair these lists.
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16.3.3 Managing Documents with Split and Merge

The ability to expand and contract the outline in a fashion which best suits how your
work is important, so there are two tools which make it easy to fashion your outline into
as broad or detailed a map as you require.

Before discussing the specific tools which let you cut apart documents or sew them back
together, it would be useful to also discuss a few methods that you can use to mitigate the
regular need for them.

When you wish to merge two or more documents together, it is good to ask whether
or not this action is necessary. With most applications, and thus the habits we have culti-
vated from using them, the answer to whether or not one should merge is, yes. However
Scrivener offers two powerful answers for the merging problem. First, for visualising
smaller pieces of a document as a single document, but only temporarily, you can select
any container in the binder, or even just a scattering of items, and choose to view and edit
them much as though they were a single document (section 15.9). Second, the compila-
tion (chapter 24) system enables you to publish your final work as a single document, no
matter how many pieces it may be divided into within Scrivener.

For splitting long documents, in some cases you may be able to utilise use import tools
which do most, if not all, of the splitting for you. File » Import» Import and Split..., will
let you supply a separator, or a string of characters, that mark natural sections within
the original file. Whenever Scrivener encounters this separator, it will automatically start
putting the remaining content into a new binder item, continuing to split into new binder
items until it runs out of material. The second tool, special for MultiMarkdown users,
is File » Import» MultiMarkdown File.... This tool will examine the incoming file for its
header structure, and not only split files between headers, but title them according to
those headers, and even reconstruct the hierarchy of the original document. Finally, if
you’ve done your original outlining in a dedicated outliner program, it will likely support
an OPML export, which you can drag into Scrivener’s binder. It will recreate the outline
structure, placing any original outline notes into the text area for each outline header.

For most other cases, read on.

Splitting The Document
Often, when importing material that you have composed in other applications that do
not support an easy to use built-in outline, your text will arrive in Scrivener in one large
chunk. Where you choose to break this long document apart is up to you, and the split
tools make it easy to do so.

To split in a document into two pieces, you will first need to place the caret at the

precise point in the document where you wish the split to occur. If you select a range of
text, the start of the selection will be considered the caret point, for purposes of splitting.
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Once the selected location has been chosen you can use one of two methods to split the
document:

Documents » Split » af Selection (88-K) This will create the new document directly below
the current document in the outline. It will contain everything that followed the
caret position, and this material will be removed from the original document. It
can be useful to think of splitting in terms of “above” and “below” the selection.
Everything above the caret (and also to the left if in the middle of a line) will remain
in the original document, while everything to the right and below of the caret will
be moved to the new document.

After splitting, you will be given the option to name the new document in the
Binder.

Documents » Split »- with Selection as Title (X8-K) This alternative method will only ap-
pear when a range of text has been selected in the editor. This method works iden-
tically as “at Selection” does, only the selected text will automatically become the
title of the new document. This text will remain selected after you split, making it
easy to remove it, or style it as a header.

When splitting documents, most meta-data will be carried over to the new document.
The only exceptions to this will be any snapshots and the synopsis. Snapshots will remain
attached to the original document (everything falling before the split point), and can thus
be useful in seeing what a document looked like before it was split up. It is thus a good
idea to set up any common meta-data like keywords and labels before you start splitting
up a document, to avoid having to make numerous identical changes later on.

It is not possible to undo a split action, but you can use the Merge feature to effectively
undo any unwanted splits.

Pro Tip: You might also find the ability to search by formatting (subsection 21.1.6) to
be of use as well, as often the places you will want to split the document will coincide
with headers. While the Find by Formatting panel is open, you can use the Split with Se-
lection as Title function without closing it, and then quickly go to the next search result
within the portion that has been split off. Or, if you wish to use keyboard shortcuts,
this means you can alternate between using 8K to split the found text, and ~\88-G

to skip to the next search result, even with the Find by Formatting box closed.

Merging Documents Together
In opposition to splitting, the ability to select two or more documents and merge them
together into a single document is also made easy with Scrivener. Unlike the split func-
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tion, merging is a super-document level action, and thus requires a selection to be made in
a corkboard, outliner, binder view, or from within a collection; you cannot merge from
within a text file.

Documents do not have to be in consecutive order, they can be picked from throughout
the project. When selecting non-linear items, here are some tips to determine ordering:

« If the view you are picking documents from is based on the outline order, such
the binder, outliner, or corkboard (for this purpose, a freeform corkboard is still
considered to adhere to Outline Order. If you wish to impose a new order based
on the freeform spatial placement, make sure to use the Commit Orderbutton (sec-
tion 11.1.4), first, and then merge), then the merged document will retain the orig-
inal outline order.

¢ When using a Collection to select items, the collection order will be used to estab-
lished the structure of the merged document.

When it comes to merging, Scrivener will attempt to retain as much meta-data as is
logically possible. The synopses, notes, keywords, references, and list of snapshots will
be combined together, much in the same fashion that the main text will be. Meta-data
which cannot be combined (such as Title, Label, any custom meta-data, compile option
flags, and so forth) will use the top-most document as a reference point. For example:

‘& Document A

- Synopsis: “This is the first document”
- Keyword: “Apples”

- Status: “First Draft”

& Document B

Synopsis: “This is the second document”

Keyword: “Carrots”

Status: “To Do”

Notes: “Mix these two together in a blender for a great tasting, healthy bever-

»

age.

Both Document A and Document B are selected in the Binder, and Documents » Merge
is invoked (4+ 8- M), producing the following single document (with the bold items indi-
cating material used from Document B):
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@ Document A
- Synopsis: “This is the first document
This is the second document”

- Keywords: “Apples”, “Carrots”
- Status: “First Draft”

- Notes: “Mix these two together in a blender for a great tasting, healthy
beverage.”

When merging, the main text will be combined according to the preferences you have
set in the General preferences tab (section C.2), under the Separators section. Merged
documents can be combined with a single line, a full empty line (useful in situations where
plain-text is in use and paragraphs need to have an empty line between them), or a custom
separator, which allows you to type in any sequence of characters. Note you can add
carriage returns and tabs to this field by holding down the Option key and typing in the
special character.

16.3.4 Typewriter Scrolling

You can turn “typewriter scrolling’” on for the main editors, QuickReference panes,
and for the composition mode editor independently via the Format » Options » sub-menu
(~88-T). When it is switched on, just as with a typewriter, the line of text you are typing
will remain centred vertically in the editor, once your text is long enough to reach the
middle of the screen. This means that your eyes do not have to be glued to the bottom of
the screen all the time when typing in a long piece of text.

When Typewriter Scrolling is enabled, your scrollbar will act as though there is more
content than the document actually has. This is because we add extra spaces below the
last line in the document in order to keep it in the middle. These spaces do not actually
exist in the file, and will vanish when the feature is disabled.

It is possible to adjust where the focus point will be. If you’d prefer for editing to
happen in a different fraction of the screen, visit the Editor preference tab (section C.7),
and set the “Typewriter scroll line” to the top quarter, third, middle (default), bottom
third, or quarter of the screen.

The Typewriter Scrolling feature is not available in Page View, given how this feature
lays out the pages in a simulacrum of the printed page, which will of course not contain
any of the dummy lines added to keep the entry position in the middle of the screen.

2Typewriter scrolling was an innovation of the The Soulmen’s Ulysses.
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15.4 Formatting Tools

15.4.1 The Ruler

The text editor in Scrivener uses a ruler for setting indents and tab stops, such as many
word processor applications provide. It can be shown or hidden via Format » Show(Hide)

Ruler or -R. This will present a simple indenting and tab stop interface (Figure 15.1).

The following elements can be found in the ruler:

Tab Stops Left stops can be created by clicking in the numbered area and dragging up, or
by right-clicking in the ruler and choosing a type. Once placed, they can be moved
via click-and-drag, and the numerical value of its position will be printed above the
mouse pointer as you drag. These will be depicted by type using icons. The four
tab stop types available are:

- Left: This is the standard type. Text will be left-aligned, with the first charac-
ter indented to the position of the tab stop.

@ Center: Text will be centre-aligned, using the position of the tab stop as an
anchor point; this can be anywhere on the line.

@ Right: Will right-align text with the right-indent set to the point of the tab
stop.

@ Decimal: Most often used for aligning rows of numbers, so that the system

decimal character is lined up vertically with everything before the decimal
being right-aligned, and any fractional values left-aligned.

To remove a tab stop, simply click and drag it down or up out of the ruler until the

icon disappears.

Indents There are three indenting controls, not to be confused with margin controls
(which Scrivener’s ruler does not address). Indenting is the action of offsetting text
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a defined distance from the margin. A left indent pushes the text boundary toward
the right, away from the left margin. A right indent pushes the text boundary
toward the left, away from the right margin.

In addition to the two primary indent marker is the first-line indent marker. This
will only indent the first line of a paragraph. Using this control, it is possible to set
the first line to indent by half an inch, while the rest of the paragraph is set to zero
(or directly adjacent to the margin).

Scrivener’s default formatting settings demonstrate the best way to use indentation,
if you need to use it at all.

Hanging Indents These are produced using the same tools as ordinary first-line indents,
only to produce a hanging indent, you will need to inverse which marker comes
first. If the first-line indent marker is to the left of the left-indent marker, then the
body of the paragraph will be pushing inward, while leaving the first line “hanging”
over the blank space left below it.

Right Indents These are rarely used, as they will often restrict flexibility down the road,
depending on your ultimate page size, and it can be confusing to calculate where
they should be set to. For instance, if you prefer to proof with a more generous page
margin of 1.75” but need a 1” margin for submission, an appropriate level of right-
indentation away from the margin would differ. However there are cases where it
is necessary, of course, and in such cases you will need to restrict yourself to using
a more limited set of paper and margin sizes.

Sometimes, when importing material from word processors you may get text which
is already indented artificially, causing it to wrap before it gets to the edge of
Scrivener’s editor window. You can either pull the right-indent marker all the way
to the right to reset the value to off, or use the Documents» Convert » Formatting
to Default Text Style menu command to clean up large amounts of text at once.

Ruler Conversions: When working with units in Scrivener, keep in mind that its ruler
starts at margin zero instead of paper zero. Since Scrivener is, by and large, not “aware”
of paper settings and page layout, it counts its ruler settings from the beginning of the
text on the left end of the page, not the beginning of the paper itself. This is in contrast
to many word processors, which start measuring at the paper left edge, and show the

print margin buffer in the display of the page.

Consequently, to convert most standard measurements to useful values here, you will
need to factor in the standard amount of print margin by adding in the margin to the
value you see in the ruler. For example, if you are using 1” margins and you need a right-
indent of 17, the right-indent should be set at 5.5” for US Letter, not the standard 6.5”.
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Figure 15.2: Format Bar: displayed in sections

Optimally, your formatting can be deferred and set in the compiler, where formatting
and paper dimensions can be operated upon in concert.

Using tab stops while writing is as simple as pressing the tab key to advance to the next
available stop. If there are no more tab stops available on that line, the system will wrap
around to the next line at the first tab stop, but no newline will be added. Tabs allow
you to enter tabular information into a single line, without using tables. To remove a tab
from the line, simply delete it as you would any other character. Tabs can be viewed as
symbols with Format » Options » Show (Hide) Invisibles.

Ruler settings are adjusted per-paragraph. If you wish to set tab stops or indents for
many paragraphs at once, you will need to select them prior to using the ruler. If for
some reason you need to apply ruler settings from one portion of text to another, it is
possible to copy paragraph settings by using Format » Text » Copy Ruler and » Paste Ruler
menu commands.

15.4.2 The Format Bar
The Format Bar provides quick access to common formatting features. If you are looking
for tab and margin controls, you can still toggle that per text view with 8- R. The visibility
of the Format Bar is toggled with 88 -R.

The first section (Figure 15.2) of controls handle font face, size, and variant. All of
these tools act immediately on the currently selected text. If no selection is given, then
they will alter how you type from the current caret position onward.

¢ The first drop-down contains formatting presets (subsection 15.4.3); handy ways to
apply many formatting preferences at once.

& The second menu lets you select from all of the available font families installed on
your computer.

¢ The third provides the variants available for that family. Note that not all fonts
come with a full complement of variants. If for some reason you cannot change a
selection of text to bold or italic, check this menu to make sure that the current font
supports these variants.
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& The fourth menu provides a quick list of common font sizes. If you need a custom
size that is not available on this list, use the Font Panel... item at the bottom to access
the standard macOS font palette (subsection 15.4.4).

The aforementioned Presets menu hooks into Scrivener’s formatting preset system. As
is the case with Apple’s default system, it is important to note that these are format and
ruler “brushes”, not word processor stylesheets. They apply saved formats to the selected
text or the caret position, but once these have been applied they will not automatically
update later on if you change the preset.

The next three buttons (section two (Figure 15.2)) provide toggling shortcuts to the
most common text formatting tools: bold, italic, and underscore, respectively. When
the caret is in a range of text that matches the format style, the appropriate buttons will
appear activated.

Directly to the right of these, control for paragraph-level text alignment exist in button
form. Paragraph-level alignment comes in four flavours:

@ Left Align (default)
@ Centre Align
@ Right Align

- Full Justification

In all cases, these adjust the entire paragraph. If you need multiple alignments on a
single line, you will need to add special alignment tab-stops to the ruler (8-R).

In the third section the left colour box will alter the foreground text colour. Click the
button once to set the selected text to the depicted colour (black by default), or right-click
to access a pop-over with convenient colour selection utilities. You can opt to strip out all
colour code from here with the top-left square that has a red slash drawn through it, as well
as access the standard colour palette and any custom colours you’ve added to it. For more
information on using the colour tools, see Text Colour and Highlights (section 18.4).

The second colour selection drop-down works in an identical fashion to the first, but
it sets the background highlight colour for the selected range. Click once to toggle the
current highlight (or use 138 -H) for the selected text, or use right-click to access further
options as described above.

The final, fourth section of the Format Bar accesses paragraph & line spacing, and lists.

The spacing drop-down provides some quick presets for global line spacing, but for
more complex multi-type spacing preferences, as well as paragraph spacing (above or be-
low), select the Other... item at the bottom of this menu.
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The list tool provides most common Western list formats. For custom and interna-
tional formats, select the Other... menu item. Lists can be enumerated or bulleted in a
variety of methods. They will transform the current paragraph (even if empty) into the
first list item, and will continue generating new list lines until you enter a blank line.
While entering lists, it is possible to indent or outdent lists with Tab and 1 Tab.

16.4.3 Formatting Presets (Styles)

For occasions when you need to apply a certain style of formatting repetitively through-
out your work, a tool that can store formatting settings and apply them later to other
ranges of text will make writing in Scrivener more convenient.

Presets are not Stylesheets: If you are familiar with using stylesheets from traditional
word processors, you might be looking for something similar in Formatting Presets.
While presets do make the propagation of formatting easier, they do not assign the
target text with any kind of named range, like stylesheets do, so that they can be uni-
versally updated centrally by the stylesheet. Once applied, the text merely ends up
looking as the preset ordains it to, with no further connection to that preset. It is thus
a good idea to make sure you have your formats locked down as close as possible, if

you intend to use this feature to generate output-ready content.

A few Presets have been provided to you for convenience, or as starting points for your
own preferred look and feel. Note that Presets are not in any way tied to the rest of the
application or project formatting rules. For instance, if you change the application default
to use paragraph spacing instead of first-line indentation, the Body preset will not change
and will still apply an indent to the target text. This is by design, as “Body” is nothing
special and can even be deleted or completely redefined.

There are two basic types of presets available:

1. Paragraph style: this will save all of your ruler settings, as well as alignment and
line-spacing attributes, and anything else found in the Format » Text » sub-menu.

2. Character attributes: this will save any format level adjustments, like bold, under-
score, kerning, or anything else found in the Format » Font » sub-menu.

These two types can be used exclusively, or combined into a single Preset, controlling
all aspects of the text appearance, and both can optionally also apply font size and font
family information. The Preset menus will display small icons in blue, next to each entry,
indicating whether the style will impact one or both of these types when applied to your
text.
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Applying Presets
To apply a preset, first select the text you wish to apply the preset to, then use one of the
following methods:

¢ Use the Formatting Presets button on the Format Toolbar to select a preset from
the drop-down menu.

- Use the Format » Formatting » Apply Preset » sub-menu to select the preset, or use
the “Apply Formatting Preset” sub-menu from the right-click menu.

The types of formatting applied to the text you have selected will depend upon the type
of preset. For character attribute presets, you must select the text you wish to apply the
preset to, just as you would when using bold or italics. For paragraph style presets, the
cursor can be anywhere in the target paragraph and no explicit selection need be made.
Of course, if you wish to change many paragraphs at once you can use standard selection
to do so. Whatever paragraphs the selection falls into will be impacted, even if they are
not fully selected.

Presets which contain both character and paragraph attributes will apply all stylings to
the entire paragraph, regardless of selection. If you wish to only apply font styles to a
portion of your paragraph, then you will need to create a character attribute preset to do
so. For example, if you saved the bold attribute into the paragraph and character preset,
the entire paragraph will be emboldened, regardless of the selection you’ve made.

Creating New Presets

To create a new preset, you will need to create exemplar text in your editor, containing the
styling you wish to preserve for future use. Place the cursor in the text where that format
appears. It is often best to not select any text for this procedure, as doing such will increase
ambiguity where multiple styles and attributes are employed within the selection.

Invoke Format» Formatting » New Preset From Selection. You will be presented with
a sheet that will let you name the new style, choose whether it will impact character
attributes, paragraph styles, or both, and optionally if font settings should be stored as
well. If you do not want the preset to change the underlying font family or size, then
make sure these checkboxes are disabled. Once a name has been added to the sheet, you
will be able to save the preset for future use. It will appear in the Format Bar menu, as
well as in the application menus.

Modifying a Preset

To modify an existing preset:
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1. Apply the preset to some sample text and then modify the styling of this text in the
editor using the standard formatting tools.

2. With the cursor still located within the sample text, use the For-
mat » Formatting » Redefine Preset from Selection» sub-menu to select the
preset you wish to modify.

You will be presented with the same sheet you used to create the preset, only the in-
formation you saved into it will be pre-populated into the sheet. In most cases you will
not need to change anything here, and can just submit the form to apply the formatting
changes you’ve made. If you do wish to change the parameters of how much the style
operates, you can make these changes to the sheet, or even change the name of it.

If you wish to create a derivative, instead of replacing an existing preset, use the pre-
set to style your text, modify it, and then use the Format » Formatting » New Preset From
Selection menu command to create the new version.

Deleting a Preset

Deleting a formatting preset can be done at any time by using the For-
mat» Formatting » Delete Preset»  sub-menu.  This command cannot be undone,
but if you do accidentally delete an important preset, you can re-create it by finding an
example in your text, and creating a new one from scratch.

15.4.4 Font Palette

The font palette is a standard tool provided by Apple, and can be toggled with For-
mat » Fonf» Show Fontfs and » Hide Fonfs. You can also use &-T to toggle this view at
any time. This palette provides full access to the font typesetting engine, including access
to many OpenType features and custom font effects. For basic font changes, the Format
Bar (subsection 15.4.2) will suffice.

The precise appearance of the palette will change depending how large you make it. As
the size of the palette increases, more options will be made available to you. Since this
palette is provided by Apple, please refer to the help files provided by TextEdit, for details
in using it.

To use the font palette to change the appearance of your text, you will need to first
select the text you wish to change, and then call up the palette. Any changes you make
will be immediately reflected in the editor.

15.4.5 Resetting Formatting
Oftentimes, after you've gathered material from the Web, or imported documents that
you’ve written in another word processor, the formatting of the imported material will
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not match the default font in Scrivener for new documents. While you can change this
default at any time with the Formatting preference tab (section C.8), this will not impact
documents you've already created or imported, as Scrivener has no way of knowing if that
is what you really want to do. Often it might be okay to leave the file as non-standard,
especially if it is research material that you never intend to include directly in the draft or
even edit.

If you do want to retrofit these documents to your current defaults, you can do so with
the Documents » Convert » Formatting to Default Text Style menu command. Since this
command works at the document level, you can select as many cards, outliner rows, or
binder sidebar items as you please and convert them all in one go.

After clicking the menu command, a window will pop up asking how much formatting
you wish to apply to the selected document(s). Most of these options work in a negative
fashion. By example: if you select “Preserve alignment” and the document is left-aligned,
even if your preferences are for full justification, it will not be applied because you have
elected to preserve the original alignment. The only exception is the “Convert font only”
option, which acts as a handy way of preserving all paragraph level formatting, without
individually checking off their options.

Once you’ve used this window to set up how deeply this command will impact a docu-
ment, you can waive it in the future by holding down the Option key when selecting the
menu item.

Please note that because this command impacts broad changes in potentially many
dozens or more of documents at once, there is no undo. The procedure only impacts
formatting, so it is safe to use, but if you are unsure of whether or not the result will
favourable, either Snapshot (section 15.6) the documents first, or perform the conversion
one-by-one and proof the results. Once you are confident you have the right settings
engaged, you can proceed at a more rapid pace.

Some simple tips for preserving common formatting based ranges:

¢ Preserving Block Quotes: Block quotes are usually indicated entirely by some
form of increased left, and sometimes right as well, indent. Preserving tabs and
indents will protect most block quotes from being reduced to normal text by this
tool.

¢ Preserving List Spacing: Some styles call for lists to be single-spaced even if the text
around them has a greater line-height or inter-paragraph spacing. Using “Preserve
line spacing” will protect these lists at the expensive of not applying your preferred
line spacing to standard paragraphs.
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@ Preserving Titles: If you've got a document with a lot of headers already formatted
into it, you could try preserving font size, style and line spacing, but this will in
many cases be the three things you want to apply. Titles are going to be harder to
manage automatically, and may require manual effort to keep their formatting as
intended. Another thing you can consider doing is switching to using Scrivener’s
philosophy of using the compile feature to generate titles from your binder names,
and leave worrying about special formatting for headers to the computer.

Ranges of text that have been blocked out with Preserve Formatting (subsection 15.4.6)
will never be altered by this tool, much in the same way that the compiler will leave them
alone by default.

One last tip is to use “pre-emptive” format conversion. If you know that you will wish
to discard the formatting of the text you are pasting, you can use the special Edit » Paste
and Match Style command to do so. This will treat the text as though it were plain-text,
and as such it will take on all of the characteristics of the text around the cursor position
where it is pasted. Since the text is treated as plain-text, this means you will lose any inline
formatting and function, such as hyperlinks and italics. If you intend to keep this level of
formatting, deferring the problem to later by using the document conversion feature will
be a better choice.

16.4.6 Preserve Formatting

If you are planning on letting Scrivener’s compiler do all or most of the final formatting
for you, it can often be useful to preserve ranges of text from the formatting engine. A
common example of this would be the use of block-quoting as a left indent. Technical
writers might find it useful to set apart blocks of text as “code”, using a special font and
layout. In the past, you had to break out these special sections into their own documents
and preserve the formatting of the entire document. Now you can define these ranges
right in their original context.

To specify a range of text for preservation, select the text in the editor, and then in-
voke the Format» Formatting » Preserve Formatting menu command. This will draw a
blue dashed box around the text, which can be worked around and within like any other
type of formatting range, such as italics. Also like other formatting tools, to toggle a
preserved range off, simply select the entire range and use this same menu command.

Preserved formatting will also protect your text when using the Docu-
ments » Convert » Formatting fo Default Text Style tool, which is useful for homogenising
the look of your document according to your preferences. Any text contained within
these blocks will retain their original formatting and not be touched by this tool.
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MultiMarkdown users can use preserved formatting ranges to define code blocks. Any
paragraphs located within a Preserve Formatting range will have a tab character added to

the front of each line within it, informing the MMD engine to treat the text like a code
block.

Authors working with HTML may use Preserve Formatting to preserve ranges of raw
HTML code. If you wish to type in some HTML code by hand and have it passed straight
through to the final result, you can use this tool in conjunction with the HTML Settings

compile pane (section 24.16) setting, “Treat ‘Preserve Formatting’ blocks as raw HTML”,
enabled.

15.5 Inline Images

While images themselves cannot be placed into the Draft as binder items, you can insert an
image into the text either by dragging an image file in from the Finder; dragging an image
document in from the Binder, Outliner or Corkboard; or by selecting Edit » Insert » Image
From File.... The image will be placed at the current cursor position. Images placed into
documents in this fashion will create a new copy of that image, even if it was dragged in
from the Binder. This becomes important when working with placeholder images. If
you intend to later edit your images or replace them with updated copies from a graphic
designer, you may wish to instead use Linked Inline Images (subsection 15.5.3).

To resize the inline image, double-click on it. This will bring up the image scaling
panel. Use the controls to shrink the image or increase its size, and then click on OK.
Unchecking “Lock aspect ratio” allows you to adjust the width and height independently
and therefore distort the image. Clicking Cancel restores the image to its former size and
returns you to the editor. Note that some images types (notably, vector PDF) cannot be
resized; double-clicking on such images will do nothing.

It is important to note that resizing images in the editor is an output, rather than an
aesthetic, decision. When an image is resized in the editor, it will be directed to use that
size in the final output as well. If you find the graphics you are using are too large, and are
getting in the way of writing, you may consider using placeholder thumbnails instead.
Using linked images is ideal for working this way, as you can swap out the full-size images
on the disk prior to compiling.

In the case of print-ready images, this often won’t be too much of a problem as the text
editor will display a rough approximation of the image’s final size, rather than its actual
pixel size, when the DPI and physical measurements are set to an appropriate value for
printing. For instance a 300 DPI image that is meant to be 2.5” wide on the printed page
will appear approximately 2.5” wide on your monitor, and so it will not dominate the
editor.
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For this reason, the primary unit of measurement used is points, rather than pixels,
though these will be displayed below for your reference, as well as the current DPI of
the image. Adjusting the scale of an image does not impact its literal pixels, but rather the
point value which will be used to determine how large it displays. When targetting digital
devices, 72 DPI is a good rule of thumb, though some experimentation may be required.

When using MultiMarkdown, inline images (and linked images for that matter) will be
converted to MMD syntax, and the images themselves will be gathered into the compile
folder for you.

Viewing inline images full-size: To view an image contained inside text on its own,
you can drag the image from the text into the header view of one of the editors. You
can then double-click on the image and zoom in or out on the image. Note that any
changes made here will not impact the embedded image in the text.

If an image is resized, or has alignment or line-spacing attributes applied to it, these
options will be used in the final compilation. This is true even if the compiler has been
set up to ascribe new formatting rules to your manuscript. In short, images come with a
sort of limited Preserve Formatting (subsection 15.4.6) block implicitly around them.

To save the image to the disk, right-click on the image and select Save as Picture....

15.5.1 Working with Print-Ready Images

If you’ve been provided full size, print-ready graphics for publication, it is often best to
not embed them directly into your document. Embedding images in the document is
good for small placeholders, but since the images are saved into the RTF file itself, adding
very large high resolution graphics to your files may slow down Scrivener’s ability to load
and save your file while you work on it. If you need to work with print-ready graphics,
read the following section on linking your images to the document, or alternatively
specifying them with tags, rather than embedding them directly.

Additionally, the text engine is optimised to display graphics at their relative dis-
play size rather than their literal pixel size. An image that is set to 300 DPI that is four
inches wide will display at a calculated size of 288 pixels, rather than the full 1,200 pixels,
in the editor. This can impact the display size of the graphics in the output formats as
well. Even though the graphics are not resampled, they will be displayed as they were in
the editor, which may mean they will be displayed out of size with the intended output.

16.6.2 Embedding Inline PDFs

It is possible to drag PDF files into your editor to embed them. This feature is meant to
allow the usage of graphics saved in the PDF format. It will not allow multi-page docu-
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ments to be inserted into the final manuscript, and if the original PDF is pre-formatted
for print, you will very likely need to crop the result down significantly so that it can fit
within the page margins, using a PDF editor such as Preview, or Acrobat Pro.

When compiling to formats that do not support embedded PDFs (which is pretty much
all of them), a raster graphic will be automatically generated for you and embedded as a
PNG file, if the compile format allows embedded graphics. If it does not, such as with
plain-text files, then as with standard graphic files, they will be omitted as per usual. When
use File » Export » Files... and selecting RTF, this conversion will also take place. This will
cause a loss of vector data, and so the processes uses a large PNG that is then shrunk down
to scale to maximise quality. You can adjust the DPI use for this in the Import & Export
preference tab (section C.10).

16.6.3 Linked Inline Images

Linked images are useful when the actual graphics in your project text are incomplete
or placeholders for larger, production-ready graphics. If you are familiar with desktop
publishing tools like Adobe InDesign, then the manner in which linked images work will
be familiar to you. For those not aware, linked images are the placement of graphics
in your text in such a way that the representation of the image in your editor is being
generated by files outside of the document, as opposed to be saved as a part of the document.

To create a linked image, use the Edit » Inserf » Image Linked to File... menu command.
Linked images will look and act like embedded images in every way. You can by and large
ignore the difference between them while working.

When compiling with linked images, the current version of those images on disk will
be used to create the embedded copies used in the compiled version. Since nearly all of the
compilation formats do not support active image linking, Scrivener must take the current
version and embed it in the final copy. So if you are in a workflow that involves external
help from designers, be sure to get your external images up to date before producing final
compiled copies.

For increased performance, Scrivener uses a cached version of your image when you
create alink to it while the project is open. Whenever you re-open the project, this thumb-
nail will be updated with the current image on the disk.

A Note on Links and Multiple Computers: Those familiar with the use of linked
resources will already know that using links means that the position of those external
resources must remain stable, in order for the host program (Scrivener in this case) to
maintain a connection with them. If the files are moved or renamed, the link breaks
and you will need to manually update them. This means that in most cases, links will

only work on one machine, since the full path name of a file tends to vary, given that it
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includes the name of the computer’s hard drive. It is possible to carefully work around
that, particularly with the use of external hard drives that are all mapped to the same
drive assignment on the computer, or keeping all satellite computers identical in regards
to user names and hard drive names.

This problem becomes impossible to work around when working cross-platform, as
the path addressing scheme used to name a file differs between Mac and Windows com-
puters. This does not mean that using linked images prohibits cross-platform usage
(or vice versa), but what it does mean is that only one machine can be your “home”
computer in terms of final document assembly. A project can lose track of the linked
images while you are working on other machines, but since these links are stored as
text paths to the files, when you return to the home computer, they will all link up

again.

156.5.4 Image Placeholder Tags

It can at times be desirable to not include the graphic in the source text at all, but rather
to specify its name or file path, using text, similar to how one would link to an image
in a web page or forum post. Textual links images afford you additional powers over
typical images displayed in the editor. Since they are text based, they can be hinged upon
compile settings, and thus you could images into one document format but not another if
you pleased. You can also specify the dimensions of an image precisely, using text, which
is important for getting them right the first time, if you do not intend to polish off the
compiled document after compiling. Finally, image tags mean you can bring images to
areas of the document that otherwise wouldn’t support them—on account of their being
defined by plain-text fields—such as custom separators, title prefix and suffix fields.

The basic syntax for the image tag is:

<$img: IMAGE_IDENTIFICATION;w=WIDTH;h=HEIGHT>

Everything after the image identification is optional.

Image Identification

The image must be specified either by its imported name, as displayed in the binder, or
by a valid UNIX style path to the image’s location on your computer. Path names can
be relative to the location of the Scrivener project, so if the graphics and the project are
stored in the same folder, you would only need to declare the path as ‘image name.png’
for it to work. You can also use the UNIX shortcut for your home folder, the tilde. Full
absolute paths are acceptable as well. Here are some examples

<$img:~/Dropbox/MyBookFolder/scene_break.png>
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You might wish to use something like that, if you want to put a graphical break in
between scenes, as a custom separator (subsection C.2.4). This also demonstrates a safe
way to link to an image that will work from multiple computers all using this Dropbox
account. They will also see a valid image at this path since the details of the user folder
name are obscured by the tilde.

This references a graphic that has been stored in a sub-folder called Resources, which is
a folder alongside the Scrivener project:

<$img:Resources/python_chart. jpg>

Here 1s an absolute link to an external hard drive called “Research”, where a PDF in
the sub-folder “MyThesis” in included. As with all embedded PDFs, you should ensure
it is only one page in length and smaller than the text print block (sans margins):

<$img: /Volumes/Research/MyThesis/some_data.pdf>

When using graphics that you have imported into the project binder, you can refer to
them by their binder title (you needn’t know the extension or type of graphic it is). This
will be used in precedence over any path names, and the first matching title name (count-
ing from the top of the project) will be preferred over any other images likewise named in
the project. A simple example, specifying an image that is called “Python Growth Rates
in Everglades™:

<$img:Python Growth Rates in Everglades>

If for some reason you have two graphics named “Python Growth Rates in Everglades”,
the image that is “highest” on the binder list will be selected. It starts at the top of the
binder and works down until it finds a match. Likewise, if it finds any match at all it will
use it, instead of looking outside of the Scrivener project for a graphic. So if the binder
name included the file extension, it would still use the imported version instead of a copy
with an identical name located in the Scrivener project’s location (making it a relative

link).

Specifying Image Width and Height

The width and height of the image is an optional value, declared in pixels. If you have
already sized the graphics correctly in accordance with your printer’s specifications and
output quality, then you will not need (or indeed want) to change the image size using
Scrivener. However if you are not concerned with pre-sizing the images and just want to
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let Scrivener handle them for you, you can specify the width and height of the image in
the placeholder tag, to instruct the compiler to resize it as necessary. It is valid to specify
only the height or the width alone. This will cause the compiler to shrink or expand the
image to match the specification you’ve provided, automatically resizing the opposing
measurement, keeping the image’s original shape, or aspect ratio, intact. If you declare
both the width and height yourself, it is possible to squish or squash the image however
you please.

<$img:Portrait of Dickens.jpg;w=650>

This will resize the portrait so that it is 650 pixels wide, and it will adjust the height
of the image so that it remains proportional with the original in terms of aspect ratio; no
squished faces here!

Tips for Usage

Here are some ideas for how this feature can be used, as well as some handy tips for com-
mon uses.

. Common Width and Height: you will need to know how many dots per inch your
printer works with. It is not possible to know how many pixels you should use to
make a picture full page height or width, until you know how many pixels it will
be using to render an inch of image. You may need to contact your publisher to
determine what the print resolution for the graphic plates will be. Once you know
this number, you can multiply it by the width or height of the “text block”, that
being the area within the margins.

A simple example would be US Letter with 1” margins, printed at 300 DPI. The
width of the page is 8.5”, subtracting two inches for the margins on each side, mak-
ing the text block 6.5”. That means 300- 6.5 = 1950: 1,950 pixels wide.

. Using Replacements to Change Images: Replacements (section 24.18) in the compiler
will be evaluated prior to any images being included. That means you could use the
feature to scan for the placeholder tag and remove it from the document, or perhaps
change the path of the image to something else, which could be useful if you have
two different groups of images, one optimised for black & white printing, and the
other for an online full colour PDF or lower resolution e-book.

@ Searching for images: since the image is defined as text, that means you can search for
it by name, or even search for all “<$img...” tags in the draft to get a list of documents
with figures, which could be saved as a dynamic collection (subsection 7.4.4).
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- Using images in the title prefix or suffix: when compiling, it is possible to use an
image in the prefix or suffix title area of the Formatting compile option pane (sec-
tion 24.11.2), which means you can now do such things as adorn chapter titles with
lines or other symbols.

- Using images for section separators: in a similar vein, you might wish to use a graphic
to separate individual sections, rather than a string of text or blank space. It is pos-
sible to use image placeholders in the Separators compile option pane (section 24.9)

- Specifying an image when two or more share the same name: in cases where you have
multiple images with the same name in the Binder, if you need to ensure that a
certain one of these (rather than the first one in the list from top-down) is used,
select the image placeholder and create a Scrivener Link (section 8.5) pointing to
that image.

15.6 Using Snapshots

In essence, the theory behind a Snapshot is very simple. You can think of it as a way of
manually saving your file for future reference. In a program like Scrivener which auto-
matically saves your work as you work, you lose the benefit of being able to work “off
the disk” for a while, and choosing at defined moments in time to either save what you’ve
done, or discard it and return to what you have on the disk at the last save point. Of
course, on the other hand, if your computer crashes (and as much as we try to avoid it,
sometimes Scrivener crashes too) with an auto-saving program, you might only lose a few
minutes of work, or even nothing at all, rather than everything you’ve done since the last
save.

Snapshots help you bridge the gap between these two ways of working. It is like saving
your document as you go, the only difference is, you get a record of each save point.
That means you can go back and examine the evolution of the file and pick out just the
right spot to restore from. In the course of editing, you might change your mind about
something you deleted more than one save iteration ago. With a traditional save as you go
model, you’d be out of luck. With Scrivener, you can just go back through your Snapshot
history, find the point in time where the deleted passage still existed, and copy and paste
it back to the present—or even just roll back the whole document to that spot.

What About Milestones: In addition to this usage, some people like to use Snapshots
to set “milestones” as well as just capture periodic changes. Scrivener accommodates
both styles of working, as you can take “Untitled” Snapshots with a single keystroke.
You can also name your snapshots either when you take them, or later on. Named
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snapshots are easy to pick out of the crowd of Untitled ones, and it also makes it easier
to clean up old routine Untitled ones once they’ve outlived their usefulness.

Theory aside, snapshots provide a way of backing up and saving different versions of
individual documents. Taking a “snapshot” of a document takes a copy of the text of that
document as it exists at that exact moment in time and stores it so that you can return to it,
or restore it, at a later date. With routine usage, you need never need worry about making
major edits to a document, because you can take a snapshot of it before you begin editing
and then restore the older version later if you change your mind about the edits you have
made. Snapshots only affect the text of documents (not notes, synopses or meta-data),
and are therefore only available for documents that contain text (files and folders).

You can tell if a text document has any associated snapshots by its icon. Documents
that have had snapshots taken of them have the top-right of the paper icon folded down
in a “dog-ear”. You can also tell by looking at the top of the Inspector pane if it is open.
When there is an asterisk in the corner of the Snapshot button then it has Snapshots.

There are two primary ways to manage Snapshots: using the Documents » Snapshots »
sub-menu, and the Inspector pane (section 19.8), the latter of which will be covered com-
pletely in the referenced section. You can also conveniently use the -5 keyboard short-
cut while editing a document to take a quick snapshot in the background.

156.6.1 Creating Snapshots
While working on a document, there are three easy ways to snapshot it for future refer-
ence.

The key thing to understand about Snapshots is that they provide a way to set save
points for individual items in the binder. They are not a tool for providing an overall
snapshot of the entire project, structurally speaking, and are probably not the best tool
for taking a quick snapshot of your entire draft. In most cases, large scale backups like this
would be best created using the File » Back Up » Back Up To... menu item, or by duplicating
large portions of the Binder and stashing them elsewhere for future reference.

That aside, it is simple to quickly snapshot multiple documents.

1. Select the documents you wish to snapshot in the binder sidebar, corkboard, or
outliner

2. Press -5, or Documents » Snapshots » Take Snapshots of Selected Documents to
create a snapshot into each item’s individual snapshot list.

Snapshots can later be accessed in the Inspector pane. You can jump straight to
them with ~X$-M, or Documents » Snapshots » Show Snapshots.
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3. The alternate way of taking a snapshot is to supply them with a title as they are
created, use Documents » Snapshots » Take Snapshot with Title, or > $8-5.

This can be done for single or multiple selections as well. In the latter case, the title
will be added to each document in the selection. Snapshots can also be titled at a
later time using the Inspector.

Extensive Annotation: A trick for more thoroughly commenting on the purpose or
state of a Snapshot can be to combine it with the use of inline annotations. Consider
writing a short synopsis of what the snapshot was taken for at the top of the document
before snapshotting, and then removing it afterward. Now that statement will always
be clearly presented to you at the top of the Snapshot text preview.

The third method for creating snapshots is from the Snapshot pane itself in the Inspec-
tor. Click the + button in the header area of this pane to create a new snapshot.

156.6.2 Managing and Comparing Snapshots

Existing snapshots are all managed in the inspector pane. To jump to snapshots,
click the button with the camera in the Inspector footer bar or use the Docu-
ments » Snapshots » Show Snapshots menu item (~\C8-M). In the snapshots pane, you
can create new snapshots from the current text with the + button, remove old snapshots
by selecting them in the snapshot list and clicking the - button, or roll back to a prior
version of your text using the Roll Back button.

More details on the functions available in the inspector can be found in Snapshots Pane
(section 19.8).

16.6.3 Comparing Changes

The comparison feature lets you analyse the differences between versions of your text.
There are two ways of using this:

1. Compare with current: select the snapshot you wish to compare against the current
text, and then click the Compare button. The changes will be highlighted in the
text preview area.

2. Compare two snapshots: select two snapshots in the table and then click the Com-
pare button. The differences between those two versions will be highlighted.

While in comparison mode, the text preview area will switch to plain-text so that only
actual changes to the content can be analysed. To return to standard viewing mode, click
the Original button.
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Comparisons can be reviewed in the standard editor, and are thus useful in conjunc-
tion with a split view, as you can review the edits alongside the current version of the
document. To view a snapshot in an editor split, drag the snapshot from the table in
the Inspector to the header bar of the split you wish to load it in. If you hold down the
Option key while doing this, comparison mode will be engaged for the split.

16.6.4 Viewing Snapshots in the Editor

It is possible to load snapshots as read-only text into the main editor splits. To do this,
simply drag the snapshot you wish to view into the header bar for the editor split you
wish to load it in. You can also load the snapshot in comparison mode by holding down
the Option key as you drag the snapshot into the header bar.

15.6.5 Automatically Created Snapshots

There are two ways in which snapshots will be optionally created for you:

- Synchronisation: the various tools for synchronisation in the File » Sync » sub-menu
are set by default to take snapshots of any documents that are changed (either on
the server or in Scrivener). When this sort of action is taken, the snapshot will
be titled appropriately with a descriptive parenthetical regarding why the snapshot
was taken.

- Automatic Snapshots on Manual Save: not enabled by default, this “Take snapshot of
changed text documents on manual save” option, in the General preference tab (sub-
section C.2.2) will create a snapshot of each binder item with text content that has
been altered during the current session. This is only considered for changes made to
the text content itself. Since snapshots do not save meta-data such as the synopsis or
notes, changes made only to these text fields will not trigger an automatic snapshot.
Snapshots taken for this reason will be marked as “Untitled (Save)”.

15.7 Auto-Completion

There are three forms of auto-completion in Scrivener:

Character substitution Adjustments made to the characters as you type them in, such as
setting quotes to typographer’s “curly” or “smart” quotes, as they are alternatively
called; or adjusting stand-alone 1’s at the start of a sentence to capital form.

Word and phrase completion As you type, you can have Scrivener suggest words for
you either automatically, or with a shortcut (the default); custom phrases can be
added to each project, such as proper nouns or frequently used scientific terms.
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Separate from the project phrase list, you can also auto-complete based on existing
title names from the binder.

Scriptwriting abbreviations Common scriptwriting abbreviations such as “O.C.”,
“Ext.” and so on, can be suggested as you type. These are generally defined in
the script formatting definition (Format s Scriptwriting » Script Settings).

15.7.1 Character Substitutions

With character substitutions, you can set which characters will be replaced as you type.
Scrivener uses a combination of built-in enhancements, plus macOS’ (Snow Leopard and
greater) built-in substitution engine. These can all be set in the Corrections preferences
tab (section C.9). Each option is documented more fully, there.

These adjustments always happen automatically as you type, but some require you to
terminate the word you are typing in, before they will take action.

156.7.2 Custom Auto-completion

Word and phrase completion can be used to suggest completions as you type, but more
commonly you will use a keyboard shortcut to trigger the completion menu. 8-, XEsc,
and Esc (all by itself) work on most systems, but on some only one will work. In partic-
ular, \CEsc is frequently set to open Front Row on most Mac laptops.

Each project has its own custom auto-completion list, which adds words and phrases
to the stock dictionary that is provided. There are two ways to add items to this list:

1. The menu item, Project» Auto-Complete List... and use the + button to add new
lines to this table.

2. Select the text word or phrase you want to add, in the editor, then right-click on it
and select Add Selection to Auto-Complete List.

If you would like for Scrivener to suggest custom phrases to you as you type, set “Sug-
gest completions as you type” in the Auto-Complete preference tab, and then disable “In
script mode only”; making sure the third option is enabled, otherwise the entire language
dictionary will be unlocked and most will find this to be too intrusive.

Copying completions between projects: If you wish to transfer custom completions
from one project to another, you can simply open both projects simultaneously, access
their respective Auto-Complete lists, and drag and drop the terms from one panel to
another.
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16.7.3 Auto-Completion Scope

When using the scriptwriting feature of Scrivener, key words and phrases can be auto-
matically added to the auto-complete list where appropriate. For example, if you type in
the name of a character in the Character element, it will automatically be added to your
project’s auto-complete list.

By default, these special automatic entries will only be made in reference to the element
they came from. A character name, to continue that example, would be defined in the
auto-complete list as being applicable only to the Character element type. It will not
appear as a suggestion when you are typing in the Scene Heading element. So by and
large you will never have to bother with setting anything up here. As you write, Scrivener
learns about your script and becomes better at making suggestions to you depending on
where you are and what you are typing.

If you want to make changes to the scope of a completion, so that it is present in dif-
ferent or even all element types, this is possible in the Project » Auto-Complete List... win-
dow. In the Scope column, you can change the element type or assign it to. There are
two special settings available:

¢ General: The default when adding your own to the list by hand. Documents set to

use scriptwriting will ignore entries of this scope (excepting text set to “General”
or “General (Centered)”).

- All (Text & Scripts): Similar to General, only these entries will absolutely be available
everywhere, even in scripting elements that maintain their own lists.

If a script element has been set to not use the project auto-complete list in its script
settings, then it will ignore the entry, no matter what scope settings you use.

15.7.4 Binder Title Completion

If you have started typing in the name of a title that is found in your binder, you can
request a list of completions from Scrivener by pressing a different shortcut, ~Esc. A list
of all the titles that are still candidates for a match will be presented. As with the above,
you can use the arrow keys to select and item and hit return to insert the full title.

This feature is particularly useful in conjunction with the “wiki style” Scrivener link
option. Simply type in (( start typing in the title name, hit ~Esc, select a title, and then
close with)). A Scrivener link will be automatically created for you.

16.7.5 Scriptwriting Auto-Completion
Scriptwriting mode, by default, engages a more aggressive auto-completion method,
which scans as you type and looks for completions, matching the behaviour of most
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scriptwriting programs on the market. Most of the script formats that are shipped with
Scrivener come stocked with many common phrases and abbreviations, which will be
contextually tied to the element you are currently working in. For example, “MO-
MENTS LATER” will appear whilst typing in a Scene Heading element, but will not
appear in a Dialogue element.

Most script formatting settings will also automatically add anything typed into cer-
tain key areas of some elements into the project’s master auto-completion list. Character
names, locations, and so on will be checked for and added, making rote data entry more
efficient as you write.

Since auto-completion cannot reliably determine appropriate letter case, sometimes it
may produce results that are undesirable, such as a mixed case location name in a slug-
line. To remedy this, when selecting the auto-completion you wish to use, hold down the
Shift key. Any word or phrase selected with the Shift key held down will complete using
uppercase letters.

15.8 Text Bookmarks

Text bookmarks are useful when you wish to quickly mark a spot in your text in a way
that can be easily recalled later on, or for marking out sections of text in longer documents.
There are two types of bookmarks:

1. Bookmark Annotation: This is your standard bookmark. Great for quickly marking
a spot for later editing, quick navigation, or whatever you require.

2. Bookmark Header Annotation: Will create an offset label in the bookmark navi-
gation menu, indenting regular bookmarks beneath it until another header style
bookmark is encountered. Useful for documents with many bookmarks.

Bookmarks work by placing a special marking at the beginning of a paragraph or line,
and there are two tools for doing this without disrupting the writing process. Use the
Ediit » Insert » Bookmark Annotation menu command, or {18 -B to place the marker at the
front of the current paragraph without moving your cursor.

Use Edit » Insert » Bookmark Header Annotation to insert a header style annotation in a
similar fashion as a standard annotation.

Custom bookmark labels: Bookmarks are simply an inline annotation starting with
an asterisk and a space. The first few words of the line following will be used to label
the bookmark in the navigation menu. If you wish to provide a custom label, add it to
the annotation after the asterisk and the rest of the line will be ignored.
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The same holds true for header style bookmarks. These use two asterisks and then a
space, so to give them a custom label, enter the label into the annotation after these
asterisks.

In addition to formal bookmarks, any inline annotations that appear on a line by them-
selves will be added to this menu as well, regardless of whether or not they have an asterisk
in front.

16.8.1 Navigating to Bookmarks

Once bookmarks have been created, they can be viewed in the header bar icon menu,
under Bookmarks, or View » Text Bookmarks menu. To navigate to a particular bookmark,
select it from this menu.

When viewing several documents in a Scrivenings session, all of the bookmarks found
within the individual documents will be used to populate this menu.

To remove a bookmark, simply delete the inline annotation on the respective line.

156.9 Editing Multiple Documents

The “Scrivenings” view mode (View » Scrivenings) allows you to edit multiple text docu-
ments as though they were one long document. This way, you can write in small chunks
and then combine them in any way you like to see how they work together. For instance,
you might write lots of small scenes for a chapter, and then edit them all together in an
Scrivenings session to see how the chapter works as a whole.

Scrivenings mode is only available when the entire selection (or contents of the selected
container) are text or folders.

16.9.1 Viewing Multiple Texts as One Document

Scrivenings mode is, like corkboard and outliner view modes, another way to view multi-
ple selections of documents. How you view more than one document changes, depending
on your approach. Viewing more than one document can be as simple as clicking on a
folder. By default, this will view the items within that container as index cards on a cork-
board. However using the Group Mode segmented control, you can easily switch your
view over to Scrivenings, the left-most icon showing a stack of papers. Another way of
switching is to use the View » Scrivenings menu command, or pressing &~ 1 on your key-
board. As with corkboard or outliner, you can also form scrivenings sessions by selecting
multiple items in the binder, or clicking on the header bar of a collection or search result.
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Unlike corkboard and outliner, scrivenings can be taken into composition mode. Sim-
ply press the Compose button in the toolbar after setting up the session. Read more about
composition mode (chapter 17) for general information on this feature.

You can tell when you are in Scrivenings mode by the horizontal divider lines that
will be drawn between each section represented in the session. Meanwhile, the header
bar will state the name of the currently viewed container followed by “Composite” in
parenthesis—or “Multiple Selection” followed by the title of the document you are cur-
rently editing within the session. Asyou switch from document to document, the inspec-
tor will follow along so you can see which document you are in by glancing at the index
card in the inspector.

Scrivenings sessions are one of the few areas in Scrivener that consider your text from a
“flat” perspective. There is no indication of depth while editing documents. A prologue
at the very top will be printed right along with items which are buried in sub-folders. This
is intentional, so you can concentrate solely on the same flow of text that your readers
will use.

The footer bar will switch to an alternate mode which disables the per-document goal
meter (subsection 14.2.3) as it no longer has any meaning in a multiple document setting.
Additionally, the word and character counter in the footer will count the entire session,
making Scrivenings a great way to quickly view the word count of a particular section of
the Binder.

If you would like for titles to be displayed more prominently, you can enable them
by switching them on in Format » Options » Show Titles in Scrivenings. The appearance
of these titles will be dictated in Formatting preferences tab (section C.8). These titles
can be edited in the same fashion as editing any other piece of text in the editor (though
formatting will not be allowed).

In that same section you can opt to use a slimmer divider which uses no vertical space
to draw itself. This will be of most use to those who must work with accurate page counts
in Page View, or simply as an aesthetic preference.

16.9.2 Editing with Scrivenings

For the most part, editing in Scrivenings mode is just like editing single documents one
at a time, thus most of the tools that you have learned so far will be available to you. You
can select all of the text and format it, copy and paste it to another application, create
snapshots of individual portions of the session, and so on.

Due to the manner in which multiple real files are being combined as though they were
one “file”, it is not possible to select across a file boundary with the keyboard, or to delete
text from across multiple files at once.
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These limitations are unavoidable. If you were to delete a range of text that spanned two
or more documents, Scrivener would have to guess where one document now ended and
the other now began—and if the whole of the text of one document had been deleted in
the process, Scrivener would have to decide whether to delete that document, too. These
are all decisions that are better left to you.

Since Scrivenings is a full view mode, it affords a great degree of latitude in how inte-
grated it is with the outlining process, especially with a locked editor (\x-L).

¢ While editing, new documents can be created with &-N, inserting them below the
current document that is being edited; likewise with splitting documents.

& With titles turned on, it is possible to create new items without ever switching back
to the Binder, making this combination of actions one of the most seamless ways
to flesh out your outline while you write.

@ Moving documents around in the Binder will automatically update the order in
which they appear in the Scrivenings session.

8 Deleted documents will be removed from the session.

& Merging documents from the Binder will make this change in the session

15.9.3 Useful Tips

Navigating with the sidebar navigation buttons If you click one of the navigation
buttons (subsection 14.1.4) in the header bar, and that navigation action will re-
sult in movement within the boundaries of the active session, you will be navigated
from section to section without disturbing the session. If you leave the boundaries
of the session, or if the original selection was the result of a non-linear multiple
selection, it will be dismissed.

Using the Go To menu to navigate While the active split is in Scrivenings mode, the
header bar’s item icon menu will display only the contents of the current Scriven-
ings session. Selecting items from that list will jump you straight to that document
like a small table of contents.

Selecting only the document you are editing Use \C8-A to select the entire text area
for only the document you are actively editing within the session. Standard $-A
will always select the text of the entire session. Selecting by section is also a useful
way to get a quick word count of the active document in the footer bar.
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Jumping to the end or beginning of a section In conjunction with the above tip, a
neat trick for jumping to the very beginning or end of the current section is to
select the section with 8- A, and then use the LeftArrow to jump to the begin-
ning, or the RightArrow to jump to the end, as this is standard behaviour for any
selection.

Isolating the current document If; in the course of editing a scrivenings session, you
find you wish to isolate the current document so you can focus on it exclusively,
you can simply tap -4, or use View » Go To » Editor Selection. To return, you can
use View » Go To » Enclosing Group, or use N3 —R.

Lock in Place navigation If you are in an Edit Scrivenings session and lock the ed-
itor containing the Scrivenings view in place (using “Lock in Place” from the
View » Edifor » Lock In Place or header view icon menu), clicking on documents in
the sidebar that are in the Scrivenings session will move the insertion point to the
beginning of that document in the editor (just like Go To).

Meta-data grouping Some forms of meta-data will group themselves when using
scrivenings. footnotes and comments (section 18.2) will be displayed all together
in the inspector in a single large stack, allowing you to quickly see if any of the con-
stituent articles within the session have notes. Text Bookmarks (section 15.8) will
also be grouped together in their access menu.

Vertically accurate scrivenings divider If for reasons of taste, or formatting necessity,
you require a zero-height scrivenings divider, you can toggle on a slim mode in the
Formatting preference tab (subsection C.8.3). This mode will draw small “crop
marks” in the margins instead of using a divider across the middle. If vertical ac-
curacy is a necessity, you will also want to avoid usage of titles in the scrivenings
session. When in slim mode, the height of the page should be preserved for pur-
poses of rough preview with the Page View editing mode.

Viewing only items which can be compiled By filtering items in views (section 8.9),
you can create a Scrivenings session that includes only items which can be compiled
with a single click. This can be exceptionally useful if you tend to write notes into
your drafting area, and set those notes to not be included in the compile. To use this
feature, Option-click on the container (including a Collection or Hoist header bar)
you wish to filter, or with a selection of items, use the Documents » Open » with
Compilable Subdocuments menu command.
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Page View

By selecting View » Page View » Show Page View while editing a text document, you can
transform the visual presentation of the editor to using a virtual page, which can option-
ally show two opposing pages at once, with View » Page View » Two Pages Across. Since
Scrivener does not keep track of actual post-print layout pages, this should not be relied
upon as a full-spread layout preview, as the even/odd arrangement you see in the editor
might very well end up being swapped in the final product.

In fact, for most uses, Page View is for simulating the look and feel of writing on real
pages, and is thus an aesthetic preference, not a print preview tool. In some cases, espe-
cially where the compiled product will look identical to the formatting you see in the
editor, it can be used as a fairly accurate gauge of writing progress in terms of literal pages.
Read on for tips on the best ways to set up this feature for this style of working.

Editing in Page View is otherwise identical to use the standard drafting style editor in
all ways, and will work with Scrivenings mode, too. The two optional editor features,
Typewriter Scrolling (subsection 15.3.4) and line numbering, will be unavailable while
using this editor mode.

16.1 Page View Dimensions

Page View will place your text in a to-scale representation of your project’s print and
margin settings, found in the File » Page Setup... dialogue. These settings will be used
regardless of your compile settings, giving your the option to use a different paper shape
for the screen than you would use for print.

16.2 Tips for Accuracy

When used in conjunction with export fonts, formatting and accurate page dimensions,
the resulting page estimate (which will be calculated in the footer bar statistics area) can be
quite close to the actual end product, and thus will be of considerable use to anyone who
requires pages as a metric, such as scriptwriters. Do note however that page numbering
will always be relative to the section of text you are viewing. It is not intended to be a
method of finding “page 83” from a stack of printed out papers by your desk. It would
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be computationally prohibitive to provide this information in real-time, based on the fact
that Scrivener is fundamentally not a “What You See 1s What You Get” editor, like a word
processor.

To increase page count accuracy in a scrivenings session, you should use the “Separate
with single line breaks” option in the Formatting preferences tab (subsection C.8.3). This
alternate method for showing the boundaries of documents in scrivenings mode uses no
height, and so will not vertically distort the size of the session. The use of the titling
feature in scrivenings should also be avoided as they will add extra height that likely will
not be in the final composite. This method cannot be used with any content that requires
a lot of post-compile layout, such as footnotes, as footnotes will be added to the total
height of the page and change the flow from what you see in the editor.

Finally, you should ensure that your File » Page Setup... settings match your compile
settings, so that what you see in the editor matches the shape of the document that will
eventually be compiled.
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Composition Mode

Composition mode allows you to edit your text in a distraction-free environment. Made
popular by a plethora of “zen-ware” applications which promise a stripped down and of-
ten plain-text writing view, Scrivener’s approach is decidedly more expressive—though
you can keep things dirt simple if that is what you are looking for. You can view any
text document (or Scrivenings session) in Composition mode, with a virtual page treat-
ment on a background (by default, black). Meanwhile you will have full access to your
document’s meta-data in a floating low-impact Inspector panel, as well as the ability to
view QuickReference panels for purposes or research availability and other referencing.
Ultimately, you can compose and refer to your notes without the noise of the rest of
your desktop or even Scrivener itself. Consequently, you’ll find that Scrivener “disables
itself” to a degree, while in Composition mode. Menu commands that would otherwise
be available are turned off—in most cases because these are commands which would have
no meaning at all, such as commands for merging two selected items in the binder, or
enabling corkboard view.

To determine what will be loaded into Composition, Scrivener uses the active selection.
This selection can be made either in the sidebar, or in an outliner or corkboard view. This
works by implication as well: when no cards are selected in a corkboard, technically the
container is selected, as can be witnessed in the inspector, and so it is the container’s text
itself that will be loaded in Composition, which might often be blank.

There are two exceptions to this rule:

1. View as Scrivenings: If you are viewing a group of documents in Scrivenings mode,
then Composition mode will use that same mode. This is the easiest way to load an
entire container’s text into Composition mode, as it requires no further selection.

2. Pre-load documents into history: If multiple items are selected and Scrivenings mode
is not enabled, then each item will be loaded into the Composition mode’s history
queue. Working in this fashion, you can use 8- (and $-) to flip between the docu-
ments without returning to the main project window.

236
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Launch Composition mode either by hitting 8 -F, or select View » Enfer Composition
Mode.

When you first enter Composition mode, you will see your document in the middle
of the screen set to a warm-grey paper colour, and masking the rest of the screen, a black
background. Nearly every aspect of this experience can be changed, some right within
Composition mode. You will also briefly see the Control Strip (detailed below). To
retrieve it after it has disappeared, slide the mouse pointer down to the bottom of the
screen and let it sit for a moment. So long as the mouse remains within the control strip,
it will stay visible. Once moved back up, the control strip will disappear out of view.

The menu bar can be accessed by similarly sliding the mouse pointer to the top of the
screen. After a momentary pause, the menu will appear. This is a useful way to access
advanced formatting tools, and even navigate around in your project using the View » Go
To» sub-menu without leaving composition mode.

17.1 Using Background Image and Textures

You can replace the default solid background colour with an image of your choosing, by
using the View » Composition Backdrop » sub-menu. The image will be scaled to fit your
screen using the maximum height or width, whichever is better. This can mean that if
the image does not match your screen’s aspect ratio, the background colour may still be
visible along the sides or top and bottom.

Textures can be assigned to the background area on either side of the “paper” or the
paper itself behind the text. Textures are graphic files you select which will be tiled to
fill the entire visible area. Textures can be configured in the Appearance preference tab
(section C.3), as an additional option in the customisable colours section.

17.2 The Control Strip

The Composition control strip contains various controls for manipulating the interface
elements available to Composition mode. All of these settings operate on a project-by-
project basis, as opposed to the global scope of the application preferences.

It is possible to leave the control strip open perpetually, by leaving the mouse at the
bottom of the screen. If you wish to keep track of your word count, or are working in
script mode, this can be a handy way to keep tabs on your status. If you do so, you may
wish to set the paper height (detailed below), so that the bottom of the page does not fall
below the controls.

In order from left to right:
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Text scale This operates in an identical fashion to the text scale zoom in the standard
editor. The only difference is that Composition mode stores its own scale setting,
independent of the editor splits.

Paper Position Select where the “paper” (the column of text) should be anchored on the
screen: on the left, in the centre or on the right. You may want it in a non-central
position, for instance, if you have a lot of notes to which to refer and you want the
inspector open (and wide) next to the text.

Paper Width Use this slider to change the width of the text. You can set it so that the
text takes up the whole width of the screen or appears as a column.

Paper Height To access this slider, hold down the Option key. It will replace the Paper
Width slider, from above. This sets how tall the paper column should be, giving
you a “letterbox presentation” at its more extreme settings.

Keywords Brings up the standard Project Keywords (section 9.3) which you can use in
conjunction with the inspector (below) to assign keywords to the current docu-
ment.

Inspector Brings up the floating Inspector panel (see below).

Go To Operates as a handy navigation tool, and functions identically to the main
View » Go To» menu. Using this, you can switch between documents without re-
turning to the main project window. You may also use the history shortcut keys,
- (and %) to navigate to and front documents you’ve visited while in composi-
tion mode. Composition history is separate from the main editor history—it will
not add to it and when you first start composition mode, history will be empty.

Dynamic Controls & Statistics The middle portion of the control strip changes de-
pending upon your editing mode. In standard editing mode, this will display the
word and character count for the document. As with the standard editor, this will
also display the counts for any selected text, using a blue label.

In scripting mode, this portion of the strip will display element hints as well as the
element selection menu (which you can always call up with 8-V, even if the strip
is not visible).

Background Fade Fades the background (everything outside of the text paper column)
in and out. Useful if you want to refer to material in other applications (or the main
project window) in the background whilst remaining in composition mode.
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Paper Fade When a backdrop image is in use, the “Background Fade” slider will be re-
placed with this one, which operates in an identical fashion, only it lets you blend
the paper colour with the backdrop, or reduce its visibility entirely.

When both a background texture or backdrop and a paper texture are in use, this
slider will be entirely disabled.

Exit Composition Mode The button at the far right will exit Composition mode. You
may also press the Esc key, or X8 -F to return to the main project window.

17.3 Floating Inspector HUD

The composition mode version of the inspector gives you near full access to the inspector
data which will float over the editor so it doesn’t get hidden behind the background. Use
the top-drop down menu to access the different data panes. Label and Status will always
be visible at the bottom of this window. For a full discussion on these views and what
they represent, read Meta-Data Types (section 9.1), and Inspector (chapter 19).

The top selection drop-down will provide you with the following options:
@ Synopsis

a Picture: If a photograph has been attached to the index card, you can view it with
this option.

& Document Notes

@ Project Notes: If you have created additional document notepads, they will all be
listed here.

- Keywords
8 References
‘¢ Custom Meta-Data

& Comments & Footnotes

Each of the individual panes will be provided with a full complement of editing con-
trols, so you can add and remove items from these lists, just as you would with the standard
inspector.
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17.4 Customising Appearance

Appearance settings can be set in the Compose preference tab (section C.5). Refer to the
documentation provided for this pane for greater detail on available options.

17.5 Composition Mode with Multiple Displays

When using two monitors, you can configure Scrivener to use the secondary display as the
composition window instead of the primary display. This can be adjusted in preferences.

Also, if you don’t mind taking a performance hit, you can choose to leave the main
Scrivener interface open on the primary display. When doing so, Option-clicking on text
or folder items in the Binder will load these items into your live composition session. As
with the standard editor, using the Command and Shift keys will select multiple docu-
ments and form a Scrivenings session. To utilise this in the active composition window,
just add the Option key to these modifier keys.



Chapter 18

Annotations and Footnotes

As a tool designed for the production of texts, there are many methods for facilitating
not only the writing process, but the editing process, and the “public notation” process
which is typically expressed via some form of page or section footnote, or endnote at the
conclusion of the work. This chapter will cover all of the various methods that Scrivener
provides. We will cover:

@ Annotation and Commentary: the ability to place production notes within the doc-
ument, making it easy to communicate changes or needs to yourself, collaborators,
your editor, or to receive the communications from others. Scrivener supports the
RTF standards for commentary, and will convert any word processor applied notes
to your preferred notation style, which can be configured in the Import & Export
preference tab (section C.10).

- Footnotes and/or Endnotes: being a drafting tool, Scrivener makes no attempt to
typeset and number either of these as you write, however it is easy to insert notes
precisely where you need them, and when you compile they will presented accord-
ing to your exacting demands. As with comments, RTF standards are supported
and incoming notes will be converted to your preferred notation style. Scrivener
supports two note streams, allowing you to output both footnotes and endnotes, if
required. In the case where specific formatting is required, it may be advantageous
to use a citation manager that can scan an RTF and produce a bibliography for you
(section 21.6).

@ Text colours and Highlighters: to aid in increasing the visibility of passages, you
are provided with an extensive complement of tools for highlighting and marking
your text in colour.

¢ Revision markings: the automatic application of text colour, as you edit and write,
can be assigned individual colours for up to five revisions, making it easy to make
sure your colleagues (or yourself) know what you have changed and vice versa.

241
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Marking your text is one thing, finding those markings amongst a 100,000 word draft
is another. The robust Find by Format and Text Function (subsection 21.1.6) makes it
easy to quickly step through your draft, point by point, isolating and addressing issues or
reviewing changes that you’ve made.

Annotations and footnotes (this document will refer to all reader notes as footnotes,
even if their intended result will be endnotes) come in two different flavours. Inline no-
tation, which are added directly to your text, and linked notation, which are attached as
a special form of “link” to the base text of your book, with the content of the note stored
off to the side in the inspector, much as in many word processors. Which of these to use
will remain up to you and your preferences in most cases. You might even find that a
mixture of methods will suit you, using inline notation for short comments to yourself
about prose, and linked notes for other types of comments. There are advantages and
disadvantages to each method:

: Inline notes are always visible in your text; there is no way to diminish their promi-
nence. So for some forms of notation, this can be an advantage in that you cannot
defer or easily ignore them. This also makes it easier to see your notes and your
book at the same reading speed—there is no need to look off to the side to get a feel
for the “meta” book.

- Linked notes do not disturb the flow of text, no matter how large they may be. This
means even the lengthiest of notes can be placed into your text without having to
scan from word to word in order to read the underlying book text.

- Inline notes, being within the text itself, do not require any additional interface to
use and never require the mouse to read. They thus work well with a slim workflow,
or in situations where screen space is at a premium.

@ Linked notes can act like bookmarks. Clicking on them in the inspector will whisk
you right to the spot in the text where they are anchored.

& Inline notes can be placed anywhere you like (especially annotations), even in be-
tween paragraphs or at the very beginning or end of a section, whereas linked notes
require something to “anchor to”. This makes them more useful when jotting down
notes in sections before you’ve even started to write.

@ Linked notes can be easily viewed together in a collected interface no matter how
far they are spread apart in the document. This becomes especially advantageous
in a Scrivenings session. A note on page 10 has the same prominence as a note on

page 1.
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It follows then that inline notes are only visible in the current contextual surround-
ings. Notes that are pages away, and do not presently concern you in your writing
and editing, are hidden by the same virtue that hides these irrelevant texts from you:
the sheer bulk of your words.

: Inline notes exist around your text and do not depend upon it to exist. This means
you can edit the text that the note refers to freely, without worrying about losing
your comments. This is in opposition to linked notes, which are anchored to the
text—if the text is removed or entirely altered, the note will be deleted. By corol-
lary, inline note quantities can exceed the textual capacity of the base text. For
most authors this will not become an issue, but in some fields, such as qualitative
data analysis, where the amount of annotation can exceed the text, running out of
suitable anchor text could become a problem with linked notes. Inline notes, being
unanchored, have no limits.

These are just a few examples, and hopefully that gives you an idea of the individual
unique merits in these formats. In some special cases, using all four methods together
will afford you with additional compile powers, such as handling multiple note streams,
or using annotations as “functional” text and linked comments strictly as notes. The next
few sections will address each of these types in more depth.

18.1 Inline Notation

Scrivener sports a unique method for taking notes and indicating footnotes, by placing
them directly into the main text stream itself. It mimics the natural annotation process
that one applies when working with paper, where notes are scribbled below the problem
lines themselves, into margins, or anywhere else they will fit in. It means your notes
remain prominent and easy to find so long as they remain issues worthy of attention. The
same treatment can be given to footnotes as well. Keeping the actual text of the footnote
directly in-line with the text it augments can increase productivity and help keep your
meta-book relevant and cohesive. Further advantages are in entry speed. Since notation
is done directly in the text while you are typing or editing, it is easy to flow from “editor”
to “writer” without disrupting the process with floating windows, margin bubbles, or the
many other mechanisms that applications use to attach notes.

Despite the advantages, there are still cases and tastes which would prefer to keep no-
tation out of the main text area. If you have interest in commenting on your work or
adding footnotes to it without adding text to the main editing area, please skip down to
Linked Notation (section 18.2).
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What They Are: Inline notation is fundamentally a form of formatting, just like any
other formatting spans in your document, such as bold or italic. Yes, Scrivener has
tools for working with notations in unique ways, but they will respond to many of
the actions that are designed for working around formatting, such as Paste and Match
Style. When cutting and pasting text into and out of notations, try to think of them
as analogous to bold text. To paste some external text into a note, you’ll need to use
Paste and Match Style for the text to acquire the notation formatting. The same is true
going in other direction. Additionally, ranges can be toggled on and off for a section

of text, just as you could with an italic range.

How you interface with inline annotations and footnotes is identical at the writing
phase. Since inline notation works just like ordinary formatting, creating a note or foot-
note from existing text is as easy as selecting the range of text you wish to adjust and
clicking on the appropriate menu command or toolbar icon. To create an annotation,
you can use Format s Inline Annotation or press {+8-A on your keyboard. As with other
formatting tools, this works in a toggle fashion. If you select some text that is already
set to be an annotation and use this command, it will be returned to regular text. For
footnotes, everything is the same; just use Format » Inline Footnote or 1+ &-F.

To create a new footnote or annotation from text that does not yet exist, you can use
these same commands to start typing in the desired notation mode wherever your cursor
is placed in the editor.

Moving notes around is a simple matter of cutting and pasting the text itself. Since
notations are formatting, they will move along with the text no matter where you take
them, unless you use Paste and Match Style.

18.1.1 Inline Annotations

Annotated text will appear red with a “bubble” around it, by default. You can change
the colour by placing the cursor anywhere within it and using the colours palette, which
is toggled via Format » Font» Show Colors, or 4+8-C. On a per project basis, Scrivener
will remember the last colour you chose and use it for the next new note you create (thus
you can effectively change the application default to another colour by creating your own
starter template). To split an annotation into two pieces, select the portion you wish to
split off and assign it a different colour.

To ensure your text exports as expected, you must check that the text surrounding
your annotation would make sense were the annotation not present, including how you
set out your whitespace (spaces, newlines etc). In other words, if you place an annotation
between two sentences, make sure that there is only one space (or two if you use two spaces
between sentences) separating the sentences outside of the annotation. On the other hand,
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when you choose to compile annotations into the document inline, all spacing within the
annotation will be preserved; the end result will look like it does in the main editor.

Since you can choose to omit annotations from the text when you export or print
it, they are very useful for jotting down notes and ideas inside the main text that are not
really part of the main text, but which would be better placed next to the section of text to
which they refer, than in the Notes pane. When you export to RTF format, annotations
can also be converted to RTF comments that appear in marginal boxes in compatible
word processors, rather than omitted, as well as a few other display options for other
word processors or formats. For details on what options are available for omission or
conversion during compile, see Footnotes/Comments (section 24.21).

While it is possible to use annotations to create footnotes, this compile-time conversion
has fewer options available to it than standard footnotes. For fully featured footnotes,
continue to the next section.

Important note: Although you can create tables and bulleted lists insi